Loading ...
Sorry, an error occurred while loading the content.

Re: [Cadillac_Performance_Association] new member

Expand Messages
  • bill lutzius
    Good luck Mario,guess you could drop the pan and check the rod bearings.I changed my rod bearings in the car and it was not to hard.Sounds like you are more of
    Message 1 of 9 , Nov 26, 2003
    • 0 Attachment
      Good luck Mario,guess you could drop the pan and check
      the rod bearings.I changed my rod bearings in the car
      and it was not to hard.Sounds like you are more of a
      motor head then me.Could be a loose converter
      bolt.This could be a many beer job.Starting with a
      6er.
      --- cad500ci@... wrote:
      > hi bill:
      > it is not a ticking. it is more like a loud thud.
      > the noise first surfaced at
      > 75 mph. it sounded like a dead lifter and then got
      > louder. when i got off the
      > freeway and shut down, the noise was still there but
      > not as loud upon
      > restart. the noise only appears after the engine oil
      > hits 200 degrees. there is
      > plenty of vacuum and the needle is steady. there is
      > 50 psi oil pressure at startup
      > then it drops to 30-35 at higher oil temps. i have
      > not had the time to pull
      > the engine yet but that is on the agenda this
      > december. have to get it running
      > for the new year, as it is a driver.
      > thanks for all the suggestions. i'll keep you posted
      > on what i findciao,
      > mario
      >


      __________________________________
      Do you Yahoo!?
      Free Pop-Up Blocker - Get it now
      http://companion.yahoo.com/
    Your message has been successfully submitted and would be delivered to recipients shortly.