Loading ...
Sorry, an error occurred while loading the content.

12201980-1985 eldo/seville cooling....need help, how to succesfully pull it off???

Expand Messages
  • mpascino_ny
    Jul 18 3:18 PM
    • 0 Attachment
      Hello again everyone, I have a 1985 eldorado and a 1985 seville, both
      cars have olds 350s with mild mods, one is MPI, both have 325-4l's.
      I have never really had any problems to speak of with the cars, more
      of just pet pevvs I guess. Both cars have 3 core radiators, which in
      theroy should be more than enough to keep em running cool. Each
      summer season that has gone by, both cars have minor trouble running
      cool. Both radiators are roughly 5 years old, and have been reguarly
      flushed. I have measured the temps across the radiator with an IR
      probe and found it to be pretty uniform. Both cars have mechanical
      clutch fans, both newer. The cars only start to run warm when on the
      highway. Around town isn't really a problem. I can't understand
      what could possibly be the problem. I am using fan shroud off a 1980
      toronado, which is a direct bolt on. Once I start to run warm, I
      find the radiator temp is about equal to the engine itself,
      suggesting I am not getting enough air flow to cool the radiator
      down. There is nothing in front of the radiator or evaporator for
      the AC to restrict air flow. Has anyone else had this problem? Is
      it possible there is not enough room for air to flow through the
      engine compartment? I seem to think the problem was not existant
      when I first did the swap, but I also didn't drive either vehicle
      much back then, and prob not much during the hot summer days. The
      eldorado is at the point where I can not drive it anymore. I have a
      160 degree thermostat in it, and when I drive it easy, it still runs
      up to 190 degrees within 15 minutes. Sorry for the long message but
      I am stuck. One car is set up similar to a 1979 eldo, cooling system
      and all. Does anyone know if they had cooling problems from the
      factory. I just don't see how at 70 MPH how I could not have enough
      air through the radiator.......I am considering buying a brand new
      radiator and giving it a whirl as a last resort, maybe even having
      one of mine recored with 4 cores. Cody, do you have any trouble
      keeping the 472 cool? Thanks in advance for and info or advice.
      Mike Pascino
    • Show all 11 messages in this topic