Loading ...
Sorry, an error occurred while loading the content.

CAMM-3 PNC-300 problems with code and communication

Expand Messages
  • jbhill001
    Hello! We are dusting off a CAMM-3 PNC-300 that s been around here for over 10 years. The machine seems to function ok but we are really struggling with
    Message 1 of 2 , Jul 30 9:36 AM
    • 0 Attachment
      Hello!

      We are dusting off a CAMM-3 PNC-300 that's been around here for over 10 years. The machine seems to function ok but we are really struggling with communication and programming. We haven't been able to find any manuals for this one so that hasn't helped. We are currently setup through a serial cable to a Windows 7 64 bit PC.

      The error that won't go away is a ESC.E Err15: Framing/Parity error. We have tried numerous settings, always matching the PC to the machine but we still get this error. We are using a COM port emulator just to try to fix this and then we'll work on the CAM side. If we send an H to the machine we'll get this Err15 error but if we press the Enter button and then Enter again when the display shows Pause On CONTINUE it will run the code, in this case home the machine.

      Can anyone shed any light on this problem?

      Thanks!
      Jason
    • Tom Fitzgibbons
      Jason -- Don t have experience with that problem specifically, but the only simple solution I have ever found is running the CAMM-3 with an older PC. My dad
      Message 2 of 2 , Jul 30 1:45 PM
      • 0 Attachment
        Jason --
         
        Don't have experience with that problem specifically, but the only simple solution I have ever found is running the CAMM-3 with an older PC.
         
        My dad has an old CNC engraver (similiar vintage to CAMM-3) which also had the same type of problem you are experiencing trying to run through an emulator.  I can't explain the technical reasons, but I think it has to do with how ports are assigned (in software vs. hardware).
        I had a CAMM-3 PNC 3000 that I ran with a parallel port connection using Windows 98.  I upgraded it 2-3 years ago to Windows XP on a 'Net Top' PC still using the parallel port connection and running the Roland software.  The only special issue was setting the communication speed so it didn't overflow the buffer.
         
         
        Don't know if that helps, but it may be an option.
         
        Tom Fitzgibbons
         

        ---------- Original Message ----------
        From: "jbhill001" <jbhill001@...>
        To: CAMM-3@yahoogroups.com
        Subject: [CAMM-3] CAMM-3 PNC-300 problems with code and communication
        Date: Mon, 30 Jul 2012 16:36:14 -0000

         

        Hello!

        We are dusting off a CAMM-3 PNC-300 that's been around here for over 10 years. The machine seems to function ok but we are really struggling with communication and programming. We haven't been able to find any manuals for this one so that hasn't helped. We are currently setup through a serial cable to a Windows 7 64 bit PC.

        The error that won't go away is a ESC.E Err15: Framing/Parity error. We have tried numerous settings, always matching the PC to the machine but we still get this error. We are using a COM port emulator just to try to fix this and then we'll work on the CAM side. If we send an H to the machine we'll get this Err15 error but if we press the Enter button and then Enter again when the display shows Pause On CONTINUE it will run the code, in this case home the machine.

        Can anyone shed any light on this problem?

        Thanks!
        Jason

         

         



        ____________________________________________________________
        Woman is 53 But Looks 25
        Mom reveals 1 simple wrinkle trick that has angered doctors...
        ConsumerLifestyleMag.com
      Your message has been successfully submitted and would be delivered to recipients shortly.