Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] BPQmail

Expand Messages
  • John Wiseman
    RIchard, I don t have FBB set up on this machine, so I can t check, but my recollection is that the user and password must be entered in the FBB forwarding
    Message 1 of 9 , Feb 9, 2013
    • 0 Attachment
      RIchard,
       
      I don't have FBB set up on this machine, so I can't check, but my recollection is that the user and password must be entered in the FBB forwarding script on a single line. Maybe someone who uses it can confirm the format.
       
      To use a normal Telnet client, you must connect to TCPPORT. What FBB calls telnet isn't telnet at all, but a raw TCP connection.
       
      73, John G8BPQ
       
      I've been informed that what you need is
       
      C C CALL IPADDRESS PORT
      V .USER$WPASSWORD$W
       
      This assumes that the Telnet USER record is set to connect to the BBS, if not, you can add BBS$W on the end of  the V line.
       


      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
      Sent: 09 February 2013 15:08
      To: BPQ32@yahoogroups.com
      Subject: [BPQ32] BPQmail

       

      I recently installed LinBPQ – works very well and I have two forwarding partners – must admit, some teething problems but worked through them ..

      I also have a LinFBB BBS (ZS0MEE) on my LAN (all on the same Ubuntu 12.10 Linux box .. I’ve had two FBB BBS’s (WinFBB and LinFBB) on my LAN some years before and allowed forwarded between them – no big deal ..

      Scratching around in on-line doc, I created FBBPORT=xxxxx in the Telnet Port in the LinBPQ config file (yes I can telnet into LinBPQ and access the BPQmail BB S) .. Under the telnet port I also created another user (the FBB BBS) with password and ensured that when it logs in, it would go straight to the BPQBBS .. I created the necessary forwarding include file in FBB … It didn’t work ..

      I then tried to pretend I was the FBB BBS logging in. Telnet’ing into BPQmail I got no prompts. Found that if I press <enter> three times I got the ‘callsign:’ prompt. Entered the FBB BBS callsign and had to press <enter> three times again to get the ‘password:’ prompt. One ,enter> and I got the BPQmail prompt.  Everything thereafter appeared on the same line (no CR/LF) – I understand this is ‘raw’ data though the data is readable ..

      I then edited the relevant FBB include file to create three <enters> before and after the callsign – still not working … Under LinFBB I can monitor the traffic and I can see any results in the BPQmail telnet log file – BPQmail doesn’t respond but I can see the text going out on the FBB monitor when I let FBB initiate a forward. When I pretend to be a BBS and manually connect the results are show in the log file and appear to be normal.

      My question – how can I get BPQmail to respond to a forward request from FBB ???

      73, Dick ZS6RO

      Johannesburg

      South Africa.

    • Mike
      Richard 1 You must use the FBBPORT= in bpq32.cfg to connect from FBB 2 C C Call Sign, Static IP Address, FBBPORT address: Example: C C N9PMO 65.31.82.124 8011
      Message 2 of 9 , Feb 9, 2013
      • 0 Attachment
        Richard

        1 You must use the FBBPORT= in bpq32.cfg to connect from FBB
        2 C C Call Sign, Static IP Address, FBBPORT address:
        Example:
        C C N9PMO 65.31.82.124 8011

        Example N9ABC is connecting station, Password, Call of BPQ-BBS, or the
        BBS Cmd can be used
        V N9ABC$W****$WC N9PMO-1$W
        OR
        V N9ABC$W****$WBBS$W

        If the remote bpq switch is not a static IP address, a Port Mapper or
        BPQ IP Gateway
        Must be used, IF both are on the same computer the IP address would be
        127.0.0.1
        If on LAN 192.168.xx.xxx

        Mike N9PMO
        www.n9pmo.com
        -----Original Message-----
        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
        Richard
        Sent: Saturday, February 09, 2013 9:08 AM
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] BPQmail

         
        I recently installed LinBPQ – works very well and I have two forwarding
        partners – must admit, some teething problems but worked through them ..
         
        I also have a LinFBB BBS (ZS0MEE) on my LAN (all on the same Ubuntu
        12.10 Linux box .. I’ve had two FBB BBS’s (WinFBB and LinFBB) on my LAN
        some years before and allowed forwarded between them – no big deal ..
         
        Scratching around in on-line doc, I created FBBPORT=xxxxx in the Telnet
        Port in the LinBPQ config file (yes I can telnet into LinBPQ and access
        the BPQmail BBS) .. Under the telnet port I also created another user
        (the FBB BBS) with password and ensured that when it logs in, it would
        go straight to the BPQBBS .. I created the necessary forwarding include
        file in FBB … It didn’t work ..
         
        I then tried to pretend I was the FBB BBS logging in. Telnet’ing into
        BPQmail I got no prompts. Found that if I press <enter> three times I
        got the ‘callsign:’ prompt. Entered the FBB BBS callsign and had to
        press <enter> three times again to get the ‘password:’ prompt. One
        ,enter> and I got the BPQmail prompt.  Everything thereafter appeared on
        the same line (no CR/LF) – I understand this is ‘raw’ data though the
        data is readable ..
         
        I then edited the relevant FBB include file to create three <enters>
        before and after the callsign – still not working … Under LinFBB I can
        monitor the traffic and I can see any results in the BPQmail telnet log
        file – BPQmail doesn’t respond but I can see the text going out on the
        FBB monitor when I let FBB initiate a forward. When I pretend to be a
        BBS and manually connect the results are show in the log file and appear
        to be normal.
         
        My question – how can I get BPQmail to respond to a forward request from
        FBB ???
         
        73, Dick ZS6RO
        Johannesburg
        South Africa.
      • Richard
        Thanks for the replies guys . When South Africa had more than a few BBS s many years back I was instrumental in configuring most of them up - what I m saying
        Message 3 of 9 , Feb 9, 2013
        • 0 Attachment

          Thanks for the replies guys …

           

          When South Africa had more than a few BBS’s many years back I was instrumental in configuring most of them up – what I’m saying here, is that I know the various configurations of FBB are required for include files for forwarding *Grin …

           

          I have the telnet section correct as I am able to telnet into LinBPQ and also the HTTPPORT connection.

           

          I am able to connect through the FBBPORT connecting as a ‘BBS’ by creating a dummy BBS in LinBPQ and using the dummy BBS callsign manually.  And this is where the issue is. Any other telnet connection will bring up the user: prompt immediately, but as a dummy BBS and when I use LinFBB to make an actual connection, three <enter>’s are required to bring up the prompts !!! (Try it) ….

           

          To get three <enter>’s in FBB I edited the relevant include file with “V $W$W$Wcallsign$W$W$Wpassword$WBBS$W” .. I also tried the standard “V callsign$Wpassword$WBBS$W” and in the LinBPQ log I can see that the ‘callsign’ is recognized in LinBPQ but then there is nothing else in the log until a timeout occurs ..

           

          In my understanding,  that when using FBBPORT connection, the prompts don’t show up unless I repeatedly press <enter> or if using LinFBB to initiate a forward to LinBPQ, only the ‘user: callsign’ is apparently received ..

           

          Hope that is clear enough ??? … How do I cure this – or this a bug in LinBPQ ???

           

          73, Dick ZS6RO

           

          ~~~~~~~~~~~~~~~~~~~~~

          RIchard,

           

          I don't have FBB set up on this machine, so I can't check, but my recollection is that the user and password must be entered in the FBB forwarding script on a single line. Maybe someone who uses it can confirm the format.

           

          To use a normal Telnet client, you must connect to TCPPORT. What FBB calls telnet isn't telnet at all, but a raw TCP connection.

           

          73, John G8BPQ

           

          I've been informed that what you need is

           

          C C CALL IPADDRESS PORT
          V .USER$WPASSWORD$W

           

          This assumes that the Telnet USER record is set to connect to the BBS, if not, you can add BBS$W on the end of  the V line.

           

           

        • John Wiseman
          Another user has it working, so I don t think there is a bug in LinBPQ The incoming connection has to connect to the BBS. This can be done either by adding the
          Message 4 of 9 , Feb 10, 2013
          • 0 Attachment
            Another user has it working, so I don't think there is a bug in LinBPQ
             
            The incoming connection has to connect to the BBS. This can be done either by adding the LinBPQ BBS application name to the Telnet USER line:
             
            USER=user,password,gm8bpq,BBSAPPL
             
            or by sending the applicaton name as port of the login script:
             
             V USER$WPASSWORD$WBBSAPPL$W
             
            The . on the front isn't needed.
             
            If it still doesn't work, please send my your BPQTelnetServer.log file.
             
            Just to re-iterate, the FBBPORT is only for use by automated systems, such as FBB forwarding or BPQTrrmTCP. It should not be used for manual connections from a telnet client. Manual telnet connections should be to TCPPORT.
             
            73,
             
            John


            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
            Sent: 10 February 2013 07:46
            To: BPQ32@yahoogroups.com
            Subject: RE: [BPQ32] BPQmail

             

            Thanks for the replies guys …

            When South Africa had more than a few BBS’s many years back I was instrumental in configuring most of them up – what I’m saying here, is that I know the various configurations of FBB are required for include files for forwarding *Grin …

            I have the telnet section correct as I am able to telnet into LinBPQ and also the HTTPPORT connection.

            I am able to connect through the FBBPORT connecting as a ‘BBS’ by creating a dummy BBS in LinBPQ and using the dummy BBS callsign manually.  And this is where the issue is. Any other telnet connection will bring up the user: prompt immediately, but as a dummy BBS and when I use LinFBB to make an actual connection, three <enter>’s are required to bring up the prompts !!! (Try it) ….

            To get three <enter>’s in FBB I edited the relevant include file with “V $W$W$Wcallsign$W$W$Wpassword$WBBS$W” .. I also tried the standard “V callsign$Wpassword$WBBS$W” and in the LinBPQ log I can see that the ‘callsign’ is recognized in LinBPQ but then there is nothing else in the log until a timeout occurs ..

            In my understanding,  that when using FBBPORT connection, the prompts don’t show up unless I repeatedly press <enter> or if using LinFBB to initiate a forward to LinBPQ, only the ‘user: callsign’ is apparently received ..

            Hope that is clear enough ??? … How do I cure this – or this a bug in LinBPQ ???

            73, Dick ZS6RO

            ~~~~~~~~~~~~~~~~~~~~~

            RIchard,

            I don't have FBB set up on this machine, so I can't check, but my recollection is that the user and password must be entered in the FBB forwarding script on a single line. Maybe someone who uses it can confirm the format.

            To use a normal Telnet client, you must connect to TCPPORT. What FBB calls telnet isn't telnet at all, but a raw TCP connection.

            73, John G8BPQ

            I've been informed that what you need is

            C C CALL IPADDRESS PORT
            V .USER$WPASSWORD$W

            This assumes that the Telnet USER record is set to connect to the BBS, if not, you can add BBS$W on the end of  the V line.

          • Richard
            I understand John .. My manual connect to FBBPORT port was a test at the time to ensure that I could see things were happening - I got more responses from
            Message 5 of 9 , Feb 10, 2013
            • 0 Attachment

              I understand John ..  My manual connect to FBBPORT port was a ‘test’ at the time to ensure that I could see things were happening – I got more responses from the manual test than from the automated one. I do use the correct ports for their specified functions … What I do know here is that the when, either manually or from automatic means via LinFBB, the prompts don’t show up and nothing shows in the logs. I would like to talk to this other ‘user’ you mention – it could easily be something I overlooked.

              I had tried all of what you suggested below, yesterday before I actually posted to this group – I only talk to groups after I have tried everything that I can think of at the time. (I’ve Googled most of the BPQmail Doc and read between the lines when considering LinBPQ) …

              I know (this may seem like an arrogant statement – sorry if it comes out like that – not meant to be) that the configuration of LinBPQ and LinFBB are correct – I have tried many alternatives and some which no one has dreamed off yet *Grin ..

              To get around the problem, I have made LinBPQ and XR32 (LinFBB is linked to XR32 (XR32 on Wine) via a pseudo AXIP pipe and radio users (radios on XR32) can connect to LinFBB directly) link to each other via an AXIP route. In LinBPQ I created the connect script to connect to the XR32 then LinFBB. Also on this connection I arranged for LinBPQ to request reverse forwarding. All this works flawlessly and LinBPQ now has got all relevant bulls etc from LinFBB – if anything relevant is on LinBPQ it will be sent to LinFBB .. I also rem’ed out the connect script in LinFBB include file to stop useless connects to LinBPQ.

               

              I like LinBPQ for various reasons. Once I have got things sorted out here I will use XR32 <> LinBPQ and do away with LinFBB. Theoretically I guess I don’t need to sort out why LinFBB won’t initiate a forward to LinBPQ, because as I progress along here I will do away with LinFBB, BUT its the challenge – why doesn’t it work for me ??? – That’s what I want to know, then I can rest easy *Smile …

               

              73, Dick ZS6RO.

              dick at zs6ro (dot) co (dot) za

               

              ~~~~~~~~~~~~~~~~

               

              Another user has it working, so I don't think there is a bug in LinBPQ

               

              The incoming connection has to connect to the BBS. This can be done either by adding the LinBPQ BBS application name to the Telnet USER line:

               

              USER=user,password,gm8bpq,BBSAPPL

               

              or by sending the applicaton name as port of the login script:

               

               V USER$WPASSWORD$WBBSAPPL$W

               

              The . on the front isn't needed.

               

              If it still doesn't work, please send my your BPQTelnetServer.log file.

               

              Just to re-iterate, the FBBPORT is only for use by automated systems, such as FBB forwarding or BPQTrrmTCP. It should not be used for manual connections from a telnet client. Manual telnet connections should be to TCPPORT.

               

              73,

               

              John

               


            • Peter - ZL2BAU
              ... Hi Dick, There are a couple of things in LinFBB that you need to do in order to get LinFBB to forward to LinBPQMail using it`s telnet port. In LinFBB there
              Message 6 of 9 , Feb 10, 2013
              • 0 Attachment
                On 11/02/13 02:08, Richard wrote:
                 

                I understand John ..  My manual connect to FBBPORT port was a ‘test’ at the time to ensure that I could see things were happening – I got more responses from the manual test than from the automated one. I do use the correct ports for their specified functions … What I do know here is that the when, either manually or from automatic means via LinFBB, the prompts don’t show up and nothing shows in the logs. I would like to talk to this other ‘user’ you mention – it could easily be something I overlooked.

                I had tried all of what you suggested below, yesterday before I actually posted to this group – I only talk to groups after I have tried everything that I can think of at the time. (I’ve Googled most of the BPQmail Doc and read between the lines when considering LinBPQ) …

                I know (this may seem like an arrogant statement – sorry if it comes out like that – not meant to be) that the configuration of LinBPQ and LinFBB are correct – I have tried many alternatives and some which no one has dreamed off yet *Grin ..

                To get around the problem, I have made LinBPQ and XR32 (LinFBB is linked to XR32 (XR32 on Wine) via a pseudo AXIP pipe and radio users (radios on XR32) can connect to LinFBB directly) link to each other via an AXIP route. In LinBPQ I created the connect script to connect to the XR32 then LinFBB. Also on this connection I arranged for LinBPQ to request reverse forwarding. All this works flawlessly and LinBPQ now has got all relevant bulls etc from LinFBB – if anything relevant is on LinBPQ it will be sent to LinFBB .. I also rem’ed out the connect script in LinFBB include file to stop useless connects to LinBPQ.

                 

                I like LinBPQ for various reasons. Once I have got things sorted out here I will use XR32 <> LinBPQ and do away with LinFBB. Theoretically I guess I don’t need to sort out why LinFBB won’t initiate a forward to LinBPQ, because as I progress along here I will do away with LinFBB, BUT its the challenge – why doesn’t it work for me ??? – That’s what I want to know, then I can rest easy *Smile …

                 

                73, Dick ZS6RO.

                dick at zs6ro (dot) co (dot) za


                Hi Dick,

                           There are a couple of things in LinFBB that you need to do in order to get LinFBB to forward to LinBPQMail using it`s telnet port.

                In LinFBB there are 3 things to do.

                1 - Remove the "." from the forward script in xfbb
                2 - added the BBS "BPQBBS$W" to end of the callsign / password string
                3 - Set forwarding to text in xfbb "N 0"

                This allows LinFBB to forward to LinBPQMail directly on the same computer, here is my connect script
                from LinFBB, please not, you have to add your own "password"

                #
                --------------------------------------------
                #
                # BBS : ZL2BAU.#79.NZL.OC (LinBPQMail)
                #
                A WAIBBS
                #
                IF H 00-23
                   P B
                     N 0
                     L B 230
                     L O 3
                       C C ZL2BAU 127.0.0.1 8011
                         V zl2bau$Wpassword$WBPQBBS$W
                ENDIF
                #
                < /fwd/waibbs
                #
                --------------------------------------------
                #

                Regards ..... Peter

                    ZL2BAU - Waimate BBS - South Canterbury APRS iGate

                    Located In - Waimate - South Island - New Zealand
                    Grid Location : RE55MG ( 44.44.26S / 171.03.23E )
                    New Zealand / World Wide Telnet BBS Forwarding
                    E-Mail : peter.zl2bau@...
                    Packet Mail : ZL2BAU @ ZL2BAU.#79.NZL.OC
                    NZART Member Number : 104431
                    Internet BBS : telnet://zl2bau.dyndns.org:6303
                    Internet Node : telnet://zl2bau.dyndns.org
                    Internet Node Call : BAUNOD:ZL2BAU-3 (44.147.210.26)
                    Xrouter HTTP Web Server : http://zl2bau.dyndns.org
                    BBS HTTP Web Server : http://zl2bau.dyndns.org:82
                    BPQ32 HTTP Web Server : http//zl2bau.dyndns.org:8083
                    Xrouter Chat Server : telnet://zl2bau.dyndns.org:3600
                    Xrouter APRS Server : telnet://zl2bau.dyndns.org:1448
                    Tcp/Ip Routing : 44.147.210.23/24 (44.147.210.26)
                    Default UDP Port : 93 (Other ports to suite)



              • Richard
                Thanks Peter, but I have explained in each posting, that I have tried all the usual tricks even before I sent the first post to this group, with no luck ..
                Message 7 of 9 , Feb 10, 2013
                • 0 Attachment

                  Thanks Peter, but I have explained in each posting, that I have tried all the usual ‘tricks’ even before I sent the first post to this group, with no luck .. You mention “BPQBBS” – in LinBPQ one uses “BBS” … Thing is nothing gets recognized and nothing shows in the log ..

                  As I mentioned in an earlier post, I have turned it around and now get LinBPQ to initiate a compressed forward with LinFBB, both LinBPQ and LinFBB are on the same Linux box, and the BPQ log reflects all the transactions and it works ..

                  73, Dick ZS6RO.

                  ~~~~~~~~~~~~~~~~
                  Hi Dick,

                             There are a couple of things in LinFBB that you need to do in order to get LinFBB to forward to LinBPQMail using it`s telnet port.

                  In LinFBB there are 3 things to do.

                  1 - Remove the "." from the forward script in xfbb
                  2 - added the BBS "BPQBBS$W" to end of the callsign / password string
                  3 - Set forwarding to text in xfbb "N 0"

                  This allows LinFBB to forward to LinBPQMail directly on the same computer, here is my connect script
                  from LinFBB, please not, you have to add your own "password"

                  #
                  --------------------------------------------
                  #
                  # BBS : ZL2BAU.#79.NZL.OC (LinBPQMail)
                  #
                  A WAIBBS
                  #
                  IF H 00-23
                     P B
                       N 0
                       L B 230
                       L O 3
                         C C ZL2BAU 127.0.0.1 8011
                           V zl2bau$Wpassword$WBPQBBS$W
                  ENDIF
                  #
                  < /fwd/waibbs
                  #
                  --------------------------------------------
                  #

                  Regards ..... Peter

                      ZL2BAU - Waimate BBS - South Canterbury APRS iGate

                      Located In - Waimate - South Island - New Zealand
                      Grid Location : RE55MG ( 44.44.26S / 171.03.23E )
                      New Zealand / World Wide Telnet BBS Forwarding
                      E-Mail : peter.zl2bau@...
                      Packet Mail : ZL2BAU @ ZL2BAU.#79.NZL.OC
                      NZART Member Number : 104431
                      Internet BBS : telnet://zl2bau.dyndns.org:6303
                      Internet Node : telnet://zl2bau.dyndns.org
                      Internet Node Call : BAUNOD:ZL2BAU-3 (44.147.210.26)
                      Xrouter HTTP Web Server : http://zl2bau.dyndns.org
                      BBS HTTP Web Server : http://zl2bau.dyndns.org:82
                      BPQ32 HTTP Web Server : http//zl2bau.dyndns.org:8083
                      Xrouter Chat Server : telnet://zl2bau.dyndns.org:3600
                      Xrouter APRS Server : telnet://zl2bau.dyndns.org:1448
                      Tcp/Ip Routing : 44.147.210.23/24 (44.147.210.26)
                      Default UDP Port : 93 (Other ports to suite)

                Your message has been successfully submitted and would be delivered to recipients shortly.