Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] Re: ubuntu port

Expand Messages
  • John Wiseman
    You have to create a symlink From the docs: As serial port names are pretty variable in Linux, the code accesses them via symlinks in the linbpq directory to
    Message 1 of 15 , Feb 3 7:12 AM
    • 0 Attachment
      You have to create a symlink
       
      From the docs:
       

      As serial port names are pretty variable in Linux, the code accesses them via symlinks in the linbpq directory to ports called com1 – com255. So, for example, to access a TNC connected to the serial port on the PI, enter

       

       ln –s /dev/ttyAMA0 com1  (lower case!)

       

      In  you case

       

      ln -s /dev/ttyS0 com1

       

      73, John

       



      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kenny
      Sent: 03 February 2013 14:49
      To: BPQ32@...
      Subject: [BPQ32] Re: ubuntu port

       

      Hi John
      its ttys0,.. ttySierra zero
      never made a symlink
      the rights are ok

      Ken

      --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:

      >
      > Ok, Ken.
      >
      > Do you create the symlink from
      com1 to /dev/ttyS0? (Is it S zero or S letter
      > o?). Also check the rights
      on com1 and /dev/ttyS0.
      >
      > 73, John
      >
      >
      >
      _____
      >
      > From:
      href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
      > kenny
      > Sent: 03 February 2013 13:35
      > To:
      href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com
      > Subject:
      [BPQ32] Re: ubuntu port
      >
      >
      >
      >
      >
      > Hi
      John
      > i am using your sample now,the error
      > i am now getting
      is:
      > ASYNC Com1 Chan A /home/linbpq/com1 could not be opened
      >
      > Ken
      >
      > --- In
      href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com , "John
      >
      Wiseman" wrote:
      > >
      > > Ken,
      > >
      > > When
      you say not seeing it, do you mean there is an error reported on
      > >
      startup, or just that it doesn't work.?
      > >
      > > PORT
      > > ID=KISS
      > > TYPE=ASYNC
      > > PROTOCOL=KISS
      > >
      SPEED=9600
      > > COMPORT=1
      > > CHANNEL=A
      > >
      QUALITY=0
      > > MAXFRAME=2
      > > FRACK=7000
      > >
      RESPTIME=1500
      > > RETRIES=10
      > > PACLEN=128
      > >
      TXDELAY=500
      > > SLOTTIME=100
      > > PERSIST=64
      > >
      ;
      > > ENDPORT
      > >
      > > 73, John
      > >
      > >
      > > _____
      > >
      > > From:
      href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com
      >
      [mailto:BPQ32@yahoogroups.com ] On Behalf
      > Of
      > > kenny
      > > Sent: 03 February 2013
      12:45
      > > To:
      href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com
      > >
      Subject: [BPQ32] ubuntu port
      > >
      > >
      > >
      > >
      > > Hi All
      > > anyone got a sample port setting for
      ttyS0 (com1)
      > > my ubuntu,bpq is not seeing it.
      > >
      > > Ken g7vja
      > >
      > >
      > >
      > >
      > > _
      > >
      >
      d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
      > > .
      > >
      >

    • kenny
      All working now John i have never had to make a symlink before,learn something new everyday. with my Xrouter running under ubuntu i never had to make a
      Message 2 of 15 , Feb 3 7:48 AM
      • 0 Attachment
        All working now John
        i have never had to make a symlink before,learn something new everyday.
        with my Xrouter running under ubuntu i never had to make a symlink.

        regards
        Ken g7vja


        --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:
        >
        > You have to create a symlink
        >
        > From the docs:
        >
        > As serial port names are pretty variable in Linux, the code accesses them
        > via symlinks in the linbpq directory to ports called com1 - com255. So, for
        > example, to access a TNC connected to the serial port on the PI, enter
        >
        >
        >
        > ln -s /dev/ttyAMA0 com1 (lower case!)
        >
        >
        >
        > In you case
        >
        >
        >
        > ln -s /dev/ttyS0 com1
        >
        >
        >
        > 73, John
        >
        >
        >
        >
        >
        > _____
        >
        > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
        > kenny
        > Sent: 03 February 2013 14:49
        > To: BPQ32@...
        > Subject: [BPQ32] Re: ubuntu port
        >
        >
        >
        >
        > Hi John
        > its ttys0,.. ttySierra zero
        > never made a symlink
        > the rights are ok
        >
        > Ken
        >
        > --- In BPQ32@yahoogroups.com , "John
        > Wiseman" wrote:
        > >
        > > Ok, Ken.
        > >
        > > Do you create the symlink from com1 to /dev/ttyS0? (Is it S zero or S
        > letter
        > > o?). Also check the rights on com1 and /dev/ttyS0.
        > >
        > > 73, John
        > >
        > >
        > > _____
        > >
        > > From: BPQ32@yahoogroups.com
        > [mailto:BPQ32@yahoogroups.com ] On Behalf
        > Of
        > > kenny
        > > Sent: 03 February 2013 13:35
        > > To: BPQ32@yahoogroups.com
        > > Subject: [BPQ32] Re: ubuntu port
        > >
        > >
        > >
        > >
        > >
        > > Hi John
        > > i am using your sample now,the error
        > > i am now getting is:
        > > ASYNC Com1 Chan A /home/linbpq/com1 could not be opened
        > >
        > > Ken
        > >
        > > --- In BPQ32@yahoogroups.com , "John
        > > Wiseman" wrote:
        > > >
        > > > Ken,
        > > >
        > > > When you say not seeing it, do you mean there is an error reported on
        > > > startup, or just that it doesn't work.?
        > > >
        > > > PORT
        > > > ID=KISS
        > > > TYPE=ASYNC
        > > > PROTOCOL=KISS
        > > > SPEED=9600
        > > > COMPORT=1
        > > > CHANNEL=A
        > > > QUALITY=0
        > > > MAXFRAME=2
        > > > FRACK=7000
        > > > RESPTIME=1500
        > > > RETRIES=10
        > > > PACLEN=128
        > > > TXDELAY=500
        > > > SLOTTIME=100
        > > > PERSIST=64
        > > > ;
        > > > ENDPORT
        > > >
        > > > 73, John
        > > >
        > > >
        > > > _____
        > > >
        > > > From: BPQ32@yahoogroups.com
        > > [mailto:BPQ32@yahoogroups.com ] On
        > Behalf
        > > Of
        > > > kenny
        > > > Sent: 03 February 2013 12:45
        > > > To: BPQ32@yahoogroups.com
        > > > Subject: [BPQ32] ubuntu port
        > > >
        > > >
        > > >
        > > >
        > > > Hi All
        > > > anyone got a sample port setting for ttyS0 (com1)
        > > > my ubuntu,bpq is not seeing it.
        > > >
        > > > Ken g7vja
        > > >
        > > >
        > > >
        > > >
        > > > _
        > > >
        > > d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
        > > > .
        > > >
        > >
        >
      • John Wiseman
        Well, this isn t xrouter! I thought the instructions were pretty clear. Sorry. 73, John _____ From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On
        Message 3 of 15 , Feb 3 7:59 AM
        • 0 Attachment
          Well, this isn't xrouter! I thought the instructions were pretty clear. Sorry.
           
          73, John
           

          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kenny
          Sent: 03 February 2013 15:48
          To: BPQ32@yahoogroups.com
          Subject: [BPQ32] Re: ubuntu port

           

          All working now John
          i have never had to make a symlink before,learn something new everyday.
          with my Xrouter running under ubuntu i never had to make a symlink.

          regards
          Ken g7vja

          --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:

          >
          > You have to create a symlink
          >
          > From the
          docs:
          >
          > As serial port names are pretty variable in Linux, the
          code accesses them
          > via symlinks in the linbpq directory to ports called
          com1 - com255. So, for
          > example, to access a TNC connected to the serial
          port on the PI, enter
          >
          >
          >
          > ln -s /dev/ttyAMA0 com1
          (lower case!)
          >
          >
          >
          > In you case
          >
          >
          >
          > ln -s /dev/ttyS0 com1
          >
          >
          >
          > 73,
          John
          >
          >
          >
          >
          >
          > _____
          >
          > From:
          href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
          > kenny
          > Sent: 03 February 2013 14:49
          > To:
          BPQ32@...
          > Subject: [BPQ32] Re: ubuntu port
          >
          >
          >
          >
          > Hi John
          > its ttys0,.. ttySierra zero
          > never made
          a symlink
          > the rights are ok
          >
          > Ken
          >
          > --- In
          BPQ32@yahoogroups.com , "John
          > Wiseman" wrote:
          > >
          > > Ok, Ken.
          > >
          > > Do you create the symlink from com1 to /dev/ttyS0? (Is it S zero
          or S
          > letter
          > > o?). Also check the rights on com1 and
          /dev/ttyS0.
          > >
          > > 73, John
          > >
          > >
          > > _____
          > >
          > > From:
          href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com
          >
          [mailto:BPQ32@yahoogroups.com ] On Behalf
          > Of
          > > kenny
          > > Sent: 03 February 2013
          13:35
          > > To:
          href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com
          > >
          Subject: [BPQ32] Re: ubuntu port
          > >
          > >
          > >
          > >
          > >
          > > Hi John
          > > i am using your
          sample now,the error
          > > i am now getting is:
          > > ASYNC Com1
          Chan A /home/linbpq/com1 could not be opened
          > >
          > >
          Ken
          > >
          > > --- In
          href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com , "John
          > > Wiseman" wrote:
          > > >
          > > > Ken,
          > > >
          > > > When you say not seeing it, do you mean there is an error
          reported on
          > > > startup, or just that it doesn't work.?
          > > >
          > > > PORT
          > > > ID=KISS
          > > >
          TYPE=ASYNC
          > > > PROTOCOL=KISS
          > > > SPEED=9600
          > > > COMPORT=1
          > > > CHANNEL=A
          > > >
          QUALITY=0
          > > > MAXFRAME=2
          > > > FRACK=7000
          > > > RESPTIME=1500
          > > > RETRIES=10
          > > >
          PACLEN=128
          > > > TXDELAY=500
          > > > SLOTTIME=100
          > > > PERSIST=64
          > > > ;
          > > > ENDPORT
          > > >
          > > > 73, John
          > > >
          > > >
          > > > _____
          > > >
          > > > From:
          href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com
          > >
          [mailto:BPQ32@yahoogroups.com ] On
          > Behalf
          > > Of
          > > > kenny
          > > >
          Sent: 03 February 2013 12:45
          > > > To:
          href="mailto:BPQ32%40yahoogroups.com">BPQ32@yahoogroups.com
          > > > Subject: [BPQ32] ubuntu port
          > > >
          > > >
          > > >
          > > >
          > > > Hi All
          > > > anyone
          got a sample port setting for ttyS0 (com1)
          > > > my ubuntu,bpq is
          not seeing it.
          > > >
          > > > Ken g7vja
          > > >
          > > >
          > > >
          > > >
          > > >
          _
          > > >
          > >
          d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
          > > > .
          > > >
          > >
          >

        • Tommi Holopainen
          I tryed symlink, but I dont know how to do... I got toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$ ln --s /dev/ttyUSB0 com1 ln: target `com1 is not a
          Message 4 of 15 , Feb 4 10:50 AM
          • 0 Attachment
            I tryed symlink, but I dont know how to do... I got

            toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$ ln –s /dev/ttyUSB0 com1
            ln: target `com1' is not a directory
            toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$


            Do I have to do com1 directory or something in  bpq_ubuntu folder?


            -Tommi OH7JJT


            On 03.02.2013 17:59, John Wiseman wrote:
             

            Well, this isn't xrouter! I thought the instructions were pretty clear. Sorry.
             
            73, John
             

            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kenny
            Sent: 03 February 2013 15:48
            To: BPQ32@yahoogroups.com
            Subject: [BPQ32] Re: ubuntu port

             

            All working now John
            i have never had to make a symlink before,learn something new everyday.
            with my Xrouter running under ubuntu i never had to make a symlink.

            regards
            Ken g7vja

            --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:
            >
            > You have to create a symlink
            >
            > From the docs:
            >
            > As serial port names are pretty variable in Linux, the code accesses them
            > via symlinks in the linbpq directory to ports called com1 - com255. So, for
            > example, to access a TNC connected to the serial port on the PI, enter
            >
            >
            >
            > ln -s /dev/ttyAMA0 com1 (lower case!)
            >
            >
            >
            > In you case
            >
            >
            >
            > ln -s /dev/ttyS0 com1
            >
            >
            >
            > 73, John
            >
            >
            >
            >
            >
            > _____
            >
            > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
            > kenny
            > Sent: 03 February 2013 14:49
            > To: BPQ32@...
            > Subject: [BPQ32] Re: ubuntu port
            >
            >
            >
            >
            > Hi John
            > its ttys0,.. ttySierra zero
            > never made a symlink
            > the rights are ok
            >
            > Ken
            >
            > --- In BPQ32@yahoogroups.com , "John
            > Wiseman" wrote:
            > >
            > > Ok, Ken.
            > >
            > > Do you create the symlink from com1 to /dev/ttyS0? (Is it S zero or S
            > letter
            > > o?). Also check the rights on com1 and /dev/ttyS0.
            > >
            > > 73, John
            > >
            > >
            > > _____
            > >
            > > From: BPQ32@yahoogroups.com
            > [mailto:BPQ32@yahoogroups.com ] On Behalf
            > Of
            > > kenny
            > > Sent: 03 February 2013 13:35
            > > To: BPQ32@yahoogroups.com
            > > Subject: [BPQ32] Re: ubuntu port
            > >
            > >
            > >
            > >
            > >
            > > Hi John
            > > i am using your sample now,the error
            > > i am now getting is:
            > > ASYNC Com1 Chan A /home/linbpq/com1 could not be opened
            > >
            > > Ken
            > >
            > > --- In BPQ32@yahoogroups.com , "John
            > > Wiseman" wrote:
            > > >
            > > > Ken,
            > > >
            > > > When you say not seeing it, do you mean there is an error reported on
            > > > startup, or just that it doesn't work.?
            > > >
            > > > PORT
            > > > ID=KISS
            > > > TYPE=ASYNC
            > > > PROTOCOL=KISS
            > > > SPEED=9600
            > > > COMPORT=1
            > > > CHANNEL=A
            > > > QUALITY=0
            > > > MAXFRAME=2
            > > > FRACK=7000
            > > > RESPTIME=1500
            > > > RETRIES=10
            > > > PACLEN=128
            > > > TXDELAY=500
            > > > SLOTTIME=100
            > > > PERSIST=64
            > > > ;
            > > > ENDPORT
            > > >
            > > > 73, John
            > > >
            > > >
            > > > _____
            > > >
            > > > From: BPQ32@yahoogroups.com
            > > [mailto:BPQ32@yahoogroups.com ] On
            > Behalf
            > > Of
            > > > kenny
            > > > Sent: 03 February 2013 12:45
            > > > To: BPQ32@yahoogroups.com
            > > > Subject: [BPQ32] ubuntu port
            > > >
            > > >
            > > >
            > > >
            > > > Hi All
            > > > anyone got a sample port setting for ttyS0 (com1)
            > > > my ubuntu,bpq is not seeing it.
            > > >
            > > > Ken g7vja
            > > >
            > > >
            > > >
            > > >
            > > > _
            > > >
            > > d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
            > > > .
            > > >
            > >
            >


          • John Wiseman
            Tommi, I don t understand that. com1 isn t a directory. Thre only clue I found was in the ln docs * It is an error if the last argument is not a directory and
            Message 5 of 15 , Feb 4 12:13 PM
            • 0 Attachment
              Tommi,
               
              I don't understand that. com1 isn't a directory.
               
              Thre only clue I found was in the ln  docs
               
              * It is an error if the last argument is not a directory and more than two files are given.
               
              The character before the s looks a bit long for a - (minux sign). Maybe it was mistyped. It may be worth trying retyping the command.
               
              John
               
               

              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Tommi Holopainen
              Sent: 04 February 2013 18:50
              To: BPQ32@yahoogroups.com
              Subject: Re: [BPQ32] Re: ubuntu port

               

              I tryed symlink, but I dont know how to do... I got

              toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$ ln –s /dev/ttyUSB0 com1
              ln: target `com1' is not a directory  
              toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$


              Do I have to do com1 directory or something in  bpq_ubuntu folder?


              -Tommi OH7JJT


            • Jim
              try this Tommie ln -s /dev/ttyUSB0 com1 must be USB uppercase the 0 (zero) Jim wu3v if sucessful it should show in the directory as @com1 ... From: Tommi
              Message 6 of 15 , Feb 5 12:00 AM
              • 0 Attachment
                try this Tommie
                ln -s /dev/ttyUSB0 com1
                must be USB uppercase the 0 (zero)
                Jim wu3v
                if sucessful it should show in the directory as
                @com1
                 
                ----- Original Message -----
                Sent: Monday, February 04, 2013 06:50 PM
                Subject: Re: [BPQ32] Re: ubuntu port

                 

                I tryed symlink, but I dont know how to do... I got

                toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$ ln –s /dev/ttyUSB0 com1
                ln: target `com1' is not a directory
                toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$


                Do I have to do com1 directory or something in  bpq_ubuntu folder?


                -Tommi OH7JJT


                On 03.02.2013 17:59, John Wiseman wrote:
                 

                Well, this isn't xrouter! I thought the instructions were pretty clear. Sorry.
                 
                73, John
                 

                From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kenny
                Sent: 03 February 2013 15:48
                To: BPQ32@yahoogroups.com
                Subject: [BPQ32] Re: ubuntu port

                 

                All working now John
                i have never had to make a symlink before,learn something new everyday.
                with my Xrouter running under ubuntu i never had to make a symlink.

                regards
                Ken g7vja

                --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:
                >
                > You have to create a symlink
                >
                > From the docs:
                >
                > As serial port names are pretty variable in Linux, the code accesses them
                > via symlinks in the linbpq directory to ports called com1 - com255. So, for
                > example, to access a TNC connected to the serial port on the PI, enter
                >
                >
                >
                > ln -s /dev/ttyAMA0 com1 (lower case!)
                >
                >
                >
                > In you case
                >
                >
                >
                > ln -s /dev/ttyS0 com1
                >
                >
                >
                > 73, John
                >
                >
                >
                >
                >
                > _____
                >
                > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
                > kenny
                > Sent: 03 February 2013 14:49
                > To: BPQ32@...
                > Subject: [BPQ32] Re: ubuntu port
                >
                >
                >
                >
                > Hi John
                > its ttys0,.. ttySierra zero
                > never made a symlink
                > the rights are ok
                >
                > Ken
                >
                > --- In BPQ32@yahoogroups.com , "John
                > Wiseman" wrote:
                > >
                > > Ok, Ken.
                > >
                > > Do you create the symlink from com1 to /dev/ttyS0? (Is it S zero or S
                > letter
                > > o?). Also check the rights on com1 and /dev/ttyS0.
                > >
                > > 73, John
                > >
                > >
                > > _____
                > >
                > > From: BPQ32@yahoogroups.com
                > [mailto:BPQ32@yahoogroups.com ] On Behalf
                > Of
                > > kenny
                > > Sent: 03 February 2013 13:35
                > > To: BPQ32@yahoogroups.com
                > > Subject: [BPQ32] Re: ubuntu port
                > >
                > >
                > >
                > >
                > >
                > > Hi John
                > > i am using your sample now,the error
                > > i am now getting is:
                > > ASYNC Com1 Chan A /home/linbpq/com1 could not be opened
                > >
                > > Ken
                > >
                > > --- In BPQ32@yahoogroups.com , "John
                > > Wiseman" wrote:
                > > >
                > > > Ken,
                > > >
                > > > When you say not seeing it, do you mean there is an error reported on
                > > > startup, or just that it doesn't work.?
                > > >
                > > > PORT
                > > > ID=KISS
                > > > TYPE=ASYNC
                > > > PROTOCOL=KISS
                > > > SPEED=9600
                > > > COMPORT=1
                > > > CHANNEL=A
                > > > QUALITY=0
                > > > MAXFRAME=2
                > > > FRACK=7000
                > > > RESPTIME=1500
                > > > RETRIES=10
                > > > PACLEN=128
                > > > TXDELAY=500
                > > > SLOTTIME=100
                > > > PERSIST=64
                > > > ;
                > > > ENDPORT
                > > >
                > > > 73, John
                > > >
                > > >
                > > > _____
                > > >
                > > > From: BPQ32@yahoogroups.com
                > > [mailto:BPQ32@yahoogroups.com ] On
                > Behalf
                > > Of
                > > > kenny
                > > > Sent: 03 February 2013 12:45
                > > > To: BPQ32@yahoogroups.com
                > > > Subject: [BPQ32] ubuntu port
                > > >
                > > >
                > > >
                > > >
                > > > Hi All
                > > > anyone got a sample port setting for ttyS0 (com1)
                > > > my ubuntu,bpq is not seeing it.
                > > >
                > > > Ken g7vja
                > > >
                > > >
                > > >
                > > >
                > > > _
                > > >
                > > d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
                > > > .
                > > >
                > >
                >


              • Jim
                also just after boot or pluging in the usb dongle type dmesg tail or dmesg -tail that will gove you the last system changes Jim ... From: Tommi Holopainen To:
                Message 7 of 15 , Feb 5 12:04 AM
                • 0 Attachment
                  also just after boot or pluging in the usb dongle type
                  dmesg tail or
                  dmesg -tail
                  that will gove you the last system changes
                  Jim
                   
                   
                   
                  ----- Original Message -----
                  Sent: Monday, February 04, 2013 06:50 PM
                  Subject: Re: [BPQ32] Re: ubuntu port

                   

                  I tryed symlink, but I dont know how to do... I got

                  toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$ ln –s /dev/ttyUSB0 com1
                  ln: target `com1' is not a directory
                  toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$


                  Do I have to do com1 directory or something in  bpq_ubuntu folder?


                  -Tommi OH7JJT


                  On 03.02.2013 17:59, John Wiseman wrote:
                   

                  Well, this isn't xrouter! I thought the instructions were pretty clear. Sorry.
                   
                  73, John
                   

                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kenny
                  Sent: 03 February 2013 15:48
                  To: BPQ32@yahoogroups.com
                  Subject: [BPQ32] Re: ubuntu port

                   

                  All working now John
                  i have never had to make a symlink before,learn something new everyday.
                  with my Xrouter running under ubuntu i never had to make a symlink.

                  regards
                  Ken g7vja

                  --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:
                  >
                  > You have to create a symlink
                  >
                  > From the docs:
                  >
                  > As serial port names are pretty variable in Linux, the code accesses them
                  > via symlinks in the linbpq directory to ports called com1 - com255. So, for
                  > example, to access a TNC connected to the serial port on the PI, enter
                  >
                  >
                  >
                  > ln -s /dev/ttyAMA0 com1 (lower case!)
                  >
                  >
                  >
                  > In you case
                  >
                  >
                  >
                  > ln -s /dev/ttyS0 com1
                  >
                  >
                  >
                  > 73, John
                  >
                  >
                  >
                  >
                  >
                  > _____
                  >
                  > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
                  > kenny
                  > Sent: 03 February 2013 14:49
                  > To: BPQ32@...
                  > Subject: [BPQ32] Re: ubuntu port
                  >
                  >
                  >
                  >
                  > Hi John
                  > its ttys0,.. ttySierra zero
                  > never made a symlink
                  > the rights are ok
                  >
                  > Ken
                  >
                  > --- In BPQ32@yahoogroups.com , "John
                  > Wiseman" wrote:
                  > >
                  > > Ok, Ken.
                  > >
                  > > Do you create the symlink from com1 to /dev/ttyS0? (Is it S zero or S
                  > letter
                  > > o?). Also check the rights on com1 and /dev/ttyS0.
                  > >
                  > > 73, John
                  > >
                  > >
                  > > _____
                  > >
                  > > From: BPQ32@yahoogroups.com
                  > [mailto:BPQ32@yahoogroups.com ] On Behalf
                  > Of
                  > > kenny
                  > > Sent: 03 February 2013 13:35
                  > > To: BPQ32@yahoogroups.com
                  > > Subject: [BPQ32] Re: ubuntu port
                  > >
                  > >
                  > >
                  > >
                  > >
                  > > Hi John
                  > > i am using your sample now,the error
                  > > i am now getting is:
                  > > ASYNC Com1 Chan A /home/linbpq/com1 could not be opened
                  > >
                  > > Ken
                  > >
                  > > --- In BPQ32@yahoogroups.com , "John
                  > > Wiseman" wrote:
                  > > >
                  > > > Ken,
                  > > >
                  > > > When you say not seeing it, do you mean there is an error reported on
                  > > > startup, or just that it doesn't work.?
                  > > >
                  > > > PORT
                  > > > ID=KISS
                  > > > TYPE=ASYNC
                  > > > PROTOCOL=KISS
                  > > > SPEED=9600
                  > > > COMPORT=1
                  > > > CHANNEL=A
                  > > > QUALITY=0
                  > > > MAXFRAME=2
                  > > > FRACK=7000
                  > > > RESPTIME=1500
                  > > > RETRIES=10
                  > > > PACLEN=128
                  > > > TXDELAY=500
                  > > > SLOTTIME=100
                  > > > PERSIST=64
                  > > > ;
                  > > > ENDPORT
                  > > >
                  > > > 73, John
                  > > >
                  > > >
                  > > > _____
                  > > >
                  > > > From: BPQ32@yahoogroups.com
                  > > [mailto:BPQ32@yahoogroups.com ] On
                  > Behalf
                  > > Of
                  > > > kenny
                  > > > Sent: 03 February 2013 12:45
                  > > > To: BPQ32@yahoogroups.com
                  > > > Subject: [BPQ32] ubuntu port
                  > > >
                  > > >
                  > > >
                  > > >
                  > > > Hi All
                  > > > anyone got a sample port setting for ttyS0 (com1)
                  > > > my ubuntu,bpq is not seeing it.
                  > > >
                  > > > Ken g7vja
                  > > >
                  > > >
                  > > >
                  > > >
                  > > > _
                  > > >
                  > > d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
                  > > > .
                  > > >
                  > >
                  >


                • holopainen_tommi
                  Hello Nw Working Just booting PC and copied ur line Maybe some typing error or something Tnx -Tommi OH7JJT
                  Message 8 of 15 , Feb 5 8:50 AM
                  • 0 Attachment
                    Hello

                    Nw Working
                    Just booting PC and copied ur line
                    Maybe some typing error or something

                    Tnx

                    -Tommi OH7JJT



                    --- In BPQ32@yahoogroups.com, "Jim" wrote:
                    >
                    > try this Tommie
                    > ln -s /dev/ttyUSB0 com1
                    > must be USB uppercase the 0 (zero)
                    > Jim wu3v
                    > if sucessful it should show in the directory as
                    > @com1
                    >
                    > ----- Original Message -----
                    > From: Tommi Holopainen
                    > To: BPQ32@yahoogroups.com
                    > Sent: Monday, February 04, 2013 06:50 PM
                    > Subject: Re: [BPQ32] Re: ubuntu port
                    >
                    >
                    >
                    >
                    > I tryed symlink, but I dont know how to do... I got
                    >
                    > toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$ ln -s /dev/ttyUSB0 com1
                    > ln: target `com1' is not a directory
                    > toshiba@toshiba-laptop:~/Lataukset/bpq_ubuntu$
                    >
                    >
                    > Do I have to do com1 directory or something in bpq_ubuntu folder?
                    >
                    >
                    > -Tommi OH7JJT
                    >
                    >
                    > On 03.02.2013 17:59, John Wiseman wrote:
                    >
                    >
                    >
                    > Well, this isn't xrouter! I thought the instructions were pretty clear. Sorry.
                    >
                    > 73, John
                    >
                    >
                    > ----------------------------------------------------------------------------
                    >
                    > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kenny
                    > Sent: 03 February 2013 15:48
                    > To: BPQ32@yahoogroups.com
                    > Subject: [BPQ32] Re: ubuntu port
                    >
                    >
                    >
                    > All working now John
                    > i have never had to make a symlink before,learn something new everyday.
                    > with my Xrouter running under ubuntu i never had to make a symlink.
                    >
                    > regards
                    > Ken g7vja
                    >
                    > --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:
                    > >
                    > > You have to create a symlink
                    > >
                    > > From the docs:
                    > >
                    > > As serial port names are pretty variable in Linux, the code accesses them
                    > > via symlinks in the linbpq directory to ports called com1 - com255. So, for
                    > > example, to access a TNC connected to the serial port on the PI, enter
                    > >
                    > >
                    > >
                    > > ln -s /dev/ttyAMA0 com1 (lower case!)
                    > >
                    > >
                    > >
                    > > In you case
                    > >
                    > >
                    > >
                    > > ln -s /dev/ttyS0 com1
                    > >
                    > >
                    > >
                    > > 73, John
                    > >
                    > >
                    > >
                    > >
                    > >
                    > > _____
                    > >
                    > > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
                    > > kenny
                    > > Sent: 03 February 2013 14:49
                    > > To: BPQ32@
                    > > Subject: [BPQ32] Re: ubuntu port
                    > >
                    > >
                    > >
                    > >
                    > > Hi John
                    > > its ttys0,.. ttySierra zero
                    > > never made a symlink
                    > > the rights are ok
                    > >
                    > > Ken
                    > >
                    > > --- In BPQ32@yahoogroups.com , "John
                    > > Wiseman" wrote:
                    > > >
                    > > > Ok, Ken.
                    > > >
                    > > > Do you create the symlink from com1 to /dev/ttyS0? (Is it S zero or S
                    > > letter
                    > > > o?). Also check the rights on com1 and /dev/ttyS0.
                    > > >
                    > > > 73, John
                    > > >
                    > > >
                    > > > _____
                    > > >
                    > > > From: BPQ32@yahoogroups.com
                    > > [mailto:BPQ32@yahoogroups.com ] On Behalf
                    > > Of
                    > > > kenny
                    > > > Sent: 03 February 2013 13:35
                    > > > To: BPQ32@yahoogroups.com
                    > > > Subject: [BPQ32] Re: ubuntu port
                    > > >
                    > > >
                    > > >
                    > > >
                    > > >
                    > > > Hi John
                    > > > i am using your sample now,the error
                    > > > i am now getting is:
                    > > > ASYNC Com1 Chan A /home/linbpq/com1 could not be opened
                    > > >
                    > > > Ken
                    > > >
                    > > > --- In BPQ32@yahoogroups.com , "John
                    > > > Wiseman" wrote:
                    > > > >
                    > > > > Ken,
                    > > > >
                    > > > > When you say not seeing it, do you mean there is an error reported on
                    > > > > startup, or just that it doesn't work.?
                    > > > >
                    > > > > PORT
                    > > > > ID=KISS
                    > > > > TYPE=ASYNC
                    > > > > PROTOCOL=KISS
                    > > > > SPEED=9600
                    > > > > COMPORT=1
                    > > > > CHANNEL=A
                    > > > > QUALITY=0
                    > > > > MAXFRAME=2
                    > > > > FRACK=7000
                    > > > > RESPTIME=1500
                    > > > > RETRIES=10
                    > > > > PACLEN=128
                    > > > > TXDELAY=500
                    > > > > SLOTTIME=100
                    > > > > PERSIST=64
                    > > > > ;
                    > > > > ENDPORT
                    > > > >
                    > > > > 73, John
                    > > > >
                    > > > >
                    > > > > _____
                    > > > >
                    > > > > From: BPQ32@yahoogroups.com
                    > > > [mailto:BPQ32@yahoogroups.com ] On
                    > > Behalf
                    > > > Of
                    > > > > kenny
                    > > > > Sent: 03 February 2013 12:45
                    > > > > To: BPQ32@yahoogroups.com
                    > > > > Subject: [BPQ32] ubuntu port
                    > > > >
                    > > > >
                    > > > >
                    > > > >
                    > > > > Hi All
                    > > > > anyone got a sample port setting for ttyS0 (com1)
                    > > > > my ubuntu,bpq is not seeing it.
                    > > > >
                    > > > > Ken g7vja
                    > > > >
                    > > > >
                    > > > >
                    > > > >
                    > > > > _
                    > > > >
                    > > > d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
                    > > > > .
                    > > > >
                    > > >
                    > >
                    >
                  • Shawn Bush
                    Well I would love to get this running, but it seems to be hard coded for com1... I created a sym link to /dev/ttyS0 called com1 and its in the same directory
                    Message 9 of 15 , Feb 6 4:53 AM
                    • 0 Attachment
                      Well I would love to get this running, but it seems to be hard coded for com1...
                      I created a sym link to /dev/ttyS0 called com1 and its in the same directory as bpq is, but it dosen't seem to like to read it, and the instructions mention a modded BBS .exe file that creates a linbpq.conf. I have ran it several times and I see no such file any where.

                      lrwxrwxrwx 1 linbpq linbpq      10 Feb  5 11:30 com1 -> /dev/ttyS0
                    • John Wiseman
                      No, you can specify any port com1 - com255. What error message do you get when you start linbpq? What are the rights on /dev/ttyS0? I ve just run BPQMailChat,
                      Message 10 of 15 , Feb 6 5:12 AM
                      • 0 Attachment
                        No, you can specify any port com1 - com255. What error message do you get when you start linbpq? What are the rights on /dev/ttyS0?
                         
                        I've just run BPQMailChat, and it created linmail.cfg in the BPQ32/BPQMailChat fiolder. It should display version 1.4.53.10 - if not, you are running the wrong version.
                         
                        73, John
                         
                         


                        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Shawn Bush
                        Sent: 06 February 2013 12:54
                        To: BPQ32@yahoogroups.com
                        Subject: [BPQ32] Re: ubuntu port

                         

                        Well I would love to get this running, but it seems to be hard coded for com1...
                        I created a sym link to /dev/ttyS0 called com1 and its in the same directory as bpq is, but it dosen't seem to like to read it, and the instructions mention a modded BBS .exe file that creates a linbpq.conf. I have ran it several times and I see no such file any where.

                        lrwxrwxrwx 1 linbpq linbpq      10 Feb  5 11:30 com1 -> /dev/ttyS0

                      Your message has been successfully submitted and would be delivered to recipients shortly.