Loading ...
Sorry, an error occurred while loading the content.

Re: 220 ESMTP UCE strictly prohibited

Expand Messages
  • james_nf8i
    In the old SMTP spec, HELO is a perfectly valid Client Hello string. However, if the client wants to use Extended SMTP (ESMTP) options, it should send EHLO,
    Message 1 of 6 , Dec 3, 2012
    • 0 Attachment
      In the old SMTP spec, HELO is a perfectly valid Client Hello string. However, if the client wants to use "Extended SMTP" (ESMTP) options, it should send EHLO, the Extended Hello string. STARTTLS is only valid when using Extended SMTP, so the client should send EHLO (but only if the client is prepared to do ESMTP).

      The other option that is commonly used is to run plain ol' SMTP (or ESMTP) over SSL/TLS on port 465. In this case, STARTTLS is NOT used; instead, the entire connection is done over SSL (similar to HTTPS on 443).

      73 de NF8I,

      ~James

      --- In BPQ32@yahoogroups.com, "k9drh@..." <k9drh@...> wrote:
      >
      >
      > from what I know about email it looks like mailchat is sending HELO instead of EHLO before StartTLS. I could be wrong but there is something wrong.
    • k9drh@sbcglobal.net
      Follow up and closure Thanks John, It seems as though iPage Post Office server is very Persnickety. John provided me with a modified version of BPQMailChat to
      Message 2 of 6 , Dec 8, 2012
      • 0 Attachment
        Follow up and closure
        Thanks John,
        It seems as though iPage Post Office server is very Persnickety.
        John provided me with a modified version of BPQMailChat to get me up and running.
        Thanks John again.
        73 Dave K9DRH

        --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
        >
        > Dave,
        >
        > I suspect I am not complient, but some servers are less fussy than others.
        > I'm travelling at the moment, but will investigae when I arrive.
        >
        > I use wireshark to monitor what is actually sent on tcp sessions.
        >
        > 73, John
        >
        >
        >
        > _____
        >
        > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
        > k9drh@...
        > Sent: 03 December 2012 12:36
        > To: BPQ32@yahoogroups.com
        > Subject: [BPQ32] Re: 220 ESMTP UCE strictly prohibited
        >
        >
        >
        >
        > Thanks John,
        > however after future investigation I probably should have renamed this to
        > 503 AUTH command used when not advertised
        > since this is the real error prventing me from sending emails.
        > I do not believe this is a code problem since gmail works.
        > This eigbox.net server must have some options set wrong. Hold off until I
        > get an answer from them.
        > You are compliant with RFC 5321 right?
        > Is there a way to capture the raw hex being sent to the TCP port?
        > The fact the successful logon from the "250 bosauthsmtp11.eigbox.net Hello
        > K9DRH [99.140.215.91]"
        > It is the next commands or order of commands sent that the server is
        > complaining about with 503 error.
        >
        > 73, Dave
        >
        > --- In BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com> , "John
        > Wiseman" <john.wiseman@> wrote:
        > >
        > > Probaby my misunderstanding of the SMTP specs.
        > >
        > > I'll look into it.
        > >
        > > 73, John
        > >
        > > _____
        > >
        > > From: BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com>
        > [mailto:BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com> ] On Behalf
        > Of
        > > k9drh@
        > > Sent: 02 December 2012 18:00
        > > To: BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com>
        > > Subject: [BPQ32] 220 ESMTP UCE strictly prohibited
        > >
        > >
        > >
        > >
        > >
        > > Well I searched and did not find an answer in the messages so I am asking
        > if
        > > anyone knows how to resolve this in MailChat.
        > > Website is new and hosted by iPage. I had email gateway working on gmail
        > and
        > > decided to use my own site. POP works and receives email just fine. I can
        > > configure Outlook and express and everything works with k9drh.com.
        > > from what I know about email it looks like mailchat is sending HELO
        > instead
        > > of EHLO before StartTLS. I could be wrong but there is something wrong.
        > > Here's a clip of the log.
        > >
        > > Connecting to Server smtp.k9drh.com to send Msg 307
        > > 220 ESMTP Sat, 01 Dec 2012 13:01:28 -0500: UCE strictly prohibited
        > > HELO K9DRH
        > > 250 bosauthsmtp11.eigbox.net Hello K9DRH [99.140.215.91]
        > > AUTH LOGIN
        > > 503 AUTH command used when not advertised
        > > QUIT
        > > 221 bosauthsmtp11.eigbox.net closing connection
        > >
        > > Any ideas or suggestion.
        > > OH and before anyone says it pop is 110 and smtp 587 smtp auth checked as
        > > per ipage.
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.