Loading ...
Sorry, an error occurred while loading the content.
 

Re: [BPQ32] Does anybody else have bpq32 crashing?

Expand Messages
  • Steve
    I m not running APRS but I have a telnet connection and about 2 weeks ago I was having crash after crash. John diagnosed that issue as being related to
    Message 1 of 14 , Jul 9, 2012
      I'm not running APRS but I have a telnet connection and about 2 weeks ago I was having crash after crash. John diagnosed that issue as being related to excessively long lines in messages composed with Outpost. He supplied a trial bpq.dll and it fixed the issue. No idea if this is in anyway related to what you are seeing but I was pulling my hair out too.

      73,
      Steve KB1TCE

      On 7/9/2012 1:18 PM, Bill Vodall wrote:  

      Last week I put the latest BPQ32 on the little ASUS 900 Win XP system.
      It was running fine... Great. Wow!

      Yesterday I turned on BPQAPRS. Then I tweaked the config to turn on
      the local Webpage and Terminal Server. Since then I've had some "do
      you want to tell Microsoft what happened" crashes. This morning it
      won't run more than a few minutes. Tonight I'll gather more info..

      I really like the HTTPPORT web server. It shows great promise.

      73
      Bill - WA7NWP

    • John Wiseman
      Bill, I m not aware of any problems specifically related to the Web Server. A problem was found in the APRS code that causes crashes if UIVIew is used as an IS
      Message 2 of 14 , Jul 9, 2012

        Bill,

         

        I’m not aware of any problems specifically related to the Web Server. A problem was found in the APRS code that causes crashes if UIVIew is used as an IS Server, but it is possible there could also be problems if corrupt messages were received from APRS-IS.

         

        This should fix that problem - https://dl.dropbox.com/u/31910649/bpq32_5.2.7.6.zip

         

        For the record, this version has the fix for crashes caused by very long lines received by the Telnet Server – this mainly affects Outpost users, and corrects reporting of MARS stations to the WL2K maps.

         

        73, John

         


        From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of Bill Vodall
        Sent: 09 July 2012 18:19
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] Does anybody else have bpq32 crashing?

         

         

        Last week I put the latest BPQ32 on the little ASUS 900 Win XP system.
        It was running fine... Great. Wow!

        Yesterday I turned on BPQAPRS. Then I tweaked the config to turn on
        the local Webpage and Terminal Server. Since then I've had some "do
        you want to tell Microsoft what happened" crashes. This morning it
        won't run more than a few minutes. Tonight I'll gather more info..

        I really like the HTTPPORT web server. It shows great promise.

        73
        Bill - WA7NWP

      • Bill Vodall
        ... Thanks John, I ll install it tonight and see what happens.. Bill
        Message 3 of 14 , Jul 9, 2012
          > I’m not aware of any problems specifically related to the Web Server. A
          > problem was found in the APRS code that causes crashes if UIVIew is used as
          > an IS Server, but it is possible there could also be problems if corrupt
          > messages were received from APRS-IS.
          >
          > This should fix that problem -
          > https://dl.dropbox.com/u/31910649/bpq32_5.2.7.6.zip


          Thanks John, I'll install it tonight and see what happens..

          Bill
        • Jerry
          I been having crashes.. BPQAPRS for some reason.. Working long days and nights no time to troubleshoot. Ley me know if anyone finds any answers.. this is a bad
          Message 4 of 14 , Jul 9, 2012

            I been having crashes.. BPQAPRS for some reason.. Working long days and nights no time to troubleshoot…

             

            Ley me know if anyone finds any answers.. this is a bad time for crashes.. The next two Saturdays are vital to Indiana to gain any momentum and I cannot keep it running very long..

             

            I find it at least once a day crashed and nothing working…

             

            The 14th is a Hamfest I planned to demo at

             

            The 21st is a statewide test and I Will not be home to baby sit my bbs.. So I am on pins and needles on what to do.. Do I wait for a fix or revert to something else.. either permanently or until I have some time to troubleshoot..

             

            Never a good thing, a BBS that runs, it does not..

             

             

            73

             

             

            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Mike Melnik
            Sent: Monday, July 09, 2012 1:35 PM
            To: BPQ32@yahoogroups.com
            Subject: RE: [BPQ32] Does anybody else have bpq32 crashing?

             

             

            Bill

            Yes I have many crashes with BPQ32 latest version but before the HTTP was
            added
            I was having some problems, I am glad you brought this up, I will disable my
            HTTP
            Server, I have at least one crash a day, all BPQ32 Programs windows will
            white out
            And can not access the BPQ Tray Icon.

            I am running Debug View with a new BPQ32.DLL that reports more information
            to Debug
            View, John is aware of my problem, there has also been a couple of others
            that have
            Crashed, but may not be related.

            On the other side of the coin many using the HTTP server or latest version
            of BPQ32
            Have not reported any problems that I know of.

            Just to verify your thoughts try disabling your HTTP server and let us know.

            73

            Mike-N9PMO
            www.n9pmo.com
            -----Original Message-----
            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Bill
            Vodall
            Sent: Monday, July 09, 2012 12:19 PM
            To: BPQ32@yahoogroups.com
            Subject: [BPQ32] Does anybody else have bpq32 crashing?

             
            Last week I put the latest BPQ32 on the little ASUS 900 Win XP system.
            It was running fine... Great. Wow!

            Yesterday I turned on BPQAPRS. Then I tweaked the config to turn on
            the local Webpage and Terminal Server. Since then I've had some "do
            you want to tell Microsoft what happened" crashes. This morning it
            won't run more than a few minutes. Tonight I'll gather more info..

            I really like the HTTPPORT web server. It shows great promise.

            73
            Bill - WA7NWP

          • Bill Vodall
            ... I tried 5.2.7.6 last night and this morning. Maybe better - maybe not. I still get instruction at 0x4206d2d0 referenced memory at 0xffffffffe2 . The
            Message 5 of 14 , Jul 10, 2012
              >
              > This should fix that problem -
              > https://dl.dropbox.com/u/31910649/bpq32_5.2.7.6.zip


              I tried 5.2.7.6 last night and this morning. Maybe better - maybe
              not. I still get

              ""instruction at "0x4206d2d0" referenced memory at "0xffffffffe2".
              The memory could not be "read".

              after a few minutes of the program running.

              I will be home tonight to experiment more and will try turning on the
              Term/http server on my laptop later this afternoon.

              73
              Bill - WA7NWP
            • John Wiseman
              Bill, 0x4206d2d0 is in the C runtime, not my code, which makes it much more difficult to track down, so if you can get a bit more info as to what might be
              Message 6 of 14 , Jul 10, 2012
                Bill,
                 
                0x4206d2d0 is in the 'C' runtime, not my code, which makes it much more difficult to track down, so if you can get a bit more info as to what might be causing it, it would help.
                 
                Thanks,
                John
                 
                 


                From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Bill Vodall
                Sent: 10 July 2012 20:40
                To: BPQ32@yahoogroups.com
                Subject: Re: [BPQ32] Does anybody else have bpq32 crashing?

                 

                >
                > This should fix that problem -
                >

                href="https://dl.dropbox.com/u/31910649/bpq32_5.2.7.6.zip">https://dl.dropbox.com/u/31910649/bpq32_5.2.7.6.zip

                I tried 5.2.7.6 last night and this morning. Maybe better - maybe
                not. I still get

                ""instruction at "0x4206d2d0" referenced memory at "0xffffffffe2".
                The memory could not be "read".

                after a few minutes of the program running.

                I will be home tonight to experiment more and will try turning on the
                Term/http server on my laptop later this afternoon.

                73
                Bill - WA7NWP
              • Bill Vodall
                ... I ran all yesterday and it didn t crash... Only this was on 145.01 and I copied very few packets... :( I switched to the continuous stream on 144.39 -
                Message 7 of 14 , Jul 11, 2012
                  > 0x4206d2d0 is in the 'C' runtime, not my code, which makes it much more
                  > difficult to track down, so if you can get a bit more info as to what might
                  > be causing it, it would help.

                  I ran all yesterday and it didn't crash... Only this was on 145.01
                  and I copied very few packets... :(

                  I switched to the continuous stream on 144.39 - CRASH...

                  I completely turned off the TCP (httpport, tcpport, fbbport) 'port'
                  section and restarted. A few minutes later - CRASH.

                  So this morning, before making breakfast for my sweety I tried turning
                  off the APRS section. That was over an hour ago and it's still
                  running.

                  Is there any way to feed a datafile of test packets to bpq32? If
                  so, I could build a test of the recent packets and find out which are
                  causing the problem..

                  73
                  Bill
                • David Ream
                  Bill I had that trouble in the past and it turned out to be Norton antivirus. Went to another software and have had no trouble since. Dave W2EFC ... From: Bill
                  Message 8 of 14 , Jul 11, 2012
                    Bill
                    I had that trouble in the past and it turned out to be Norton antivirus. Went to another software and have had no trouble since.
                    Dave W2EFC

                    --- On Wed, 7/11/12, Bill Vodall <wa7nwp@...> wrote:

                    From: Bill Vodall <wa7nwp@...>
                    Subject: Re: [BPQ32] Does anybody else have bpq32 crashing?
                    To: BPQ32@yahoogroups.com
                    Date: Wednesday, July 11, 2012, 2:42 PM

                     
                    > 0x4206d2d0 is in the 'C' runtime, not my code, which makes it much more
                    > difficult to track down, so if you can get a bit more info as to what might
                    > be causing it, it would help.

                    I ran all yesterday and it didn't crash... Only this was on 145.01
                    and I copied very few packets... :(

                    I switched to the continuous stream on 144.39 - CRASH...

                    I completely turned off the TCP (httpport, tcpport, fbbport) 'port'
                    section and restarted. A few minutes later - CRASH.

                    So this morning, before making breakfast for my sweety I tried turning
                    off the APRS section. That was over an hour ago and it's still
                    running.

                    Is there any way to feed a datafile of test packets to bpq32? If
                    so, I could build a test of the recent packets and find out which are
                    causing the problem..

                    73
                    Bill
                  • Mike Melnik
                    Bill You can use the Import in the BPQMailChat, Actions, you will need To add the Header SP or SB, TO and end the file with /ex Just copy the file you want to
                    Message 9 of 14 , Jul 11, 2012
                      Bill

                      You can use the Import in the BPQMailChat, Actions, you will need
                      To add the Header SP or SB, TO and end the file with /ex
                      Just copy the file you want to import save it as messages.in Not .txt
                      Save it in the BPQ32\MailChat folder, not root directory, click
                      Import the message will be in your BBS.

                      For the record, myself and two others are testing a New BPQ32.EXE and
                      BPQ32.DLL
                      These give a more comprehensive report to Debug View, John is working on the
                      Problem, just be patient.

                      Also if running WinFbb 7.00e, g or I in the Port configuration, last page,
                      set the
                      MUX to 0.

                      Usually the program you start first will be the program that shows the fail,
                      but does not
                      Mean this is the program that is causing the problem.

                      Hope this helps a bit.

                      73

                      Mike-N9PMO
                      www.n9pmo.com
                      -----Original Message-----
                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Bill
                      Vodall
                      Sent: Wednesday, July 11, 2012 9:43 AM
                      To: BPQ32@yahoogroups.com
                      Subject: Re: [BPQ32] Does anybody else have bpq32 crashing?

                       
                      > 0x4206d2d0 is in the 'C' runtime, not my code, which makes it much more
                      > difficult to track down, so if you can get a bit more info as to what
                      might
                      > be causing it, it would help.

                      I ran all yesterday and it didn't crash... Only this was on 145.01
                      and I copied very few packets... :(

                      I switched to the continuous stream on 144.39 - CRASH...

                      I completely turned off the TCP (httpport, tcpport, fbbport) 'port'
                      section and restarted. A few minutes later - CRASH.

                      So this morning, before making breakfast for my sweety I tried turning
                      off the APRS section. That was over an hour ago and it's still
                      running.

                      Is there any way to feed a datafile of test packets to bpq32? If
                      so, I could build a test of the recent packets and find out which are
                      causing the problem..

                      73
                      Bill
                    • Bill
                      The problem is aprs packets, not bbs messages.... My little asus eee doesn t have mailchat installed and probably never will as the use here is more of a
                      Message 10 of 14 , Jul 11, 2012

                        The problem is aprs packets, not bbs messages....   My little asus eee doesn't have mailchat installed and probably never will as the use here is more of a packet switch, gateway and web resource server.....


                        On Jul 11, 2012, at 5:11 PM, "Mike Melnik" <mmelnik1@...> wrote:

                         

                        Bill

                        You can use the Import in the BPQMailChat, Actions, you will need
                        To add the Header SP or SB, TO and end the file with /ex
                        Just copy the file you want to import save it as messages.in Not .txt
                        Save it in the BPQ32\MailChat folder, not root directory, click
                        Import the message will be in your BBS.

                        For the record, myself and two others are testing a New BPQ32.EXE and
                        BPQ32.DLL


                        Cool...  Thanks...

                      • Bill Vodall
                        FYI - Still running on 144.39 with no problems... Bill
                        Message 11 of 14 , Jul 12, 2012
                          FYI - Still running on 144.39 with no problems...

                          Bill

                          On Wed, Jul 11, 2012 at 7:42 AM, Bill Vodall <wa7nwp@...> wrote:
                          >> 0x4206d2d0 is in the 'C' runtime, not my code, which makes it much more
                          >> difficult to track down, so if you can get a bit more info as to what might
                          >> be causing it, it would help.
                          >
                          > I ran all yesterday and it didn't crash... Only this was on 145.01
                          > and I copied very few packets... :(
                          >
                          > I switched to the continuous stream on 144.39 - CRASH...
                          >
                          > I completely turned off the TCP (httpport, tcpport, fbbport) 'port'
                          > section and restarted. A few minutes later - CRASH.
                          >
                          > So this morning, before making breakfast for my sweety I tried turning
                          > off the APRS section. That was over an hour ago and it's still
                          > running.
                        • Jerry
                          I am now home and off work.. Can you resend me those files and instructions to help find the issues here.. thanks JK From: BPQ32@yahoogroups.com
                          Message 12 of 14 , Jul 12, 2012

                            I am now home and off work.. Can you resend me those files and instructions to help find the issues here.. thanks JK

                             

                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Mike Melnik
                            Sent: Wednesday, July 11, 2012 8:12 PM
                            To: BPQ32@yahoogroups.com
                            Subject: RE: [BPQ32] Does anybody else have bpq32 crashing?

                             

                             

                            Bill

                            You can use the Import in the BPQMailChat, Actions, you will need
                            To add the Header SP or SB, TO and end the file with /ex
                            Just copy the file you want to import save it as messages.in Not .txt
                            Save it in the BPQ32\MailChat folder, not root directory, click
                            Import the message will be in your BBS.

                            For the record, myself and two others are testing a New BPQ32.EXE and
                            BPQ32.DLL
                            These give a more comprehensive report to Debug View, John is working on the
                            Problem, just be patient.

                            Also if running WinFbb 7.00e, g or I in the Port configuration, last page,
                            set the
                            MUX to 0.

                            Usually the program you start first will be the program that shows the fail,
                            but does not
                            Mean this is the program that is causing the problem.

                            Hope this helps a bit.

                            73

                            Mike-N9PMO
                            www.n9pmo.com
                            -----Original Message-----
                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Bill
                            Vodall
                            Sent: Wednesday, July 11, 2012 9:43 AM
                            To: BPQ32@yahoogroups.com
                            Subject: Re: [BPQ32] Does anybody else have bpq32 crashing?

                             

                            > 0x4206d2d0 is in the 'C' runtime, not my code, which makes it much more
                            > difficult to track down, so if you can get a bit more info as to what
                            might
                            > be causing it, it would help.

                            I ran all yesterday and it didn't crash... Only this was on 145.01
                            and I copied very few packets... :(

                            I switched to the continuous stream on 144.39 - CRASH...

                            I completely turned off the TCP (httpport, tcpport, fbbport) 'port'
                            section and restarted. A few minutes later - CRASH.

                            So this morning, before making breakfast for my sweety I tried turning
                            off the APRS section. That was over an hour ago and it's still
                            running.

                            Is there any way to feed a datafile of test packets to bpq32? If
                            so, I could build a test of the recent packets and find out which are
                            causing the problem..

                            73
                            Bill

                          Your message has been successfully submitted and would be delivered to recipients shortly.