Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

Expand Messages
  • John Wiseman
    Thanks, Steve. That is encouraging. Can you try this? - it should fix the problem with long lines. https://dl.dropbox.com/u/31910649/bpq32.zip Remember
    Message 1 of 26 , Jul 1 2:07 PM
    • 0 Attachment
      Thanks, Steve.
       
      That is encouraging. Can you try this? - it should fix the problem with long lines.
       
       
      Remember bpq32.dll goes in the system32 folder.
       
      73,
      John
       


      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kb1tce
      Sent: 01 July 2012 19:17
      To: BPQ32@yahoogroups.com
      Subject: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

       

      Well John, we're now thinking that's it.

      We checked one of the messages from our "crasher" and it consisted of two lines. The second line by itself was about 500 words and 1000 bytes.

      That message was crashing W0ECM's local BPQ32 when sending from Outpost. He had received it ok (by HF/Winmor) but when he tried to forward it to me he got the crash. He then inserted a pile of carriage returns and everything went fine.

      We were fooling ourselves with the brief test messages on Outpost 2.4 because we didn't have messages that contained the real problem.

      Hopefully that's it as far as the diagnosis goes. I would be quite willing to try your test version that addresses this.

      73,
      Steve KB1TCE

      --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:

      >
      > I recently found an error in the
      Telnet code which could cause a problem
      > with sending messages from
      Outpost with a very long list of TO calls (around
      > 30, depending on the
      length of each address). It could also cause problems
      > with very long
      lines (greater than 500 or so bytes) in the message body. If
      > either
      could apply in your case I can send you a test version to see if it
      >
      fixes the problem.
      >
      > 73,
      > John

    • shansen@belljar.net
      John, I should have some time to work with it tomorrow. Thanks much, Steve KB1TCE
      Message 2 of 26 , Jul 1 2:11 PM
      • 0 Attachment
        John,

        I should have some time to work with it tomorrow.

        Thanks much,
        Steve KB1TCE


        > Thanks, Steve.
        >
        > That is encouraging. Can you try this? - it should fix the problem with
        > long
        > lines.
        >
        > https://dl.dropbox.com/u/31910649/bpq32.zip
        >
        > Remember bpq32.dll goes in the system32 folder.
        >
        > 73,
        > John
        >
      • Ken Jacobs
        I confirmed that long lines from Outpost were crashing BPQ as well. The new code seems to have fixed the long lines from Outpost. I tested a msg with almost 3k
        Message 3 of 26 , Jul 1 2:20 PM
        • 0 Attachment
          I confirmed that long lines from Outpost were crashing BPQ as well. The new code seems to have fixed the long lines from Outpost. I tested a msg with almost 3k in a single line with no crash.

          Ken

          On 07/01/2012 02:07 PM, John Wiseman wrote:
           

          Thanks, Steve.
           
          That is encouraging. Can you try this? - it should fix the problem with long lines.
           
           
          Remember bpq32.dll goes in the system32 folder.
           
          73,
          John
           


          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kb1tce
          Sent: 01 July 2012 19:17
          To: BPQ32@yahoogroups.com
          Subject: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

           

          Well John, we're now thinking that's it.

          We checked one of the messages from our "crasher" and it consisted of two lines. The second line by itself was about 500 words and 1000 bytes.

          That message was crashing W0ECM's local BPQ32 when sending from Outpost. He had received it ok (by HF/Winmor) but when he tried to forward it to me he got the crash. He then inserted a pile of carriage returns and everything went fine.

          We were fooling ourselves with the brief test messages on Outpost 2.4 because we didn't have messages that contained the real problem.

          Hopefully that's it as far as the diagnosis goes. I would be quite willing to try your test version that addresses this.

          73,
          Steve KB1TCE

          --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
          >
          > I recently found an error in the Telnet code which could cause a problem
          > with sending messages from Outpost with a very long list of TO calls (around
          > 30, depending on the length of each address). It could also cause problems
          > with very long lines (greater than 500 or so bytes) in the message body. If
          > either could apply in your case I can send you a test version to see if it
          > fixes the problem.
          >
          > 73,
          > John



        • kb1tce
          John (and Ken), It works here also. I took the offending message from before and no issues after installing the new dll file. Thanks so much, Steve KB1TCE
          Message 4 of 26 , Jul 2 5:18 AM
          • 0 Attachment
            John (and Ken),

            It works here also. I took the offending message from before and no issues after installing the new dll file.

            Thanks so much,
            Steve KB1TCE

            --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
            >
            > Thanks, Steve.
            >
            > That is encouraging. Can you try this? - it should fix the problem with long
            > lines.
            >
            > https://dl.dropbox.com/u/31910649/bpq32.zip
            >
            > Remember bpq32.dll goes in the system32 folder.
            >
            > 73,
            > John
          • John Wiseman
            The BPQ32.dll I uploaded last week was not built correctly, and may cause stability problems with some confgurations. If you installed it. plese replace with
            Message 5 of 26 , Jul 6 3:20 AM
            • 0 Attachment
              The BPQ32.dll I uploaded last week was not built correctly, and may cause stability problems with some confgurations. If you installed it. plese replace with this:
               
               
              73, John

              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of John Wiseman
              Sent: 01 July 2012 22:08
              To: BPQ32@yahoogroups.com
              Subject: RE: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

               

              Thanks, Steve.
               
              That is encouraging. Can you try this? - it should fix the problem with long lines.
               
               
              Remember bpq32.dll goes in the system32 folder.
               
              73,
              John
               


              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kb1tce
              Sent: 01 July 2012 19:17
              To: BPQ32@yahoogroups.com
              Subject: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

               

              Well John, we're now thinking that's it.

              We checked one of the messages from our "crasher" and it consisted of two lines. The second line by itself was about 500 words and 1000 bytes.

              That message was crashing W0ECM's local BPQ32 when sending from Outpost. He had received it ok (by HF/Winmor) but when he tried to forward it to me he got the crash. He then inserted a pile of carriage returns and everything went fine.

              We were fooling ourselves with the brief test messages on Outpost 2.4 because we didn't have messages that contained the real problem.

              Hopefully that's it as far as the diagnosis goes. I would be quite willing to try your test version that addresses this.

              73,
              Steve KB1TCE

              --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:

              >
              > I recently found an error in the
              Telnet code which could cause a problem
              > with sending messages from
              Outpost with a very long list of TO calls (around
              > 30, depending on the
              length of each address). It could also cause problems
              > with very long
              lines (greater than 500 or so bytes) in the message body. If
              > either
              could apply in your case I can send you a test version to see if it
              >
              fixes the problem.
              >
              > 73,
              > John

            • Steve
              John, I had one crash shortly after installing the new dll but it s been ok since (1 week and counting). It also helps that the telnet users have gotten some
              Message 6 of 26 , Jul 6 4:42 AM
              • 0 Attachment
                John,

                I had one crash shortly after installing the new dll but it's been ok since (1 week and counting). It also helps that the telnet users have gotten some carriage return religion.

                I'll install the new dll today.

                Thanks again,
                Steve KB1TCE

                On 7/6/2012 6:20 AM, John Wiseman wrote:  

                The BPQ32.dll I uploaded last week was not built correctly, and may cause stability problems with some confgurations. If you installed it. plese replace with this:
                 
                 
                73, John

                From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of John Wiseman
                Sent: 01 July 2012 22:08
                To: BPQ32@yahoogroups.com
                Subject: RE: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

                 

                Thanks, Steve.
                 
                That is encouraging. Can you try this? - it should fix the problem with long lines.
                 
                 
                Remember bpq32.dll goes in the system32 folder.
                 
                73,
                John
                 


                From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kb1tce
                Sent: 01 July 2012 19:17
                To: BPQ32@yahoogroups.com
                Subject: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

                 

                Well John, we're now thinking that's it.

                We checked one of the messages from our "crasher" and it consisted of two lines. The second line by itself was about 500 words and 1000 bytes.

                That message was crashing W0ECM's local BPQ32 when sending from Outpost. He had received it ok (by HF/Winmor) but when he tried to forward it to me he got the crash. He then inserted a pile of carriage returns and everything went fine.

                We were fooling ourselves with the brief test messages on Outpost 2.4 because we didn't have messages that contained the real problem.

                Hopefully that's it as far as the diagnosis goes. I would be quite willing to try your test version that addresses this.

                73,
                Steve KB1TCE

                --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
                >
                > I recently found an error in the Telnet code which could cause a problem
                > with sending messages from Outpost with a very long list of TO calls (around
                > 30, depending on the length of each address). It could also cause problems
                > with very long lines (greater than 500 or so bytes) in the message body. If
                > either could apply in your case I can send you a test version to see if it
                > fixes the problem.
                >
                > 73,
                > John

              • Steve
                Installed the new DLL yesterday and so far so good. Also, my telnet users are getting good with the Enter key so that doesn t hurt. I did have one crash
                Message 7 of 26 , Jul 7 5:06 AM
                • 0 Attachment
                  Installed the new DLL yesterday and so far so good. Also, my telnet users are getting good with the Enter key so that doesn't hurt.

                  I did have one crash shortly after installing the new DLL but it was good thereafter for close to 6 days before I installed the latest version. The Windows error message was the same as before: Switch BPQ32 Corrupt Raw Message.

                  Thanks,
                  Steve, KB1TCE

                  On 7/6/2012 6:20 AM, John Wiseman wrote:  

                  The BPQ32.dll I uploaded last week was not built correctly, and may cause stability problems with some confgurations. If you installed it. plese replace with this:
                   
                   
                  73, John

                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of John Wiseman
                  Sent: 01 July 2012 22:08
                  To: BPQ32@yahoogroups.com
                  Subject: RE: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

                   

                  Thanks, Steve.
                   
                  That is encouraging. Can you try this? - it should fix the problem with long lines.
                   
                   
                  Remember bpq32.dll goes in the system32 folder.
                   
                  73,
                  John
                   


                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kb1tce
                  Sent: 01 July 2012 19:17
                  To: BPQ32@yahoogroups.com
                  Subject: [BPQ32] Re: Winmor TNC Whack-a-Mole (Outpost Issue?)

                   

                  Well John, we're now thinking that's it.

                  We checked one of the messages from our "crasher" and it consisted of two lines. The second line by itself was about 500 words and 1000 bytes.

                  That message was crashing W0ECM's local BPQ32 when sending from Outpost. He had received it ok (by HF/Winmor) but when he tried to forward it to me he got the crash. He then inserted a pile of carriage returns and everything went fine.

                  We were fooling ourselves with the brief test messages on Outpost 2.4 because we didn't have messages that contained the real problem.

                  Hopefully that's it as far as the diagnosis goes. I would be quite willing to try your test version that addresses this.

                  73,
                  Steve KB1TCE

                  --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
                  >
                  > I recently found an error in the Telnet code which could cause a problem
                  > with sending messages from Outpost with a very long list of TO calls (around
                  > 30, depending on the length of each address). It could also cause problems
                  > with very long lines (greater than 500 or so bytes) in the message body. If
                  > either could apply in your case I can send you a test version to see if it
                  > fixes the problem.
                  >
                  > 73,
                  > John

                Your message has been successfully submitted and would be delivered to recipients shortly.