Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] Problems With Telpac

Expand Messages
  • Harmen, VE3EMA
    Clint, Try Applmask = 0x8 I m assuming that AGWPE is only being used for TELPAC = 4th application. 1 2 4 8 16 32 64 8 in HEX = 8 Harmen
    Message 1 of 14 , May 12, 2007
    • 0 Attachment

      Clint,

       

      Try Applmask = 0x8

       

      I’m assuming that AGWPE is only being used for TELPAC = 4th application.

      1 2 4 8 16 32 64

       

      8 in HEX = 8

       

      Harmen

       


      >

      > APPLICATIONS= BBS,,*SYS, TELPAC,DX ;
      >
      > APPL4CALL=KC9S- 10
      > APPL4ALIAS=TELPAC
      > APPL4QUAL=255
      > APPL5CALL=KC9S- 3
      > APPL5ALIAS=DX
      > APPL5QUAL=255
      > ;
      >
      > KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and BBS
      > are running perfectly. I just can't get TELPAC to work. Please help.
      > Thanks.
      >
      > Clint, KC9S

    • abertheaume
      Clint, One suggestion... Are you running AGW along with BPQ? If not, make sure the AGW port in Telpac is set to 8001 also. Even if you do have AGW running,
      Message 2 of 14 , May 12, 2007
      • 0 Attachment
        Clint,
        One suggestion... Are you running AGW along with BPQ? If not, make
        sure the AGW port in Telpac is set to 8001 also. Even if you do
        have AGW running, try changiing the Telpac port regardless and see
        if that makes a difference.
        Art, N9ZZK

        -- In BPQ32@yahoogroups.com, "cprealm" <clint.parrish@...> wrote:
        >
        > I'm having problems connecting to Telpac from my BPQ node. When I
        try
        > to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
        > initializes fine with AGWtoBPQ on port 8001. I have tried some of
        the
        > other suggestions already posted and haven't found a solution. Here
        > is a sample from the application part of my config file:
        >
        > APPLICATIONS=BBS,,*SYS,TELPAC,DX ;
        >
        > APPL4CALL=KC9S-10
        > APPL4ALIAS=TELPAC
        > APPL4QUAL=255
        > APPL5CALL=KC9S-3
        > APPL5ALIAS=DX
        > APPL5QUAL=255
        > ;
        >
        >
        > KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
        BBS
        > are running perfectly. I just can't get TELPAC to work. Please
        help.
        > Thanks.
        >
        > Clint, KC9S
        >
      • Mark Harloff
        Art, I am confused (as well as Clint may be).. Why would a change need to be made from 8000 to any other the UDP port for the interface between AGW and BPQ on
        Message 3 of 14 , May 12, 2007
        • 0 Attachment
          Art,

          I am confused (as well as Clint may be)..

          Why would a change need to be made from 8000 to any other the UDP port
          for the interface between AGW and BPQ on the same machine..(I assume he
          is running Both applications on the same machine)..?

          Am I missing something here ?

          - Mark


          abertheaume wrote:
          >
          >
          > Clint,
          > One suggestion... Are you running AGW along with BPQ? If not, make
          > sure the AGW port in Telpac is set to 8001 also. Even if you do
          > have AGW running, try changiing the Telpac port regardless and see
          > if that makes a difference.
          > Art, N9ZZK
          >
          > -- In BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com>, "cprealm"
          > <clint.parrish@...> wrote:
          >>
          >> I'm having problems connecting to Telpac from my BPQ node. When I
          > try
          >> to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
          >> initializes fine with AGWtoBPQ on port 8001. I have tried some of
          > the
          >> other suggestions already posted and haven't found a solution. Here
          >> is a sample from the application part of my config file:
          >>
          >> APPLICATIONS=BBS,,*SYS,TELPAC,DX ;
          >>
          >> APPL4CALL=KC9S-10
          >> APPL4ALIAS=TELPAC
          >> APPL4QUAL=255
          >> APPL5CALL=KC9S-3
          >> APPL5ALIAS=DX
          >> APPL5QUAL=255
          >> ;
          >>
          >>
          >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
          > BBS
          >> are running perfectly. I just can't get TELPAC to work. Please
          > help.
          >> Thanks.
          >>
          >> Clint, KC9S
        • Art Bertheaume
          Mark, Clint did not state that he is running AGW along with BPQ and he did state he has AGWtoBPQ on port 8001. The deffault port on set up for Telpac is 8000.
          Message 4 of 14 , May 12, 2007
          • 0 Attachment
            Mark,
                Clint did not state that he is running AGW along with BPQ and he did state he has AGWtoBPQ on port 8001.  The deffault port on set up for Telpac is 8000.  I didn't assume he was running both applications and it can't hurt to have Telpac pointed to 8001 if that is what AGWtoBPQ is on.  But after more thought,  Clint either changed Telpac to 8001 or he is running AGW also, Otherwise, Telpac would not have initialized to begin with.   
            Mark Harloff <mharloff@...> wrote:
            Art,

            I am confused (as well as Clint may be)..

            Why would a change need to be made from 8000 to any other the UDP port
            for the interface between AGW and BPQ on the same machine..(I assume he
            is running Both applications on the same machine)..?

            Am I missing something here ?

            - Mark

            abertheaume wrote:
            >
            >
            > Clint,
            > One suggestion.. . Are you running AGW along with BPQ? If not, make
            > sure the AGW port in Telpac is set to 8001 also. Even if you do
            > have AGW running, try changiing the Telpac port regardless and see
            > if that makes a difference.
            > Art, N9ZZK
            >
            > -- In BPQ32@yahoogroups. com <mailto:BPQ32% 40yahoogroups. com>, "cprealm"
            > <clint.parrish@ ...> wrote:
            >>
            >> I'm having problems connecting to Telpac from my BPQ node. When I
            > try
            >> to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
            >> initializes fine with AGWtoBPQ on port 8001. I have tried some of
            > the
            >> other suggestions already posted and haven't found a solution. Here
            >> is a sample from the application part of my config file:
            >>
            >> APPLICATIONS= BBS,,*SYS, TELPAC,DX ;
            >>
            >> APPL4CALL=KC9S- 10
            >> APPL4ALIAS=TELPAC
            >> APPL4QUAL=255
            >> APPL5CALL=KC9S- 3
            >> APPL5ALIAS=DX
            >> APPL5QUAL=255
            >> ;
            >>
            >>
            >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
            > BBS
            >> are running perfectly. I just can't get TELPAC to work. Please
            > help.
            >> Thanks.
            >>
            >> Clint, KC9S

          • cprealm
            Some additional information... I am running AGWPE with AGWtoBPQ because I can t get Winpack to run on AGWtoBPQ alone. I have tried everyone s suggestions
            Message 5 of 14 , May 13, 2007
            • 0 Attachment
              Some additional information...

              I am running AGWPE with AGWtoBPQ because I can't get Winpack to run on
              AGWtoBPQ alone.

              I have tried everyone's suggestions including setting applmask to 0x8
              and rearranging the order of applications in the config file.

              The strange thing is, I can get TELPAC to work when it is set as
              application 5. But the Spider DX cluster, set as application 4, will
              not run. I get the same "Sorry, all DX ports..." message. But when I
              switch the application order, DX will run but not TELPAC.

              Also, TELPAC stops responding through BPQ after a while. It won't let
              me disconnect using the "bye" command. Same with DX Spider.

              Any help would be appreciated.

              Clint


              --- In BPQ32@yahoogroups.com, Art Bertheaume <abertheaume@...> wrote:
              >
              > Mark,
              > Clint did not state that he is running AGW along with BPQ and
              he did state he has AGWtoBPQ on port 8001. The deffault port on set
              up for Telpac is 8000. I didn't assume he was running both
              applications and it can't hurt to have Telpac pointed to 8001 if that
              is what AGWtoBPQ is on. But after more thought, Clint either changed
              Telpac to 8001 or he is running AGW also, Otherwise, Telpac would not
              have initialized to begin with.
              > Mark Harloff <mharloff@...> wrote:
              > Art,
              >
              > I am confused (as well as Clint may be)..
              >
              > Why would a change need to be made from 8000 to any other the UDP port
              > for the interface between AGW and BPQ on the same machine..(I assume he
              > is running Both applications on the same machine)..?
              >
              > Am I missing something here ?
              >
              > - Mark
              >
              > abertheaume wrote:
              > >
              > >
              > > Clint,
              > > One suggestion... Are you running AGW along with BPQ? If not, make
              > > sure the AGW port in Telpac is set to 8001 also. Even if you do
              > > have AGW running, try changiing the Telpac port regardless and see
              > > if that makes a difference.
              > > Art, N9ZZK
              > >
              > > -- In BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com>,
              "cprealm"
              > > <clint.parrish@> wrote:
              > >>
              > >> I'm having problems connecting to Telpac from my BPQ node. When I
              > > try
              > >> to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
              > >> initializes fine with AGWtoBPQ on port 8001. I have tried some of
              > > the
              > >> other suggestions already posted and haven't found a solution. Here
              > >> is a sample from the application part of my config file:
              > >>
              > >> APPLICATIONS=BBS,,*SYS,TELPAC,DX ;
              > >>
              > >> APPL4CALL=KC9S-10
              > >> APPL4ALIAS=TELPAC
              > >> APPL4QUAL=255
              > >> APPL5CALL=KC9S-3
              > >> APPL5ALIAS=DX
              > >> APPL5QUAL=255
              > >> ;
              > >>
              > >>
              > >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
              > > BBS
              > >> are running perfectly. I just can't get TELPAC to work. Please
              > > help.
              > >> Thanks.
              > >>
              > >> Clint, KC9S
              >
            • abertheaume
              Hi Clint, Harmen is on the right track with this with his suggestion of ApplMask configuration. Here, I have a BBS as Appl1 and Telpac as Appl4 and both
              Message 6 of 14 , May 13, 2007
              • 0 Attachment
                Hi Clint,
                Harmen is on the right track with this with his suggestion of
                ApplMask configuration.

                Here, I have a BBS as Appl1 and Telpac as Appl4 and both applications
                are configured to use AGW. Using the guidelines provided in the
                BPQCFG.txt file..
                <snip>

                AGWtoBPQ.exe includes an 'Applications Mask' created from the
                position of
                ; the 'application' in the APPLICATIONS= string. The mask is formed
                from the
                ; sum of the numbers 1,2,4,8,16,32,64,128. Thus in this configuraton
                the
                ; applications occupy positions 1 and 4, with associated masks of 1
                and 8,
                ; which added together equal 9. Thus when using the AGWtoBPQ
                interface the
                ; 'Appl Mask' must be entered as 9.
                <end>

                So, I have a BBS as App1 = 1
                I have Telpac as App4 = 8
                -----------------------------
                The sum of the values =9, and therefore, I set my ApplMask to 9
                in the AGWtoBPQ config.

                Now, if you have..

                BBS as App1, value is 1
                Telpac as App4, value is 8
                Dx as App5 value is 16
                ----------------------------
                Sum of values is =25


                This is of course if you have all three applications configured to
                use AGW. If you are not using AGW with your BBS, then subtract 1.
                If your are not using AGW for your DX application, then subtract 16.
                the value of 25 is derived if all three applications are using AGW.

                If I managed to confuse you last night, I am certain I did a better
                job of it tonight!

                Art, N9ZZK


                --- In BPQ32@yahoogroups.com, "cprealm" <clint.parrish@...> wrote:
                >
                > Some additional information...
                >
                > I am running AGWPE with AGWtoBPQ because I can't get Winpack to run
                on
                > AGWtoBPQ alone.
                >
                > I have tried everyone's suggestions including setting applmask to
                0x8
                > and rearranging the order of applications in the config file.
                >
                > The strange thing is, I can get TELPAC to work when it is set as
                > application 5. But the Spider DX cluster, set as application 4,
                will
                > not run. I get the same "Sorry, all DX ports..." message. But
                when I
                > switch the application order, DX will run but not TELPAC.
                >
                > Also, TELPAC stops responding through BPQ after a while. It won't
                let
                > me disconnect using the "bye" command. Same with DX Spider.
                >
                > Any help would be appreciated.
                >
                > Clint
                >
                >
                > --- In BPQ32@yahoogroups.com, Art Bertheaume <abertheaume@> wrote:
                > >
                > > Mark,
                > > Clint did not state that he is running AGW along with BPQ
                and
                > he did state he has AGWtoBPQ on port 8001. The deffault port on set
                > up for Telpac is 8000. I didn't assume he was running both
                > applications and it can't hurt to have Telpac pointed to 8001 if
                that
                > is what AGWtoBPQ is on. But after more thought, Clint either
                changed
                > Telpac to 8001 or he is running AGW also, Otherwise, Telpac would
                not
                > have initialized to begin with.
                > > Mark Harloff <mharloff@> wrote:
                > > Art,
                > >
                > > I am confused (as well as Clint may be)..
                > >
                > > Why would a change need to be made from 8000 to any other the UDP
                port
                > > for the interface between AGW and BPQ on the same machine..(I
                assume he
                > > is running Both applications on the same machine)..?
                > >
                > > Am I missing something here ?
                > >
                > > - Mark
                > >
                > > abertheaume wrote:
                > > >
                > > >
                > > > Clint,
                > > > One suggestion... Are you running AGW along with BPQ? If not,
                make
                > > > sure the AGW port in Telpac is set to 8001 also. Even if you do
                > > > have AGW running, try changiing the Telpac port regardless and
                see
                > > > if that makes a difference.
                > > > Art, N9ZZK
                > > >
                > > > -- In BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com>,
                > "cprealm"
                > > > <clint.parrish@> wrote:
                > > >>
                > > >> I'm having problems connecting to Telpac from my BPQ node.
                When I
                > > > try
                > > >> to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
                > > >> initializes fine with AGWtoBPQ on port 8001. I have tried some
                of
                > > > the
                > > >> other suggestions already posted and haven't found a solution.
                Here
                > > >> is a sample from the application part of my config file:
                > > >>
                > > >> APPLICATIONS=BBS,,*SYS,TELPAC,DX ;
                > > >>
                > > >> APPL4CALL=KC9S-10
                > > >> APPL4ALIAS=TELPAC
                > > >> APPL4QUAL=255
                > > >> APPL5CALL=KC9S-3
                > > >> APPL5ALIAS=DX
                > > >> APPL5QUAL=255
                > > >> ;
                > > >>
                > > >>
                > > >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
                > > > BBS
                > > >> are running perfectly. I just can't get TELPAC to work. Please
                > > > help.
                > > >> Thanks.
                > > >>
                > > >> Clint, KC9S
                > >
                >
              • cprealm
                I got it! My applmask magic hex number in AGWtoBPQ.exe was 19 or 0x19. I worked backwards from 0x11 which ran my bbs and the fifth application. So from my
                Message 7 of 14 , May 13, 2007
                • 0 Attachment
                  I got it! My applmask magic hex number in AGWtoBPQ.exe was 19 or
                  0x19. I worked backwards from 0x11 which ran my bbs and the fifth
                  application. So from my config file:

                  APPLICATIONS=BBS,,*.SYS,TELPAC,DX;

                  APPL4CALL=KC9S-10
                  APPL4ALIAS=TELPAC
                  APPL4QUAL=255
                  APPL5CALL=KC9S-3
                  APPL5ALIAS=DX
                  APPL5QUAL=255

                  ;

                  Because the second and third applications did not need AGW, the HEX
                  math is as follows: BBS (HEX=1) - BLANK (HEX=2) - REMOTE (HEX=4) +
                  TELPAC (=8) + DX (=16) = 19. 1 - 2 - 4 + 8 + 16 = 19.

                  Thanks to everyone but especially Mike for helping me with WinFBB and
                  for Art for giving me a quick review of Hexadecimal math since
                  college. And Art you weren't confusing. I'll be in touch with the
                  two of you shortly. 73 to all and again thanks.

                  Clint, KC9S


                  --- In BPQ32@yahoogroups.com, "abertheaume" <abertheaume@...> wrote:
                  >
                  > Hi Clint,
                  > Harmen is on the right track with this with his suggestion of
                  > ApplMask configuration.
                  >
                  > Here, I have a BBS as Appl1 and Telpac as Appl4 and both applications
                  > are configured to use AGW. Using the guidelines provided in the
                  > BPQCFG.txt file..
                  > <snip>
                  >
                  > AGWtoBPQ.exe includes an 'Applications Mask' created from the
                  > position of
                  > ; the 'application' in the APPLICATIONS= string. The mask is formed
                  > from the
                  > ; sum of the numbers 1,2,4,8,16,32,64,128. Thus in this configuraton
                  > the
                  > ; applications occupy positions 1 and 4, with associated masks of 1
                  > and 8,
                  > ; which added together equal 9. Thus when using the AGWtoBPQ
                  > interface the
                  > ; 'Appl Mask' must be entered as 9.
                  > <end>
                  >
                  > So, I have a BBS as App1 = 1
                  > I have Telpac as App4 = 8
                  > -----------------------------
                  > The sum of the values =9, and therefore, I set my ApplMask to 9
                  > in the AGWtoBPQ config.
                  >
                  > Now, if you have..
                  >
                  > BBS as App1, value is 1
                  > Telpac as App4, value is 8
                  > Dx as App5 value is 16
                  > ----------------------------
                  > Sum of values is =25
                  >
                  >
                  > This is of course if you have all three applications configured to
                  > use AGW. If you are not using AGW with your BBS, then subtract 1.
                  > If your are not using AGW for your DX application, then subtract 16.
                  > the value of 25 is derived if all three applications are using AGW.
                  >
                  > If I managed to confuse you last night, I am certain I did a better
                  > job of it tonight!
                  >
                  > Art, N9ZZK
                  >
                  >
                  > --- In BPQ32@yahoogroups.com, "cprealm" <clint.parrish@> wrote:
                  > >
                  > > Some additional information...
                  > >
                  > > I am running AGWPE with AGWtoBPQ because I can't get Winpack to run
                  > on
                  > > AGWtoBPQ alone.
                  > >
                  > > I have tried everyone's suggestions including setting applmask to
                  > 0x8
                  > > and rearranging the order of applications in the config file.
                  > >
                  > > The strange thing is, I can get TELPAC to work when it is set as
                  > > application 5. But the Spider DX cluster, set as application 4,
                  > will
                  > > not run. I get the same "Sorry, all DX ports..." message. But
                  > when I
                  > > switch the application order, DX will run but not TELPAC.
                  > >
                  > > Also, TELPAC stops responding through BPQ after a while. It won't
                  > let
                  > > me disconnect using the "bye" command. Same with DX Spider.
                  > >
                  > > Any help would be appreciated.
                  > >
                  > > Clint
                  > >
                  > >
                  > > --- In BPQ32@yahoogroups.com, Art Bertheaume <abertheaume@> wrote:
                  > > >
                  > > > Mark,
                  > > > Clint did not state that he is running AGW along with BPQ
                  > and
                  > > he did state he has AGWtoBPQ on port 8001. The deffault port on set
                  > > up for Telpac is 8000. I didn't assume he was running both
                  > > applications and it can't hurt to have Telpac pointed to 8001 if
                  > that
                  > > is what AGWtoBPQ is on. But after more thought, Clint either
                  > changed
                  > > Telpac to 8001 or he is running AGW also, Otherwise, Telpac would
                  > not
                  > > have initialized to begin with.
                  > > > Mark Harloff <mharloff@> wrote:
                  > > > Art,
                  > > >
                  > > > I am confused (as well as Clint may be)..
                  > > >
                  > > > Why would a change need to be made from 8000 to any other the UDP
                  > port
                  > > > for the interface between AGW and BPQ on the same machine..(I
                  > assume he
                  > > > is running Both applications on the same machine)..?
                  > > >
                  > > > Am I missing something here ?
                  > > >
                  > > > - Mark
                  > > >
                  > > > abertheaume wrote:
                  > > > >
                  > > > >
                  > > > > Clint,
                  > > > > One suggestion... Are you running AGW along with BPQ? If not,
                  > make
                  > > > > sure the AGW port in Telpac is set to 8001 also. Even if you do
                  > > > > have AGW running, try changiing the Telpac port regardless and
                  > see
                  > > > > if that makes a difference.
                  > > > > Art, N9ZZK
                  > > > >
                  > > > > -- In BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com>,
                  > > "cprealm"
                  > > > > <clint.parrish@> wrote:
                  > > > >>
                  > > > >> I'm having problems connecting to Telpac from my BPQ node.
                  > When I
                  > > > > try
                  > > > >> to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
                  > > > >> initializes fine with AGWtoBPQ on port 8001. I have tried some
                  > of
                  > > > > the
                  > > > >> other suggestions already posted and haven't found a solution.
                  > Here
                  > > > >> is a sample from the application part of my config file:
                  > > > >>
                  > > > >> APPLICATIONS=BBS,,*SYS,TELPAC,DX ;
                  > > > >>
                  > > > >> APPL4CALL=KC9S-10
                  > > > >> APPL4ALIAS=TELPAC
                  > > > >> APPL4QUAL=255
                  > > > >> APPL5CALL=KC9S-3
                  > > > >> APPL5ALIAS=DX
                  > > > >> APPL5QUAL=255
                  > > > >> ;
                  > > > >>
                  > > > >>
                  > > > >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
                  > > > > BBS
                  > > > >> are running perfectly. I just can't get TELPAC to work. Please
                  > > > > help.
                  > > > >> Thanks.
                  > > > >>
                  > > > >> Clint, KC9S
                  > > >
                  > >
                  >
                • Harmen, VE3EMA
                  Are you using AGW for Spider DX Cluster as well? If I understand the APPLMASK properly, a value of 0x10 means that one application is running in position 5. 1
                  Message 8 of 14 , May 13, 2007
                  • 0 Attachment

                    Are you using AGW for Spider DX Cluster as well?

                     

                    If I understand the APPLMASK properly, a value of 0x10 means that one application is running in position 5.

                     

                    1 2 4 6 16 32 64

                     

                    16 in HEX = 10    (0x10)

                     

                    If applications 4 and 5 are both utilizing BPQtoAGW.exe, then you would have,

                     

                    1 2 4 6 16 32 64

                     

                    6 + 16 = 22

                    22 in HEX = 16    (0X16)

                     

                    73 Harmen, VE3EMA

                     

                     

                     

                     


                    From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of cprealm
                    Sent: Sunday, May 13, 2007 6:04 PM
                    To: BPQ32@yahoogroups.com
                    Subject: [BPQ32] Re: Problems With Telpac

                     

                    Some additional information. ..

                    I am running AGWPE with AGWtoBPQ because I can't get Winpack to run on
                    AGWtoBPQ alone.

                    I have tried everyone's suggestions including setting applmask to 0x8
                    and rearranging the order of applications in the config file.

                    The strange thing is, I can get TELPAC to work when it is set as
                    application 5. But the Spider DX cluster, set as application 4, will
                    not run. I get the same "Sorry, all DX ports..." message. But when I
                    switch the application order, DX will run but not TELPAC.

                    Also, TELPAC stops responding through BPQ after a while. It won't let
                    me disconnect using the "bye" command. Same with DX Spider.

                    Any help would be appreciated.

                    Clint

                    --- In BPQ32@yahoogroups. com, Art Bertheaume <abertheaume@ ...> wrote:

                    >
                    > Mark,
                    > Clint did not state that he is running AGW along with BPQ and
                    he did state he has AGWtoBPQ on port 8001. The deffault port on set
                    up for Telpac is 8000. I didn't assume he was running both
                    applications and it can't hurt to have Telpac pointed to 8001 if that
                    is what AGWtoBPQ is on. But after more thought, Clint either changed
                    Telpac to 8001 or he is running AGW also, Otherwise, Telpac would not
                    have initialized to begin with.
                    > Mark Harloff <mharloff@.. .> wrote:
                    > Art,
                    >
                    > I am confused (as well as Clint may be)..
                    >
                    > Why would a change need to be made from 8000 to any other the UDP port
                    > for the interface between AGW and BPQ on the same machine..(I assume he
                    > is running Both applications on the same machine)..?
                    >
                    > Am I missing something here ?
                    >
                    > - Mark
                    >
                    > abertheaume wrote:
                    > >
                    > >
                    > > Clint,
                    > > One suggestion.. . Are you running AGW along with BPQ? If not,
                    make
                    > > sure the AGW port in Telpac is set to 8001 also. Even if you do
                    > > have AGW running, try changiing the Telpac port regardless and see
                    > > if that makes a difference.
                    > > Art, N9ZZK
                    > >
                    > > -- In BPQ32@yahoogroups. com
                    <mailto:BPQ32% 40yahoogroups. com>,
                    "cprealm"
                    > > <clint.parrish@ > wrote:
                    > >>
                    > >> I'm having problems connecting to Telpac from my BPQ node. When I
                    > > try
                    > >> to connect, I get "Sorry - All TELPAC ports are in
                    use." TELPAC
                    > >> initializes fine with AGWtoBPQ on port 8001. I have tried some of
                    > > the
                    > >> other suggestions already posted and haven't found a solution.
                    Here
                    > >> is a sample from the application part of my config file:
                    > >>
                    > >> APPLICATIONS= BBS,,*SYS, TELPAC,DX ;
                    > >>
                    > >> APPL4CALL=KC9S- 10
                    > >> APPL4ALIAS=TELPAC
                    > >> APPL4QUAL=255
                    > >> APPL5CALL=KC9S- 3
                    > >> APPL5ALIAS=DX
                    > >> APPL5QUAL=255
                    > >> ;
                    > >>
                    > >>
                    > >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
                    > > BBS
                    > >> are running perfectly. I just can't get TELPAC to work. Please
                    > > help.
                    > >> Thanks.
                    > >>
                    > >> Clint, KC9S
                    >

                  • Ron Stordahl
                    Harmen The application mask, is in hexidecimal, as you have explained it below. But keep in mind that you only want a 1 in the position in the mask if the
                    Message 9 of 14 , May 14, 2007
                    • 0 Attachment
                      Harmen

                      The application mask, is in hexidecimal, as you have explained it below.  But keep in mind that you only want a '1' in the position in the mask if the interface (AGWtoBPQ) is to an application which interfaces with AGWtoBPQ via TCP.  So for example, if you are running the 32 bit version of FBB and the interface is via a DLL, then you would want a '0' in that position.  If the BBS is the first position, then that mask element would be a 0.  If in the fifth position you are interfacing to Telpac via the AGW interface, then you would have a 1 in that position.  If in position 4 you had something like 'DX/C N5IN' then the interface is to a remote application and the mask element would be a 0.

                      So the key is to write done the mask in binary beginning with the first position.  Now to evaluate the mask you have to reverse the string so that the most significant digits are first. 

                      In the example you have given the binary would be 00001.  Reversed this is binary 10000, which is equivalent to 0x10 (i.e. 10 hexadecimal)

                      In your second example, are you sure that application in position 4 is using the AGWtoBPQ TCP interface?  If so, then the 4th would have a value of 8, not 6, the binary mask would be 00011 which when reversed and converted to hex would be 0x18.

                      I do intend to explain the mask fully in a forthcomming version of the beta document....but at the moment I have a major assignment at work which I simply must complete before I return my attention to BPQ.  I thought I would have it out of the way by May 1, but I am still weighed down...perhaps one more week..I hope.

                      Ron, N5IN

                      Harmen, VE3EMA wrote:

                      Are you using AGW for Spider DX Cluster as well?

                       

                      If I understand the APPLMASK properly, a value of 0x10 means that one application is running in position 5.

                       

                      1 2 4 6 16 32 64

                       

                      16 in HEX = 10    (0x10)

                       

                      If applications 4 and 5 are both utilizing BPQtoAGW.exe, then you would have,

                       

                      1 2 4 6 16 32 64

                       

                      6 + 16 = 22

                      22 in HEX = 16    (0X16)

                       

                      73 Harmen, VE3EMA

                       

                       

                       

                       


                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of cprealm
                      Sent: Sunday, May 13, 2007 6:04 PM
                      To: BPQ32@yahoogroups.com
                      Subject: [BPQ32] Re: Problems With Telpac

                       

                      Some additional information. ..

                      I am running AGWPE with AGWtoBPQ because I can't get Winpack to run on
                      AGWtoBPQ alone.

                      I have tried everyone's suggestions including setting applmask to 0x8
                      and rearranging the order of applications in the config file.

                      The strange thing is, I can get TELPAC to work when it is set as
                      application 5. But the Spider DX cluster, set as application 4, will
                      not run. I get the same "Sorry, all DX ports..." message. But when I
                      switch the application order, DX will run but not TELPAC.

                      Also, TELPAC stops responding through BPQ after a while. It won't let
                      me disconnect using the "bye" command. Same with DX Spider.

                      Any help would be appreciated.

                      Clint

                      --- In BPQ32@yahoogroups. com, Art Bertheaume <abertheaume@ ...> wrote:
                      >
                      > Mark,
                      > Clint did not state that he is running AGW along with BPQ and
                      he did state he has AGWtoBPQ on port 8001. The deffault port on set
                      up for Telpac is 8000. I didn't assume he was running both
                      applications and it can't hurt to have Telpac pointed to 8001 if that
                      is what AGWtoBPQ is on. But after more thought, Clint either changed
                      Telpac to 8001 or he is running AGW also, Otherwise, Telpac would not
                      have initialized to begin with.
                      > Mark Harloff <mharloff@.. .> wrote:
                      > Art,
                      >
                      > I am confused (as well as Clint may be)..
                      >
                      > Why would a change need to be made from 8000 to any other the UDP port
                      > for the interface between AGW and BPQ on the same machine..(I assume he
                      > is running Both applications on the same machine)..?
                      >
                      > Am I missing something here ?
                      >
                      > - Mark
                      >
                      > abertheaume wrote:
                      > >
                      > >
                      > > Clint,
                      > > One suggestion.. . Are you running AGW along with BPQ? If not, make
                      > > sure the AGW port in Telpac is set to 8001 also. Even if you do
                      > > have AGW running, try changiing the Telpac port regardless and see
                      > > if that makes a difference.
                      > > Art, N9ZZK
                      > >
                      > > -- In BPQ32@yahoogroups. com <mailto:BPQ32% 40yahoogroups. com>,
                      "cprealm"
                      > > <clint.parrish@ > wrote:
                      > >>
                      > >> I'm having problems connecting to Telpac from my BPQ node. When I
                      > > try
                      > >> to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
                      > >> initializes fine with AGWtoBPQ on port 8001. I have tried some of
                      > > the
                      > >> other suggestions already posted and haven't found a solution. Here
                      > >> is a sample from the application part of my config file:
                      > >>
                      > >> APPLICATIONS= BBS,,*SYS, TELPAC,DX ;
                      > >>
                      > >> APPL4CALL=KC9S- 10
                      > >> APPL4ALIAS=TELPAC
                      > >> APPL4QUAL=255
                      > >> APPL5CALL=KC9S- 3
                      > >> APPL5ALIAS=DX
                      > >> APPL5QUAL=255
                      > >> ;
                      > >>
                      > >>
                      > >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
                      > > BBS
                      > >> are running perfectly. I just can't get TELPAC to work. Please
                      > > help.
                      > >> Thanks.
                      > >>
                      > >> Clint, KC9S
                      >

                    • Harmen, VE3EMA
                      I apologize if I created any confusion with my error in last evening s Applmask value explanation. I did mean to say; 1, 2, 4, 8, 16, 32, 64 not 1, 2, 4, 6
                      Message 10 of 14 , May 14, 2007
                      • 0 Attachment

                        I apologize if I created any confusion with my error in last evening’s Applmask value explanation.

                        I did mean to say;

                         

                        1, 2, 4, 8, 16, 32, 64  not  1, 2, 4, 6 ,8 ,16, 32, 64

                         

                        So, if AGWtoBPQ.exe applications occupy positions 4 and 5 in the BPQCFG.txt, APPLICATIONS= line, then using decimal values;

                         

                        Position 4 = 8

                        Position 5 = 16

                         

                        Add them together,

                         

                        8 + 16 = 24 (decimal)

                        24 converted to Hex = 18

                         

                         

                         

                        Watching too many double overtime hockey games....

                        73, Harmen VE3EMA

                         

                         

                      • cprealm
                        Thanks to all for your help. Yes, I did have the hex math wrong. I posted my solution last night but apparently it was lost in the mix. 73. Clint
                        Message 11 of 14 , May 14, 2007
                        • 0 Attachment
                          Thanks to all for your help. Yes, I did have the hex math wrong. I
                          posted my solution last night but apparently it was lost in the mix.

                          73.

                          Clint

                          --- In BPQ32@yahoogroups.com, "cprealm" <clint.parrish@...> wrote:
                          >
                          > I got it! My applmask magic hex number in AGWtoBPQ.exe was 19 or
                          > 0x19. I worked backwards from 0x11 which ran my bbs and the fifth
                          > application. So from my config file:
                          >
                          > APPLICATIONS=BBS,,*.SYS,TELPAC,DX;
                          >
                          > APPL4CALL=KC9S-10
                          > APPL4ALIAS=TELPAC
                          > APPL4QUAL=255
                          > APPL5CALL=KC9S-3
                          > APPL5ALIAS=DX
                          > APPL5QUAL=255
                          >
                          > ;
                          >
                          > Because the second and third applications did not need AGW, the HEX
                          > math is as follows: BBS (HEX=1) - BLANK (HEX=2) - REMOTE (HEX=4) +
                          > TELPAC (=8) + DX (=16) = 19. 1 - 2 - 4 + 8 + 16 = 19.
                          >
                          > Thanks to everyone but especially Mike for helping me with WinFBB and
                          > for Art for giving me a quick review of Hexadecimal math since
                          > college. And Art you weren't confusing. I'll be in touch with the
                          > two of you shortly. 73 to all and again thanks.
                          >
                          > Clint, KC9S
                          >
                          >
                          > --- In BPQ32@yahoogroups.com, "abertheaume" <abertheaume@> wrote:
                          > >
                          > > Hi Clint,
                          > > Harmen is on the right track with this with his suggestion of
                          > > ApplMask configuration.
                          > >
                          > > Here, I have a BBS as Appl1 and Telpac as Appl4 and both applications
                          > > are configured to use AGW. Using the guidelines provided in the
                          > > BPQCFG.txt file..
                          > > <snip>
                          > >
                          > > AGWtoBPQ.exe includes an 'Applications Mask' created from the
                          > > position of
                          > > ; the 'application' in the APPLICATIONS= string. The mask is formed
                          > > from the
                          > > ; sum of the numbers 1,2,4,8,16,32,64,128. Thus in this configuraton
                          > > the
                          > > ; applications occupy positions 1 and 4, with associated masks of 1
                          > > and 8,
                          > > ; which added together equal 9. Thus when using the AGWtoBPQ
                          > > interface the
                          > > ; 'Appl Mask' must be entered as 9.
                          > > <end>
                          > >
                          > > So, I have a BBS as App1 = 1
                          > > I have Telpac as App4 = 8
                          > > -----------------------------
                          > > The sum of the values =9, and therefore, I set my ApplMask to 9
                          > > in the AGWtoBPQ config.
                          > >
                          > > Now, if you have..
                          > >
                          > > BBS as App1, value is 1
                          > > Telpac as App4, value is 8
                          > > Dx as App5 value is 16
                          > > ----------------------------
                          > > Sum of values is =25
                          > >
                          > >
                          > > This is of course if you have all three applications configured to
                          > > use AGW. If you are not using AGW with your BBS, then subtract 1.
                          > > If your are not using AGW for your DX application, then subtract 16.
                          > > the value of 25 is derived if all three applications are using AGW.
                          > >
                          > > If I managed to confuse you last night, I am certain I did a better
                          > > job of it tonight!
                          > >
                          > > Art, N9ZZK
                          > >
                          > >
                          > > --- In BPQ32@yahoogroups.com, "cprealm" <clint.parrish@> wrote:
                          > > >
                          > > > Some additional information...
                          > > >
                          > > > I am running AGWPE with AGWtoBPQ because I can't get Winpack to run
                          > > on
                          > > > AGWtoBPQ alone.
                          > > >
                          > > > I have tried everyone's suggestions including setting applmask to
                          > > 0x8
                          > > > and rearranging the order of applications in the config file.
                          > > >
                          > > > The strange thing is, I can get TELPAC to work when it is set as
                          > > > application 5. But the Spider DX cluster, set as application 4,
                          > > will
                          > > > not run. I get the same "Sorry, all DX ports..." message. But
                          > > when I
                          > > > switch the application order, DX will run but not TELPAC.
                          > > >
                          > > > Also, TELPAC stops responding through BPQ after a while. It won't
                          > > let
                          > > > me disconnect using the "bye" command. Same with DX Spider.
                          > > >
                          > > > Any help would be appreciated.
                          > > >
                          > > > Clint
                          > > >
                          > > >
                          > > > --- In BPQ32@yahoogroups.com, Art Bertheaume <abertheaume@> wrote:
                          > > > >
                          > > > > Mark,
                          > > > > Clint did not state that he is running AGW along with BPQ
                          > > and
                          > > > he did state he has AGWtoBPQ on port 8001. The deffault port on set
                          > > > up for Telpac is 8000. I didn't assume he was running both
                          > > > applications and it can't hurt to have Telpac pointed to 8001 if
                          > > that
                          > > > is what AGWtoBPQ is on. But after more thought, Clint either
                          > > changed
                          > > > Telpac to 8001 or he is running AGW also, Otherwise, Telpac would
                          > > not
                          > > > have initialized to begin with.
                          > > > > Mark Harloff <mharloff@> wrote:
                          > > > > Art,
                          > > > >
                          > > > > I am confused (as well as Clint may be)..
                          > > > >
                          > > > > Why would a change need to be made from 8000 to any other the UDP
                          > > port
                          > > > > for the interface between AGW and BPQ on the same machine..(I
                          > > assume he
                          > > > > is running Both applications on the same machine)..?
                          > > > >
                          > > > > Am I missing something here ?
                          > > > >
                          > > > > - Mark
                          > > > >
                          > > > > abertheaume wrote:
                          > > > > >
                          > > > > >
                          > > > > > Clint,
                          > > > > > One suggestion... Are you running AGW along with BPQ? If not,
                          > > make
                          > > > > > sure the AGW port in Telpac is set to 8001 also. Even if you do
                          > > > > > have AGW running, try changiing the Telpac port regardless and
                          > > see
                          > > > > > if that makes a difference.
                          > > > > > Art, N9ZZK
                          > > > > >
                          > > > > > -- In BPQ32@yahoogroups.com <mailto:BPQ32%40yahoogroups.com>,
                          > > > "cprealm"
                          > > > > > <clint.parrish@> wrote:
                          > > > > >>
                          > > > > >> I'm having problems connecting to Telpac from my BPQ node.
                          > > When I
                          > > > > > try
                          > > > > >> to connect, I get "Sorry - All TELPAC ports are in use." TELPAC
                          > > > > >> initializes fine with AGWtoBPQ on port 8001. I have tried some
                          > > of
                          > > > > > the
                          > > > > >> other suggestions already posted and haven't found a solution.
                          > > Here
                          > > > > >> is a sample from the application part of my config file:
                          > > > > >>
                          > > > > >> APPLICATIONS=BBS,,*SYS,TELPAC,DX ;
                          > > > > >>
                          > > > > >> APPL4CALL=KC9S-10
                          > > > > >> APPL4ALIAS=TELPAC
                          > > > > >> APPL4QUAL=255
                          > > > > >> APPL5CALL=KC9S-3
                          > > > > >> APPL5ALIAS=DX
                          > > > > >> APPL5QUAL=255
                          > > > > >> ;
                          > > > > >>
                          > > > > >>
                          > > > > >> KC9S-10 is my TELPAC node. My Applmask=0x10. My DX cluster, and
                          > > > > > BBS
                          > > > > >> are running perfectly. I just can't get TELPAC to work. Please
                          > > > > > help.
                          > > > > >> Thanks.
                          > > > > >>
                          > > > > >> Clint, KC9S
                          > > > >
                          > > >
                          > >
                          >
                        Your message has been successfully submitted and would be delivered to recipients shortly.