Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] Re: COM20 is already in use

Expand Messages
  • John Wiseman
    Art, Sorry, I replied before I read the second part of you message WINMOR.DLL is part of BPQ32.dll. It isn t a separate file. John _____ From:
    Message 1 of 10 , Aug 15, 2011
    • 0 Attachment

      Art,

       

      Sorry, I replied before I read the second part of you message

       

      WINMOR.DLL is part of BPQ32.dll. It isn’t a separate file.

       

       

      John

       

       


      From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of Arthur L Howard
      Sent: 15 August 2011 17:24
      To: BPQ32@yahoogroups.com
      Subject: RE: [BPQ32] Re: COM20 is already in use

       

       

      Hello John:

       

      All three have COM20.

       

      I believe the BP! Hostmodes Version 1.1.5.1 problem of Open Failed needs to be fixed before AirMail can successfully open the Packet Client.

       

      I had a more serious problem this morning. VSP Manager seemed to have lost control. It could not display either the Physical Ports or Virtual Ports when started. I  removed the soft ware with Uninstall. I removed the virtual ports using Device Manager. I removed the Virtual Serial Bus Enumerator 7(Eltima Software) with Device Manager. There were two copies!

       

      After installing VSP Manager again it works correctly.

       

      However, the problem is now with BPQ Virtual COM Driver Control Channel Open Failed. I looked at the bpq32.dfg file. It contains the following:

      ; AIRMAIL/WINMOR configuration.

      SIMPLE

      NODECALL=KC0TPG-1

      INFOMSG:

      Airmail to WINMOR Gateway

      ***

      PORT

      ID= WINMOR Port 1

      TYPE=EXTERNAL

      DLLNAME=WINMOR.dll

      PROTOCOL=WINMOR

      CONFIG ; Driver-Specific Configuration

      ADDR 127.0.0.1 8500 PATH C:\Program Files (x86)\bpq32\Winmor TNC\Winmor TNC.exe

      CWID True

      BW 1600

      DRIVELEVEL 100

      ENDPORT

      APPLICATION 1,AIRMAIL,,KC0TPG-2

      ; End of Config

       

      The DLLNAME=WINMORE.dll entry focused me to go look for this file. I cannot find this file? Wh ere is it supposed to be located?

       

      73

      Art

      KC0TPG

       

      Arthur L Howard

      Captain S/V Samana

      WDB7645

      KC0TPG

       

      From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of John Wiseman
      Sent: Monday, August 15, 2011 1:25 AM
      To: BPQ32@yahoogroups.com
      Subject: RE: [BPQ32] Re: COM20 is already in use

       

       

      Ok, Art.

       

      Which ports did you create in VSP Manager, and which one did you use for BPQHostModes and which for Airmail?

      &nbs p;

       

      John

       


      From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of Arthur L Howard
      Sent: 14 August 2011 23:24
      To: BPQ32@yahoogroups.com
      Subject: RE: [BPQ32] Re: COM20 is already in use

       

       

       

      Hello John:

       

      I am using VSP Manager

      Version: 1.0.3.01

      Copyright Steve Nance (K5FR) 2009-2011

      Virtual Serial Port Manager

       

      I found the VSP Manager using the link from http://www.cantab.net/users/john.wiseman/Documents/AirmailtoWINMOR.htm

       

      To: http://k5fr.com/ddutilwiki/index.php?title=VSP_Manager

       

      73,

       

      Art

      KC0TPG

       

       

      Arthur L Howard

      Captain S/V Samana

      WDB7645

      KC0TPG

       

      From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of John Wiseman
      Sent: Sunday, August 1 4, 2011 12:49 PM
      To: BPQ32@yahoogroups.com
      Subject: RE: [BPQ32] Re: COM20 is already in use

      </ div>

       

       

      Ok, Art.

       

      I see you are using the 64 bit version of WIN7.

       

      Did you follow the modified instructions for using 64 bit Windows (ie using a 3rd party Virtual COM Port ?)

       

      If not, then try it!

       

      If you did, the chances are that you tried to open the same one of the device pair in BPQHostModes and Airmail. Each must use one of the pair. And in this case, you do need “Use Real COM Ports” checked.

       

      73,

      John

       

       

       

       


      From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of kc0tpg
      Sent: 14 August 2011 17:42
      To: BPQ32@yahoogroups.com
      Subject: [BPQ32] Re: COM20 is already in use

       

       

      Hello John:

      Yes, Use Real COM Ports was checked. I unchecked this and clicked Save Settings, exited from BPQ32.dll Console and restarted BPQHostModes.exe
      I then received the following error message:
      BPQ Virtual COM Driver Control Channel Open Failed.
      I then clicked on the error message which the n closed. BPQ Hostmodes Version 1.1.5.1 has "Open Failed" message for COM 20.
      COM = 20, Streams=1, Applmask=1 Mode has Kant with a dot and DED is empty. RTS blank, CTS checked, DCD blan k, DSR checked, DTR blank.
      BPQ32 .dll Console Version 5.0.0.1 has:
      BPQ32 Ver 5.0.0 Build 1 Loaded from C:\windows\system32\bp132.dll by BPQHostModes.exe
      Windows Ver 6.1, Using Registry Key HKEY_LOCAL_MACHINE
      Using config from: C:\Program Files <x86>\BPQ32\bpq32.cfg
      Conversion <probably> successful
      G8BPQ AX25 Packet Switch System Version V5.0.0.1 February 2011
      Copyright &#8976; 2001-2011 John Wiseman G8BPQ
      BUFF 42083A94
      END 420C57DC

      Initialising Port 01 WINMOR Host 127.0.0.1 8500
      Port Initialisation Complete

      WINMOR TNC.ini has:
      [WINMOR TNC Form]
      MyCallsign=KC0TPG-1
      Registration=793338C773CF0C6E09574D3DBFCA17CA
      TCP Control Port =8500
      MyGridsquare=EN33HD
      StartMinimized=False
      DebugLog=True
      CommandTrace= False
      CaptureDevice=Microphone (USB Audio CODEC )-3a
      PlaybackDevice=Speakers (USB Audio CODEC )-4d
      TCP Address=127.0.0.1
      ResponseDelay=100
      LeaderExtension=0
      Top=50
      Left=0
      WINMOR Status – Port 1 has:
      Comms State Connected to WINMORE TNC
      TNC State Blank
      Mode FSK4_2CarShort
      Chanel State Busy
      Proto State Disconnected
      Traffic 0 0 0 0 0 (This is a symbol I cannot reproduce!)
      TNC Restarts 0 Last Restart Never
      The message area has:
      DISCONNECTED

      WINMOR Sound Card TNC Port :8500
      The waterfall is working. I clicked on Send ID and the SignaLink USB box PTT red light went on. This seemed to work OK. The ICOM IC-7000 went into transmit mode. It appears that the WINMOR Sound Card TNC can communicate with the SignaLink USB and put the radio into transmit mode and send information.

      I then tried to start AirMail Packet Client and received the following:
      2011/08/14 15:55:03 Packet initialization failed

      I th en tried to start Terminal in AirMail and received the following error:
      No Ready signal (CTS) from COM20
      Check Controller connection and try again

      The challenge continues!

      Art
      KC0TPG

      --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:

      >
      > Art,
      >
      >
      >
      > The only thing I can think of is that the "Use Real COM Ports"
      box in
      > BPQHostModes is checked.
      >
      >
      >
      > 73, John G8BPQ
      >
      >
      >
      >
      >
      > _____
      >
      > From: BPQ32@yahoogroups.com
      [mailto:BPQ32@yahoogroups.com] On Behalf Of
      > kc0tpg
      > Sent: 14 August 2011 01:08
      > To: BPQ32@yahoogroups.com
      > Subject: [BPQ32] COM20 is already in use
      >
      >
      >
      >
      >
      > I have installed BPQ32 and Winmor. I start BPQ32 Host Mode and all works
      OK.
      > The WINMORE sound card (SignaLink USB) starts and all looks OK.> I then
      start AirMail and it works OK. I then go to Modules and select Packed
      > Client. I get the following error message.
      > COM20 is already in use.
      > Check Options settings and connections.
      > I have rebooted the computer, rechecked all entries and reread multiple
      > times
      > WA7RF's
      > Airmail/BPQ32/WINMOR
      > Setup Instructions
      > By
      > Robert S. Fisher
      > WA7RF
      > Updated by G8BPQ
      >
      > Obviously I am missing something. Are there any ideas I may try?
      > Sailmail works fine with Telnet.
      >
      > Art
      >

    Your message has been successfully submitted and would be delivered to recipients shortly.