Loading ...
Sorry, an error occurred while loading the content.

Re: almost there!

Expand Messages
  • MIchael Melnik Sr.
    ... Joost ZS5S I sent you a new BPQCFG.TXT for the May62006 BPQ, i also want to point out the setting in your PK 232 Called PID, it is unclear but seems to
    Message 1 of 45 , Dec 3, 2006
    • 0 Attachment
      --- In BPQ32@yahoogroups.com, zs5s@... wrote:
      Joost ZS5S
      I sent you a new BPQCFG.TXT for the May62006 BPQ, i also want to
      point out the setting in your PK 232 Called PID, it is unclear
      but seems to point to it needs to be on for BPQ32U to talk with
      your TNC, for Receive, John G8BPQ or Ron N5IN my have more
      Information on this. There is also some warnings about the use of
      this mode, i have tried both on and off in my Kantronics TNC's and
      never saw much differance except extra received frames, NON-AX25

      Mike/N9PMO
      >
      >
      > I am most grateful to John, G8BPQ and Mike, N9PMO, for assisting me
      > in getting BPQ32 and FBB32 up and running and talking to each
      other.
      >
      > What I expected to be a piece of cake, activating the PK232 and
      > the VHF transceiver, turns out te be another hurdle.
      >
      > - PC, PK232 and the radio are wired up correctly.
      >
      > - On the pc, I open up Hyper Terminal and connect to the PK232.
      > After typing the * (star) I enter a string of commands.
      > I found five different strings to get the PK232 in KISS mode but
      > none of them seems to work ... probably something else is wrong.
      > After typing in
      > EXPERT ON
      > XFLOW OFF
      > Hyper Terminal displays whatever activity there is on the
      channel.
      > The strings of commands normally end in
      > KISS ON
      > HOST ON
      > Next I close Hyper Terminal .... and wonder whether the commands
      > are retained in the PK232?
      > FBB is activated which opens BPQ32 instantly.
      > In the 'Port' section of BPQ I have the following:
      >
      > PORT
      > PORTNUM=1 ; Optional but sets port number if
      stated
      > ID=144.625 1200 Baud ; Displayed by PORT command
      > TYPE=ASYNC ; EXTERNAL = calls an external module
      > PROTOCOL=KISS
      > IOADDR=1 ; 3F8 serial 1, 2F8H serial
      > CHANNEL=A ; A=1, B=2 etc. - required param
      > INTLEVEL=3
      > SPEED=9600
      > QUALITY=10 ; Setting to 0 stops node broadcasts
      > MAXFRAME=1 ; Max outstanding frames (1 through
      7)
      > TXDELAY 500
      > SLOTTIME=100
      > PERSIST=64
      > FULLDUP=0
      > FRACK=7000 ; Level 2 timeout in miliseconds
      > RESPTIME=2000 ; Level 2 delayed ack timer in
      milliseconds
      > RETRIES=7 ; Level 2 maximum retry value
      > PACLEN=225 ; Default max packet length for this
      port
      > MHEARD=Y
      > PORTALIAS=DIGI
      > DIGIFLAG=1
      > MINQUAL=200
      > UNPROTO=MAIL, ZS0HIL-2 ; DEFAULT UNPROTO ADDR (no 'v'
      required)
      > ENDPORT
      > ;
      >
      > I can hear Packet activity on the radio channel and it shows on the
      > PK232 Tune bar but no display of what is going on on the Monitor
      > functions in FBB and BPQTerminal.
      >
      > Beacon and unproto signals are generated but the VHF transceiver is
      > not transmitting.
      >
      > It baffles me and your assistance would be highly appreciated.
      >
      > 73,
      >
      > Joost, ZS5S
      >
      > ------------------------------------------------------------------
      >
      > For Homepage double-click: http://zs5s.net
      >
    • John Wiseman
      With PROTOCOL=KISS, the FULLDUP parameter is passed to the TNC, and all the KISS implementations I know of will obey the param (ie not transmit if carrier is
      Message 45 of 45 , Apr 7, 2008
      • 0 Attachment
        With PROTOCOL=KISS, the FULLDUP parameter is passed to the TNC, and all the KISS implementations I know of will obey the param (ie not transmit if carrier is present and FULLDUP=0). Also all that I know will operate true full duplex (simultaneous transmit and receive) if the frequencies are far enough apart (probably crossband, but with good enough cavity filters could be in same band), No handshaking signals are used, so a 3 wire cable is fine.
         
        With PROTCOL=NETROM, FULLDUP controls the link between the PC and TNC(s). With BPQ32 it has to be set to 1, and only supports 1 TNC, but with the old DOS BPQCODE you could set FULLDUP=0, and connect a stack of NET/ROM TNC's via a diode matrix. In this case the RTS and CTS lines control the matrix.
         
        73,
        John G8BPQ
         
         
        -----Original Message-----
        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com]On Behalf Of Ron Stordahl
        Sent: 07 April 2008 15:29
        To: BPQ32@yahoogroups.com
        Subject: Re: [BPQ32] Full DCD signal but will still transmit

        I am quite interested in this issue.  I have always used the JKISS or BPQKISS ROM, with minimal wiring (RX,TX and GND) and FULLDUP=0, and have never noticed the TNC (MFJ1270C's) stomp on a signal being received (with the DCD led illuminated) .

        This does bring up the possibility that if the RX and TX frequencies are far removed, it may be possible to operate full duplex.  I had thought the hardware prevented this, but perhaps not?

        With PROTOCOL=NETROM is is necessary that FULLDUP=1 for the interface to function.  Might it then transmit with DCD on and thus stomp on the received packet?

        While I have always used the minimal cabling, might full cabling be required in some cases?

        http://groups. yahoo.com/ group/BPQ32/ files/BPQ32_ RS232_Cabling/

        Ron, N5IN



        ----- Original Message ----
        From: John Wiseman <john.wiseman@ ntlworld. com>
        To: BPQ32@yahoogroups. com
        Sent: Monday, April 7, 2008 2:56:06 AM
        Subject: RE: [BPQ32] Full DCD signal but will still transmit

        Dave,
         
        Setting FULLDUP=0 in the port definition should stop it, although this relies on the TNC obeying the relevant KISS command.
         
        73,
        John
         
        -----Original Message-----
        From: BPQ32@yahoogroups. com [mailto:BPQ32@ yahoogroups. com]On Behalf Of David Calder
        Sent: 06 April 2008 18:19
        To: BPQ32@yahoogroups. com
        Subject: [BPQ32] Full DCD signal but will still transmit

         
        My BPQ ports will transmit on top of someone even if the TNC shows it having
        a full good DCD. IT will just tromp on them anyway.
         
        In the old BPQ (which is on my dead machine) I seem to remember a port
        command to stop that. What was it?
         
        Thanks,
        73 Dave
        n4zkf
         

      Your message has been successfully submitted and would be delivered to recipients shortly.