Loading ...
Sorry, an error occurred while loading the content.

Re: [BPQ32] almost there!

Expand Messages
  • Art Bertheaume
    Hello John and Group, John, for KISS mode, you need to have HOST OFF. Reset your TNC and open Hyperterm. Send the TNC an asterisk to initialize it. You
    Message 1 of 45 , Dec 3, 2006
      Hello John and Group,
        John,  for KISS mode, you need to have HOST OFF.  Reset your TNC and open Hyperterm.   Send the TNC an asterisk to initialize it.   You will need to insure HOST mode is off. 
      At the cmd: prompt, 
      Type    HOST OFF
      Then    MYC  ZS5S
      Then    KISS ON
      Then    RESTART
      You will not see the text of RESTART when you type it but it is required.
      I am using two AEA 232MBX's myself, and this is all I have to do put it in KISS mode.   I believe the error you are having is by putting the TNC into HOST mode.
      Art,  N9ZZK

      zs5s@... wrote:

      I am most grateful to John, G8BPQ and Mike, N9PMO, for assisting me
      in getting BPQ32 and FBB32 up and running and talking to each other.

      What I expected to be a piece of cake, activating the PK232 and
      the VHF transceiver, turns out te be another hurdle.

      - PC, PK232 and the radio are wired up correctly.

      - On the pc, I open up Hyper Terminal and connect to the PK232.
      After typing the * (star) I enter a string of commands.
      I found five different strings to get the PK232 in KISS mode but
      none of them seems to work ... probably something else is wrong.
      After typing in
      Hyper Terminal displays whatever activity there is on the channel.
      The strings of commands normally end in
      KISS ON
      HOST ON
      Next I close Hyper Terminal .... and wonder whether the commands
      are retained in the PK232?
      FBB is activated which opens BPQ32 instantly.
      In the 'Port' section of BPQ I have the following:

      PORTNUM=1 ; Optional but sets port number if stated
      ID=144.625 1200 Baud ; Displayed by PORT command
      TYPE=ASYNC ; EXTERNAL = calls an external module
      IOADDR=1 ; 3F8 serial 1, 2F8H serial
      CHANNEL=A ; A=1, B=2 etc. - required param
      QUALITY=10 ; Setting to 0 stops node broadcasts
      MAXFRAME=1 ; Max outstanding frames (1 through 7)
      TXDELAY 500
      FRACK=7000 ; Level 2 timeout in miliseconds
      RESPTIME=2000 ; Level 2 delayed ack timer in milliseconds
      RETRIES=7 ; Level 2 maximum retry value
      PACLEN=225 ; Default max packet length for this port
      UNPROTO=MAIL, ZS0HIL-2 ; DEFAULT UNPROTO ADDR (no 'v' required)

      I can hear Packet activity on the radio channel and it shows on the
      PK232 Tune bar but no display of what is going on on the Monitor
      functions in FBB and BPQTerminal.

      Beacon and unproto signals are generated but the VHF transceiver is
      not transmitting.

      It baffles me and your assistance would be highly appreciated.


      Joost, ZS5S

      ------------ --------- --------- --------- --------- --------- -

      For Homepage double-click: http://zs5s. net

    • John Wiseman
      With PROTOCOL=KISS, the FULLDUP parameter is passed to the TNC, and all the KISS implementations I know of will obey the param (ie not transmit if carrier is
      Message 45 of 45 , Apr 7, 2008
        With PROTOCOL=KISS, the FULLDUP parameter is passed to the TNC, and all the KISS implementations I know of will obey the param (ie not transmit if carrier is present and FULLDUP=0). Also all that I know will operate true full duplex (simultaneous transmit and receive) if the frequencies are far enough apart (probably crossband, but with good enough cavity filters could be in same band), No handshaking signals are used, so a 3 wire cable is fine.
        With PROTCOL=NETROM, FULLDUP controls the link between the PC and TNC(s). With BPQ32 it has to be set to 1, and only supports 1 TNC, but with the old DOS BPQCODE you could set FULLDUP=0, and connect a stack of NET/ROM TNC's via a diode matrix. In this case the RTS and CTS lines control the matrix.
        John G8BPQ
        -----Original Message-----
        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com]On Behalf Of Ron Stordahl
        Sent: 07 April 2008 15:29
        To: BPQ32@yahoogroups.com
        Subject: Re: [BPQ32] Full DCD signal but will still transmit

        I am quite interested in this issue.  I have always used the JKISS or BPQKISS ROM, with minimal wiring (RX,TX and GND) and FULLDUP=0, and have never noticed the TNC (MFJ1270C's) stomp on a signal being received (with the DCD led illuminated) .

        This does bring up the possibility that if the RX and TX frequencies are far removed, it may be possible to operate full duplex.  I had thought the hardware prevented this, but perhaps not?

        With PROTOCOL=NETROM is is necessary that FULLDUP=1 for the interface to function.  Might it then transmit with DCD on and thus stomp on the received packet?

        While I have always used the minimal cabling, might full cabling be required in some cases?

        http://groups. yahoo.com/ group/BPQ32/ files/BPQ32_ RS232_Cabling/

        Ron, N5IN

        ----- Original Message ----
        From: John Wiseman <john.wiseman@ ntlworld. com>
        To: BPQ32@yahoogroups. com
        Sent: Monday, April 7, 2008 2:56:06 AM
        Subject: RE: [BPQ32] Full DCD signal but will still transmit

        Setting FULLDUP=0 in the port definition should stop it, although this relies on the TNC obeying the relevant KISS command.
        -----Original Message-----
        From: BPQ32@yahoogroups. com [mailto:BPQ32@ yahoogroups. com]On Behalf Of David Calder
        Sent: 06 April 2008 18:19
        To: BPQ32@yahoogroups. com
        Subject: [BPQ32] Full DCD signal but will still transmit

        My BPQ ports will transmit on top of someone even if the TNC shows it having
        a full good DCD. IT will just tromp on them anyway.
        In the old BPQ (which is on my dead machine) I seem to remember a port
        command to stop that. What was it?
        73 Dave

      Your message has been successfully submitted and would be delivered to recipients shortly.