Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] Re: Winmor TNC Warning

Expand Messages
  • John Wiseman
    From the BPQ32 WINMOR documentation: The driver supports PTT control via a serial port, using the DTR and/or RTS control lines, or ICOM CI-V commands, via the
    Message 1 of 17 , Mar 5, 2010
    • 0 Attachment
      Message
      From the BPQ32 WINMOR documentation:
       
      The driver supports PTT control via a serial port, using the DTR and/or RTS control lines, or ICOM CI-V commands, via the Rig Control Driver. 
       
       
      and
       

      The WINMOR driver is configured via file BPQtoWINMOR.cfg. 

      The first line defines which BPQ Port this config relates to, the IP address and Port of the WINMOR TNC, an optional PTT paameter, and an optional application for incoming WINMOR connects to be routed to. If PTT is omitted, VOX operation is assumed, and if the application is omitted, calls are connected to the Node command interpreter. You will need this if you want to accept calls from software that doesn't have a connect script, such as RMS Express. 

      Typical first lines are:

      PORT 3 127.0.0.1 8500                No PTT (ie use VOX), Connects to Command Handler 
      PORT 3 127.0.0.1 8500 BBS            No PTT, route incoming connections to the BBS
      PORT 3 127.0.0.1 8500 PTT DTR        PTT control via DTR Line, Connects to Command Handle
      PORT 3 127.0.0.1 8500 PTT CI-V BBS   PTT cotrol via CI-V commands, route incoming connections to the BBS
      
      Other PTT options are PTT RTS, PTT DTRRTS 
      

       
      From the Rig Control Driver Documentation
       

      RigControl.cfg

      #
      #	Config file for RigContol
      #
      #	One copy of RigControl can support more than one Serial interface.
      #
      #	The ICOM implemetation allows more than one rig to be attached to the same interface
      #
      #	The COM Line defines a Serial Connection, and the type of radio 
      #
      #	For a Port that just provides PTT control via the serial port RTS or DTR Lines, use TYPE of PTTONLY
      #
      
      COM65 19200 PTTONLY
      
      # For PTT control, specify only a Name and a BPQ Port Number.
      
      RADIO IC7000 4
      
      

       
      73,
      John

       

      -----Original Message-----
      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Howard Z
      Sent: 05 March 2010 15:13
      To: BPQ32@yahoogroups.com
      Subject: [BPQ32] Re: Winmor TNC Warning

       

      Ok,

      Let me see...

      I see where to specify the Audio In and Audio Out.
      That's done in Winmor and stored it Winmor's INI file.

      Where does one specify PTT?
      The COM port and RTS/DTR?
      This should be in the host program - i.e. BPQ ???

      Howard



      I am using the Free version of SPAMfighter.
      We are a community of 6 million users fighting spam.
      SPAMfighter has removed 352 of my spam emails to date.
      The Professional version does not have this message.
    • Rick Muething
      Howard, The host can also set the audio capture/playback and read the available sound cards from the TNC. The host program takes care of the PTT .It receives a
      Message 2 of 17 , Mar 5, 2010
      • 0 Attachment

        Howard,

         

        The host can also set the audio capture/playback and read the available sound cards from the TNC.

         

        The host program takes care of the PTT …It receives a PTT True/PTT False signal from the WINMOR TNC

        The host can chose to:

        Ignore the PTT signals from the TNC and let the audio key the radio or sound card (e.g. SignaLink) via VOX

        or

        Key the radio via RS232 control port (Some radios). This would be the same port used for setting frequency, filter etc. Not all radios support serial port PTT keying but this is one of the cleanest ways if your radio does.

        or

        Key the radio via a dedicated RS232 port using DTR or RTS.

         

        We did not key the radio in the TNC since if you are using a radio control port for PTT keying it would cause a port conflict. Best done in the host.

         

        Rick KN6KB


        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Howard Z
        Sent: Friday, March 05, 2010 10:13 AM
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] Re: Winmor TNC Warning

         

         

        Ok,

        Let me see...

        I see where to specify the Audio In and Audio Out.
        That's done in Winmor and stored it Winmor's INI file.

        Where does one specify PTT?
        The COM port and RTS/DTR?
        This should be in the host program - i.e. BPQ ???

        Howard

        No virus found in this incoming message.
        Checked by AVG - www.avg.com
        Version: 9.0.733 / Virus Database: 271.1.1/2707 - Release Date: 03/04/10 14:34:00

      • Howard Z
        Here is a portion of my bpqcfg.txt file the Winmore is the third port I have defined here: PORT PORTNUM=3 ID=WINMOR Port 1 TYPE=EXTERNAL PROTOCOL=WINMOR
        Message 3 of 17 , Mar 5, 2010
        • 0 Attachment
          Here is a portion of my bpqcfg.txt file
          the Winmore is the third port I have defined here:

          PORT
          PORTNUM=3
          ID=WINMOR Port 1
          TYPE=EXTERNAL
          PROTOCOL=WINMOR
          DLLNAME=WINMOR.DLL
          PORTCALL=CALL ; Optional - set if you want to accept connects to a call other than the Node Call.
          ;INTERLOCK=n; ; Optional - set if you have two ports sharing the same radio.
          ; Set the same Interlock value on both ports.
          QUALITY=0
          ENDPORT

          Here is my BPQtoWINMOR file:
          Note that I must enter PORT 3 or else the BPQ WINMOR TNC window will not appear. But actually the PTT port is COM8 - so I have no place to enter COM8

          ; Config file for BPQtoWINMOR
          ;
          ;PORT 3 127.0.0.1 8500
          ;PORT 3 127.0.0.1 8500 BBS
          ;PORT 3 127.0.0.1 8500 PTT DTR
          ;PORT 3 127.0.0.1 8500 PTT CI-V BBS
          PORT 3 127.0.0.1 8500 PTT RTS
          CWID True
          DEBUGLOG True
          LOG True
          BW 1600
          DRIVELEVEL 88
          MODE AUTO
          ROBUST False
          SHOW True
          BUSYLOCK True

          Last, but not least, here is the WINMOR TNC.ini file


          [WINMOR TNC Form]
          TCP Control Port=8500
          MyCallsign=N3ZH
          MyGridsquare=FM19MB
          StartMinimized=False
          DebugLog=True
          CaptureDevice=Line 1 (Virtual Audio Cable)-6a
          PlaybackDevice=Line 2 (Virtual Audio Cable)-a3
          ResponseDelay=100
          LeaderExtension=0
          Top=295
          Left=42

          BTW, BPQ32 BLOWS up every time.
          I run the BPQ terminal, enter attach 3, then C followed by a callsign - then blows up.

          Howard
        • Art Bertheaume
          Howard The port in BPQtoWinmor refers to the Winmor port you have set for winmor in BPQCFG.txt.    You will need to define the serial port(com port) in
          Message 4 of 17 , Mar 5, 2010
          • 0 Attachment
            Howard
            The "port" in BPQtoWinmor refers to the Winmor port you have set for winmor in BPQCFG.txt. 
             
            You will need to define the serial port(com port) in Rigcontrol.cfg
             
            Art, N9ZZK

            --- On Fri, 3/5/10, Howard Z <Howard_Z@...> wrote:

            From: Howard Z <Howard_Z@...>
            Subject: [BPQ32] Re: Winmor TNC Warning
            To: BPQ32@yahoogroups.com
            Date: Friday, March 5, 2010, 9:49 AM

             
            Here is a portion of my bpqcfg.txt file
            the Winmore is the third port I have defined here:

            PORT
            PORTNUM=3
            ID=WINMOR Port 1
            TYPE=EXTERNAL
            PROTOCOL=WINMOR
            DLLNAME=WINMOR. DLL
            PORTCALL=CALL ; Optional - set if you want to accept connects to a call other than the Node Call.
            ;INTERLOCK=n; ; Optional - set if you have two ports sharing the same radio.
            ; Set the same Interlock value on both ports.
            QUALITY=0
            ENDPORT

            Here is my BPQtoWINMOR file:
            Note that I must enter PORT 3 or else the BPQ WINMOR TNC window will not appear. But actually the PTT port is COM8 - so I have no place to enter COM8

            ; Config file for BPQtoWINMOR
            ;
            ;PORT 3 127.0.0.1 8500
            ;PORT 3 127.0.0.1 8500 BBS
            ;PORT 3 127.0.0.1 8500 PTT DTR
            ;PORT 3 127.0.0.1 8500 PTT CI-V BBS
            PORT 3 127.0.0.1 8500 PTT RTS
            CWID True
            DEBUGLOG True
            LOG True
            BW 1600
            DRIVELEVEL 88
            MODE AUTO
            ROBUST False
            SHOW True
            BUSYLOCK True

            Last, but not least, here is the WINMOR TNC.ini file

            [WINMOR TNC Form]
            TCP Control Port=8500
            MyCallsign=N3ZH
            MyGridsquare= FM19MB
            StartMinimized= False
            DebugLog=True
            CaptureDevice= Line 1 (Virtual Audio Cable)-6a
            PlaybackDevice= Line 2 (Virtual Audio Cable)-a3
            ResponseDelay= 100
            LeaderExtension= 0
            Top=295
            Left=42

            BTW, BPQ32 BLOWS up every time.
            I run the BPQ terminal, enter attach 3, then C followed by a callsign - then blows up.

            Howard

          • John Wiseman
            Howard, You probably should remove the PORTCALL line from bpqcfg.txt You also need a rigcontrol.cfg containing: COM8 19200 PTTONLY RADIO XXXX 3 73, John ...
            Message 5 of 17 , Mar 5, 2010
            • 0 Attachment
              Message
              Howard,
               
              You probably should remove the PORTCALL line from bpqcfg.txt
               
              You also need a rigcontrol.cfg containing:


              COM8 19200 PTTONLY

              RADIO XXXX  3
               
               
              73,
              John
               
               

               
              -----Original Message-----
              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Howard Z
              Sent: 05 March 2010 15:50
              To: BPQ32@yahoogroups.com
              Subject: [BPQ32] Re: Winmor TNC Warning

               

              Here is a portion of my bpqcfg.txt file
              the Winmore is the third port I have defined here:

              PORT
              PORTNUM=3
              ID=WINMOR Port 1
              TYPE=EXTERNAL
              PROTOCOL=WINMOR
              DLLNAME=WINMOR. DLL
              PORTCALL=CALL ; Optional - set if you want to accept connects to a call other than the Node Call.
              ;INTERLOCK=n; ; Optional - set if you have two ports sharing the same radio.
              ; Set the same Interlock value on both ports.
              QUALITY=0
              ENDPORT

              Here is my BPQtoWINMOR file:
              Note that I must enter PORT 3 or else the BPQ WINMOR TNC window will not appear. But actually the PTT port is COM8 - so I have no place to enter COM8

              ; Config file for BPQtoWINMOR
              ;
              ;PORT 3 127.0.0.1 8500
              ;PORT 3 127.0.0.1 8500 BBS
              ;PORT 3 127.0.0.1 8500 PTT DTR
              ;PORT 3 127.0.0.1 8500 PTT CI-V BBS
              PORT 3 127.0.0.1 8500 PTT RTS
              CWID True
              DEBUGLOG True
              LOG True
              BW 1600
              DRIVELEVEL 88
              MODE AUTO
              ROBUST False
              SHOW True
              BUSYLOCK True

              Last, but not least, here is the WINMOR TNC.ini file

              [WINMOR TNC Form]
              TCP Control Port=8500
              MyCallsign=N3ZH
              MyGridsquare= FM19MB
              StartMinimized= False
              DebugLog=True
              CaptureDevice= Line 1 (Virtual Audio Cable)-6a
              PlaybackDevice= Line 2 (Virtual Audio Cable)-a3
              ResponseDelay= 100
              LeaderExtension= 0
              Top=295
              Left=42

              BTW, BPQ32 BLOWS up every time.
              I run the BPQ terminal, enter attach 3, then C followed by a callsign - then blows up.

              Howard



              I am using the Free version of SPAMfighter.
              We are a community of 6 million users fighting spam.
              SPAMfighter has removed 352 of my spam emails to date.
              The Professional version does not have this message.
            • Howard Z
              OK, I got the Winmor TNC working with BPQ32 I can open the BPQTerminal program 1. type attach 3 2. type c callsign and the Winmor TNC will transmit trying to
              Message 6 of 17 , Mar 8, 2010
              • 0 Attachment
                OK,
                I got the Winmor TNC working with BPQ32

                I can open the BPQTerminal program
                1. type attach 3
                2. type c callsign
                and the Winmor TNC will transmit trying to connect.

                But, now the big picture question - what can we do with it?

                I have the impression that this extends BPQ & VHF Packet to HF via Winmor.
                1. This will mean sending out beacon text announcing the BPQ BBS, ARcluster, and RMS
                2. Accepting connect requests with the appropriate callsign for
                2a. WinFbb connects
                2b. RMS Packet connects
                2c. ARcluster connects

                Am I right?
                I am waiting for a beacon via Winmor via my HF radio.

                Howard

                --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
                >
                > Howard,
                >
                > You probably should remove the PORTCALL line from bpqcfg.txt
                >
                > You also need a rigcontrol.cfg containing:
                >
                >
                > COM8 19200 PTTONLY
                >
                > RADIO XXXX 3
                >
                >
                > 73,
                > John
                >
                >
                >
                >
                >
                > -----Original Message-----
                > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
                > Howard Z
                > Sent: 05 March 2010 15:50
                > To: BPQ32@yahoogroups.com
                > Subject: [BPQ32] Re: Winmor TNC Warning
                >
                >
                >
                >
                > Here is a portion of my bpqcfg.txt file
                > the Winmore is the third port I have defined here:
                >
                > PORT
                > PORTNUM=3
                > ID=WINMOR Port 1
                > TYPE=EXTERNAL
                > PROTOCOL=WINMOR
                > DLLNAME=WINMOR.DLL
                > PORTCALL=CALL ; Optional - set if you want to accept connects to a call
                > other than the Node Call.
                > ;INTERLOCK=n; ; Optional - set if you have two ports sharing the same radio.
                > ; Set the same Interlock value on both ports.
                > QUALITY=0
                > ENDPORT
                >
                > Here is my BPQtoWINMOR file:
                > Note that I must enter PORT 3 or else the BPQ WINMOR TNC window will not
                > appear. But actually the PTT port is COM8 - so I have no place to enter COM8
                >
                > ; Config file for BPQtoWINMOR
                > ;
                > ;PORT 3 127.0.0.1 8500
                > ;PORT 3 127.0.0.1 8500 BBS
                > ;PORT 3 127.0.0.1 8500 PTT DTR
                > ;PORT 3 127.0.0.1 8500 PTT CI-V BBS
                > PORT 3 127.0.0.1 8500 PTT RTS
                > CWID True
                > DEBUGLOG True
                > LOG True
                > BW 1600
                > DRIVELEVEL 88
                > MODE AUTO
                > ROBUST False
                > SHOW True
                > BUSYLOCK True
                >
                > Last, but not least, here is the WINMOR TNC.ini file
                >
                > [WINMOR TNC Form]
                > TCP Control Port=8500
                > MyCallsign=N3ZH
                > MyGridsquare=FM19MB
                > StartMinimized=False
                > DebugLog=True
                > CaptureDevice=Line 1 (Virtual Audio Cable)-6a
                > PlaybackDevice=Line 2 (Virtual Audio Cable)-a3
                > ResponseDelay=100
                > LeaderExtension=0
                > Top=295
                > Left=42
                >
                > BTW, BPQ32 BLOWS up every time.
                > I run the BPQ terminal, enter attach 3, then C followed by a callsign - then
                > blows up.
                >
                > Howard
                >
                >
                >
                >
                >
                >
                > _____
                >
                > I am using the Free version of SPAMfighter <http://www.spamfighter.com/len>
                > .
                > We are a community of 6 million users fighting spam.
                > SPAMfighter has removed 352 of my spam emails to date.
                > The Professional version does not have this message.
                >
              • John Wiseman
                At the moment Winmor in connected (ARQ) mode is mainly used for BBS BBS forwarding, for both Packet BBS system and RMS/WL2K. There is some keyboard to
                Message 7 of 17 , Mar 8, 2010
                • 0 Attachment
                  Message
                  At the moment Winmor in connected (ARQ) mode is mainly used for BBS<>BBS forwarding, for both Packet BBS system and RMS/WL2K. There is some keyboard to keyboard activity using FEC mode. Although it could be used for interactive access to an application such as AR Cluster, it is not optimised for that.
                   
                  As I understand it, beaconing on HF is not regarded as a very friendly think to do. But WINMOR stations always send an ID after a connection, which will appear in your MHeard list.
                   
                   
                  John G8BPQ
                   
                   
                   
                  -----Original Message-----
                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Howard Z
                  Sent: 08 March 2010 19:34
                  To: BPQ32@yahoogroups.com
                  Subject: [BPQ32] Re: Winmor TNC Warning

                   

                  OK,
                  I got the Winmor TNC working with BPQ32

                  I can open the BPQTerminal program
                  1. type attach 3
                  2. type c callsign
                  and the Winmor TNC will transmit trying to connect.

                  But, now the big picture question - what can we do with it?

                  I have the impression that this extends BPQ & VHF Packet to HF via Winmor.
                  1. This will mean sending out beacon text announcing the BPQ BBS, ARcluster, and RMS
                  2. Accepting connect requests with the appropriate callsign for
                  2a. WinFbb connects
                  2b. RMS Packet connects
                  2c. ARcluster connects

                  Am I right?
                  I am waiting for a beacon via Winmor via my HF radio.

                  Howard

                  --- In BPQ32@yahoogroups. com, "John Wiseman" <john.wiseman@ ...> wrote:
                  >
                  > Howard,
                  >
                  > You probably should remove the PORTCALL line from bpqcfg.txt
                  >
                  > You also need a rigcontrol.cfg containing:
                  >
                  >
                  > COM8 19200 PTTONLY
                  >
                  > RADIO XXXX 3
                  >
                  >
                  > 73,
                  > John
                  >
                  >
                  >
                  >
                  >
                  > -----Original Message-----
                  > From: BPQ32@yahoogroups. com [mailto:BPQ32@yahoogroups. com] On Behalf Of
                  > Howard Z
                  > Sent: 05 March 2010 15:50
                  > To: BPQ32@yahoogroups. com
                  > Subject: [BPQ32] Re: Winmor TNC Warning
                  >
                  >
                  >
                  >
                  > Here is a portion of my bpqcfg.txt file
                  > the Winmore is the third port I have defined here:
                  >
                  > PORT
                  > PORTNUM=3
                  > ID=WINMOR Port 1
                  > TYPE=EXTERNAL
                  > PROTOCOL=WINMOR
                  > DLLNAME=WINMOR. DLL
                  > PORTCALL=CALL ; Optional - set if you want to accept connects to a call
                  > other than the Node Call.
                  > ;INTERLOCK=n; ; Optional - set if you have two ports sharing the same radio.
                  > ; Set the same Interlock value on both ports.
                  > QUALITY=0
                  > ENDPORT
                  >
                  > Here is my BPQtoWINMOR file:
                  > Note that I must enter PORT 3 or else the BPQ WINMOR TNC window will not
                  > appear. But actually the PTT port is COM8 - so I have no place to enter COM8
                  >
                  > ; Config file for BPQtoWINMOR
                  > ;
                  > ;PORT 3 127.0.0.1 8500
                  > ;PORT 3 127.0.0.1 8500 BBS
                  > ;PORT 3 127.0.0.1 8500 PTT DTR
                  > ;PORT 3 127.0.0.1 8500 PTT CI-V BBS
                  > PORT 3 127.0.0.1 8500 PTT RTS
                  > CWID True
                  > DEBUGLOG True
                  > LOG True
                  > BW 1600
                  > DRIVELEVEL 88
                  > MODE AUTO
                  > ROBUST False
                  > SHOW True
                  > BUSYLOCK True
                  >
                  > Last, but not least, here is the WINMOR TNC.ini file
                  >
                  > [WINMOR TNC Form]
                  > TCP Control Port=8500
                  > MyCallsign=N3ZH
                  > MyGridsquare= FM19MB
                  > StartMinimized= False
                  > DebugLog=True
                  > CaptureDevice= Line 1 (Virtual Audio Cable)-6a
                  > PlaybackDevice= Line 2 (Virtual Audio Cable)-a3
                  > ResponseDelay= 100
                  > LeaderExtension= 0
                  > Top=295
                  > Left=42
                  >
                  > BTW, BPQ32 BLOWS up every time.
                  > I run the BPQ terminal, enter attach 3, then C followed by a callsign - then
                  > blows up.
                  >
                  > Howard
                  >
                  >
                  >
                  >
                  >
                  >
                  > _____
                  >
                  > I am using the Free version of SPAMfighter <http://www.spamfigh ter.com/len>
                  > .
                  > We are a community of 6 million users fighting spam.
                  > SPAMfighter has removed 352 of my spam emails to date.
                  > The Professional version does not have this message.
                  >



                  I am using the Free version of SPAMfighter.
                  We are a community of 6 million users fighting spam.
                  SPAMfighter has removed 363 of my spam emails to date.
                  The Professional version does not have this message.
                • Howard Z
                  In the bpqcfg.txt file, what is an easy way to disable Winmor without deleting all the PORT...ENDPORT ? Howard
                  Message 8 of 17 , Mar 9, 2010
                  • 0 Attachment
                    In the bpqcfg.txt file, what is an easy way to disable Winmor without deleting all the PORT...ENDPORT ?

                    Howard
                  • John Wiseman
                    Put /* PORT . . . . ENDPORT */ round the definition. ... From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Howard Z Sent: 09 March 2010
                    Message 9 of 17 , Mar 9, 2010
                    • 0 Attachment
                      Message
                      Put
                       
                      /*
                      PORT
                      .
                      .
                      .
                      .
                      ENDPORT
                      */
                       
                      round the definition.
                       
                       
                      -----Original Message-----
                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Howard Z
                      Sent: 09 March 2010 16:30
                      To: BPQ32@yahoogroups.com
                      Subject: [BPQ32] Re: Winmor TNC Warning

                       

                      In the bpqcfg.txt file, what is an easy way to disable Winmor without deleting all the PORT...ENDPORT ?

                      Howard



                      I am using the Free version of SPAMfighter.
                      We are a community of 6 million users fighting spam.
                      SPAMfighter has removed 378 of my spam emails to date.
                      The Professional version does not have this message.
                    • Jerry - N9LYA
                      Put a ; in front of each line from port and endport and each line between. Then rerun bpqcfg and re-read bpqcfg into the system.. 73 jerry ; port ; ; ;
                      Message 10 of 17 , Mar 9, 2010
                      • 0 Attachment
                        Put a ; in front of each line from port and endport and each line between. Then rerun bpqcfg and re-read bpqcfg into the system.. 73 jerry
                         
                        ; port
                        ;
                        ;
                        ;
                        ;endport


                        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Howard Z
                        Sent: Tuesday, March 09, 2010 11:30 AM
                        To: BPQ32@yahoogroups.com
                        Subject: [BPQ32] Re: Winmor TNC Warning

                         

                        In the bpqcfg.txt file, what is an easy way to disable Winmor without deleting all the PORT...ENDPORT ?

                        Howard

                      Your message has been successfully submitted and would be delivered to recipients shortly.