Loading ...
Sorry, an error occurred while loading the content.

No Level 2 Connects with RMS Packet with BPQ32

Expand Messages
  • Rob
    The other day I setup our Section Traffic Manager with BPQ32 to run his RMS Packet Stations. He was using two instances of RMS Packet on 2 different AGW Ports
    Message 1 of 3 , Feb 14, 2010
    • 0 Attachment
      The other day I setup our Section Traffic Manager with BPQ32 to run his RMS Packet Stations. He was using two instances of RMS Packet on 2 different AGW Ports on 2 different frequencies. He wanted to solve the SSID-15 trasnposition problem with Airmail users so I encouraged him to run BPQ.

      I set BPQ32 up with the two AGW ports defined and one instance of RMS Packet running. He did not want to run as a node and be sending KEEPLI packets out on the users LANs so I did not enable switch support. Everything is working great and his able to accept RMS Packet connects from either port but only with L3 connects from other nodes on those frequencies. When users try him directly without going through another node, L2 connects, his -10 (call defined in RMS BPQ Setup) does not respond.

      I have enabled all BPQ ports in RMS Packet. Both AGW RF ports, Loopback and L4 connects.

      Again in BPQ, I have NODE=0 and BBS=0, no switch support and no BBS support. What do I need to tweak the configuration so he can accept L2, L3 and L4 connects without broadcasting all of the net/rom L3 and L4 frames on users frequencies. He needs to accept connects direct from users and through the main node on frequency (one hop).

      Thanks,

      Rob
      WA7RF
    • John Wiseman
      Rob, The BBS param s name is historic, from the time BPQ only supported one L4 application. It enables application support, and as RMS Packet is an
      Message 2 of 3 , Feb 15, 2010
      • 0 Attachment
        Message
        Rob,
         
        The BBS param's name is historic, from the time BPQ only supported one L4 application. It enables application support, and as RMS Packet is an application, it should be set to one.
         
        The NODE param has nothing to do with sending NODES broadcasts - it controls whether a user can connect to the node's command interpreter. With NODE=0, users can only connect the the Applications(s).
         
        If I understand your requirement, users should only be able to connect to RMS Packet, and not be able to use the node as a stepping point to other system. If so, you need NODE=0,  BBS=1. You should set both NODECALL and BBSCALL to Callsign-10. Note the call programmed into RMS Packet is not used on-air.
         
        I'm not clear why you are running AGW. Unless you are using soundcard modems, it would probably be better to define the TNCs directly to BPQ32.
         
        Whether or not NODES broadcasts are sent on a port is controlled by the PORT QUALITY parameter.If set to zero, NODES broadcasts will not be sent, and any heard will be ignored.
         
        With those setting users will be able to connect to the -10 call, and will be connected to RMS Packet, and there will be no NODES broadcasts.
         
        I'm not sure what you mean by the "main node", and the SSID-15 transposition problem. I'm assuming that some users are connecting via a node, and when a user makes a L2 connect to the RMS system, the SSID is inverted. To avoid this, you want L4 connects from the node to the RMS system. I assume this node is on one of the user's LAN frequencies. If so you have a problem - the L3/L4 system depends on NODES broadcasts. So you can't have a port that is free from NODES, but allows L4 connects. By setting NODEs broadcast intervals and Node and Port MINQUALS to suitable values, you can minimize the NODES broadcast overhead.
         
        Let me know if I've misunderstood anything.
         
        73,
        John
         
         
         
         
         
        -----Original Message-----
        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Rob
        Sent: 15 February 2010 06:21
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] No Level 2 Connects with RMS Packet with BPQ32

         

        The other day I setup our Section Traffic Manager with BPQ32 to run his RMS Packet Stations. He was using two instances of RMS Packet on 2 different AGW Ports on 2 different frequencies. He wanted to solve the SSID-15 trasnposition problem with Airmail users so I encouraged him to run BPQ.

        I set BPQ32 up with the two AGW ports defined and one instance of RMS Packet running. He did not want to run as a node and be sending KEEPLI packets out on the users LANs so I did not enable switch support. Everything is working great and his able to accept RMS Packet connects from either port but only with L3 connects from other nodes on those frequencies. When users try him directly without going through another node, L2 connects, his -10 (call defined in RMS BPQ Setup) does not respond.

        I have enabled all BPQ ports in RMS Packet. Both AGW RF ports, Loopback and L4 connects.

        Again in BPQ, I have NODE=0 and BBS=0, no switch support and no BBS support. What do I need to tweak the configuration so he can accept L2, L3 and L4 connects without broadcasting all of the net/rom L3 and L4 frames on users frequencies. He needs to accept connects direct from users and through the main node on frequency (one hop).

        Thanks,

        Rob
        WA7RF

      • WA4ZKO
        What version did the KEEPLI show up in? Maybe he would be better off just running the latest version that does NOT have the KEEPLI functionality in it?
        Message 3 of 3 , Feb 15, 2010
        • 0 Attachment
          What version did the "KEEPLI" show up in? Maybe he would be better off just running the latest version that does NOT have the KEEPLI functionality in it? Especially if he just wants node functionality (not BBS/CHAT) on that particular installation.

          John can correct me, but I think bumping this line/parm in bpqcfg.txt can be used to dial the KEEPLI pooling back somewhat:

          T3=120 ; Link validation timer in seconds

          Ramifications of raising this value?

          Regardless, I would vote for a way to turn the KEEPLI fuctionality off on a port by port basis. Example, have it on for the AXIP/UDP links, backbone ports, but be able to turn it off on the user port. Then maybe this can be done with PORT QUALITY in many cases.

          Unfortunately a lot of folks with "flat" networks are trying to do user access and node-to-node connectivity on the same single port/freq....a bad design (IMHO) but goes on a lot here in the states.

          73
          Jeff
          WA4ZKO

          --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
          >
          > Rob,
          >
          > The BBS param's name is historic, from the time BPQ only supported one
          > L4 application. It enables application support, and as RMS Packet is an
          > application, it should be set to one.
          >
          > The NODE param has nothing to do with sending NODES broadcasts - it
          > controls whether a user can connect to the node's command interpreter.
          > With NODE=0, users can only connect the the Applications(s).
          >
          > If I understand your requirement, users should only be able to connect
          > to RMS Packet, and not be able to use the node as a stepping point to
          > other system. If so, you need NODE=0, BBS=1. You should set both
          > NODECALL and BBSCALL to Callsign-10. Note the call programmed into RMS
          > Packet is not used on-air.
          >
          > I'm not clear why you are running AGW. Unless you are using soundcard
          > modems, it would probably be better to define the TNCs directly to
          > BPQ32.
          >
          > Whether or not NODES broadcasts are sent on a port is controlled by the
          > PORT QUALITY parameter.If set to zero, NODES broadcasts will not be
          > sent, and any heard will be ignored.
          >
          > With those setting users will be able to connect to the -10 call, and
          > will be connected to RMS Packet, and there will be no NODES broadcasts.
          >
          > I'm not sure what you mean by the "main node", and the SSID-15
          > transposition problem. I'm assuming that some users are connecting via a
          > node, and when a user makes a L2 connect to the RMS system, the SSID is
          > inverted. To avoid this, you want L4 connects from the node to the RMS
          > system. I assume this node is on one of the user's LAN frequencies. If
          > so you have a problem - the L3/L4 system depends on NODES broadcasts. So
          > you can't have a port that is free from NODES, but allows L4 connects.
          > By setting NODEs broadcast intervals and Node and Port MINQUALS to
          > suitable values, you can minimize the NODES broadcast overhead.
          >
          > Let me know if I've misunderstood anything.
          >
          > 73,
          > John
          >
          >
          >
          >
          >
          >
          > -----Original Message-----
          > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
          > Rob
          > Sent: 15 February 2010 06:21
          > To: BPQ32@yahoogroups.com
          > Subject: [BPQ32] No Level 2 Connects with RMS Packet with BPQ32
          >
          >
          >
          >
          > The other day I setup our Section Traffic Manager with BPQ32 to run his
          > RMS Packet Stations. He was using two instances of RMS Packet on 2
          > different AGW Ports on 2 different frequencies. He wanted to solve the
          > SSID-15 trasnposition problem with Airmail users so I encouraged him to
          > run BPQ.
          >
          > I set BPQ32 up with the two AGW ports defined and one instance of RMS
          > Packet running. He did not want to run as a node and be sending KEEPLI
          > packets out on the users LANs so I did not enable switch support.
          > Everything is working great and his able to accept RMS Packet connects
          > from either port but only with L3 connects from other nodes on those
          > frequencies. When users try him directly without going through another
          > node, L2 connects, his -10 (call defined in RMS BPQ Setup) does not
          > respond.
          >
          > I have enabled all BPQ ports in RMS Packet. Both AGW RF ports, Loopback
          > and L4 connects.
          >
          > Again in BPQ, I have NODE=0 and BBS=0, no switch support and no BBS
          > support. What do I need to tweak the configuration so he can accept L2,
          > L3 and L4 connects without broadcasting all of the net/rom L3 and L4
          > frames on users frequencies. He needs to accept connects direct from
          > users and through the main node on frequency (one hop).
          >
          > Thanks,
          >
          > Rob
          > WA7RF
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.