Loading ...
Sorry, an error occurred while loading the content.

Re: [BPQ32] Re: BPQ32 with DxNet by F5MZN

Expand Messages
  • Jim
    Hello John I have changed the line in dxnet.cfg to set/port agw. I am now back using dxnet 4.2 but it s no more hopeful than dxnet 4.3b15 was. I can see
    Message 1 of 16 , Jan 28, 2006
    • 0 Attachment
      Hello John

      I have changed the line in dxnet.cfg to set/port agw.

      I am now back using dxnet 4.2 but it's no more hopeful than dxnet 4.3b15
      was.

      I can see connect attempts for other nodes to GB7BDX via the agwtobpq
      beta interface but the connection is showing as false while the
      listening changes from true to false.

      Jim




      John Wiseman wrote:
      > Jim,
      >
      > You need set/port agw.
      >
      > Other settings look fine.
      >
      > Mke sure the set/call in dxnet.cfg matches (including any ssid) the bbscall
      > in bpqcfg.txt.
      >
      > 73,
      > John
      >
      >
      > -----Original Message-----
      > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Jim
      > Sent: 28 January 2006 11:54
      > To: BPQ32@yahoogroups.com
      > Subject: Re: [BPQ32] Re: BPQ32 with DxNet by F5MZN
      >
      >
      > Hi
      >
      > I am still having some trouble with linking dxnet and bpq32 . I have
      > decided to ditch agwpe as I only have 2 kiss tncs to control.
      >
      > In dxnet.cfg I have edited the line to read
      >
      > set/port agwtobpq
      >
      > Is this all I need to do with dxnet ?
      >
      > What is the correct set up for agwtobpq, I currently have tcp port as
      > 8000,listening sessions 10 and applmask 1.
      >
      > Here is my bpqcfg.txt below:
      >
      > ; CONFIGURATION FILE FOR BPQ32: GM8BPQ SWITCH SOFTWARE
      > ; AR-Cluster node N5IN 2005/Sept/14
      > ;
      > HOSTINTERRUPT=127 ; Interrupt used for BPQ host mode support
      > EMS=0 ; Doesn't use EMS RAM
      > DESQVIEW=0 ; DesqView unused
      > NODECALL=GM0FTJ-4 ; Node callsign
      > NODEALIAS=SELK ; Node alias
      > BBSCALL=GB7BDX ; BBS/AR-Cluster callsign
      > BBSALIAS=BDX ; BBS/AR-Cluster alias
      > IDMSG: ; The UI broadcast text follows:
      > Selkirk AX25 switch
      > *** ; Denotes end of IDMSG text
      > UNPROTO=ID ; The UI broadcast address
      > INFOMSG: ; The INFO command text follows:
      > Type DX to connect to the DX Cluster.
      > *** ; Denotes end of INFOMSG text
      > CTEXT: ; The CTEXT text follows:
      > Type DX to connect to the DX Cluster.
      > SELK:GM0FTJ-4} DX CONNECT BYE INFO NODES ROUTES PORTS USERS MHEARD
      > *** ; Denotes end of CTEXT text
      > FULL_CTEXT=0 ; 0=send CTEXT to L2 connects to NODEALIAS
      > only
      > ; ; 1=send CTEXT to all connectees
      > ;
      > ; Network System Parameters:
      > ;
      > OBSINIT=6 ; Initial obsolence value set when a node is
      > ; included in a received nodes broadcast.
      > This
      > ; value is decremented by 1 every
      > NODESINTERVAL.
      > OBSMIN=4 ; When the obsolence value of a node falls
      > below
      > ; this value that node's information is not
      > included
      > ; in a node broadcast.
      > NODESINTERVAL=15 ; Nodes broadcast interval in minutes
      > IDINTERVAL=60 ; 'IDMSG' UI broadcast interval in minutes
      > BTINTERVAL=0 ; The CW beacon interval in minutes, 0=OFF
      > L3TIMETOLIVE=25 ; Max L3 hops
      > L4RETRIES=3 ; Level 4 retry count
      > L4TIMEOUT=300 ; Level 4 timeout in seconds
      > L4DELAY=10 ; Level 4 delayed ack timer in seconds
      > L4WINDOW=4 ; Level 4 window size
      > MAXLINKS=63 ; Max level 2 links
      > MAXNODES=128 ; Max nodes in nodes table
      > MAXROUTES=64 ; Max adjacent nodes
      > MAXCIRCUITS=128 ; Max L4 circuits
      > MINQUAL=194 ; Minimum quality to add to nodes table
      > BBSQUAL=255 ; BBS quality relative to NODE - used to
      > limit
      > ; spread' of BBS node info through the
      > network to
      > ; your required service area. Max is 255.
      > BUFFERS=255 ; Packet buffers - 255 means allocate as
      > many
      > ; as possible, normally about 130, depending
      > ; upon other table sizes.
      > ;
      > ; TNC default parameters:
      > ;
      > PACLEN=236 ; Max packet size (236 max for net/rom)
      > ;
      > ; PACLEN is a problem! The ideal size depends on the link(s) over
      > ; which a packet will be sent. For a session involving another node,
      > ; we have no idea what is at the far end. Ideally each node should
      > have
      > ; the capability to combine and then refragment messages to suit each
      > ; link segment - maybe when there are more of my nodes about than
      > 'real'
      > ; ones, I'll do it. When the node is accessed directly, things are a
      > ; bit easier, as we know at least something about the link. So,
      > currently
      > ; there are two PACLEN params, one here and one in the PORTS section.
      > ; This one is used to set the initial value for sessions via other
      > nodes
      > ; and for sessions initiated from here. The other is used for incoming
      > ; direct (Level 2) sessions. In all cases the TNC PACLEN command can
      > ; be used to override the defaults.
      > ;
      > TRANSDELAY=1 ; Transparent node send delay in seconds
      > ;
      > ; Level 2 Parameters:
      > ;
      > ; T1, T2 and N2 are now in the PORTS section
      > ;
      > T3=180 ; Link validation timer in seconds
      > IDLETIME=900 ; Idle link shutdown timer in seconds
      > ;
      > ;
      > ; Configuration Options:
      > ;
      > BBS=1 ; Include BBS support
      > NODE=1 ; Include switch support
      > HIDENODES=1 ; If set to 1, nodes beginning with a #
      > ; require a 'N *' command to be displayed.
      > ;
      > ; The *** LINKED command is intended for use by gateway software, and
      > ; concern has been expressed that it could be misused. It is
      > recommended
      > ; that it be disabled (=N) if unneeded.
      > ;
      > ENABLE_LINKED=y ; Controls processing of *** LINKED command
      > ; Y = allows unrestricted use
      > ; A = allows use by application program
      > ; N = disabled
      > ;
      > ; AX25 port definitions:
      > ;
      > ; With the following definition BPQ32 access the TNC directly:
      > PORT
      > PORTNUM=1 ; Optonal but sets port number if stated
      > ID=BPQ 144.900 MHz ; Displayed by PORTS command
      > TYPE=ASYNC ; Port is RS232 Com
      > PROTOCOL=KISS ; TNC is used in KISS mode
      > IOADDR=1 ; 1 = SERIAL PORT COM1 ETC.
      > SPEED=9600 ; RS232 COM PORT SPEED
      > ; CHANNEL=A ; Address if multichannel TNC
      > QUALITY=0 ; Setting to 0 stops node broadcasts
      > MAXFRAME=3 ; Max outstanding frames (1 thru 7)
      > TXDELAY=500 ; Transmit keyup delay in milliseconds
      > SLOTTIME=100 ; CMSA interval timer in milliseconds
      > PERSIST=64 ; PERSIST=256/(# of transmitters-1)
      > FULLDUP=0 ;
      > FRACK=7000 ; Level 2 timout in milliseconds
      > RESPTIME=500 ; Level 2 delayed ack timer in milliseconds
      > RETRIES=10 ; Level 2 maximum retry value
      > PACLEN=80 ; Default max packet length for this port
      > L3ONLY=0 ; 1=No user downlink connects on this port
      > DIGIFLAG=0 ; Digipeat: 0=OFF, 1=ALL, 255=UI Only
      > DIGIPORT=0 ; Port # on which to send digi'd frames
      > USERS=0 ; Limit # of L2 sessions, 0 = no limit
      > ENDPORT
      > ;
      > PORT
      > PORTNUM=2 ; Optonal but sets port number if stated
      > ID=BPQ 70.325 MHz ; Displayed by PORTS command
      > TYPE=ASYNC ; Port is RS232 Com
      > PROTOCOL=KISS ; TNC is used in KISS mode
      > IOADDR=2 ; 1 = SERIAL PORT COM1 ETC.
      > SPEED=9600 ; RS232 COM PORT SPEED
      > ; CHANNEL=A ; Address if multichannel TNC
      > QUALITY=0 ; Setting to 0 stops node broadcasts
      > MAXFRAME=3 ; Max outstanding frames (1 thru 7)
      > TXDELAY=500 ; Transmit keyup delay in milliseconds
      > SLOTTIME=100 ; CMSA interval timer in milliseconds
      > PERSIST=64 ; PERSIST=256/(# of transmitters-1)
      > FULLDUP=0 ;
      > FRACK=7000 ; Level 2 timout in milliseconds
      > RESPTIME=500 ; Level 2 delayed ack timer in milliseconds
      > RETRIES=10 ; Level 2 maximum retry value
      > PACLEN=80 ; Default max packet length for this port
      > L3ONLY=0 ; 1=No user downlink connects on this port
      > DIGIFLAG=0 ; Digipeat: 0=OFF, 1=ALL, 255=UI Only
      > DIGIPORT=0 ; Port # on which to send digi'd frames
      > USERS=0 ; Limit # of L2 sessions, 0 = no limit
      > ENDPORT
      > ;
      > PORT
      > PORTNUM=3 ; Optonal but sets port number if stated
      > ID=AX/IP/UDP ; Displayed by PORTS command
      > TYPE=EXTERNAL ; Calls an external module
      > DLLNAME=BPQAXIP.DLL ; Uses BPQAXIP.DLL
      > QUALITY=194 ; Setting to 0 stops node broadcasts
      > MAXFRAME=7 ; Max outstanding frames (1 thru 7)
      > FRACK=3000 ; Level 2 timout in milliseconds
      > RESPTIME=1000 ; Level 2 delayed ack timer in milliseconds
      > RETRIES=10 ; Level 2 maximum retry value
      > PACLEN=236 ; Max = 236
      > ENDPORT
      > ;
      > ;
      > ROUTES: ; Locked routes
      > ;
      > ; CALLSIGN,QUALITY,PORT[,MAXFRAME,FRACK,PACLEN]
      > ; The values in [...] if stated override the port defaults.
      > ;
      > ;
      > *** ; Denotes end of locked routes
      > ;
      > ; Applications supported:
      > ;
      > ; The first three are reserved for BBS, HOST and REMOTE SYSOP.
      > ; Five additional applications, up to 12 bytes each, can be
      > ; defined as you wish. Applications beginning with a * are not
      > ; shown in the valid commands display.
      > ;
      > APPLICATIONS=DX,,*SYS ;BBS=DX, no host, remote sysop=*SYS
      > ;
      > John Wiseman wrote:
      >
      >>Hi,
      >>
      >>The following applies to any application using the AGWPE interface -
      >>not just DxNet.
      >>
      >>The default port that AGWtoBPQ listens on is now 8000 - sounds like
      >>the doc's need updating!
      >>
      >>However the port being used can be seen (and changed) on the AGWtoBPQ
      >>screen. If you change it, you need to restart the program.
      >>
      >>You don't need to run AGWPE, unless you want BPQ to use a port type
      >>not supported directly be BPQ (eg Sound Card Modems). In that case you
      >>must run AGWPE and AGWtoBPQ on diffferent ports. I suggest you change
      >>AGWPE to use 8001, so your applications can continue to use 8000.
      >>
      >>When you try to connect to your application from the BPQ switch, there
      >>a two possible error messages:
      >>
      >>"Sorry, All BBS Ports are in use - Please try later"
      >>
      >>Although on working system, this means what is says - all the
      >>connections are currently in use, nomally it means there is no
      >>application running. In this context, it means that AGWtoBPQ is not
      >>running, has listening ports set to 0, or applmask not set to 1.
      >>
      >>The other is "No AGWPE Host Sessions available". This means that you
      >>have reached AGWtoBPQ, but there is no application connected to it, or
      >>that the callsign being used by the application does not match the
      >>BBSCALL defined in BPQCFG.TXT. The next version of AGWtoBPQ will have
      >>a facility to check what applications are connected, and what callsign
      >>they are using. If anyone needs it to track down where the problem is,
      >>I'll send you a pre-release copy.
      >>
      >>73,
      >>John G8BPQ
      >>
      >>
      >>-----Original Message-----
      >>From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf
      >>Of Jim
      >>Sent: 28 January 2006 01:01
      >>To: BPQ32@yahoogroups.com
      >>Subject: Re: [BPQ32] Re: BPQ32 with DxNet by F5MZN
      >>
      >>
      >>Hello all
      >>
      >>I currently have bpq32 running with agw using bpq2agw.exe and talking
      >>to
      >>the rf ports fine.
      >>
      >>However I can't get bpq32 to talk to dxnet via agwpe.
      >>
      >>Dxnet is set up to talk to agwpe on port 8000 and this has always
      >>worked
      >>fine.
      >>
      >>However reading the docs for agwtobpq it appears it listens on port
      >>8001.
      >>
      >>I guess then I would need to change the set/port agw in the dxnet
      >>setup
      >>file to set/port agw:8001.
      >>
      >>Also how do you change the default setup of agwtobpq ?
      >>
      >>Jim
      >>
      >>
      >>hawkxpflyer wrote:
      >>
      >>
      >>>John,
      >>>
      >>>Here is the link where I picked up the 4.3 version of DxNet
      >>>
      >>>ftp://ftp.lip6.fr/pub/hamradio/DxNet_f5mzn/windows/
      >>>
      >>>The link below is where I picked up the 4.3 manual for DX net and on
      >>>page 10 of this manual is where I got my questions..
      >>>
      >>>Karl
      >>>
      >>>
      >>>
      >>>--- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@n...>
      >>>wrote:
      >>>
      >>>
      >>>
      >>>>Karl,
      >>>>
      >>>>I'm no expert on DXNET, but with the source I have, which appears
      >>>
      >>>to be
      >>>
      >>>
      >>>
      >>>>v4.2, but is the latest I can find, the dos version supports BPQ,
      >>>
      >>>but the
      >>>
      >>>
      >>>
      >>>>Windows version only supports AGW. If you have a later source,
      >>>
      >>>could you
      >>>
      >>>
      >>>
      >>>>send me a copy? (or a link to download it from).
      >>>>
      >>>>The first version of BPQ32 was 4.09, so it is unlikely it was
      >>>
      >>>tested with
      >>>
      >>>
      >>>
      >>>>4.08a. It could be talking about the DOS version, or possibly a 16
      >>>
      >>>bit
      >>>
      >>>
      >>>
      >>>>Windows version.
      >>>>
      >>>>One way to be sure if DXNET is actually using BPQ32 is NOT to start
      >>>
      >>>BPQ32
      >>>
      >>>
      >>>
      >>>>before starting DXNET. Starting DXNET should autoload BPQ. If it
      >>>
      >>>doesn't,
      >>>
      >>>
      >>>
      >>>>then it isn't trying to use BPQ32.
      >>>>
      >>>>
      >>>>Regards,
      >>>>
      >>>>John
      >>>>
      >>>>
      >>>>-----Original Message-----
      >>>>From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On
      >>>
      >>>Behalf Of
      >>>
      >>>
      >>>
      >>>>hawkxpflyer
      >>>>Sent: 23 January 2006 14:37
      >>>>To: BPQ32@yahoogroups.com
      >>>>Subject: [BPQ32] Re: BPQ32 with DxNet by F5MZN
      >>>>
      >>>>
      >>>>Jim,
      >>>>
      >>>>My commentary about the manual came from the Windows version of
      >>>>DxNet. I found this on page 10 of the v4.3 manual.
      >>>>
      >>>>For some reason I am really missing something as well using this
      >>>>application with BPQ. I start BPQ32 and then Dxnet. I cannot get
      >>>
      >>>to
      >>>
      >>>
      >>>
      >>>>DxNet through the BPQ terminal program. When I try to connect from
      >>>>an rf connection I receive a Busy back from BPQ. If I type DX from
      >>>>the switch, I get "All Dx Ports are in Use. Try later" Any idea
      >>>>what I am missing?
      >>>>
      >>>>Karl
      >>>>
      >>>>
      >>>>
      >>>>--- In BPQ32@yahoogroups.com, Jim <yahoomail@g...> wrote:
      >>>>
      >>>>
      >>>>
      >>>>>Hi
      >>>>>
      >>>>>Version 4.3beta15 does work with agw.We use it on GB7BDX.
      >>>>>
      >>>>>You could be right about bpq4.08 ,I must read the instruction
      >>>>
      >>>>manual
      >>>>
      >>>>
      >>>>
      >>>>>again ! If bpq can run then we will be changing over to that.
      >>>>>
      >>>>>Jim
      >>>>>
      >>>>>
      >>>>>hawkxpflyer wrote:
      >>>>>
      >>>>>
      >>>>>
      >>>>>>Thanks Jim,
      >>>>>>
      >>>>>>I am a bit confused then. Based on the manual for DxNet 4.3 It
      >>>>>>states that Support for the AGW Packet Engine autostart has
      >>>
      >>>been
      >>>
      >>>
      >>>
      >>>>>>removed. Appears with this version you must set/port AGW.
      >>>
      >>>Same
      >>>
      >>>
      >>>
      >>>>>>thing if you use Flex. Further down on the same page it states
      >>>>>>that "this version has been tested with Bpq 4.08 and 4.08a" and
      >>>>
      >>>>then
      >>>>
      >>>>
      >>>>
      >>>>>>goes on to talk about editing the BPQCfg.
      >>>>>>
      >>>>>>>From all that I gathered that a change was made to v4.3 and v4.4
      >>>>
      >>>>of
      >>>>
      >>>>
      >>>>
      >>>>>>DxNet to use BPQ instead of AGWpe. I know that v4.2 runs on top
      >>>>
      >>>>of
      >>>>
      >>>>
      >>>>
      >>>>>>AGWpe because that is what I have.
      >>>>>>
      >>>>>>I have had very little success with AGW and would prefer not to
      >>>>
      >>>>have
      >>>>
      >>>>
      >>>>
      >>>>>>to go that route unless I have to ..
      >>>>>>
      >>>>>>Thanks again.
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>--- In BPQ32@yahoogroups.com, Jim <yahoomail@g...> wrote:
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>>Hi,
      >>>>>>>
      >>>>>>>I think you would need to use the bpqtoagw interface and use agw
      >>>>>>
      >>>>>>with
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>>dxnet,however I think John is working on a direct interface
      >>>>
      >>>>between
      >>>>
      >>>>
      >>>>
      >>>>>>>dxnet and bpq32.
      >>>>>>>
      >>>>>>>Jim
      >>>>>>>
      >>>>>>>
      >>>>>>>hawkxpflyer wrote:
      >>>>>>>
      >>>>>>>
      >>>>>>>
      >>>>>>>
      >>>>>>>>Anyone had any success in getting this combination to work. I
      >>>>>>>>currently have BPQ32 running quite well. I now wish to put
      >>>>
      >>>>DxNet
      >>>>
      >>>>
      >>>>
      >>>>>>in as
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>>>well as our ARES groups around here use it for ARES purposes.
      >>>>>>>>
      >>>>>>>>I have the BBS function enabled in BPQ but cannot access it. I
      >>>>>>
      >>>>>>am
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>>>missing something.
      >>>>>>>>
      >>>>>>>>Thanks
      >>>>>>>>Karl
      >>>>>>>>KB8DM
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>Yahoo! Groups Links
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>>
      >>>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>Yahoo! Groups Links
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>Yahoo! Groups Links
      >>>>
      >>>
      >>>
      >>>
      >>>
      >>>
      >>>
      >>>
      >>>
      >>>Yahoo! Groups Links
      >>>
      >>>
      >>>
      >>>
      >>>
      >>>
      >>>
      >>>
      >>
      >>
      >>
      >>
      >>Yahoo! Groups Links
      >>
      >>
      >>
      >>
      >>
      >>
      >>
      >>
      >>
      >>
      >>Yahoo! Groups Links
      >>
      >>
      >>
      >>
      >>
      >>
      >>
      >>
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.