Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] BPQ and Telnet Access?

Expand Messages
  • John Wiseman
    You need to run BPQTelnetServer to enable users to connect to the switch using telnet. John ... From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On
    Message 1 of 11 , Sep 14, 2009
    • 0 Attachment
      Message
      You need to run BPQTelnetServer to enable users to connect to the switch using telnet.
       
       
      John
       
       
       
       
       
      -----Original Message-----
      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kd6pgi
      Sent: 14 September 2009 05:34
      To: BPQ32@yahoogroups.com
      Subject: [BPQ32] BPQ and Telnet Access?

       

      Okay, now that I have BPQ running smoothly and talking to the RMS, BBS, and CHAT...it is time to figure out how to telnet into the bpq. I can even access the bbs remotely from my email program. I already have an AX/IP/UDP port setup in BPQ and my router is setup with my DYNDNS account.

      So, what else do I need to do to talk to the switch over telnet? What do I need to run, install, tweak? The docs are kinda vague regarding the telnet end of things.

    • Sergej
      ... Look for BPQTelnetServer in BPQ32 directory - this program do that. Also in help files some description. 73, Sergej uz2hz / ut1hzm
      Message 2 of 11 , Sep 14, 2009
      • 0 Attachment
        kd6pgi asked:

        > So, what else do I need to do to talk to the switch over telnet? What do I need to run, install,
        > tweak? The docs are kinda vague regarding the telnet end of things.

        Look for BPQTelnetServer in BPQ32 directory - this program do that.
        Also in help files some description.

        73, Sergej
        uz2hz / ut1hzm
      • kd6pgi
        Thanks...I have the telnetserver running and working great. The only thing I noticed is the callsign I put in the telnetcfg file gets truncated when I connect
        Message 3 of 11 , Sep 14, 2009
        • 0 Attachment
          Thanks...I have the telnetserver running and working great. The only thing I noticed is the callsign I put in the telnetcfg file gets truncated when I connect to the telnetserver. If I log into the bbs, it thinks I am a new user because the callsign is different. I can log into the rms fine. If I leave the callsign off, the bbs knows it is me, but I cannot log into rms because the callsign is not there. Any ideas for a fix?


          --- In BPQ32@yahoogroups.com, "John Wiseman" <john.wiseman@...> wrote:
          >
          > You need to run BPQTelnetServer to enable users to connect to the switch
          > using telnet.
          >
          >
          > John
          >
          >
          >
          >
          >
          >
          > -----Original Message-----
          > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
          > kd6pgi
          > Sent: 14 September 2009 05:34
          > To: BPQ32@yahoogroups.com
          > Subject: [BPQ32] BPQ and Telnet Access?
          >
          >
          >
          >
          > Okay, now that I have BPQ running smoothly and talking to the RMS, BBS,
          > and CHAT...it is time to figure out how to telnet into the bpq. I can
          > even access the bbs remotely from my email program. I already have an
          > AX/IP/UDP port setup in BPQ and my router is setup with my DYNDNS
          > account.
          >
          > So, what else do I need to do to talk to the switch over telnet? What do
          > I need to run, install, tweak? The docs are kinda vague regarding the
          > telnet end of things.
          >
        • wa4zko
          I think you can accomplish what you need via a setting in the BPQtelnetserver.cfg file. Example you want to login as kd6pgi, use a password of pass1234, and
          Message 4 of 11 , Sep 14, 2009
          • 0 Attachment
            I think you can accomplish what you need via a setting in the BPQtelnetserver.cfg file. Example you want to login as kd6pgi, use a password of pass1234, and show up as kd6pgi-2 on the switch, you would have a line in the cfg file like:

            USER=kd6pgi,pass1234,kg6pgi-2

            The third part lets you force what you want the callsign to be on the switch. Modify to suit your situation. I think this is what you need?


            73
            Jeff
            WA4ZKO

            --- In BPQ32@yahoogroups.com, "kd6pgi" <kd6pgi@...> wrote:
            >
            > Thanks...I have the telnetserver running and working great. The only thing I noticed is the callsign I put in the telnetcfg file gets truncated when I connect to the telnetserver. If I log into the bbs, it thinks I am a new user because the callsign is different. I can log into the rms fine. If I leave the callsign off, the bbs knows it is me, but I cannot log into rms because the callsign is not there. Any ideas for a fix?
            >
            >
          • kd6pgi@gorge.net
            That is how it is setup right now... USER=kd6pgi,pass1234,kg6pgi Except, when logged in to the switch it truncates the callsign to KD6PG (without the I). Do I
            Message 5 of 11 , Sep 14, 2009
            • 0 Attachment
              That is how it is setup right now...

              USER=kd6pgi,pass1234,kg6pgi

              Except, when logged in to the switch it truncates the
              callsign to KD6PG (without the I). Do I need an SSID
              on the callsign to make it work correctly?


              ------- Original Message -------
              From : wa4zko[mailto:wa4zko@...]
              Sent : 9/14/2009 1:52:36 PM
              To : BPQ32@yahoogroups.com
              Cc :
              Subject : RE: [BPQ32] Re: BPQ and Telnet Access?








              I think you can accomplish what you
              need via a setting in the BPQtelnetserver.cfg file.
              Example you want to login as kd6pgi, use a password
              of pass1234, and show up as kd6pgi-2 on the switch,
              you would have a line in the cfg file like:



              USER=kd6pgi,pass1234,kg6pgi-2



              The third part lets you force what you want the
              callsign to be on the switch. Modify to suit your
              situation. I think this is what you need?



              73

              Jeff

              WA4ZKO



              --- In BPQ32@yahoogroups.com, "kd6pgi" <kd6pgi@...>
              wrote:

              >

              > Thanks...I have the telnetserver running and
              working great. The only thing I noticed is the
              callsign I put in the telnetcfg file gets truncated
              when I connect to the telnetserver. If I log into the
              bbs, it thinks I am a new user because the callsign
              is different. I can log into the rms fine. If I leave
              the callsign off, the bbs knows it is me, but I
              cannot log into rms because the callsign is not
              there. Any ideas for a fix?

              >

              >
            • wa4zko
              If you connect just to the switch using telnet and issue the User command, what does it show your call as? If it shows correct there, maybe it s something
              Message 6 of 11 , Sep 14, 2009
              • 0 Attachment
                If you connect just to the switch using telnet and issue the User command, what does it show your call as? If it shows correct there, maybe it's something going on between the switch and the BBS module?

                Interesting.

                WA4ZKO


                --- In BPQ32@yahoogroups.com, "kd6pgi@..." <kd6pgi@...> wrote:
                >
                > That is how it is setup right now...
                >
                > USER=kd6pgi,pass1234,kg6pgi
                >
                > Except, when logged in to the switch it truncates the
                > callsign to KD6PG (without the I). Do I need an SSID
                > on the callsign to make it work correctly?
                >
                >
                > ------- Original Message -------
                > From : wa4zko[mailto:wa4zko@...]
                > Sent : 9/14/2009 1:52:36 PM
                > To : BPQ32@yahoogroups.com
                > Cc :
                > Subject : RE: [BPQ32] Re: BPQ and Telnet Access?
                >
                >
                >
                >
                >
                >
                >
                >
                > I think you can accomplish what you
                > need via a setting in the BPQtelnetserver.cfg file.
                > Example you want to login as kd6pgi, use a password
                > of pass1234, and show up as kd6pgi-2 on the switch,
                > you would have a line in the cfg file like:
                >
                >
                >
                > USER=kd6pgi,pass1234,kg6pgi-2
                >
                >
                >
                > The third part lets you force what you want the
                > callsign to be on the switch. Modify to suit your
                > situation. I think this is what you need?
                >
                >
                >
                > 73
                >
                > Jeff
                >
                > WA4ZKO
                >
                >
                >
                > --- In BPQ32@yahoogroups.com, "kd6pgi" <kd6pgi@>
                > wrote:
                >
                > >
                >
                > > Thanks...I have the telnetserver running and
                > working great. The only thing I noticed is the
                > callsign I put in the telnetcfg file gets truncated
                > when I connect to the telnetserver. If I log into the
                > bbs, it thinks I am a new user because the callsign
                > is different. I can log into the rms fine. If I leave
                > the callsign off, the bbs knows it is me, but I
                > cannot log into rms because the callsign is not
                > there. Any ideas for a fix?
                >
                > >
                >
                > >
                >
              • wa4zko
                Just tested it on mine, no ssid gets me just the bare callsign or I can force a particular SSID (actually very handy). I don t have the BBS portion running
                Message 7 of 11 , Sep 14, 2009
                • 0 Attachment
                  Just tested it on mine, no ssid gets me just the bare callsign or I can force a particular SSID (actually very handy). I don't have the BBS portion running yet, so I couldn't test that.

                  I think you have to close the bpqtelnetserver module and reopen it to get it to read the cfg file again....way it acted on mine.

                  WA4ZKO

                  --- In BPQ32@yahoogroups.com, "kd6pgi@..." <kd6pgi@...> wrote:
                  >
                  > That is how it is setup right now...
                  >
                  > USER=kd6pgi,pass1234,kg6pgi
                  >
                  > Except, when logged in to the switch it truncates the
                  > callsign to KD6PG (without the I). Do I need an SSID
                  > on the callsign to make it work correctly?
                  >
                  >
                  > ------- Original Message -------
                  > From : wa4zko[mailto:wa4zko@...]
                  > Sent : 9/14/2009 1:52:36 PM
                  > To : BPQ32@yahoogroups.com
                  > Cc :
                  > Subject : RE: [BPQ32] Re: BPQ and Telnet Access?
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  > I think you can accomplish what you
                  > need via a setting in the BPQtelnetserver.cfg file.
                  > Example you want to login as kd6pgi, use a password
                  > of pass1234, and show up as kd6pgi-2 on the switch,
                  > you would have a line in the cfg file like:
                  >
                  >
                  >
                  > USER=kd6pgi,pass1234,kg6pgi-2
                  >
                  >
                  >
                  > The third part lets you force what you want the
                  > callsign to be on the switch. Modify to suit your
                  > situation. I think this is what you need?
                  >
                  >
                  >
                  > 73
                  >
                  > Jeff
                  >
                  > WA4ZKO
                  >
                  >
                  >
                  > --- In BPQ32@yahoogroups.com, "kd6pgi" <kd6pgi@>
                  > wrote:
                  >
                  > >
                  >
                  > > Thanks...I have the telnetserver running and
                  > working great. The only thing I noticed is the
                  > callsign I put in the telnetcfg file gets truncated
                  > when I connect to the telnetserver. If I log into the
                  > bbs, it thinks I am a new user because the callsign
                  > is different. I can log into the rms fine. If I leave
                  > the callsign off, the bbs knows it is me, but I
                  > cannot log into rms because the callsign is not
                  > there. Any ideas for a fix?
                  >
                  > >
                  >
                  > >
                  >
                • kd6pgi@gorge.net
                  I think I figured out what is going on. When adding a USER to the telnet cfg file, you have to put the - after the callsign, even if there is no SSID. Then
                  Message 8 of 11 , Sep 14, 2009
                  • 0 Attachment
                    I think I figured out what is going on. When adding a
                    USER to the telnet cfg file, you have to put the -
                    after the callsign, even if there is no SSID. Then
                    when you connect to the switch with telnet, the
                    callsign shows up correctly. Of course, you can also
                    add the ssid if you want something different. But,
                    the - is needed no matter what.

                    Mine now reads: USER=kd6pgi,pass1234,kd6pgi-



                    ------- Original Message -------
                    From : wa4zko[mailto:wa4zko@...]
                    Sent : 9/14/2009 3:00:39 PM
                    To : BPQ32@yahoogroups.com
                    Cc :
                    Subject : RE: [BPQ32] Re: BPQ and Telnet Access?








                    Just tested it on mine, no ssid
                    gets me just the bare callsign or I can force a
                    particular SSID (actually very handy). I don't have
                    the BBS portion running yet, so I couldn't test that.



                    I think you have to close the bpqtelnetserver module
                    and reopen it to get it to read the cfg file
                    again....way it acted on mine.



                    WA4ZKO



                    --- In BPQ32@yahoogroups.com, "kd6pgi@..."
                    <kd6pgi@...> wrote:

                    >

                    > That is how it is setup right now...

                    >

                    > USER=kd6pgi,pass1234,kg6pgi

                    >

                    > Except, when logged in to the switch it truncates the

                    > callsign to KD6PG (without the I). Do I need an SSID

                    > on the callsign to make it work correctly?

                    >

                    >

                    > ------- Original Message -------

                    > From : wa4zko[mailto:wa4zko@...]

                    > Sent : 9/14/2009 1:52:36 PM

                    > To : BPQ32@yahoogroups.com

                    > Cc :

                    > Subject : RE: [BPQ32] Re: BPQ and Telnet Access?

                    >

                    >

                    >

                    >

                    >

                    >

                    >

                    >

                    > I think you can accomplish what you

                    > need via a setting in the BPQtelnetserver.cfg file.

                    > Example you want to login as kd6pgi, use a password

                    > of pass1234, and show up as kd6pgi-2 on the switch,

                    > you would have a line in the cfg file like:

                    >

                    >

                    >

                    > USER=kd6pgi,pass1234,kg6pgi-2

                    >

                    >

                    >

                    > The third part lets you force what you want the

                    > callsign to be on the switch. Modify to suit your

                    > situation. I think this is what you need?

                    >

                    >

                    >

                    > 73

                    >

                    > Jeff

                    >

                    > WA4ZKO

                    >

                    >

                    >

                    > --- In BPQ32@yahoogroups.com, "kd6pgi" <kd6pgi@>

                    > wrote:

                    >

                    > >

                    >

                    > > Thanks...I have the telnetserver running and

                    > working great. The only thing I noticed is the

                    > callsign I put in the telnetcfg file gets truncated

                    > when I connect to the telnetserver. If I log into the

                    > bbs, it thinks I am a new user because the callsign

                    > is different. I can log into the rms fine. If I leave

                    > the callsign off, the bbs knows it is me, but I

                    > cannot log into rms because the callsign is not

                    > there. Any ideas for a fix?

                    >

                    > >

                    >

                    > >

                    >
                  • John Wiseman
                    That sounds like a bug. I ll investigate. John ... From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kd6pgi@gorge.net Sent: 15 September
                    Message 9 of 11 , Sep 15, 2009
                    • 0 Attachment
                      Message
                      That sounds like a bug. I'll investigate.
                       
                      John
                       
                      -----Original Message-----
                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kd6pgi@...
                      Sent: 15 September 2009 04:11
                      To: BPQ32@yahoogroups.com
                      Subject: RE: [BPQ32] Re: BPQ and Telnet Access?

                       

                      I think I figured out what is going on. When adding a
                      USER to the telnet cfg file, you have to put the -
                      after the callsign, even if there is no SSID. Then
                      when you connect to the switch with telnet, the
                      callsign shows up correctly. Of course, you can also
                      add the ssid if you want something different. But,
                      the - is needed no matter what.

                      Mine now reads: USER=kd6pgi, pass1234, kd6pgi-

                      ------- Original Message -------
                      From : wa4zko[mailto:wa4zko@yahoo. com]
                      Sent : 9/14/2009 3:00:39 PM
                      To : BPQ32@yahoogroups. com
                      Cc :
                      Subject : RE: [BPQ32] Re: BPQ and Telnet Access?

                      Just tested it on mine, no ssid
                      gets me just the bare callsign or I can force a
                      particular SSID (actually very handy). I don't have
                      the BBS portion running yet, so I couldn't test that.

                      I think you have to close the bpqtelnetserver module
                      and reopen it to get it to read the cfg file
                      again....way it acted on mine.

                      WA4ZKO

                      --- In BPQ32@yahoogroups. com, "kd6pgi@..."
                      <kd6pgi@...> wrote:

                      >

                      > That is how it is setup right now...

                      >

                      > USER=kd6pgi, pass1234, kg6pgi

                      >

                      > Except, when logged in to the switch it truncates the

                      > callsign to KD6PG (without the I). Do I need an SSID

                      > on the callsign to make it work correctly?

                      >

                      >

                      > ------- Original Message -------

                      > From : wa4zko[mailto: wa4zko@.. .]

                      > Sent : 9/14/2009 1:52:36 PM

                      > To : BPQ32@yahoogroups. com

                      > Cc :

                      > Subject : RE: [BPQ32] Re: BPQ and Telnet Access?

                      >

                      >

                      >

                      >

                      >

                      >

                      >

                      >

                      > I think you can accomplish what you

                      > need via a setting in the BPQtelnetserver. cfg file.

                      > Example you want to login as kd6pgi, use a password

                      > of pass1234, and show up as kd6pgi-2 on the switch,

                      > you would have a line in the cfg file like:

                      >

                      >

                      >

                      > USER=kd6pgi, pass1234, kg6pgi-2

                      >

                      >

                      >

                      > The third part lets you force what you want the

                      > callsign to be on the switch. Modify to suit your

                      > situation. I think this is what you need?

                      >

                      >

                      >

                      > 73

                      >

                      > Jeff

                      >

                      > WA4ZKO

                      >

                      >

                      >

                      > --- In BPQ32@yahoogroups. com, "kd6pgi" <kd6pgi@>

                      > wrote:

                      >

                      > >

                      >

                      > > Thanks...I have the telnetserver running and

                      > working great. The only thing I noticed is the

                      > callsign I put in the telnetcfg file gets truncated

                      > when I connect to the telnetserver. If I log into the

                      > bbs, it thinks I am a new user because the callsign

                      > is different. I can log into the rms fine. If I leave

                      > the callsign off, the bbs knows it is me, but I

                      > cannot log into rms because the callsign is not

                      > there. Any ideas for a fix?

                      >

                      > >

                      >

                      > >

                      >




                    • John Wiseman
                      I can t reproduce that Could you send me the telnetserver.cfg that goes wrong, and I ll trace through the code. 73, John ... From: BPQ32@yahoogroups.com
                      Message 10 of 11 , Sep 15, 2009
                      • 0 Attachment
                        Message
                        I can't reproduce that Could you send me the telnetserver.cfg that goes wrong, and I'll trace through the code.
                         
                        73,
                        John
                         
                        -----Original Message-----
                        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of kd6pgi@...
                        Sent: 15 September 2009 04:11
                        To: BPQ32@yahoogroups.com
                        Subject: RE: [BPQ32] Re: BPQ and Telnet Access?

                         

                        I think I figured out what is going on. When adding a
                        USER to the telnet cfg file, you have to put the -
                        after the callsign, even if there is no SSID. Then
                        when you connect to the switch with telnet, the
                        callsign shows up correctly. Of course, you can also
                        add the ssid if you want something different. But,
                        the - is needed no matter what.

                        Mine now reads: USER=kd6pgi, pass1234, kd6pgi-

                        ------- Original Message -------
                        From : wa4zko[mailto:wa4zko@yahoo. com]
                        Sent : 9/14/2009 3:00:39 PM
                        To : BPQ32@yahoogroups. com
                        Cc :
                        Subject : RE: [BPQ32] Re: BPQ and Telnet Access?

                        Just tested it on mine, no ssid
                        gets me just the bare callsign or I can force a
                        particular SSID (actually very handy). I don't have
                        the BBS portion running yet, so I couldn't test that.

                        I think you have to close the bpqtelnetserver module
                        and reopen it to get it to read the cfg file
                        again....way it acted on mine.

                        WA4ZKO

                        --- In BPQ32@yahoogroups. com, "kd6pgi@..."
                        <kd6pgi@...> wrote:

                        >

                        > That is how it is setup right now...

                        >

                        > USER=kd6pgi, pass1234, kg6pgi

                        >

                        > Except, when logged in to the switch it truncates the

                        > callsign to KD6PG (without the I). Do I need an SSID

                        > on the callsign to make it work correctly?

                        >

                        >

                        > ------- Original Message -------

                        > From : wa4zko[mailto: wa4zko@.. .]

                        > Sent : 9/14/2009 1:52:36 PM

                        > To : BPQ32@yahoogroups. com

                        > Cc :

                        > Subject : RE: [BPQ32] Re: BPQ and Telnet Access?

                        >

                        >

                        >

                        >

                        >

                        >

                        >

                        >

                        > I think you can accomplish what you

                        > need via a setting in the BPQtelnetserver. cfg file.

                        > Example you want to login as kd6pgi, use a password

                        > of pass1234, and show up as kd6pgi-2 on the switch,

                        > you would have a line in the cfg file like:

                        >

                        >

                        >

                        > USER=kd6pgi, pass1234, kg6pgi-2

                        >

                        >

                        >

                        > The third part lets you force what you want the

                        > callsign to be on the switch. Modify to suit your

                        > situation. I think this is what you need?

                        >

                        >

                        >

                        > 73

                        >

                        > Jeff

                        >

                        > WA4ZKO

                        >

                        >

                        >

                        > --- In BPQ32@yahoogroups. com, "kd6pgi" <kd6pgi@>

                        > wrote:

                        >

                        > >

                        >

                        > > Thanks...I have the telnetserver running and

                        > working great. The only thing I noticed is the

                        > callsign I put in the telnetcfg file gets truncated

                        > when I connect to the telnetserver. If I log into the

                        > bbs, it thinks I am a new user because the callsign

                        > is different. I can log into the rms fine. If I leave

                        > the callsign off, the bbs knows it is me, but I

                        > cannot log into rms because the callsign is not

                        > there. Any ideas for a fix?

                        >

                        > >

                        >

                        > >

                        >




                      Your message has been successfully submitted and would be delivered to recipients shortly.