Loading ...
Sorry, an error occurred while loading the content.

RE: [BPQ32] block node entries

Expand Messages
  • John Wiseman
    With the latest (1.14.1) bpqaxip.dll you should only get entries in your Nodes table from stations in your bpqaxip.cfg, unless the bpqaxip.cfg has the
    Message 1 of 8 , Jul 20 12:22 AM
    • 0 Attachment
      Message
      With the latest (1.14.1) bpqaxip.dll you should only get entries in your Nodes table from stations in your bpqaxip.cfg, unless the bpqaxip.cfg has the statement:

      DONTCHECKSOURCECALL, which restores the behaviour of previous versions..

      If you have AUTOADDMAP in bpqaxip.cfg then unknown stations will be added to the table, and NODES will be accepted from them/.

      73,

      John

       

       

      -----Original Message-----
      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Mark Harloff
      Sent: 20 July 2009 01:38
      To: BPQ32 SIG
      Subject: [BPQ32] block node entries

       

      I thought the newest release had a solution to
      the 'uninvited' nodes coming in via axip... but,
      I can't seem to find anything on it.

      Anyone know if and where the settings are.. ?

      - Mark K2CAN

    • Mark Harloff
      Thanks Ron. I m pretty sure DONTCHECKSOURCECALL will solve the problem here. If it doesn t, I ll let you know. Mark K2CAN
      Message 2 of 8 , Jul 20 8:57 AM
      • 0 Attachment
        Thanks Ron. I'm pretty sure
        'DONTCHECKSOURCECALL' will solve the problem here.

        If it doesn't, I'll let you know.

        Mark K2CAN

        Ron Stordahl wrote:
        >
        >
        > You can't prevent anyone sending to you if they know your IP address.
        > Of course if you know their IP address you can block their packets using
        > a firewall, but you would only rarely have to resort to that. More
        > important would be to prevent an unwanted node from connecting to your
        > node. This can be accomplished in two ways:
        >
        > 1) If you do not have the AUTOADDMAP statement in your bpqaxip.cfg,
        > then they will not automatically be added allowing them to connect to
        > you. In addition you can include the option DONTCHECKSOURCECALL which
        > will prevent entries in your nodes table without the corresponding node
        > being configured in bpqaxip.cfg.
        >
        > 2) If you do have the AUTOADDMAP statement, which has a valid purpose,
        > then you have to take an additional measure to prevent an uninvited node
        > from connecting. You can do this by entering a bogus IP address for
        > them thus:
        >
        > MAP 'unwanted node call-SSID' 0.0.0.0 UDP 10093 B
        >
        > The 0.0.0.0 is simply an unroutable IP address resulting in no possible
        > connection.
        >
        > 3) I think AUDOADDMAP and DONTCHECKSOUCECALL are mutually exclusive, or
        > perhaps just meaningless if used together. I have not tried, perhaps
        > John can elaborate on that point.
        >
        > Ron, N5IN
        >
        >
        > *From:* Mark Harloff <mharloff@...>
        > *To:* BPQ32 SIG <BPQ32@yahoogroups.com>
        > *Sent:* Sunday, July 19, 2009 7:37:37 PM
        > *Subject:* [BPQ32] block node entries
        >
        >
        >
        > I thought the newest release had a solution to
        > the 'uninvited' nodes coming in via axip... but,
        > I can't seem to find anything on it.
        >
        > Anyone know if and where the settings are.. ?
        >
        > - Mark K2CAN
        >
        >
        >
        >
        > ------------------------------------------------------------------------
        >
        >
        > No virus found in this incoming message.
        > Checked by AVG - www.avg.com
        > Version: 8.5.392 / Virus Database: 270.13.20/2250 - Release Date: 07/20/09 06:16:00
        >
      • Mark Harloff
        Ron, Actually, it looks like John added the blocking feature in the latest release as default . So, I do not need to change anything. Left with the default
        Message 3 of 8 , Jul 20 9:07 AM
        • 0 Attachment
          Ron,

          Actually, it looks like John added the blocking
          feature in the latest release as 'default'. So,
          I do not need to change anything.
          Left with the default setting, I should not see
          any Node entries other than the ones that I have
          setup in the bpqaxip.cfg file. So far, I haven't
          even though there are a couple of systems trying
          to send me their broadcasts. Given that, it
          seems to be working fine.

          If I understand things right, the
          'DONTCHECKSOURCECALL' option would 'add' a
          callsign-ssid to the Nodes table even though
          there wasn't any corresponding entry in the AXIP
          file which is the opposite of what I am trying
          to accomplish.

          - Mark K2CAN


          Ron Stordahl wrote:
          >
          >
          > You can't prevent anyone sending to you if they know your IP address.
          > Of course if you know their IP address you can block their packets using
          > a firewall, but you would only rarely have to resort to that. More
          > important would be to prevent an unwanted node from connecting to your
          > node. This can be accomplished in two ways:
          >
          > 1) If you do not have the AUTOADDMAP statement in your bpqaxip.cfg,
          > then they will not automatically be added allowing them to connect to
          > you. In addition you can include the option DONTCHECKSOURCECALL which
          > will prevent entries in your nodes table without the corresponding node
          > being configured in bpqaxip.cfg.
          >
          > 2) If you do have the AUTOADDMAP statement, which has a valid purpose,
          > then you have to take an additional measure to prevent an uninvited node
          > from connecting. You can do this by entering a bogus IP address for
          > them thus:
          >
          > MAP 'unwanted node call-SSID' 0.0.0.0 UDP 10093 B
          >
          > The 0.0.0.0 is simply an unroutable IP address resulting in no possible
          > connection.
          >
          > 3) I think AUDOADDMAP and DONTCHECKSOUCECALL are mutually exclusive, or
          > perhaps just meaningless if used together. I have not tried, perhaps
          > John can elaborate on that point.
          >
          > Ron, N5IN
          >
          >
          > *From:* Mark Harloff <mharloff@...>
          > *To:* BPQ32 SIG <BPQ32@yahoogroups.com>
          > *Sent:* Sunday, July 19, 2009 7:37:37 PM
          > *Subject:* [BPQ32] block node entries
          >
          >
          >
          > I thought the newest release had a solution to
          > the 'uninvited' nodes coming in via axip... but,
          > I can't seem to find anything on it.
          >
          > Anyone know if and where the settings are.. ?
          >
          > - Mark K2CAN
          >
          >
          >
          >
          > ------------------------------------------------------------------------
          >
          >
          > No virus found in this incoming message.
          > Checked by AVG - www.avg.com
          > Version: 8.5.392 / Virus Database: 270.13.20/2250 - Release Date: 07/20/09 06:16:00
          >
        • John Wiseman
          With the latest (1.14.1) bpqaxip.dll you should only get entries in your Nodes table from stations in your bpqaxip.cfg, unless the bpqaxip.cfg has the
          Message 4 of 8 , Jul 20 10:37 AM
          • 0 Attachment
            Message
            With the latest (1.14.1) bpqaxip.dll you should only get entries in your Nodes table from stations in your bpqaxip.cfg, unless the bpqaxip.cfg has the statement:

            DONTCHECKSOURCECALL, which restores the behaviour of previous versions. This is the opposite to what Ron has suggested.

            If you have AUTOADDMAP in bpqaxip.cfg then unknown stations will be added to the table, and NODES will be accepted from them/.

            Ron has queried what happens if you have both - if you have DONTCHECKSOURCECALL then it won't know that the call isn't in the table, so  AUTOADDMAP won't be actioned

             

            73,

            John

             

             

            -----Original Message-----
            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Mark Harloff
            Sent: 20 July 2009 01:38
            To: BPQ32 SIG
            Subject: [BPQ32] block node entries

             

            I thought the newest release had a solution to
            the 'uninvited' nodes coming in via axip... but,
            I can't seem to find anything on it.

            Anyone know if and where the settings are.. ?

            - Mark K2CAN

          • John Wiseman
            With the latest (1.14.1) bpqaxip.dll you should only get entries in your Nodes table from stations in your bpqaxip.cfg, unless the bpqaxip.cfg has the
            Message 5 of 8 , Jul 20 10:37 AM
            • 0 Attachment
              Message
              With the latest (1.14.1) bpqaxip.dll you should only get entries in your Nodes table from stations in your bpqaxip.cfg, unless the bpqaxip.cfg has the statement:

              DONTCHECKSOURCECALL, which restores the behaviour of previous versions. This is the opposite to what Ron has suggested.

              If you have AUTOADDMAP in bpqaxip.cfg then unknown stations will be added to the table, and NODES will be accepted from them/.

              Ron has queried what happens if you have both - if you have DONTCHECKSOURCECALL then it won't know that the call isn't in the table, so  AUTOADDMAP won't be actioned

               

              73,

              John

               

               

              -----Original Message-----
              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Mark Harloff
              Sent: 20 July 2009 01:38
              To: BPQ32 SIG
              Subject: [BPQ32] block node entries

               

              I thought the newest release had a solution to
              the 'uninvited' nodes coming in via axip... but,
              I can't seem to find anything on it.

              Anyone know if and where the settings are.. ?

              - Mark K2CAN

            • Mark
              Thanks John. That clarifies it for me nicely. The default setting works perfectly for my system here. - Mark K2CAN
              Message 6 of 8 , Jul 21 5:55 AM
              • 0 Attachment
                Thanks John. That clarifies it for me nicely. The default setting works
                perfectly for my system here.

                - Mark K2CAN


                John Wiseman wrote:
                >
                >
                > With the latest (1.14.1) bpqaxip.dll you should only get entries in your
                > Nodes table from stations in your bpqaxip.cfg, unless the bpqaxip.cfg
                > has the statement:
                >
                > DONTCHECKSOURCECALL, which restores the behaviour of previous versions..
                >
                > If you have AUTOADDMAP in bpqaxip.cfg then unknown stations will be
                > added to the table, and NODES will be accepted from them/.
                >
                > 73,
                >
                > John
                >
                >
                >
                >
                >
                > -----Original Message-----
                > *From:* BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] *On
                > Behalf Of *Mark Harloff
                > *Sent:* 20 July 2009 01:38
                > *To:* BPQ32 SIG
                > *Subject:* [BPQ32] block node entries
                >
                >
                >
                > I thought the newest release had a solution to
                > the 'uninvited' nodes coming in via axip... but,
                > I can't seem to find anything on it.
                >
                > Anyone know if and where the settings are.. ?
                >
                > - Mark K2CAN
                >
                >
                >
                >
                > ------------------------------------------------------------------------
                >
                >
                > No virus found in this incoming message.
                > Checked by AVG - www.avg.com
                > Version: 8.5.375 / Virus Database: 270.13.21/2252 - Release Date: 07/21/09 05:58:00
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.