Loading ...
Sorry, an error occurred while loading the content.

Switch to BPQ32 from Digiplex using AGW

Expand Messages
  • ng7m
    I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been using Digiplex with AGWPE with mixed results. I have things working pretty well, I
    Message 1 of 10 , Apr 30 11:58 PM
    • 0 Attachment
      I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been using Digiplex with AGWPE with mixed results.

      I have things working pretty well, I can run BPQTerminal and control all of my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE controled ports too.

      The problem I have is that when I try to connect to AR_Cluster from the BPQ node interface, it says 'Sorry, All DX Ports are in use - Please try later'

      I have only one BPQ application setup and it's defined as DX for my AR-Cluster setup (NC7J)

      I have been searching around trying to see anything I could have missed in the bpqcfg.txt. Poking around for hours now... ;) no luck.

      I hope I have missed something obvious and that someone can point me in the right direction.

      BPQ as a node is working great... it's getting node broadcasts and sending out node broadcasts from the AGW controlled ports etc...

      I have my app for AR_Cluster configured like this in the bpqcfg.txt file:

      APPL1CALL=NC7J
      APPL1ALIAS=UTDXC
      APPL1QUAL=255

      My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1

      The 'all ports are in use' error is leaving me scratching my head... I can't find anything obvious searching here on the BPQ32 group either??

      de NG7M Max
    • Eric Carling
      What have you done in AR Cluster itself to accept the connection? My method is to go to cfg io devices and enable AGW PE|AGW to BPQ. This then has to be
      Message 2 of 10 , May 1, 2009
      • 0 Attachment

        What have you done in AR Cluster itself to accept the connection?

         

        My method is to go to cfg>io devices and enable AGW PE|AGW to BPQ. This then has to be configured after you press the button adjacent.

         

        Is this what you have done?

         

        Eric G0CGL / GB7CGL

         

        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of ng7m
        Sent: 01 May 2009 06:59
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW

         




        I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been using Digiplex with AGWPE with mixed results.

        I have things working pretty well, I can run BPQTerminal and control all of my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE controled ports too.

        The problem I have is that when I try to connect to AR_Cluster from the BPQ node interface, it says 'Sorry, All DX Ports are in use - Please try later'

        I have only one BPQ application setup and it's defined as DX for my AR-Cluster setup (NC7J)

        I have been searching around trying to see anything I could have missed in the bpqcfg.txt. Poking around for hours now... ;) no luck.

        I hope I have missed something obvious and that someone can point me in the right direction.

        BPQ as a node is working great... it's getting node broadcasts and sending out node broadcasts from the AGW controlled ports etc...

        I have my app for AR_Cluster configured like this in the bpqcfg.txt file:

        APPL1CALL=NC7J
        APPL1ALIAS=UTDXC
        APPL1QUAL=255

        My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1

        The 'all ports are in use' error is leaving me scratching my head... I can't find anything obvious searching here on the BPQ32 group either??

        de NG7M Max

      • ng7m
        Hi Eric, thanks for taking a look at my post. I have enabled the AGW PE|AGW to BPQ option. I had it enabled previously because I have been using AR-Cluster
        Message 3 of 10 , May 1, 2009
        • 0 Attachment
          Hi Eric, thanks for taking a look at my post.

          I have enabled the AGW PE|AGW to BPQ option. I had it enabled previously because I have been using AR-Cluster with AGWPE for a long time now. Working fine. User connections to AR-Cluster direct on my radio ports are working.

          AR-Cluster is connected to AGWPE and shows up in AGW as one of the connected applications.

          Last night was the first time I started looking at BPQ...

          Now what might be an obvious question, should I be running AGWtoBPQ too? I have only been running BPQTerminal. When I run AGWtoBPQ, i'm getting an error popup that says 'bind(sock) failed Error 10048'

          I have checked the config files and can't see where i'm specifying a port that would be incorrect.

          Does AGWtoBPQ need to be running?

          de NG7M

          --- In BPQ32@yahoogroups.com, "Eric Carling" <eric@...> wrote:
          >
          > What have you done in AR Cluster itself to accept the connection?
          >
          >
          >
          > My method is to go to cfg>io devices and enable AGW PE|AGW to BPQ. This then
          > has to be configured after you press the button adjacent.
          >
          >
          >
          > Is this what you have done?
          >
          >
          >
          > Eric G0CGL / GB7CGL
          >
          >
          >
          > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of ng7m
          > Sent: 01 May 2009 06:59
          > To: BPQ32@yahoogroups.com
          > Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW
          >
          >
          >
          >
          >
          >
          >
          >
          > I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been
          > using Digiplex with AGWPE with mixed results.
          >
          > I have things working pretty well, I can run BPQTerminal and control all of
          > my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE
          > controled ports too.
          >
          > The problem I have is that when I try to connect to AR_Cluster from the BPQ
          > node interface, it says 'Sorry, All DX Ports are in use - Please try later'
          >
          > I have only one BPQ application setup and it's defined as DX for my
          > AR-Cluster setup (NC7J)
          >
          > I have been searching around trying to see anything I could have missed in
          > the bpqcfg.txt. Poking around for hours now... ;) no luck.
          >
          > I hope I have missed something obvious and that someone can point me in the
          > right direction.
          >
          > BPQ as a node is working great... it's getting node broadcasts and sending
          > out node broadcasts from the AGW controlled ports etc...
          >
          > I have my app for AR_Cluster configured like this in the bpqcfg.txt file:
          >
          > APPL1CALL=NC7J
          > APPL1ALIAS=UTDXC
          > APPL1QUAL=255
          >
          > My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1
          >
          > The 'all ports are in use' error is leaving me scratching my head... I can't
          > find anything obvious searching here on the BPQ32 group either??
          >
          > de NG7M Max
          >
        • Ron Stordahl
          Max NG7M The BPQ32 to AR-Cluster setup is described in the BPQ32 Installation Document. Assuming you have read that I will bring up the essential points. You
          Message 4 of 10 , May 1, 2009
          • 0 Attachment
            Max NG7M

            The BPQ32 to AR-Cluster setup is described in the BPQ32 Installation Document. 

            Assuming you have read that I will bring up the essential points.

            You must in AR-Cluster Cfg>I/O Devices...>Input/Output Configuration select either BPQ-OCX or AGW PE|AGW to BPQ as the interface method.  AR-Cluster will allow you to select both, but do not do so!

            If you choose BPQ-OCX as the interface method, then upon starting AR-Cluster will bring up BPQ32.  If you choose AGW to BPQ as the interface method, you will have to manually start AGWtoBPQ.exe.

            In the BPQ-OCX interface method you do not have to select the Application Mask within BPQ32, it is hard coded in AR-Cluster to 0x1.  That means that in your APPLICATIONS= string in bpqcfg.txt the first parameter must be used for AR-Cluster.

            For the AGWtoBPQ interface method you may use any position in the APPLICATIONS= string, but you must specify the corresponding applications mask for that position in the AGWtoBPQ program thus: Config>Configuration>Appl Mask.  Since you have told us that your AR-Cluster application is in the first position in that string you would enter 0x1 in that location in the Configuration window.

            If you have done one or the other of the above the interface should work.

            I run two copies of AR-Cluster.  My main cluster, N5IN, uses the AGWtoBPQ interface.  My test cluster, N5IN-1, uses the OCX interface.  I do this just to be sure for each new release that both interface methods continue to work.

            If you continue to have problems with this I will need to see your bpqcfg.txt and bpqaxip.cfg files.

            Ron N5IN


            From: ng7m <m.matthew.george@...>
            To: BPQ32@yahoogroups.com
            Sent: Friday, May 1, 2009 1:58:59 AM
            Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW

            I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been using Digiplex with AGWPE with mixed results.

            I have things working pretty well, I can run BPQTerminal and control all of my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE controled ports too.

            The problem I have is that when I try to connect to AR_Cluster from the BPQ node interface, it says 'Sorry, All DX Ports are in use - Please try later'

            I have only one BPQ application setup and it's defined as DX for my AR-Cluster setup (NC7J)

            I have been searching around trying to see anything I could have missed in the bpqcfg.txt. Poking around for hours now... ;) no luck.

            I hope I have missed something obvious and that someone can point me in the right direction.

            BPQ as a node is working great... it's getting node broadcasts and sending out node broadcasts from the AGW controlled ports etc...

            I have my app for AR_Cluster configured like this in the bpqcfg.txt file:

            APPL1CALL=NC7J
            APPL1ALIAS=UTDXC
            APPL1QUAL=255

            My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1

            The 'all ports are in use' error is leaving me scratching my head... I can't find anything obvious searching here on the BPQ32 group either??

            de NG7M Max

          • ng7m
            Hmmmmm, more research on the 10048 error... I do have the old version of bpq32.dll still installed down the AR-Cluster/BPQ folder... I ll rename that and
            Message 5 of 10 , May 1, 2009
            • 0 Attachment
              Hmmmmm, more research on the 10048 error... I do have the old version of bpq32.dll still installed down the AR-Cluster/BPQ folder...

              I'll rename that and restart everything and see if this error is related to two copies/images of bpq32.dll getting loaded. That's the only other copy of bpq32.dll other than the one that was installed by the BPQ installer.

              Will report back...

              --- In BPQ32@yahoogroups.com, "ng7m" <m.matthew.george@...> wrote:
              >
              > Hi Eric, thanks for taking a look at my post.
              >
              > I have enabled the AGW PE|AGW to BPQ option. I had it enabled previously because I have been using AR-Cluster with AGWPE for a long time now. Working fine. User connections to AR-Cluster direct on my radio ports are working.
              >
              > AR-Cluster is connected to AGWPE and shows up in AGW as one of the connected applications.
              >
              > Last night was the first time I started looking at BPQ...
              >
              > Now what might be an obvious question, should I be running AGWtoBPQ too? I have only been running BPQTerminal. When I run AGWtoBPQ, i'm getting an error popup that says 'bind(sock) failed Error 10048'
              >
              > I have checked the config files and can't see where i'm specifying a port that would be incorrect.
              >
              > Does AGWtoBPQ need to be running?
              >
              > de NG7M
              >
              > --- In BPQ32@yahoogroups.com, "Eric Carling" <eric@> wrote:
              > >
              > > What have you done in AR Cluster itself to accept the connection?
              > >
              > >
              > >
              > > My method is to go to cfg>io devices and enable AGW PE|AGW to BPQ. This then
              > > has to be configured after you press the button adjacent.
              > >
              > >
              > >
              > > Is this what you have done?
              > >
              > >
              > >
              > > Eric G0CGL / GB7CGL
              > >
              > >
              > >
              > > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of ng7m
              > > Sent: 01 May 2009 06:59
              > > To: BPQ32@yahoogroups.com
              > > Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW
              > >
              > >
              > >
              > >
              > >
              > >
              > >
              > >
              > > I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been
              > > using Digiplex with AGWPE with mixed results.
              > >
              > > I have things working pretty well, I can run BPQTerminal and control all of
              > > my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE
              > > controled ports too.
              > >
              > > The problem I have is that when I try to connect to AR_Cluster from the BPQ
              > > node interface, it says 'Sorry, All DX Ports are in use - Please try later'
              > >
              > > I have only one BPQ application setup and it's defined as DX for my
              > > AR-Cluster setup (NC7J)
              > >
              > > I have been searching around trying to see anything I could have missed in
              > > the bpqcfg.txt. Poking around for hours now... ;) no luck.
              > >
              > > I hope I have missed something obvious and that someone can point me in the
              > > right direction.
              > >
              > > BPQ as a node is working great... it's getting node broadcasts and sending
              > > out node broadcasts from the AGW controlled ports etc...
              > >
              > > I have my app for AR_Cluster configured like this in the bpqcfg.txt file:
              > >
              > > APPL1CALL=NC7J
              > > APPL1ALIAS=UTDXC
              > > APPL1QUAL=255
              > >
              > > My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1
              > >
              > > The 'all ports are in use' error is leaving me scratching my head... I can't
              > > find anything obvious searching here on the BPQ32 group either??
              > >
              > > de NG7M Max
              > >
              >
            • Ron Stordahl
              Max I see our posts crossed paths about the same time and that you have made progress. From your post I believe you are using the AGWtoBPQ interface method.
              Message 6 of 10 , May 1, 2009
              • 0 Attachment
                Max

                I see our posts crossed paths about the same time and that you have made progress.
                From your post I believe you are using the AGWtoBPQ interface method.  In AR-Cluster you do have only one of the two interface methods selected I hope.

                The 10048 error indicates a winsock address conflict.  Confirm that in the AR-Cluster set up window for Configure AGWPE | AGWtoBPQ via TCPIP that you have selected the second interface option, TCPIP Interface ! AGWPE | AGWto BPQ Port 1, IP Address 127.0.0.1 and Port 8000.

                In AGWtoBPQ Configuration you must also specify TCP Port 8000.  Your application mask Appl Mask should be 0x1.

                Could you have another program running which is in conflict?

                Ron, N5IN


                From: ng7m <m.matthew.george@...>
                To: BPQ32@yahoogroups.com
                Sent: Friday, May 1, 2009 9:50:08 AM
                Subject: [BPQ32] Re: Switch to BPQ32 from Digiplex using AGW

                Hmmmmm, more research on the 10048 error... I do have the old version of bpq32.dll still installed down the AR-Cluster/BPQ folder...

                I'll rename that and restart everything and see if this error is related to two copies/images of bpq32.dll getting loaded. That's the only other copy of bpq32.dll other than the one that was installed by the BPQ installer.

                Will report back...

                --- In BPQ32@yahoogroups. com, "ng7m" <m.matthew.george@ ...> wrote:
                >
                > Hi Eric, thanks for taking a look at my post.
                >
                > I have enabled the AGW PE|AGW to BPQ option. I had it enabled previously because I have been using AR-Cluster with AGWPE for a long time now. Working fine. User connections to AR-Cluster direct on my radio ports are working.
                >
                > AR-Cluster is connected to AGWPE and shows up in AGW as one of the connected applications.
                >
                > Last night was the first time I started looking at BPQ...
                >
                > Now what might be an obvious question, should I be running AGWtoBPQ too? I have only been running BPQTerminal. When I run AGWtoBPQ, i'm getting an error popup that says 'bind(sock) failed Error 10048'
                >
                > I have checked the config files and can't see where i'm specifying a port that would be incorrect.
                >
                > Does AGWtoBPQ need to be running?
                >
                > de NG7M
                >
                > --- In BPQ32@yahoogroups. com, "Eric Carling" <eric@> wrote:
                > >
                > > What have you done in AR Cluster itself to accept the connection?
                > >
                > >
                > >
                > > My method is to go to cfg>io devices and enable AGW PE|AGW to BPQ. This then
                > > has to be configured after you press the button adjacent.
                > >
                > >
                > >
                > > Is this what you have done?
                > >
                > >
                > >
                > > Eric G0CGL / GB7CGL
                > >
                > >
                > >
                > > From: BPQ32@yahoogroups. com [mailto:BPQ32@yahoogroups. com] On Behalf Of ng7m
                > > Sent: 01 May 2009 06:59
                > > To: BPQ32@yahoogroups. com
                > > Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW
                > >
                > >
                > >
                > >
                > >
                > >
                > >
                > >
                > > I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been
                > > using Digiplex with AGWPE with mixed results.
                > >
                > > I have things working pretty well, I can run BPQTerminal and control all of
                > > my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE
                > > controled ports too.
                > >
                > > The problem I have is that when I try to connect to AR_Cluster from the BPQ
                > > node interface, it says 'Sorry, All DX Ports are in use - Please try later'
                > >
                > > I have only one BPQ application setup and it's defined as DX for my
                > > AR-Cluster setup (NC7J)
                > >
                > > I have been searching around trying to see anything I could have missed in
                > > the bpqcfg.txt. Poking around for hours now... ;) no luck.
                > >
                > > I hope I have missed something obvious and that someone can point me in the
                > > right direction.
                > >
                > > BPQ as a node is working great... it's getting node broadcasts and sending
                > > out node broadcasts from the AGW controlled ports etc...
                > >
                > > I have my app for AR_Cluster configured like this in the bpqcfg.txt file:
                > >
                > > APPL1CALL=NC7J
                > > APPL1ALIAS=UTDXC
                > > APPL1QUAL=255
                > >
                > > My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1
                > >
                > > The 'all ports are in use' error is leaving me scratching my head... I can't
                > > find anything obvious searching here on the BPQ32 group either??
                > >
                > > de NG7M Max
                > >
                >

              • Ron Stordahl
                Having the AR-Cluster BPQ32 folder present should not be an issue. It should be completely ignored. The BPQ32 installer sets up path information in the
                Message 7 of 10 , May 1, 2009
                • 0 Attachment
                  Having the AR-Cluster\BPQ32 folder present should not be an issue.  It should be completely ignored.  The BPQ32 installer sets up path information in the registry so that the bpq32.dll in the windows system folder is used and the configuration found in Program Files\BPQ32 is used. 

                  I have deleted the AR-Cluster\BPQ32 directory in both my installations.

                  If you do so and things change then I will be quite surprised and would have to look into it!

                  Ron


                  From: ng7m <m.matthew.george@...>
                  To: BPQ32@yahoogroups.com
                  Sent: Friday, May 1, 2009 9:50:08 AM
                  Subject: [BPQ32] Re: Switch to BPQ32 from Digiplex using AGW

                  Hmmmmm, more research on the 10048 error... I do have the old version of bpq32.dll still installed down the AR-Cluster/BPQ folder...

                  I'll rename that and restart everything and see if this error is related to two copies/images of bpq32.dll getting loaded. That's the only other copy of bpq32.dll other than the one that was installed by the BPQ installer.

                  Will report back...

                  --- In BPQ32@yahoogroups. com, "ng7m" <m.matthew.george@ ...> wrote:
                  >
                  > Hi Eric, thanks for taking a look at my post.
                  >
                  > I have enabled the AGW PE|AGW to BPQ option. I had it enabled previously because I have been using AR-Cluster with AGWPE for a long time now. Working fine. User connections to AR-Cluster direct on my radio ports are working.
                  >
                  > AR-Cluster is connected to AGWPE and shows up in AGW as one of the connected applications.
                  >
                  > Last night was the first time I started looking at BPQ...
                  >
                  > Now what might be an obvious question, should I be running AGWtoBPQ too? I have only been running BPQTerminal. When I run AGWtoBPQ, i'm getting an error popup that says 'bind(sock) failed Error 10048'
                  >
                  > I have checked the config files and can't see where i'm specifying a port that would be incorrect.
                  >
                  > Does AGWtoBPQ need to be running?
                  >
                  > de NG7M
                  >
                  > --- In BPQ32@yahoogroups. com, "Eric Carling" <eric@> wrote:
                  > >
                  > > What have you done in AR Cluster itself to accept the connection?
                  > >
                  > >
                  > >
                  > > My method is to go to cfg>io devices and enable AGW PE|AGW to BPQ. This then
                  > > has to be configured after you press the button adjacent.
                  > >
                  > >
                  > >
                  > > Is this what you have done?
                  > >
                  > >
                  > >
                  > > Eric G0CGL / GB7CGL
                  > >
                  > >
                  > >
                  > > From: BPQ32@yahoogroups. com [mailto:BPQ32@yahoogroups. com] On Behalf Of ng7m
                  > > Sent: 01 May 2009 06:59
                  > > To: BPQ32@yahoogroups. com
                  > > Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > > I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been
                  > > using Digiplex with AGWPE with mixed results.
                  > >
                  > > I have things working pretty well, I can run BPQTerminal and control all of
                  > > my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE
                  > > controled ports too.
                  > >
                  > > The problem I have is that when I try to connect to AR_Cluster from the BPQ
                  > > node interface, it says 'Sorry, All DX Ports are in use - Please try later'
                  > >
                  > > I have only one BPQ application setup and it's defined as DX for my
                  > > AR-Cluster setup (NC7J)
                  > >
                  > > I have been searching around trying to see anything I could have missed in
                  > > the bpqcfg.txt. Poking around for hours now... ;) no luck.
                  > >
                  > > I hope I have missed something obvious and that someone can point me in the
                  > > right direction.
                  > >
                  > > BPQ as a node is working great... it's getting node broadcasts and sending
                  > > out node broadcasts from the AGW controlled ports etc...
                  > >
                  > > I have my app for AR_Cluster configured like this in the bpqcfg.txt file:
                  > >
                  > > APPL1CALL=NC7J
                  > > APPL1ALIAS=UTDXC
                  > > APPL1QUAL=255
                  > >
                  > > My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1
                  > >
                  > > The 'all ports are in use' error is leaving me scratching my head... I can't
                  > > find anything obvious searching here on the BPQ32 group either??
                  > >
                  > > de NG7M Max
                  > >
                  >

                • ng7m
                  Hi Ron, thanks for jumping in here... In AR-Cluster I do not have the BPQ-OCX option checked. I have always used the AGWPE interface. Since my last post I have
                  Message 8 of 10 , May 1, 2009
                  • 0 Attachment
                    Hi Ron, thanks for jumping in here...

                    In AR-Cluster I do not have the BPQ-OCX option checked. I have always used the AGWPE interface.

                    Since my last post I have made progress, I think i'm getting close, it's clear I need to be running the AGWtoBPQ app. I was getting an error when it was starting becuase it couldn't open a socket.

                    Okay a few more details... I have AGW setup for port 8010 by the way, I used 8010 in AGW early on and decided to keep it that way for now. BPQ is talking to the AGW on 8010 because I can control the radio ports.

                    I figured out I was getting the socket bind error because I had AGWtoBPQ setup for port 8010, in my rust to configure things, I thought it was to point to port 8010 where AGWPE is listening.

                    I just fixed this... pointed AGWtoBPQ back to port 8000 and now it's starting up.

                    Plus, now when I try to make a NETROM connect to AR-Cluster, I'm seeing a different message. I now get a CONNECT and then this message comes back:

                    #BM96:W7EO-8} Connected to UTDXC:NC7J
                    No AGWPE Host Sessions available
                    #BM96:W7EO-8} Welcome back.

                    Last night was the first time I have EVER looked at BPQ config files... so thanks for helping out here. :)

                    On the AGW side, I have two radio ports... actually i'm using a Kan 9612, one 1200 baud port and a 9600 baud port on our Utah 9600 baud backbone freq.

                    So in AGW I have 3 ports setup, the 1200 baud port, the 9600 baud port and a loopback port that I was using with Digiplex... the loop back is still in place. It sounds like it won't be required when I get this working? not sure...

                    Ron, I'll send you the two config files below direct to your email. Don't laugh at my edits! It was a 1am session last night plowing through the configs for the first time. :)

                    One last thing, AR-Cluster is set for the callsign NC7J obviously.

                    I'll do some more research on the No AGWPE Host Sessions Available message too.

                    Max NG7M



                    --- In BPQ32@yahoogroups.com, Ron Stordahl <ron_n5in@...> wrote:
                    >
                    > Max NG7M
                    >
                    > The BPQ32 to AR-Cluster setup is described in the BPQ32 Installation Document.
                    >
                    > Assuming you have read that I will bring up the essential points.
                    >
                    > You must in AR-Cluster Cfg>I/O Devices...>Input/Output Configuration select either BPQ-OCX or AGW PE|AGW to BPQ as the interface method. AR-Cluster will allow you to select both, but do not do so!
                    >
                    > If you choose BPQ-OCX as the interface method, then upon starting AR-Cluster will bring up BPQ32. If you choose AGW to BPQ as the interface method, you will have to manually start AGWtoBPQ.exe.
                    >
                    > In the BPQ-OCX interface method you do not have to select the Application Mask within BPQ32, it is hard coded in AR-Cluster to 0x1. That means that in your APPLICATIONS= string in bpqcfg.txt the first parameter must be used for AR-Cluster.
                    >
                    > For the AGWtoBPQ interface method you may use any position in the APPLICATIONS= string, but you must specify the corresponding applications mask for that position in the AGWtoBPQ program thus: Config>Configuration>Appl Mask. Since you have told us that your AR-Cluster application is in the first position in that string you would enter 0x1 in that location in the Configuration window.
                    >
                    > If you have done one or the other of the above the interface should work.
                    >
                    > I run two copies of AR-Cluster. My main cluster, N5IN, uses the AGWtoBPQ interface. My test cluster, N5IN-1, uses the OCX interface. I do this just to be sure for each new release that both interface methods continue to work.
                    >
                    > If you continue to have problems with this I will need to see your bpqcfg.txt and bpqaxip.cfg files.
                    >
                    > Ron N5IN
                    >
                    >
                    >
                    >
                    > ________________________________
                    > From: ng7m <m.matthew.george@...>
                    > To: BPQ32@yahoogroups.com
                    > Sent: Friday, May 1, 2009 1:58:59 AM
                    > Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW
                    >
                    >
                    >
                    >
                    >
                    > I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been using Digiplex with AGWPE with mixed results.
                    >
                    > I have things working pretty well, I can run BPQTerminal and control all of my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE controled ports too.
                    >
                    > The problem I have is that when I try to connect to AR_Cluster from the BPQ node interface, it says 'Sorry, All DX Ports are in use - Please try later'
                    >
                    > I have only one BPQ application setup and it's defined as DX for my AR-Cluster setup (NC7J)
                    >
                    > I have been searching around trying to see anything I could have missed in the bpqcfg.txt. Poking around for hours now... ;) no luck.
                    >
                    > I hope I have missed something obvious and that someone can point me in the right direction.
                    >
                    > BPQ as a node is working great... it's getting node broadcasts and sending out node broadcasts from the AGW controlled ports etc...
                    >
                    > I have my app for AR_Cluster configured like this in the bpqcfg.txt file:
                    >
                    > APPL1CALL=NC7J
                    > APPL1ALIAS=UTDXC
                    > APPL1QUAL=255
                    >
                    > My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1
                    >
                    > The 'all ports are in use' error is leaving me scratching my head... I can't find anything obvious searching here on the BPQ32 group either??
                    >
                    > de NG7M Max
                    >
                  • Ron Stordahl
                    It is fine to use port 8010 between BPQ32 and AGWPE. This would of course have to match in bpqcfg.txt in your ports definition: ..... TYPE=EXTERNAL
                    Message 9 of 10 , May 1, 2009
                    • 0 Attachment
                      It is fine to use port 8010 between BPQ32 and AGWPE.  This would of course have to match in bpqcfg.txt in your ports definition:

                      .....
                      TYPE=EXTERNAL
                      DLLNAME=BPQtoAGW.DLL
                      IOADDR=1F4A
                      CHANNEL=A
                      .......

                      That ioaddr is 1F4A as it is hexadecimal for decimal 8010.

                      I would personally stay away from 8010, as that happens to be the default port number which we use in BPQTelnetServer.cfg!  If course you could change that too to avoid conflict.

                      However in the example configurations I intentionally used 8001 as the port number for the BPQ to AGWPE interface, which is 0x1F41.

                      In my examples I have chosen these 'defaults':

                      AGWtoBPQ interface to applications:  8000 decimal  = 1F40 hex
                      BPQtoAGW (interfacing BPQ to AGWPE) 8001 decimal = 1F41 hex
                      BPQTelnetServer port number 8010 decimal = 1F4A hex.

                      If you are getting no AGWPE host sessions available it is most likely because you do not have the applications mask set up correctly in the AGWtoBPQ program.  You do have to start AGWtoBPQ.exe youself, it doesn't start automatically.  The mask should be 0x1, because that is the default however it should already be correct.  It has been so long since I have seen this error message however..there could be another cause I suppose.

                      You are almost there it appears.

                      Ron, N5IN



                      From: ng7m <m.matthew.george@...>
                      To: BPQ32@yahoogroups.com
                      Sent: Friday, May 1, 2009 10:24:59 AM
                      Subject: [BPQ32] Re: Switch to BPQ32 from Digiplex using AGW

                      Hi Ron, thanks for jumping in here...

                      In AR-Cluster I do not have the BPQ-OCX option checked. I have always used the AGWPE interface.

                      Since my last post I have made progress, I think i'm getting close, it's clear I need to be running the AGWtoBPQ app. I was getting an error when it was starting becuase it couldn't open a socket.

                      Okay a few more details... I have AGW setup for port 8010 by the way, I used 8010 in AGW early on and decided to keep it that way for now. BPQ is talking to the AGW on 8010 because I can control the radio ports.

                      I figured out I was getting the socket bind error because I had AGWtoBPQ setup for port 8010, in my rust to configure things, I thought it was to point to port 8010 where AGWPE is listening.

                      I just fixed this... pointed AGWtoBPQ back to port 8000 and now it's starting up.

                      Plus, now when I try to make a NETROM connect to AR-Cluster, I'm seeing a different message. I now get a CONNECT and then this message comes back:

                      #BM96:W7EO-8} Connected to UTDXC:NC7J
                      No AGWPE Host Sessions available
                      #BM96:W7EO-8} Welcome back.

                      Last night was the first time I have EVER looked at BPQ config files... so thanks for helping out here. :)

                      On the AGW side, I have two radio ports... actually i'm using a Kan 9612, one 1200 baud port and a 9600 baud port on our Utah 9600 baud backbone freq.

                      So in AGW I have 3 ports setup, the 1200 baud port, the 9600 baud port and a loopback port that I was using with Digiplex... the loop back is still in place. It sounds like it won't be required when I get this working? not sure...

                      Ron, I'll send you the two config files below direct to your email. Don't laugh at my edits! It was a 1am session last night plowing through the configs for the first time. :)

                      One last thing, AR-Cluster is set for the callsign NC7J obviously.

                      I'll do some more research on the No AGWPE Host Sessions Available message too.

                      Max NG7M

                      --- In BPQ32@yahoogroups. com, Ron Stordahl <ron_n5in@.. .> wrote:
                      >
                      > Max NG7M
                      >
                      > The BPQ32 to AR-Cluster setup is described in the BPQ32 Installation Document.
                      >
                      > Assuming you have read that I will bring up the essential points.
                      >
                      > You must in AR-Cluster Cfg>I/O Devices...>Input/ Output Configuration select either BPQ-OCX or AGW PE|AGW to BPQ as the interface method. AR-Cluster will allow you to select both, but do not do so!
                      >
                      > If you choose BPQ-OCX as the interface method, then upon starting AR-Cluster will bring up BPQ32. If you choose AGW to BPQ as the interface method, you will have to manually start AGWtoBPQ.exe.
                      >
                      > In the BPQ-OCX interface method you do not have to select the Application Mask within BPQ32, it is hard coded in AR-Cluster to 0x1. That means that in your APPLICATIONS= string in bpqcfg.txt the first parameter must be used for AR-Cluster.
                      >
                      > For the AGWtoBPQ interface method you may use any position in the APPLICATIONS= string, but you must specify the corresponding applications mask for that position in the AGWtoBPQ program thus: Config>Configuratio n>Appl Mask. Since you have told us that your AR-Cluster application is in the first position in that string you would enter 0x1 in that location in the Configuration window.
                      >
                      > If you have done one or the other of the above the interface should work.
                      >
                      > I run two copies of AR-Cluster. My main cluster, N5IN, uses the AGWtoBPQ interface. My test cluster, N5IN-1, uses the OCX interface. I do this just to be sure for each new release that both interface methods continue to work.
                      >
                      > If you continue to have problems with this I will need to see your bpqcfg.txt and bpqaxip.cfg files.
                      >
                      > Ron N5IN
                      >
                      >
                      >
                      >
                      > ____________ _________ _________ __
                      > From: ng7m <m.matthew.george@ ...>
                      > To: BPQ32@yahoogroups. com
                      > Sent: Friday, May 1, 2009 1:58:59 AM
                      > Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW
                      >
                      >
                      >
                      >
                      >
                      > I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been using Digiplex with AGWPE with mixed results.
                      >
                      > I have things working pretty well, I can run BPQTerminal and control all of my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE controled ports too.
                      >
                      > The problem I have is that when I try to connect to AR_Cluster from the BPQ node interface, it says 'Sorry, All DX Ports are in use - Please try later'
                      >
                      > I have only one BPQ application setup and it's defined as DX for my AR-Cluster setup (NC7J)
                      >
                      > I have been searching around trying to see anything I could have missed in the bpqcfg.txt. Poking around for hours now... ;) no luck.
                      >
                      > I hope I have missed something obvious and that someone can point me in the right direction.
                      >
                      > BPQ as a node is working great... it's getting node broadcasts and sending out node broadcasts from the AGW controlled ports etc...
                      >
                      > I have my app for AR_Cluster configured like this in the bpqcfg.txt file:
                      >
                      > APPL1CALL=NC7J
                      > APPL1ALIAS=UTDXC
                      > APPL1QUAL=255
                      >
                      > My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1
                      >
                      > The 'all ports are in use' error is leaving me scratching my head... I can't find anything obvious searching here on the BPQ32 group either??
                      >
                      > de NG7M Max
                      >

                    • ng7m
                      Tahnks to time spent with Ron, I resolved my issue... I had the wrong port still configured in AR-Cluster, AR_Cluster was still pointed to AGWPE on the port
                      Message 10 of 10 , May 1, 2009
                      • 0 Attachment
                        Tahnks to time spent with Ron, I resolved my issue... I had the wrong port still configured in AR-Cluster, AR_Cluster was still pointed to AGWPE on the port 8010 which I had changed a few years back. So I didn't pick up on the fact that AR-Cluster needed to talk to BPQtoAGW on port 8000 for example... where it was listening.

                        It all makes sense now and I'm up and running with BPQ and have replaced Digiplex for my NETROM setup.

                        Next AXIP tunnels... so I can expose our packet users to more nodes, tunneled over the internet. :)

                        Big thanks again to Ron and others!

                        mg NG7M

                        --- In BPQ32@yahoogroups.com, Ron Stordahl <ron_n5in@...> wrote:
                        >
                        > It is fine to use port 8010 between BPQ32 and AGWPE. This would of course have to match in bpqcfg.txt in your ports definition:
                        >
                        > .....
                        > TYPE=EXTERNAL
                        > DLLNAME=BPQtoAGW.DLL
                        > IOADDR=1F4A
                        > CHANNEL=A
                        > .......
                        >
                        > That ioaddr is 1F4A as it is hexadecimal for decimal 8010.
                        >
                        > I would personally stay away from 8010, as that happens to be the default port number which we use in BPQTelnetServer.cfg! If course you could change that too to avoid conflict.
                        >
                        > However in the example configurations I intentionally used 8001 as the port number for the BPQ to AGWPE interface, which is 0x1F41.
                        >
                        > In my examples I have chosen these 'defaults':
                        >
                        > AGWtoBPQ interface to applications: 8000 decimal = 1F40 hex
                        > BPQtoAGW (interfacing BPQ to AGWPE) 8001 decimal = 1F41 hex
                        > BPQTelnetServer port number 8010 decimal = 1F4A hex.
                        >
                        > If you are getting no AGWPE host sessions available it is most likely because you do not have the applications mask set up correctly in the AGWtoBPQ program. You do have to start AGWtoBPQ.exe youself, it doesn't start automatically. The mask should be 0x1, because that is the default however it should already be correct. It has been so long since I have seen this error message however..there could be another cause I suppose.
                        >
                        > You are almost there it appears.
                        >
                        > Ron, N5IN
                        >
                        >
                        >
                        >
                        >
                        > ________________________________
                        > From: ng7m <m.matthew.george@...>
                        > To: BPQ32@yahoogroups.com
                        > Sent: Friday, May 1, 2009 10:24:59 AM
                        > Subject: [BPQ32] Re: Switch to BPQ32 from Digiplex using AGW
                        >
                        >
                        >
                        >
                        >
                        > Hi Ron, thanks for jumping in here...
                        >
                        > In AR-Cluster I do not have the BPQ-OCX option checked. I have always used the AGWPE interface.
                        >
                        > Since my last post I have made progress, I think i'm getting close, it's clear I need to be running the AGWtoBPQ app. I was getting an error when it was starting becuase it couldn't open a socket.
                        >
                        > Okay a few more details... I have AGW setup for port 8010 by the way, I used 8010 in AGW early on and decided to keep it that way for now. BPQ is talking to the AGW on 8010 because I can control the radio ports.
                        >
                        > I figured out I was getting the socket bind error because I had AGWtoBPQ setup for port 8010, in my rust to configure things, I thought it was to point to port 8010 where AGWPE is listening.
                        >
                        > I just fixed this... pointed AGWtoBPQ back to port 8000 and now it's starting up.
                        >
                        > Plus, now when I try to make a NETROM connect to AR-Cluster, I'm seeing a different message. I now get a CONNECT and then this message comes back:
                        >
                        > #BM96:W7EO-8} Connected to UTDXC:NC7J
                        > No AGWPE Host Sessions available
                        > #BM96:W7EO-8} Welcome back.
                        >
                        > Last night was the first time I have EVER looked at BPQ config files... so thanks for helping out here. :)
                        >
                        > On the AGW side, I have two radio ports... actually i'm using a Kan 9612, one 1200 baud port and a 9600 baud port on our Utah 9600 baud backbone freq.
                        >
                        > So in AGW I have 3 ports setup, the 1200 baud port, the 9600 baud port and a loopback port that I was using with Digiplex... the loop back is still in place. It sounds like it won't be required when I get this working? not sure...
                        >
                        > Ron, I'll send you the two config files below direct to your email. Don't laugh at my edits! It was a 1am session last night plowing through the configs for the first time. :)
                        >
                        > One last thing, AR-Cluster is set for the callsign NC7J obviously.
                        >
                        > I'll do some more research on the No AGWPE Host Sessions Available message too.
                        >
                        > Max NG7M
                        >
                        > --- In BPQ32@yahoogroups. com, Ron Stordahl <ron_n5in@ .> wrote:
                        > >
                        > > Max NG7M
                        > >
                        > > The BPQ32 to AR-Cluster setup is described in the BPQ32 Installation Document.
                        > >
                        > > Assuming you have read that I will bring up the essential points.
                        > >
                        > > You must in AR-Cluster Cfg>I/O Devices...>Input/ Output Configuration select either BPQ-OCX or AGW PE|AGW to BPQ as the interface method. AR-Cluster will allow you to select both, but do not do so!
                        > >
                        > > If you choose BPQ-OCX as the interface method, then upon starting AR-Cluster will bring up BPQ32. If you choose AGW to BPQ as the interface method, you will have to manually start AGWtoBPQ.exe.
                        > >
                        > > In the BPQ-OCX interface method you do not have to select the Application Mask within BPQ32, it is hard coded in AR-Cluster to 0x1. That means that in your APPLICATIONS= string in bpqcfg.txt the first parameter must be used for AR-Cluster.
                        > >
                        > > For the AGWtoBPQ interface method you may use any position in the APPLICATIONS= string, but you must specify the corresponding applications mask for that position in the AGWtoBPQ program thus: Config>Configuratio n>Appl Mask. Since you have told us that your AR-Cluster application is in the first position in that string you would enter 0x1 in that location in the Configuration window.
                        > >
                        > > If you have done one or the other of the above the interface should work.
                        > >
                        > > I run two copies of AR-Cluster. My main cluster, N5IN, uses the AGWtoBPQ interface. My test cluster, N5IN-1, uses the OCX interface. I do this just to be sure for each new release that both interface methods continue to work.
                        > >
                        > > If you continue to have problems with this I will need to see your bpqcfg.txt and bpqaxip.cfg files.
                        > >
                        > > Ron N5IN
                        > >
                        > >
                        > >
                        > >
                        > > ____________ _________ _________ __
                        > > From: ng7m <m.matthew.george@ ...>
                        > > To: BPQ32@yahoogroups. com
                        > > Sent: Friday, May 1, 2009 1:58:59 AM
                        > > Subject: [BPQ32] Switch to BPQ32 from Digiplex using AGW
                        > >
                        > >
                        > >
                        > >
                        > >
                        > > I decided to make the switch on the NC7J AR-Cluster to BPQ32... I have been using Digiplex with AGWPE with mixed results.
                        > >
                        > > I have things working pretty well, I can run BPQTerminal and control all of my ports via AGWPE Pro. I can connect to the BPQ node from the AGWPE controled ports too.
                        > >
                        > > The problem I have is that when I try to connect to AR_Cluster from the BPQ node interface, it says 'Sorry, All DX Ports are in use - Please try later'
                        > >
                        > > I have only one BPQ application setup and it's defined as DX for my AR-Cluster setup (NC7J)
                        > >
                        > > I have been searching around trying to see anything I could have missed in the bpqcfg.txt. Poking around for hours now... ;) no luck.
                        > >
                        > > I hope I have missed something obvious and that someone can point me in the right direction.
                        > >
                        > > BPQ as a node is working great... it's getting node broadcasts and sending out node broadcasts from the AGW controlled ports etc...
                        > >
                        > > I have my app for AR_Cluster configured like this in the bpqcfg.txt file:
                        > >
                        > > APPL1CALL=NC7J
                        > > APPL1ALIAS=UTDXC
                        > > APPL1QUAL=255
                        > >
                        > > My node call is NG7M-1 and on external nodes, UTDXC routes down to NG7M-1
                        > >
                        > > The 'all ports are in use' error is leaving me scratching my head... I can't find anything obvious searching here on the BPQ32 group either??
                        > >
                        > > de NG7M Max
                        > >
                        >
                      Your message has been successfully submitted and would be delivered to recipients shortly.