Loading ...
Sorry, an error occurred while loading the content.
 

RMS Forwarding Getting 'Stuck'

Expand Messages
  • w3tua
    Hi, All! I ve searched the messages in this group and all over Google but can t seem to find the solution to my problem. My BPQ32 node has two ports---one on
    Message 1 of 15 , May 23, 2014

      Hi, All!


      I've searched the messages in this group and all over Google but can't seem to find the solution to my problem.


      My BPQ32 node has two ports---one on VHF packet and one on HF Winmor. I've been trying to forward WL2K messages via RMS and have everything configured to do so. When the node attaches to the RMS port, it goes through the script and connects to the Winlink gateway station. I see the CONNECTED prompt and the connection to the CMS looks okay. Then, the session just goes into IDLE and disconnects after a minute or so of doing nothing. No forwarding starts and I can't figure out why.


      I have forwarding for 'RMS' configured in BPQMail according to the examples. There must be something simple I'm missing. I can offer screenshots of anything needed to be scrutinized if needed.


      73,

      Korey-W3TUA

    • John Wiseman
      Kory, Have a look in the bbs and CMSAccess logs (in the Logs folder under your BPQ32 folder). If there are no obvious error messages send me a copy and I ll
      Message 2 of 15 , May 23, 2014

        Kory,

         

        Have a look in the bbs and CMSAccess logs (in the Logs folder under your BPQ32 folder). If there are no obvious error messages send me a copy and I'll see if I can spot anythhing odd.

         

        73,

        John

         


        From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ]
        Sent: 23 May 2014 14:21
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] RMS Forwarding Getting 'Stuck'

         

         

        Hi, All!

         

        I've searched the messages in this group and all over Google but can't seem to find the solution to my problem.

         

        My BPQ32 node has two ports---one on VHF packet and one on HF Winmor. I've been trying to forward WL2K messages via RMS and have everything configured to do so. When the node attaches to the RMS port, it goes through the script and connects to the Winlink gateway station. I see the CONNECTED prompt and the connection to the CMS looks okay. Then, the session just goes into IDLE and disconnects after a minute or so of doing nothing. No forwarding starts and I can't figure out why.

         

        I have forwarding for 'RMS' configured in BPQMail according to the examples. There must be something simple I'm missing. I can offer screenshots of anything needed to be scrutinized if needed.

         

        73,

        Korey-W3TUA

      • w3tua
        Thanks for helping out a new guy, John. Here s the problem I see in the BBS log. RMS is not routing correctly and I don t know where to look. 140524 00:28:45
        Message 3 of 15 , May 23, 2014

          Thanks for helping out a new guy, John.

          Here's the problem I see in the BBS log. RMS is not routing correctly and I don't know where to look.

           

          140524 00:28:45 ?W3TUA     Msg 42 Routing Trace To RMS Via ke5asa@...
          140524 00:28:45 ?W3TUA     Message @ winlink.org, but local RMS user - leave here
          140524 00:28:45 >W3TUA     Message: 42 Bid:  42_W3TUA Size: 144

           

          I see the logic behind it since I had KE5ASA as a local RMS user. So, I removed him from the users list and restarted the node. This same output happened.

        • w3tua
          I thought I d reply to my own message since I figured it out. After seeing the local user issue I searched the Group again and saw where someone else had
          Message 4 of 15 , May 23, 2014


            I thought I'd reply to my own message since I figured it out.

             

            After seeing the  "local user" issue I searched the Group again and saw where someone else had the same problem.

            I discovered that using the "/" instead of the ":" between RMS and callsign fixed the routing problem.

            140524 02:44:05 >W3TUA     de W3TUA>

            140524 02:44:20 <W3TUA     sp rms/ke5asa@...
            140524 02:44:20 >W3TUA     Enter Title (only):
            140524 02:44:27 <W3TUA     Test Message
            140524 02:44:27 >W3TUA     Enter Message Text (end with /ex or ctrl/z)
            140524 02:44:47 <W3TUA     This is being sent from the BBS. Please send a reply if you get it, Tom.
            140524 02:44:48 <W3TUA     73,
            140524 02:44:51 <W3TUA     Korey-W3TUA
            140524 02:44:51 <W3TUA     /ex
            140524 02:44:51 ?W3TUA     Msg 44 Routing Trace To RMS Via ke5asa@...
            140524 02:44:51 ?W3TUA     Routing Trace to RMS Matches BBS RMS
            140524 02:44:51 >W3TUA     Message: 44 Bid:  44_W3TUA Size: 92
            140524 02:44:51 >W3TUA     de W3TUA>

            Just posted this so that others looking for the solution can find it.

             

            Thank you for offering to help and ppointing me in the right direction, John!

            73, Korey--W3TUA

             

          • k9drh@sbcglobal.net
            OK now you grabbed my attention. as a sysop as well as the rest of you what is this about? I discovered that using the / instead of the : between RMS and
            Message 5 of 15 , May 24, 2014
              OK now you grabbed my attention. as a sysop as well as the rest of you what is this about?
              "I discovered that using the "/" instead of the ":" between RMS and callsign fixed the routing problem."

              for years we have been using ":" between rms and smtp where did the "/" come from and when was the change made that you can use either or?
              What I see as a possible problem is that he added rms:xxx@....
              The rms is not needed when the address is @... you would only use rms: if it is some other email address that you want to route through winlink system say "rms:secretary@..." or smtp:secretary@.... which is right ":" or "/" ???

              73 Dave
            • w3tua
              I ll try dropping the RMS: when sending to @winlink.org addresses. Thank you! W3TUA-Korey
              Message 6 of 15 , May 24, 2014

                I'll try dropping the "RMS:" when sending to @... addresses. Thank you!


                W3TUA-Korey

              • John Wiseman
                Korey, If that is happening, it is a bug! There are two user record flags to do with RMS - Poll RMS for SSID s and RMS Express User . If a message is
                Message 7 of 15 , May 24, 2014

                  Korey,

                   

                  If that is happening, it is a bug!

                   

                  There are two user record flags to do with RMS - "Poll RMS for SSID's" and "RMS Express User". If a message is addressed @... (with or without an RMS: or RMS/), and the addressee is a local user, and has "Poll RMS for SSID;s" checked, the message should be kept on the local BBS (as if send it to a CMS, the BBS will promptly retrieve it again). Otherwise it should be forwarded to the CMS.

                   

                  Would you mind checking it again, and if you get "Message @ winlink.org, but local RMS user - leave here" when you don't have "Poll RMS" checked, could you send me the log, and your BPQBBSUsers.dat file?

                   

                  Thanks,

                  John

                   

                   

                  From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ]
                  Sent: 24 May 2014 03:53
                  To: BPQ32@yahoogroups.com
                  Subject: RE: [BPQ32] RMS Forwarding Getting 'Stuck'

                   

                   


                  I thought I'd reply to my own message since I figured it out.

                   

                  After seeing the  "local user" issue I searched the Group again and saw where someone else had the same problem.

                  I discovered that using the "/" instead of the ":" between RMS and callsign fixed the routing problem.

                  140524 02:44:05 >W3TUA     de W3TUA>

                  140524 02:44:20 <W3TUA     sp rms/ke5asa@...
                  140524 02:44:20 >W3TUA     Enter Title (only):
                  140524 02:44:27 <W3TUA     Test Message
                  140524 02:44:27 >W3TUA     Enter Message Text (end with /ex or ctrl/z)
                  140524 02:44:47 <W3TUA     This is being sent from the BBS. Please send a reply if you get it, Tom.
                  140524 02:44:48 <W3TUA     73,
                  140524 02:44:51 <W3TUA     Korey-W3TUA
                  140524 02:44:51 <W3TUA     /ex
                  140524 02:44:51 ?W3TUA     Msg 44 Routing Trace To RMS Via ke5asa@...
                  140524 02:44:51 ?W3TUA     Routing Trace to RMS Matches BBS RMS
                  140524 02:44:51 >W3TUA &n bsp;   Message: 44 Bid:  44_W3TUA Size: 92
                  140524 02:44:51 >W3TUA     de W3TUA>

                  Just posted this so that others looking for the solution can find it.

                   

                  Thank you for offering to help and ppointing me in the right direction, John!

                  73, Korey--W3TUA

                   

                • John Wiseman
                  Dave, The option of using RMS/ instead of RMS: was added because some email clients don t accept addresses with a colon. They should be treated exactly the
                  Message 8 of 15 , May 24, 2014

                    Dave,

                     

                    The option of using RMS/ instead of RMS: was added because some email clients don't accept addresses with a colon. They should be treated exactly the same.

                     

                    73, John

                     


                    From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ]
                    Sent: 24 May 2014 12:37
                    To: BPQ32@yahoogroups.com
                    Subject: [BPQ32] Re: RMS Forwarding Getting 'Stuck'

                     

                     

                    OK now you grabbed my attention. as a sysop as well as the rest of you what is this about?
                    "I discovered that using the "/" instead of the ":" between RMS and callsign fixed the routing problem."

                    for years we have been using ":" between rms and smtp where did the "/" come from and when was the change made that you can use either or?
                    What I see as a possible problem is that he added rms:xxx@....
                    The rms is not needed when the address is @... you would only use rms: if it is some other email address that you want to route through winlink system say "rms:secretary@..." or smtp:secretary@.... which is right ":" or "/" ???

                    73 Dave

                  • Jim
                    I keep getting notices of SMTP messages but I have no Internet. Where are they are being stored? Jim wu3v Please excuse any typo s that my iPhone has
                    Message 9 of 15 , May 25, 2014
                      I keep getting notices of SMTP messages but I have no Internet. 
                      Where are they are being stored?

                      Jim wu3v

                      Please excuse any typo's that my iPhone has generated. 

                      On May 24, 2014, at 12:37, "'John Wiseman' john.wiseman@... [BPQ32]" <BPQ32@yahoogroups.com> wrote:

                       

                      Dave,

                       

                      The option of using RMS/ instead of RMS: was added because some email clients don't accept addresses with a colon. They should be treated exactly the same.

                       

                      73, John

                       


                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com ]
                      Sent: 24 May 2014 12:37
                      To: BPQ32@yahoogroups.com
                      Subject: [BPQ32] Re: RMS Forwarding Getting 'Stuck'

                       

                       

                      OK now you grabbed my attention. as a sysop as well as the rest of you what is this about?
                      "I discovered that using the "/" instead of the ":" between RMS and callsign fixed the routing problem."

                      for years we have been using ":" between rms and smtp where did the "/" come from and when was the change made that you can use either or?
                      What I see as a possible problem is that he added rms:xxx@winlimk.org.
                      The rms is not needed when the address is @winlink.org you would only use rms: if it is some other email address that you want to route through winlink system say "rms:secretary@races.org" or smtp:secretary@races.org. which is right ":" or "/" ???

                      73 Dave

                    • n9acq
                      Jim RMS, read WL2K, used the internet to move messages via SMTP to non-WL2K addresses. Not sure what is used between CMSs. 73 Bill N9ACQ
                      Message 10 of 15 , May 25, 2014

                        Jim

                                        RMS, read WL2K, used the internet to move messages via SMTP to non-WL2K addresses. Not sure what is used between CMSs.

                        73 Bill

                        N9ACQ

                      • John Wiseman
                        Jim, There are stored in the normal message database. You can find them with L@ SMTP: (there is a colon on the end which may not be clear with
                        Message 11 of 15 , May 26, 2014

                          Jim,

                          There are stored in the normal message database. You can find them with

                          L@ SMTP:               (there is a colon on the end which may not be clear with some fonts)

                          I'd be interested in seeing a copy of the listing, as you shouldn't be able to get messages for SMTP if you don't have the ISP Gateway enabled. If you still have the logs for when they were created, they would be useful too.

                          Thanks,

                          John

                           


                          From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ]
                          Sent: 25 May 2014 22:16
                          To: BPQ32@yahoogroups.com
                          Subject: Re: [BPQ32] Re: RMS Forwarding Getting 'Stuck'

                           

                           

                          I keep getting notices of SMTP messages but I have no Internet. 

                          Where are they are being stored?

                           

                          Jim wu3v

                          Please excuse any typo's that my iPhone has generated. 


                          On May 24, 2014, at 12:37, "'John Wiseman' john.wiseman@... [BPQ32]" <BPQ32@yahoogroups.com> wrote:

                           

                          Dave,

                           

                          The option of using RMS/ instead of RMS: was added because some email clients don't accept addresses with a colon. They should be treated exactly the same.

                           

                          73, John

                           


                          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com ]
                          Sent: 24 May 2014 12:37
                          To: BPQ32@yahoogroups.com
                          Subject: [BPQ32] Re: RMS Forwarding Getting 'Stuck'

                           

                           

                          OK now you grabbed my attention. as a sysop as well as the rest of you what is this about?
                          "I discovered that using the "/" instead of the ":" between RMS and callsign fixed the routing problem."

                          for years we have been using ":" between rms and smtp where did the "/" come from and when was the change made that you can use either or?
                          What I see as a possible problem is that he added rms:xxx@winlimk.org.
                          The rms is not needed when the address is @winlink.org you would only use rms: if it is some other email address that you want to route through winlink system say "rms:secretary@races.org" or smtp:secretary@races.org. which is right ":" or "/" ???

                          73 Dave

                        • Mike Melnik
                          Jim The address SMTP is more then likely coming from your white pages, take a look in the list, it may be difficult to delete as it will be socialite with a
                          Message 12 of 15 , May 26, 2014
                            Jim

                            The address SMTP is more then likely coming from your white pages, take a
                            look in the list, it may be difficult to delete as it will be socialite with
                            a call sign.

                            I had a heck of a time getting it deleted, it is coming from NOS BBS'S

                            Mike N9PMO
                            BPQ32 Group Moderator
                            www.n9pmo.com
                            -----Original Message-----
                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com]
                            Sent: Sunday, May 25, 2014 4:16 PM
                            To: BPQ32@yahoogroups.com
                            Subject: Re: [BPQ32] Re: RMS Forwarding Getting 'Stuck'




                            I keep getting notices of SMTP messages but I have no Internet. 
                            Where are they are being stored?

                            Jim wu3v

                            Please excuse any typo's that my iPhone has generated. 

                            On May 24, 2014, at 12:37, "'John Wiseman' john.wiseman@... [BPQ32]"
                            <BPQ32@yahoogroups.com> wrote:
                             
                            Dave,
                             
                            The option of using RMS/ instead of RMS: was added because some email
                            clients don't accept addresses with a colon. They should be treated exactly
                            the same.
                             
                            73, John
                             

                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com]
                            Sent: 24 May 2014 12:37
                            To: BPQ32@yahoogroups.com
                            Subject: [BPQ32] Re: RMS Forwarding Getting 'Stuck'
                             
                             
                            OK now you grabbed my attention. as a sysop as well as the rest of you what
                            is this about?
                            "I discovered that using the "/" instead of the ":" between RMS and callsign
                            fixed the routing problem."

                            for years we have been using ":" between rms and smtp where did the "/" come
                            from and when was the change made that you can use either or?
                            What I see as a possible problem is that he added rms:xxx@....
                            The rms is not needed when the address is @... you would only use
                            rms: if it is some other email address that you want to route through
                            winlink system say "rms:secretary@..." or smtp:secretary@....
                            which is right ":" or "/" ???

                            73 Dave
                          • Charles Brabham
                            Am on 10.145.5 USB daily between 8am central and 8:30pm central ( 0130 UTC ) in MFSK32 mode, with beacon every half hour, TXid. N5PVL-1 BBS N5PVL-4 Node
                            Message 13 of 15 , May 27, 2014
                              Am on 10.145.5 USB daily between 8am central and 8:30pm central ( 0130
                              UTC ) in MFSK32 mode, with beacon every half hour, TXid.

                              N5PVL-1 BBS
                              N5PVL-4 Node
                              N5PVL-9 Chat

                              Node has VHF Packet on port 1, FLDIGI on port 2

                              Location Alpine, Texas DM80di

                              If you would like to learn to use BPQ32/FLDIGI, contact me bu eMail or
                              better yet, leave a message on the BBS.

                              Am running RXid. If you connect with another mode, my station will
                              respond accordingly. Preferred modes are MFSK32 for weak link, 5xPSK63R
                              for strong links.

                              73 DE Charles, N5PVL
                            • mitchwinkle
                              Charles, I have my system set on the same freq and mode if you care to give a try over to FM17gf, Central Virginia. I tried yours just now but 30m has been a
                              Message 14 of 15 , May 29, 2014
                                Charles,

                                I have my system set on the same freq and mode if you care to give a try over to FM17gf, Central Virginia.

                                I tried yours just now but 30m has been a bit cranky here lately.

                                73,

                                Mitch
                              • w3tua
                                Thanks for your help, Sir! I ve got it working correctly now. It was because I didn t have RMS in the TO box of the user config screen. After putting it in
                                Message 15 of 15 , Jun 3, 2014

                                  Thanks for your help, Sir!


                                  I've got it working correctly now. It was because I didn't have RMS in the "TO" box of the user config screen. After putting it in the BBS now sends and receives via the Winmor HF port.

                                Your message has been successfully submitted and would be delivered to recipients shortly.