Loading ...
Sorry, an error occurred while loading the content.

PiLinBPQ web management

Expand Messages
  • vlakkies
    I am struggling though setting up linbpq on a Raspberry Pi. I ve managed to get a basic system going, but even thoug linmail seems to be running, I can t
    Message 1 of 4 , May 6, 2014
    • 0 Attachment
      I am struggling though setting up linbpq on a Raspberry Pi.  I've managed to get a basic system going, but even thoug linmail seems to be running, I can't connect or manage it.  Trying to set the TCPPORT, HTTPPORT and USER gives me "Source record not recognised - Ignored:" and netstat shows no ports listening where I expect it to.  Could somebody send me a config snippet on how to configure these ports please?


    • John Wiseman
      Those parameters go in a Telnet Port config. Something like: PORT ID=Telnet Server DRIVER=TELNET CONFIG LOGGING=1 DisconnectOnClose=0 TCPPORT=8010 FBBPORT=8011
      Message 2 of 4 , May 6, 2014
      • 0 Attachment
        Those parameters go in a Telnet Port config. Something like:

        PORT
        ID=Telnet Server
        DRIVER=TELNET
        CONFIG
        LOGGING=1
        DisconnectOnClose=0
        TCPPORT=8010
        FBBPORT=8011
        HTTPPORT=8080
        LOGINPROMPT=user:
        PASSWORDPROMPT=password:
        LOCALECHO=NO
        MAXSESSIONS=10
        CTEXT=Welcome to G8BPQ's Telnet Server\nEnter ? for list of commands\n\n

        USER=john,xxxxxxx,g8bpq,,SYSOP
        ENDPORT

        FBBPORT is used for connects from BPQTermTCP, TCPPORT for connects from a
        normal Telnet Client.

        73, John

        ________________________________________
        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
        vlakkies@...
        Sent: 06 May 2014 19:16
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] PiLinBPQ web management

         
        I am struggling though setting up linbpq on a Raspberry Pi.  I've managed to
        get a basic system going, but even thoug linmail seems to be running, I
        can't connect or manage it.  Trying to set the TCPPORT, HTTPPORT and USER
        gives me "Source record not recognised - Ignored:" and netstat shows no
        ports listening where I expect it to.  Could somebody send me a config
        snippet on how to configure these ports please?
      • mitchwinkle
        I use this port def in i686 Ubuntu, but not sure if there are any differences with the Pi version. PORT PORTNUM=4 ID=TELNET (ONLINE) TYPE=EXTERNAL
        Message 3 of 4 , May 6, 2014
        • 0 Attachment
          I use this port def in i686 Ubuntu, but not sure if there are any differences with the Pi version.

          PORT
          PORTNUM=4
          ID=TELNET (ONLINE)
          TYPE=EXTERNAL
          DLLNAME=TELNET.DLL
          CONFIG ; Enable BPQ Telnet Server Connections (Inbound Only)
          CMS=1 ; Enable WL2K Server Connection
          LOGGING=1 ; Logging of Telnet Connections
          DisconnectOnClose=1 ; Disconnection
          TCPPORT=8023 ; Keyboard Connections
          FBBPORT=8011 ; FBB Telnet Inbound Connections
          HTTPPORT=8080 ; HTTP Web Server Access
          LOGINPROMPT=Callsign :
          PASSWORDPROMPT=Password :
          LOCALECHO=YES
          MAXSESSIONS=15 ; Max Number Of Connections at One Time
          USER=mycall,secret,"",SYSOP
          ENDPORT



          The FBBPORT is/can be used for the monitoring of channel activity on the packet port also, which in the Linux versions is nice to have.  (See TermTCP discussion thread on this group from last week).
        • vlakkies
          Thanks John. Once I know what keywords to google, I can actually find it in the documentation. Sorry for the dumb question.
          Message 4 of 4 , May 6, 2014
          • 0 Attachment
            Thanks John.  Once I know what keywords to google, I can actually find it in the documentation.  Sorry for the dumb question.
          Your message has been successfully submitted and would be delivered to recipients shortly.