Loading ...
Sorry, an error occurred while loading the content.

FLdigi and BPQ32 - TNC Not Ready Error

Expand Messages
  • Iain Young, G7III
    Hi Folks, I am experimenting with the latest Betas of BPQ32 and FL-Digi. Despite never having setup BPQ32 before, I got that running with a telnet and bpqether
    Message 1 of 9 , Apr 11, 2014
    • 0 Attachment
      Hi Folks,

      I am experimenting with the latest Betas of BPQ32 and FL-Digi.

      Despite never having setup BPQ32 before, I got that running with
      a telnet and bpqether interface quite easily, so proceeded to
      add the FLdigi interface.

      Due to the fact that my SDR machine is running 64 bit , and I wanted
      to run bpq32 on a spare Pi I had hanging around, I am running them
      on separate machines.

      FL-Digi host is 192.168.39.74 BPQ-Pi-Host is 192.168.39.68

      I have the following in bpq32.cfg for the FLdigi modem:

      PORT
      ID=FLDigi
      DRIVER=fldigi
      PACLEN=64
      CONFIG
      ADDR 192.168.39.74 7342
      TIMEOUT=10
      RETRIES=5
      DEFAULTMODEM BPSK250/1200
      UPDATEMAP
      ENDPORT

      FLDigi's IO configuration contains:

      Enable KISS selected. Enable ARQ, AX25 Decode, Enable CSMA all
      unselected

      KISS IP is defined as 192.168.39.74, I/O port is 7342, O is 7434.
      Dual port is selected.

      ARQ IP is set at 192.168.39.74, port 7322 for future experimentation

      BTW, is
      http://www.cantab.net/users/john.wiseman/Documents/FLDigiDriver.html
      correct ? It says '"Dual Port" must be checked.
      Normally "Enable CSMA" and "Enable Busy Channel" should be unchecked.
      as BPQ handles Buay detect. If you want to run FLDIGI and BPQ on
      different machines, specify the IP address of the BPQ machine instead
      of 127.0.0.1'

      It seems that fldigi tries to listen on this IP Address. If you do set
      the KISS IP to the BPQ Host, it tries to bind() and fails (as it's not
      a local IP of course...)


      Now, when I try to to the "ATTACH" in bpq32 (with my KISS IP set as a
      local IP on the fldigi host), bpq32 gives me the error:

      "Error - TNC Not Ready". fldigi reports lots and lots of these:

      I: ReadFromHostSocket: count 8 �BUSY:� kiss_rx_exit 0
      I: recvFrom: RecvFrom data �BUSY:� r 8 error no 0
      I: recvFrom: RecvFrom data �BUSY:� count 8 HAP:C0A82744:7343
      SAP:C0A8274A:7342
      I: ReadFromHostSocket: count 8 �BUSY:� kiss_rx_exit 0

      bpq32 claims to be "G8BPQ AX25 Packet Switch System Version 6.0.6.1
      April 2014". fldigi version is Fldigi 3.21.79.Kiss02

      Are these still the latest versions ? Can anyone see what I may have
      missed ?

      (and for completness yes, with the KISS IP set as the bpqhost I get
      the same error...)


      73s

      Iain
    • Gerhard.F5VAG
      Hi Ian, ... This works for me. All on one W7 laptop here. Fldigi is beta 05. At present I m listening on 7049.500 kHz CF MFSK32. F5VAG-13. RSids are active.
      Message 2 of 9 , Apr 11, 2014
      • 0 Attachment
        Hi Ian,

        > BTW, is
        > http://www.cantab.net/users/john.wiseman/Documents/FLDigiDriver.html
        > correct ? It says '"Dual Port" must be checked.

        This works for me. All on one W7 laptop here. Fldigi is beta 05.
        At present I'm listening on 7049.500 kHz CF MFSK32. F5VAG-13.
        RSids are active.

        73 de Gerhard, F5VAG
      • Robert Stiles
        Iain,  The port numbers need to be in sequence. 7342 I/O 7343 O.  I have seen the same issue of TNC Not ready, but it has not stopped the program from
        Message 3 of 9 , Apr 11, 2014
        • 0 Attachment
          Iain, 
          The port numbers need to be in sequence. 7342 I/O 7343 O.  I have seen the same issue of TNC Not ready, but it has not stopped the program from working.   

          Robert

          KISS IP is defined as 192.168.39.74, I/O port is 7342, O is 7434.

          Dual port is selected.

          From: "Iain Young, G7III" <g7iii@...>
          To: BPQ32@yahoogroups.com
          Sent: Friday, April 11, 2014 2:55 AM
          Subject: [BPQ32] FLdigi and BPQ32 - TNC Not Ready Error

           
          Hi Folks,

          I am experimenting with the latest Betas of BPQ32 and FL-Digi.

          Despite never having setup BPQ32 before, I got that running with
          a telnet and bpqether interface quite easily, so proceeded to
          add the FLdigi interface.

          Due to the fact that my SDR machine is running 64 bit , and I wanted
          to run bpq32 on a spare Pi I had hanging around, I am running them
          on separate machines.

          FL-Digi host is 192.168.39.74 BPQ-Pi-Host is 192.168.39.68

          I have the following in bpq32.cfg for the FLdigi modem:

          PORT
          ID=FLDigi
          DRIVER=fldigi
          PACLEN=64
          CONFIG
          ADDR 192.168.39.74 7342
          TIMEOUT=10
          RETRIES=5
          DEFAULTMODEM BPSK250/1200
          UPDATEMAP
          ENDPORT

          FLDigi's IO configuration contains:

          Enable KISS selected. Enable ARQ, AX25 Decode, Enable CSMA all
          unselected

          KISS IP is defined as 192.168.39.74, I/O port is 7342, O is 7434.
          Dual port is selected.

          ARQ IP is set at 192.168.39.74, port 7322 for future experimentation

          BTW, is
          http://www.cantab.net/users/john.wiseman/Documents/FLDigiDriver.html
          correct ? It says '"Dual Port" must be checked.
          Normally "Enable CSMA" and "Enable Busy Channel" should be unchecked.
          as BPQ handles Buay detect. If you want to run FLDIGI and BPQ on
          different machines, specify the IP address of the BPQ machine instead
          of 127.0.0.1'

          It seems that fldigi tries to listen on this IP Address. If you do set
          the KISS IP to the BPQ Host, it tries to bind() and fails (as it's not
          a local IP of course...)

          Now, when I try to to the "ATTACH" in bpq32 (with my KISS IP set as a
          local IP on the fldigi host), bpq32 gives me the error:

          "Error - TNC Not Ready". fldigi reports lots and lots of these:

          I: ReadFromHostSocket: count 8 �BUSY:� kiss_rx_exit 0
          I: recvFrom: RecvFrom data �BUSY:� r 8 error no 0
          I: recvFrom: RecvFrom data �BUSY:� count 8 HAP:C0A82744:7343
          SAP:C0A8274A:7342
          I: ReadFromHostSocket: count 8 �BUSY:� kiss_rx_exit 0

          bpq32 claims to be "G8BPQ AX25 Packet Switch System Version 6.0.6.1
          April 2014". fldigi version is Fldigi 3.21.79.Kiss02

          Are these still the latest versions ? Can anyone see what I may have
          missed ?

          (and for completness yes, with the KISS IP set as the bpqhost I get
          the same error...)

          73s

          Iain


        • John Wiseman
          Ian, May be a typo in your message, but in the FLDIGI setup output port should by 7343. I m pretty sure you need a later FLDIGI to run it on a separate
          Message 4 of 9 , Apr 11, 2014
          • 0 Attachment

            Ian,

            May be a typo in your message, but in the FLDIGI setup output port should by 7343.

            I'm pretty sure you  need a later FLDIGI to run it on a separate machine.

            I assume you'r running the Linux X86 version, so try

            https://dl.dropboxusercontent.com/u/31910649/fldigi-kiss-x86

            I'm away from home at the mmoment so can't check.

            73,

            John

             


            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Iain Young, G7III
            Sent: 11 April 2014 08:56
            To: BPQ32@yahoogroups.com
            Subject: [BPQ32] FLdigi and BPQ32 - TNC Not Ready Error

             

             

            Hi Folks,

            I am experimenting with the latest Betas of BPQ32 and FL-Digi.

            Despite never having setup BPQ32 before, I got that running with
            a telnet and bpqether interface quite easily, so proceeded to
            add the FLdigi interface.

            Due to the fact that my SDR machine is running 64 bit , and I wanted
            to run bpq32 on a spare Pi I had hanging around, I am running them
            on separate machines.

            FL-Digi host is 192.168.39.74 BPQ-Pi-Host is 192.168.39.68

            I have the following in bpq32.cfg for the FLdigi modem:

            PORT
            ID=FLDigi
            DRIVER=fldigi
            PACLEN=64
            CONFIG
            ADDR 192.168.39.74 7342
            TIMEOUT=10
            RETRIES=5
            DEFAULTMODEM BPSK250/1200
            UPDATEMAP
            ENDPORT

            FLDigi's IO configuration contains:

            Enable KISS selected. Enable ARQ, AX25 Decode, Enable CSMA all
            unselected

            KISS IP is defined as 192.168.39.74, I/O port is 7342, O is 7434.
            Dual port is selected.

            ARQ IP is set at 192.168.39.74, port 7322 for future experimentation

            BTW, is
            http://www.cantab.net/users/john.wiseman/Documents/FLDigiDriver.html
            correct ? It says '" Dual Port " must be checked.
            Normally "Enable CSMA" and "Enable Busy Channel" should be unchecked.
            as BPQ handles Buay detect. If you want to run FLDIGI and BPQ on
            different machines, specify the IP address of the BPQ machine instead
            of 127.0.0.1'

            It seems that fldigi tries to listen on this IP Address. If you do set
            the KISS IP to the BPQ Host, it tries to bind() and fails (as it's not
            a local IP of course...)

            Now, when I try to to the "ATTACH" in bpq32 (with my KISS IP set as a
            local IP on the fldigi host), bpq32 gives me the error:

            "Error - TNC Not Ready". fldigi reports lots and lots of these:

            I: ReadFromHostSocket: count 8
            BUSY: kiss_rx_exit 0
            I: recvFrom: RecvFrom data BUSY: r 8 error no 0
            I: recvFrom: RecvFrom data BUSY: count 8 HAP:C0A82744:7343
            SAP:C0A8274A:7342
            I: ReadFromHostSocket: count 8 BUSY: kiss_rx_exit 0

            bpq32 claims to be "G8BPQ AX25 Packet Switch System Version 6.0.6.1
            April 2014". fldigi version is Fldigi 3.21.79.Kiss02

            Are these still the latest versions ? Can anyone see what I may have
            missed ?

            (and for completness yes, with the KISS IP set as the bpqhost I get
            the same error...)

            73s

            Iain

          • Robert Stiles
            John, He is running an older version of FLDIGI beta which didn t support the BUSY: command. Robert ________________________________ From: John Wiseman
            Message 5 of 9 , Apr 11, 2014
            • 0 Attachment
              John, He is running an older version of FLDIGI beta which didn't support the BUSY: command.
              Robert


              From: John Wiseman <john.wiseman@...>
              To: BPQ32@yahoogroups.com
              Sent: Friday, April 11, 2014 11:11 AM
              Subject: RE: [BPQ32] FLdigi and BPQ32 - TNC Not Ready Error

               
              Ian,
              May be a typo in your message, but in the FLDIGI setup output port should by 7343.
              I'm pretty sure you  need a later FLDIGI to run it on a separate machine.
              I assume you'r running the Linux X86 version, so try
              https://dl.dropboxusercontent.com/u/31910649/fldigi-kiss-x86
              I'm away from home at the mmoment so can't check.
              73,
              John
               

              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Iain Young, G7III
              Sent: 11 April 2014 08:56
              To: BPQ32@yahoogroups.com
              Subject: [BPQ32] FLdigi and BPQ32 - TNC Not Ready Error
               
               
              Hi Folks,

              I am experimenting with the latest Betas of BPQ32 and FL-Digi.

              Despite never having setup BPQ32 before, I got that running with
              a telnet and bpqether interface quite easily, so proceeded to
              add the FLdigi interface.

              Due to the fact that my SDR machine is running 64 bit , and I wanted
              to run bpq32 on a spare Pi I had hanging around, I am running them
              on separate machines.

              FL-Digi host is 192.168.39.74 BPQ-Pi-Host is 192.168.39.68

              I have the following in bpq32.cfg for the FLdigi modem:

              PORT
              ID=FLDigi
              DRIVER=fldigi
              PACLEN=64
              CONFIG
              ADDR 192.168.39.74 7342
              TIMEOUT=10
              RETRIES=5
              DEFAULTMODEM BPSK250/1200
              UPDATEMAP
              ENDPORT

              FLDigi's IO configuration contains:

              Enable KISS selected. Enable ARQ, AX25 Decode, Enable CSMA all
              unselected

              KISS IP is defined as 192.168.39.74, I/O port is 7342, O is 7434.
              Dual port is selected.

              ARQ IP is set at 192.168.39.74, port 7322 for future experimentation

              BTW, is
              http://www.cantab.net/users/john.wiseman/Documents/FLDigiDriver.html
              correct ? It says '" Dual Port " must be checked.
              Normally "Enable CSMA" and "Enable Busy Channel" should be unchecked.
              as BPQ handles Buay detect. If you want to run FLDIGI and BPQ on
              different machines, specify the IP address of the BPQ machine instead
              of 127.0.0.1'

              It seems that fldigi tries to listen on this IP Address. If you do set
              the KISS IP to the BPQ Host, it tries to bind() and fails (as it's not
              a local IP of course...)

              Now, when I try to to the "ATTACH" in bpq32 (with my KISS IP set as a
              local IP on the fldigi host), bpq32 gives me the error:

              "Error - TNC Not Ready". fldigi reports lots and lots of these:

              I: ReadFromHostSocket: count 8
              BUSY: kiss_rx_exit 0
              I: recvFrom: RecvFrom data BUSY: r 8 error no 0
              I: recvFrom: RecvFrom data BUSY: count 8 HAP:C0A82744:7343
              SAP:C0A8274A:7342
              I: ReadFromHostSocket: count 8 BUSY: kiss_rx_exit 0

              bpq32 claims to be "G8BPQ AX25 Packet Switch System Version 6.0.6.1
              April 2014". fldigi version is Fldigi 3.21.79.Kiss02

              Are these still the latest versions ? Can anyone see what I may have
              missed ?

              (and for completness yes, with the KISS IP set as the bpqhost I get
              the same error...)

              73s

              Iain


            • Dave Webb
              ... How would I configure this? Can this be done with 2 windows machines? I think that would cure the CPU overload problem I am having. 73 Dave WB2HVF/AFC2MC
              Message 6 of 9 , Apr 11, 2014
              • 0 Attachment

                On 4/11/2014 12:11 PM, John Wiseman wrote:

                I'm pretty sure you  need a later FLDIGI to run it on a separate machine.

                How would I configure this?
                Can this be done with 2 windows machines? I think that would cure the CPU overload problem I am having.
                73
                Dave
                WB2HVF/AFC2MC



                This email is free from viruses and malware because avast! Antivirus protection is active.


              • John Wiseman
                Dave, Yes, you can have BPQ and FLDIGI on separate Windows Machines. Replace the 127.0.0.1 in both configs with the address of the other box, The latest
                Message 7 of 9 , Apr 12, 2014
                • 0 Attachment

                  Dave,

                  Yes, you can have BPQ and FLDIGI on separate Windows Machines. Replace the 127.0.0.1 in both configs with the address of the other box, The latest Windows version of FLDIGI can be downloaded from

                  https://dl.dropboxusercontent.com/u/31910649/Fldigi-3.21.81AA-KISS06-Win32.zip

                  73, John

                   


                  From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of Dave Webb
                  Sent: 11 April 2014 23:25
                  To: BPQ32@yahoogroups.com
                  Subject: Re: [BPQ32] FLdigi and BPQ32 - TNC Not Ready Error

                   

                   

                   

                  On 4/11/2014 12:11 PM, John Wiseman wrote:

                  I'm pretty sure you  need a later FLDIGI to run it on a separate machine.

                  How would I configure this?
                  Can this be done with 2 windows machines? I think that would cure the CPU overload problem I am having.
                  73
                  Dave
                  WB2HVF/AFC2MC


                  This email is free from viruses and malware because avast! Antivirus protection is active.

                   

                • Iain Young, G7III
                  Thanks John and Robert, indeed, running the later fldigi makes things work. I even have the IP gateway working with it (well it transmits, I am waiting for the
                  Message 8 of 9 , Apr 12, 2014
                  • 0 Attachment
                    Thanks John and Robert, indeed, running the later fldigi makes things
                    work. I even have the IP gateway working with it (well it transmits,
                    I am waiting for the other station to come on air to complete the
                    tests!, then next up, it's layer DTN (Disruptive|Delay Tolerant
                    Networking) over the top of that...:)


                    Thanks again both, 73s

                    Iain

                    On 11/04/14 17:11, John Wiseman wrote:
                    > Ian,
                    >
                    > May be a typo in your message, but in the FLDIGI setup output port
                    > should by 7343.
                    >
                    > I'm pretty sure you need a later FLDIGI to run it on a separate machine.
                    >
                    > I assume you'r running the Linux X86 version, so try
                    >
                    > https://dl.dropboxusercontent.com/u/31910649/fldigi-kiss-x86
                    >
                    > I'm away from home at the mmoment so can't check.
                    >
                    > 73,
                    >
                    > John
                    >
                    > ------------------------------------------------------------------------
                    >
                    > *From:*BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] *On Behalf
                    > Of *Iain Young, G7III
                    > *Sent:* 11 April 2014 08:56
                    > *To:* BPQ32@yahoogroups.com
                    > *Subject:* [BPQ32] FLdigi and BPQ32 - TNC Not Ready Error
                    >
                    > Hi Folks,
                    >
                    > I am experimenting with the latest Betas of BPQ32 and FL-Digi.
                    >
                    > Despite never having setup BPQ32 before, I got that running with
                    > a telnet and bpqether interface quite easily, so proceeded to
                    > add the FLdigi interface.
                    >
                    > Due to the fact that my SDR machine is running 64 bit , and I wanted
                    > to run bpq32 on a spare Pi I had hanging around, I am running them
                    > on separate machines.
                    >
                    > FL-Digi host is 192.168.39.74 BPQ-Pi-Host is 192.168.39.68
                    >
                    > I have the following in bpq32.cfg for the FLdigi modem:
                    >
                    > PORT
                    > ID=FLDigi
                    > DRIVER=fldigi
                    > PACLEN=64
                    > CONFIG
                    > ADDR 192.168.39.74 7342
                    > TIMEOUT=10
                    > RETRIES=5
                    > DEFAULTMODEM BPSK250/1200
                    > UPDATEMAP
                    > ENDPORT
                    >
                    > FLDigi's IO configuration contains:
                    >
                    > Enable KISS selected. Enable ARQ, AX25 Decode, Enable CSMA all
                    > unselected
                    >
                    > KISS IP is defined as 192.168.39.74, I/O port is 7342, O is 7434.
                    > Dual port is selected.
                    >
                    > ARQ IP is set at 192.168.39.74, port 7322 for future experimentation
                    >
                    > BTW, is
                    > http://www.cantab.net/users/john.wiseman/Documents/FLDigiDriver.html
                    > correct ? It says '"Dual Port" must be checked.
                    > Normally "Enable CSMA" and "Enable Busy Channel" should be unchecked.
                    > as BPQ handles Buay detect. If you want to run FLDIGI and BPQ on
                    > different machines, specify the IP address of the BPQ machine instead
                    > of 127.0.0.1'
                    >
                    > It seems that fldigi tries to listen on this IP Address. If you do set
                    > the KISS IP to the BPQ Host, it tries to bind() and fails (as it's not
                    > a local IP of course...)
                    >
                    > Now, when I try to to the "ATTACH" in bpq32 (with my KISS IP set as a
                    > local IP on the fldigi host), bpq32 gives me the error:
                    >
                    > "Error - TNC Not Ready". fldigi reports lots and lots of these:
                    >
                    > I: ReadFromHostSocket: count 8 �BUSY:� kiss_rx_exit 0
                    > I: recvFrom: RecvFrom data �BUSY:� r 8 error no 0
                    > I: recvFrom: RecvFrom data �BUSY:� count 8 HAP:C0A82744:7343
                    > SAP:C0A8274A:7342
                    > I: ReadFromHostSocket: count 8 �BUSY:� kiss_rx_exit 0
                    >
                    > bpq32 claims to be "G8BPQ AX25 Packet Switch System Version 6.0.6.1
                    > April 2014". fldigi version is Fldigi 3.21.79.Kiss02
                    >
                    > Are these still the latest versions ? Can anyone see what I may have
                    > missed ?
                    >
                    > (and for completness yes, with the KISS IP set as the bpqhost I get
                    > the same error...)
                    >
                    > 73s
                    >
                    > Iain
                    >
                    >
                  • Dave Webb
                    John, Robert Robert, Thanks for the detailed config setup. John, I downloaded from that dropbox and installed it on the xp laptop. The setup worked but I still
                    Message 9 of 9 , Apr 12, 2014
                    • 0 Attachment
                      John, Robert
                      Robert, Thanks for the detailed config setup.
                      John, I downloaded from that dropbox and installed it on the xp laptop. The setup worked but I still get that degrading of the Winmor transmissions after a connect. After disabling the FLDIGI port again, the trouble went away. So, even with FLDIGI on a different computer, something is going on with Winmor.
                      Do you think if I disable another port, such as the AXIP, and see if FLDIGI degrades Winmor then would be a valid test?
                      73
                      Dave


                      On 4/12/2014 3:04 AM, John Wiseman wrote:
                       

                      Dave,

                      Yes, you can have BPQ and FLDIGI on separate Windows Machines. Replace the 127.0.0.1 in both configs with the address of the other box, The latest Windows version of FLDIGI can be downloaded from

                      https://dl.dropboxusercontent.com/u/31910649/Fldigi-3.21.81AA-KISS06-Win32.zip

                      73, John

                       


                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com ] On Behalf Of Dave Webb
                      Sent: 11 April 2014 23:25
                      To: BPQ32@yahoogroups.com
                      Subject: Re: [BPQ32] FLdigi and BPQ32 - TNC Not Ready Error

                       

                       

                       

                      On 4/11/2014 12:11 PM, John Wiseman wrote:

                      I'm pretty sure you  need a later FLDIGI to run it on a separate machine.

                      How would I configure this?
                      Can this be done with 2 windows machines? I think that would cure the CPU overload problem I am having.
                      73
                      Dave
                      WB2HVF/AFC2MC


                      This email is free from viruses and malware because avast! Antivirus protection is active.

                       





                    This email is free from viruses and malware because avast! Antivirus protection is active.


                    Your message has been successfully submitted and would be delivered to recipients shortly.