Loading ...
Sorry, an error occurred while loading the content.
 

RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

Expand Messages
  • Richard
    Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem . John, I reported this some time ago on LinBPQ which was never resolved but since
    Message 1 of 12 , Jan 16, 2014

      Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

       

      John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

       

      I haven’t done any changes whatsoever to any config files for probably a month or so …

      I’m now going back to RPiBPQ_6.0.4.68 …

       

      73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

       

    • Richard
      John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20
      Message 2 of 12 , Jan 16, 2014

        John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

         

        I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

         

        Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

        Jan 16 22:42:28 rpibpq kernel: [ 5795.797563] mkiss: ax0: Trying crc-smack

        Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

         

        Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

        Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

        Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

         

        Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

        Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

        Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

         

        As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using single, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

         

        Any ideas ???

         

        73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

         

        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

         

        From: Richard [mailto:yahoolist@...]
        Sent: 16 January 2014 20:28
        To: 'BPQ32@yahoogroups.com'
        Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

         

        Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

         

        John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

         

        I haven’t done any changes whatsoever to any config files for probably a month or so …

        I’m now going back to RPiBPQ_6.0.4.68 …

         

        73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

         

      • Richard
        OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this
        Message 3 of 12 , Jan 16, 2014

          OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

           

          I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

           

            kissattach com10 bpq 192.168.0.88

            # Set 'crc' mode to 'none' (-c 1).

            kissparms -c 1 -p bpq

           

          Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

           

          I’m a happy little chappy – again !!!!!!!! - *Grin ……..

          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

           

          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
          Sent: 16 January 2014 23:34
          To: BPQ32@yahoogroups.com
          Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

           

           

          John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

           

          I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

           

          Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

          Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

          Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

           

          Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

          Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

          Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

           

          Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

          Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

          Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

           

          As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

           

          Any ideas ???

           

          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

           

          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

           

          From: Ric hard [mailto:yahoolist@...]
          Sent: 16 January 2014 20:28
          To: 'BPQ32@yahoogroups.com'
          Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

           

          Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

           

          John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

           

          I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

          I’m now going back to RPiBPQ_6.0.4.68 …

           

          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

           

        • Richard
          Now I’m not happy - *Grrrrr …………… I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making
          Message 4 of 12 , Jan 16, 2014

            Now I’m not happy - *Grrrrr ……………

             

            I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

             

            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
            Sent: 17 January 2014 00:37
            To: BPQ32@yahoogroups.com
            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

             

             

            OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

             

            I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

             

              kissattach com10 bpq 192.168.0.88

              # Set 'crc' mode to 'none' (-c 1).

              kissparms -c 1 -p bpq

             

            Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

             

            I’m a happy little chappy – again !!!!!!!! - *Grin ……..

            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

             

            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
            Sent: 16 January 2014 23:34
            To: BPQ32@yahoogroups.com
            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

             

             

            John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

             

            I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

             

            Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

            Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

            Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

             

            Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

            Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

            Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

             

            Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

            Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

            Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

             

            As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

             

            Any ideas ???

             

            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

             

            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

             

            From: Ric hard [mailto:yahoolist@...]
            Sent: 16 January 2014 20:28
            To: 'BPQ32@yahoogroups.com'
            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

             

            Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

             

            John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

             

            I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

            I’m now going back to RPiBPQ_6.0.4.68 …

             

            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

             

          • Clayton Brantley
            Richard:  I know how you feel!  I went back to serial mode since I only have one port here. Runs good.  Never could tame the KISS with Pi and BPQ. Clayton
            Message 5 of 12 , Jan 16, 2014
              Richard:  I know how you feel!  I went back to serial mode since I only have one port here.
              Runs good.  Never could tame the KISS with Pi and BPQ.

              Clayton N4EV



              On Thursday, January 16, 2014 7:09 PM, Richard <yahoolist@...> wrote:
               
              Now I’m not happy - *Grrrrr ……………
               
              I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….
               
              73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB
              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
              Sent: 17 January 2014 00:37
              To: BPQ32@yahoogroups.com
              Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!
               
               
              OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …
               
              I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :
               
                kissattach com10 bpq 192.168.0.88
                # Set 'crc' mode to 'none' (-c 1).
                kissparms -c 1 -p bpq
               
              Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..
               
              I’m a happy little chappy – again !!!!!!!! - *Grin ……..
              73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB
              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
               
              From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
              Sent: 16 January 2014 23:34
              To: BPQ32@yahoogroups.com
              Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!
               
               
              John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!
               
              I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..
               
              Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.
              Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack
              Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet
               
              Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.
              Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack
              Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet
               
              Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.
              Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack
              Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet
               
              As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …
               
              Any ideas ???
               
              73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB
               
              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
               
              From: Ric hard [mailto:yahoolist@...]
              Sent: 16 January 2014 20:28
              To: 'BPQ32@yahoogroups.com'
              Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!
               
              Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …
               
              John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …
               
              I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …
              I’m now going back to RPiBPQ_6.0.4.68 …
               
              73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB
               


            • Richard
              Clayton, I had the same symptoms when I ran LinBPQ !!!! … So it’s not RPi that’s the cause of this darn problem … Its exactly every 20 minutes that BPQ
              Message 6 of 12 , Jan 16, 2014

                Clayton, I had the same symptoms when I ran LinBPQ !!!! … So it’s not RPi that’s the cause of this darn problem …

                 

                Its exactly every 20 minutes that BPQ reboots (not the computer, just BPQ) – on ‘02’, ‘22’ and ‘42’ minutes from the hour, every $^^#@#% hour - *Smile …

                 

                BPQ dies for some reason and I have searched everywhere to see what could cause this, but to no avail  - *Sigh …

                 

                I thought that by writing about it someone may say “Ahhhh – I know what the problem is ….”

                 

                73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                 

                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                 

                From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Clayton Brantley
                Sent: 17 January 2014 03:27
                To: BPQ32@yahoogroups.com
                Subject: Re: [BPQ32] Latest version RPiBPQ reboots constantly !!

                 

                 

                Richard:  I know how you feel!  I went back to serial mode since I only have one port here.
                Runs good.  Never could tame the KISS with Pi and BPQ.

                Clayton N4EV

                 

                 

                On Thursday, January 16, 2014 7:09 PM, Richard <yahoolist@...> wrote:

                 

                Now I’m not happy - *Grrrrr ……………

                 

                I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

                 

                73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                Sent: 17 January 2014 00:37
                To: BPQ32@yahoogroups.com
                Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                 

                 

                OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

                 

                I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

                 

                  kissattach com10 bpq 192.168.0.88

                  # Set 'crc' mode to 'none' (-c 1).

                  kissparms -c 1 -p bpq

                 

                Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

                 

                I’m a happy little chappy – again !!!!!!!! - *Grin ……..

                73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                 

                From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                Sent: 16 January 2014 23:34
                To: BPQ32@yahoogroups.com
                Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                 

                 

                John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

                 

                I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

                 

                Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

                Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

                Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

                 

                Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

                Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

                Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

                 

                Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

                Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

                Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

                 

                As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

                 

                Any ideas ???

                 

                73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                 

                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                 

                From: Ric hard [mailto:yahoolist@...]
                Sent: 16 January 2014 20:28
                To: 'BPQ32@yahoogroups.com'
                Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                 

                Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

                 

                John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

                 

                I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

                I’m now going back to RPiBPQ_6.0.4.68 …

                 

                73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                 

                 

              • Jerry
                Look in syslog and see if you can see the error… 73 jerry From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard Sent: Thursday,
                Message 7 of 12 , Jan 16, 2014

                  Look in syslog and see if you can see the error…

                  73 jerry

                   

                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                  Sent: Thursday, January 16, 2014 8:52 PM
                  To: BPQ32@yahoogroups.com
                  Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                   

                   

                  Clayton, I had the same symptoms when I ran LinBPQ !!!! … So it’s not RPi that’s the cause of this darn problem …

                   

                  Its exactly every 20 minutes that BPQ reboots (not the computer, just BPQ) – on ‘02’, ‘22’ and ‘42’ minutes from the hour, every $^^#@#% hour - *Smile …

                   

                  BPQ dies for some reason and I have searched everywhere to see what could cause this, but to no avail  - *Sigh …

                   

                  I thought that by writing about it someone may say “Ahhhh – I know what the problem is ….”

                   

                  73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                   

                  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                   

                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Clayton Brantley
                  Sent: 17 January 2014 03:27
                  To: BPQ32@yahoogroups.com
                  Subject: Re: [BPQ32] Latest version RPiBPQ reboots constantly !!

                   

                   

                  Richard:  I know how you feel!  I went back to serial mode since I only have one port here.
                  Runs good.  Never could tame the KISS with Pi and BPQ.

                  Clayton N4EV

                   

                   

                  On Thursday, January 16, 2014 7:09 PM, Richard <yahoolist@...> wrote:

                   

                  Now I’m not happy - *Grrrrr ……………

                   

                  I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

                   

                  73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                  Sent: 17 January 2014 00:37
                  To: BPQ32@yahoogroups.com
                  Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                   

                   

                  OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

                   

                  I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

                   

                    kissattach com10 bpq 192.168.0.88

                    # Set 'crc' mode to 'none' (-c 1).

                    kissparms -c 1 -p bpq

                   

                  Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

                   

                  I’m a happy little chappy – again !!!!!!!! - *Grin ……..

                  73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                   

                  From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                  Sent: 16 January 2014 23:34
                  To: BPQ32@yahoogroups.com
                  Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                   

                   

                  John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

                   

                  I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

                   

                  Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

                  Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

                  Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

                   

                  Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

                  Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

                  Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

                   

                  Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

                  Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

                  Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

                   

                  As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

                   

                  Any ideas ???

                   

                  73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                   

                  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                   

                  From: Ric hard [mailto:yahoolist@...]
                  Sent: 16 January 2014 20:28
                  To: 'BPQ32@yahoogroups.com'
                  Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                   

                  Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

                   

                  John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

                   

                  I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

                  I’m now going back to RPiBPQ_6.0.4.68 …

                   

                  73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                   

                   

                • Richard
                  I think I have found the problem this time ….. I just checked the TCP log and see that at exactly the time intervals BPQ dies my BPQ ISP Interface tries to
                  Message 8 of 12 , Jan 16, 2014

                    I think I have found the problem this time …..

                     

                    I just checked the TCP log and see that at exactly the time intervals BPQ dies my BPQ ISP Interface tries to connect to my email server …

                     

                    I disabled it and 30 minutes has come and gone and RPiBPQ is still running … I feel confident that this is where the problem is … Something is not quite right with my ISP interface configuration and this is causing BPQ to crash …

                     

                    At least I think I have a handle on the darn problem now ….. Maybe I can even go to bed now – its 04:12 Friday morning ……..

                     

                    73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                    From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                    Sent: 17 January 2014 03:52
                    To: BPQ32@yahoogroups.com
                    Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                     

                     

                    Clayton, I had the same symptoms when I ran LinBPQ !!!! … So it’s not RPi that’s the cause of this darn problem …

                     

                    Its exactly every 20 minutes that BPQ reboots (not the computer, just BPQ) – on ‘02’, ‘22’ and ‘42’ minutes from the hour, every $^^#@#% hour - *Smile …

                     

                    BPQ dies for some reason and I have searched everywhere to see what could cause this, but to no avail  - *Sigh …

                     

                    I thought that by writing about it someone may say “Ahhhh – I know what the problem is ….”

                     

                    73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                     

                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                     

                    From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Clayton Brantley
                    Sent: 17 January 2014 03:27
                    To: BPQ32@yahoogroups.com
                    Subject: Re: [BPQ32] Latest version RPiBPQ reboots constantly !!

                     

                     

                    Richard:  I know how you feel!  I went back to serial mode since I only have one port here.
                    Runs good.  Never could tame the KISS with Pi and BPQ.

                    Clayton N4EV

                     

                     

                    On Thursday, January 16, 2014 7:09 PM, Richard <yahoolist@...> wrote:

                     

                    Now I’m not happy - *Grrrrr ……………

                     

                    I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

                     

                    73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                    From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                    Sent: 17 January 2014 00:37
                    To: BPQ32@yahoogroups.com
                    Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                     

                     

                    OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

                     

                    I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

                     

                      kissattach com10 bpq 192.168.0.88

                      # Set 'crc' mode to 'none' (-c 1).

                      kissparms -c 1 -p bpq

                     

                    Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

                     

                    I’m a happy little chappy – again !!!!!!!! - *Grin ……..

                    73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                     

                    From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                    Sent: 16 January 2014 23:34
                    To: BPQ32@yahoogroups.com
                    Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                     

                     

                    John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

                     

                    I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

                     

                    Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

                    Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

                    Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

                     

                    Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

                    Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

                    Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

                     

                    Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

                    Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

                    Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

                     

                    As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

                     

                    Any ideas ???

                     

                    73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                     

                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                     

                    From: Ric hard [mailto:yahoolist@...]
                    Sent: 16 January 2014 20:28
                    To: 'BPQ32@yahoogroups.com'
                    Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                     

                    Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

                     

                    John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

                     

                    I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

                    I’m now going back to RPiBPQ_6.0.4.68 …

                     

                    73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                     

                     

                  • Richard
                    Jerry – its fixed now – at last … I looked in all the logs and one time I thought I had it – but naturally Murphy was hanging around … And after that
                    Message 9 of 12 , Jan 16, 2014

                      Jerry – its fixed now – at last …

                       

                      I looked in all the logs and one time I thought I had it – but naturally Murphy was hanging around … And after that ‘fix’ the logs showed nothing of interest …

                       

                      73, Dick

                       

                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                       

                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Jerry
                      Sent: 17 January 2014 04:00
                      To: BPQ32@yahoogroups.com
                      Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                       

                       

                      Look in syslog and see if you can see the error…

                      73 jerry

                       

                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                      Sent: Thursday, January 16, 2014 8:52 PM
                      To: BPQ32@yahoogroups.com
                      Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                       

                       

                      Clayton, I had the same symptoms when I ran LinBPQ !!!! … So it’s not RPi that’s the cause of this darn problem …

                       

                      Its exactly every 20 minutes that BPQ reboots (not the computer, just BPQ) – on ‘02’, ‘22’ and ‘42’ minutes from the hour, every $^^#@#% hour - *Smile …

                       

                      BPQ dies for some reason and I have searched everywhere to see what could cause this, but to no avail  - *Sigh …

                       

                      I thought that by writing about it someone may say “Ahhhh – I know what the problem is ….”

                       

                      73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                       

                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                       

                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Clayton Brantley
                      Sent: 17 January 2014 03:27
                      To: BPQ32@yahoogroups.com
                      Subject: Re: [BPQ32] Latest version RPiBPQ reboots constantly !!

                       

                       

                      Richard:  I know how you feel!  I went back to serial mode since I only have one port here.
                      Runs good.  Never could tame the KISS with Pi and BPQ.

                      Clayton N4EV

                       

                       

                      On Thursday, January 16, 2014 7:09 PM, Richard <yahoolist@...> wrote:

                       

                      Now I’m not happy - *Grrrrr ……………

                       

                      I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

                       

                      73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                      Sent: 17 January 2014 00:37
                      To: BPQ32@yahoogroups.com
                      Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                       

                       

                      OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

                       

                      I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

                       

                        kissattach com10 bpq 192.168.0.88

                        # Set 'crc' mode to 'none' (-c 1).

                        kissparms -c 1 -p bpq

                       

                      Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

                       

                      I’m a happy little chappy – again !!!!!!!! - *Grin ……..

                      73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                       

                      From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                      Sent: 16 January 2014 23:34
                      To: BPQ32@yahoogroups.com
                      Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                       

                       

                      John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

                       

                      I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

                       

                      Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

                      Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

                      Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

                       

                      Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

                      Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

                      Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

                       

                      Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

                      Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

                      Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

                       

                      As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

                       

                      Any ideas ???

                       

                      73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                       

                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                       

                      From: Ric hard [mailto:yahoolist@...]
                      Sent: 16 January 2014 20:28
                      To: 'BPQ32@yahoogroups.com'
                      Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                       

                      Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

                       

                      John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

                       

                      I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

                      I’m now going back to RPiBPQ_6.0.4.68 …

                       

                      73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                       

                       

                    • Andrea-IV3ONZ
                      Linbpq seems to reboot if you have a bad configuration. Try to check your bpq.cfg file. There is an event (perhaps a beacon, every 20 minutes) that is not good
                      Message 10 of 12 , Jan 16, 2014

                        Linbpq seems to reboot if you have a bad configuration. Try to check your bpq.cfg file. There is an event (perhaps a beacon, every 20 minutes) that is not good for bpq.
                        I had a bad configuration in the mail and, same as you, I had a reboot every mail forward.

                        ----

                        73 de Andrea "Andy" Tognan Iv3onz

                        web: http://www.iv3onz.altervista. org
                        bbs: iv3onz@...
                        Ampr: iv3onz.ampr.org - 44.134.185.34
                        WL2k: iv3onz@...



                        From: Richard <yahoolist@...>;
                        To: <BPQ32@yahoogroups.com>;
                        Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!
                        Sent: Fri, Jan 17, 2014 12:09:12 AM

                         

                        Now I’m not happy - *Grrrrr ……………

                         

                        I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

                         

                        73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                        Sent: 17 January 2014 00:37
                        To: BPQ32@yahoogroups.com
                        Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                         

                         

                        OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

                         

                        I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

                         

                          kissattach com10 bpq 192.168.0.88

                          # Set 'crc' mode to 'none' (-c 1).

                          kissparms -c 1 -p bpq

                         

                        Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

                         

                        I’m a happy little chappy – again !!!!!!!! - *Grin ……..

                        73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                         

                        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                        Sent: 16 January 2014 23:34
                        To: BPQ32@yahoogroups.com
                        Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                         

                         

                        John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

                         

                        I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

                         

                        Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

                        Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

                        Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

                         

                        Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

                        Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

                        Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

                         

                        Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

                        Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

                        Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

                         

                        As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

                         

                        Any ideas ???

                         

                        73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                         

                        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                         

                        From: Ric hard [mailto:yahoolist@...]
                        Sent: 16 January 2014 20:28
                        To: 'BPQ32@yahoogroups.com'
                        Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                         

                        Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

                         

                        John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

                         

                        I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

                        I’m now going back to RPiBPQ_6.0.4.68 …

                         

                        73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                         

                      • John Wiseman
                        Thanks, Richard. At least that gives me somewhere to look! Is there anythingin the TCP log apart from the Connecting to message? 73, John _____ From:
                        Message 11 of 12 , Jan 17, 2014
                          
                          Thanks, Richard.
                           
                          At least that gives me somewhere to look!
                           
                          Is there anythingin the TCP log apart from the "Connecting to" message?
                           
                          73,
                          John
                           


                          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                          Sent: 17 January 2014 02:13
                          To: BPQ32@yahoogroups.com
                          Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                           

                          I think I have found the problem this time …..

                          I just checked the TCP log and see that at exactly the time intervals BPQ dies my BPQ ISP Interface tries to connect to my email server …

                          I disabled it and 30 minutes has come and gone and RPiBPQ is still running … I feel confident that this is where the problem is … Something is not quite right with my ISP interface configuration and this is causing BPQ to crash …

                          At least I think I have a handle on the darn problem now ….. Maybe I can even go to bed now – its 04:12 Friday morning ……..

                          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                          Sent: 17 January 2014 03:52
                          To: BPQ32@yahoogroups.com
                          Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                           

                          Clayton, I had the same symptoms when I ran LinBPQ !!!! … So it’s not RPi that’s the cause of this darn problem …

                          Its exactly every 20 minutes that BPQ reboots (not the computer, just BPQ) – on ‘02’, ‘22’ and ‘42’ minutes from the hour, every $^^#@#% hour - *Smile …

                          BPQ dies for some reason and I have searched everywhere to see what could cause this, but to no avail  - *Sigh …

                          I thought that by writing about it someone may say “Ahhhh – I know what the problem is ….”

                          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Clayton Brantley
                          Sent: 17 January 2014 03:27
                          To: BPQ32@yahoogroups.com
                          Subject: Re: [BPQ32] Latest version RPiBPQ reboots constantly !!

                           

                          Richard:  I know how you feel!  I went back to serial mode since I only have one port here.
                          Runs good.  Never could tame the KISS with Pi and BPQ.

                          Clayton N4EV

                          On Thursday, January 16, 2014 7:09 PM, Richard <yahoolist@...> wrote:

                           

                          Now I’m not happy - *Grrrrr ……………

                          I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

                          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                          Sent: 17 January 2014 00:37
                          To: BPQ32@yahoogroups.com
                          Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                           

                          OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

                          I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

                            kissattach com10 bpq 192.168.0.88

                            # Set 'crc' mode to 'none' (-c 1).

                            kissparms -c 1 -p bpq

                          Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

                          I’m a happy little chappy – again !!!!!!!! - *Grin ……..

                          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                          From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                          Sent: 16 January 2014 23:34
                          To: BPQ32@yahoogroups.com
                          Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                           

                          John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

                          I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

                          Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

                          Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

                          Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

                          Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

                          Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

                          Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

                          Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

                          Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

                          Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

                          As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

                          Any ideas ???

                          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                          From: Ric hard [mailto:yahoolist@...]
                          Sent: 16 January 2014 20:28
                          To: 'BPQ32@yahoogroups.com'
                          Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                          Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

                          John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

                          I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

                          I’m now going back to RPiBPQ_6.0.4.68 …

                          73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                        • Richard
                          John, here is an extract from TCP log at the time of crashes …. 140117 00:02:46 | Connecting to POP3 Server pop.webafrica.org.za 140117 00:02:52
                          Message 12 of 12 , Jan 18, 2014

                            John, here is an extract from TCP log at the time of crashes ….

                             

                            140117 00:02:46 |          Connecting to POP3 Server pop.webafrica.org.za

                            140117 00:02:52 <          +OK POP3 server ready <c32ae2de-cf60-488f-b261-ce3b6c731f77@...>

                            140117 00:02:52 >          USER bbsemail@...

                            140117 00:02:53 <          +OK User:'bbsemail@...' ok

                            140117 00:02:53 >          PASS xxxxxxxx

                            140117 00:02:53 <          +OK Password ok

                            140117 00:02:53 >          STAT

                            140117 00:02:53 <          +OK 0 0

                            140117 00:02:53 >          QUIT

                            140117 00:02:53 <          +OK POP3 server signing off

                            140117 00:22:39 |          Connecting to POP3 Server pop.webafrica.org.za

                            140117 00:22:40 <          +OK POP3 server ready <cb834046-c5c6-4c09-b1c7-94d351275007@...>

                            140117 00:22:40 >          USER bbsemail@...

                            140117 00:22:41 <          +OK User:'bbsemail@...' ok

                            140117 00:22:41 >          PASS xxxxxxxx

                            140117 00:22:41 <          +OK Password ok

                            140117 00:22:41 >          STAT

                            140117 00:22:41 <          +OK 0 0

                            140117 00:22:41 >          QUIT

                            140117 00:22:42 <          +OK POP3 server signing off

                            140117 00:42:37 |          Connecting to POP3 Server pop.webafrica.org.za

                            140117 00:42:38 <          +OK POP3 server ready <1254dc0a-41ed-4872-a250-7970a3196756@...>

                            140117 00:42:38 >          USER bbsemail@...

                            140117 00:42:38 <          +OK User:'bbsemail@...' ok

                            140117 00:42:38 >          PASS xxxxxxxx

                            140117 00:42:38 <          +OK Password ok

                            140117 00:42:38 >          STAT

                            140117 00:42:39 <          +OK 0 0

                            140117 00:42:39 >          QUIT

                            140117 00:42:39 <          +OK POP3 server signing off

                             

                            Since disabling it, RPiBPQ is still running for Uptime (Days Hours Mins)

                            01:10:27

                             

                            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                             

                            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                             

                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of John Wiseman
                            Sent: 17 January 2014 11:34
                            To: BPQ32@yahoogroups.com
                            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                            Thanks, Richard.

                             

                            At least that gives me somewhere to look!

                             

                            Is there anythingin the TCP log apart from the "Connecting to" message?

                             

                            73,

                            John

                             


                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                            Sent: 17 January 2014 02:13
                            To: BPQ32@yahoogroups.com
                            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                            I think I have found the problem this time …..

                            I just checked the TCP log and see that at exactly the time intervals BPQ dies my BPQ ISP Interface tries to connect to my email server …

                            I disabled it and 30 minutes has come and gone and RPiBPQ is still running … I feel confident that this is where the problem is … Something is not quite right with my ISP interface configuration and this is causing BPQ to crash …

                            At least I think I have a handle on the darn problem now ….. Maybe I can even go to bed now – its 04:12 Friday morning ……..

                            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                            Sent: 17 January 2014 03:52
                            To: BPQ32@yahoogroups.com
                            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                             

                            Clayton, I had the same symptoms when I ran LinBPQ !!!! … So it’s not RPi that’s the cause of this darn problem …

                            Its exactly every 20 minutes that BPQ reboots (not the computer, just BPQ) – on ‘02’, ‘22’ and ‘42’ minutes from the hour, every $^^#@#% hour - *Smile …

                            BPQ dies for some reason and I have searched everywhere to see what could cause this, but to no avail  - *Sigh …

                            I thought that by writing about it someone may say “Ahhhh – I know what the problem is ….”

                            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Clayton Brantley
                            Sent: 17 January 2014 03:27
                            To: BPQ32@yahoogroups.com
                            Subject: Re: [BPQ32] Latest version RPiBPQ reboots constantly !!

                             

                            Richard:  I know how you feel!  I went back to serial mode since I only have one port here.
                            Runs good.  Never could tame the KISS with Pi and BPQ.

                            Clayton N4EV

                            On Thursday, January 16, 2014 7:09 PM, Richard <yahoolist@...> wrote:

                             

                            Now I’m not happy - *Grrrrr ……………

                            I thought I had cured this darn 20 minute restart of RPiBPQ but I haven’t - *Sigh … Initially after making kissattach CRC = none, BPQ was running for well over 30 odd minutes but now it’s back to every 20 minutes again … Looking in the logs doesn’t give any clues ….

                            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                            Sent: 17 January 2014 00:37
                            To: BPQ32@yahoogroups.com
                            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                             

                            OK, looks like I have fixed the problem of my RPiBPQ restarting every 20 minutes – to date I now have 32 minutes – longest time ever !!!!! … And this with RPiBPQ version 6.0.5.1 …

                            I added “kissparms -c 1 -p bpq“  which now changes ‘kissattach’ to have ‘crc = none’ (-c 1) instead of default ‘crc = auto’ (-c 0) :

                              kissattach com10 bpq 192.168.0.88

                              # Set 'crc' mode to 'none' (-c 1).

                              kissparms -c 1 -p bpq

                            Because of the kissattach CRC mode being on ‘auto’ this was causing the continuous 20 minute BPQ restart problem ……………..

                            I’m a happy little chappy – again !!!!!!!! - *Grin ……..

                            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
                            Sent: 16 January 2014 23:34
                            To: BPQ32@yahoogroups.com
                            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                             

                            John, I think I have found the reason for this +-20 minute restart of RPiBPQ and LinBPQ .. (I found that an earlier version of RPiBPQ also restarts every 20 minutes !!

                            I looked in /var/log/messages in RPiBPQ and found that the following is repeated almost every 20 minutes..

                            Jan 16 22:42:26 rpibpq kernel: [ 5793.239336] mkiss: ax0: crc mode is auto.

                            Jan 16 22:42:28 rpibpq kernel: [ 57 95.797563] mkiss: ax0: Trying crc-smack

                            Jan 16 22:42:33 rpibpq kernel: [ 5800.267430] mkiss: ax0: Trying crc-flexnet

                            Jan 16 23:02:25 rpibpq kernel: [ 6992.210819] mkiss: ax0: crc mode is auto.

                            Jan 16 23:02:27 rpibpq kernel: [ 6994.679916] mkiss: ax0: Trying crc-smack

                            Jan 16 23:02:32 rpibpq kernel: [ 6999.150996] mkiss: ax0: Trying crc-flexnet

                            Jan 16 23:22:25 rpibpq kernel: [ 8192.556807] mkiss: ax0: crc mode is auto.

                            Jan 16 23:22:28 rpibpq kernel: [ 8195.173615] mkiss: ax0: Trying crc-smack

                            Jan 16 23:22:32 rpibpq kernel: [ 8199.641252] mkiss: ax0: Trying crc-flexnet

                            As far as I recall I haven’t ‘modprobe’ mkiss at all – does BPQ use it ?? … I am using si ngle, not dual TNCs .. I’m only using AX25 to allow DX-Cluster to be opened from BPQ …

                            Any ideas ???

                            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

                            From: Ric hard [mailto:yahoolist@...]
                            Sent: 16 January 2014 20:28
                            To: 'BPQ32@yahoogroups.com'
                            Subject: RE: [BPQ32] Latest version RPiBPQ reboots constantly !!

                            Version 6.0.51 of RPiBPQ lasts for 20 minutes, then restarts ad nausem …

                            John, I reported this some time ago on LinBPQ which was never resolved but since moving over to Raspberry Pi, everything has been fine until this latest version …

                            I haven̵ 7;t done any changes whatsoever to any config files for probably a month or so …

                            I’m now going back to RPiBPQ_6.0.4.68 …

                            73, Dick ZS6RO/ZS1RO/ZS0MEE/M0HMB

                          Your message has been successfully submitted and would be delivered to recipients shortly.