Loading ...
Sorry, an error occurred while loading the content.
 

Mailchat crashing on housekeeping since 1st January - Help!

Expand Messages
  • chris_g0cng
    Firstly a very happy New Year to John and all members of the Group. Looking through the bulletins no one else seems to have experienced my problem as below:
    Message 1 of 6 , Jan 3, 2014

      Firstly a very happy New Year to John and all members of the Group.

      Looking through the bulletins no one else seems to have experienced my problem as below:

      GB7MAX is having a problem! Since the clock rolled over to 2014 on New Years Day, GB7MAX's daily housekeeping is screwing up.  Housekeeping on my system is timed to occur at 3.00am local time ever day.  It first crashed at 3.01am on 1st January with the error message:

      COULD NOT RENAME MESSAGE NO 58115 TO 1      QUITTING

      At that point BPQ locks up, both MailChat and the BPQ32 Node.  The only way out is CTRL-ALT-DEL and then END TASK for BPQMAILCHAT which forcibly ends the process and it may then be restarted.

      All then proceeds fine until the next housekeeping when exactly the same happens!

      If I attempt a manual housekeeping - again the same!

      Looking at the    log_140103_DEBUG.txt  in the MailChat folder for today, its contents is below:

      140103 03:00:01 !          |Enter HouseKeeping
      140103 07:50:43 !          Maint Clock 1388804400 NOW 1388735443 Time to HouseKeeping 68957
      140103 07:50:51 !          Create Reg Backup
      140103 07:50:52 !          Program Starting
      140103 07:50:52 !          BPQMailChat Starting
      140103 07:50:52 !          CreateNamedPipe failed, GLE=120.

      140103 09:34:23 !          Maint Clock 1388804400 NOW 1388741663 Time to HouseKeeping 62737
      140103 09:34:23 !          Program Starting
      140103 09:34:23 !          BPQMailChat Starting
      140103 09:34:23 !          CreateNamedPipe failed, GLE=120.


      Its the same for 1st January when the error first occurred and same for yesterday 2nd January.  It seems as though the  CreateNamedPipe failed, GLE=120.  has something to do with the error, but what or how, I've no idea!


      Looking back at my message listing, my messages only go back to 58151 so 58115 was probably deleted during the last successful housekeeping on 31st December 2013 at 3.00am local.


      This error seems clearly related to the year rollover to 2014 as I've NEVER seen it before.


      HAS ANYONE ELSE EXPERIENCED THIS AND FOUND A SOLUTION??


      I'm running Mailchat Version 1.4.54.1 and BPQ32 Version 6.0.1.6  on the Windows 98 SE Operating System.


      Hoping someone can help!


      Thanks

      Chris G0CNG   Sysop GB7MAX


    • chris_g0cng
      and I should have added that I did a MANUAL housekeeping at 09:34 local time just now.
      Message 2 of 6 , Jan 3, 2014

        and I should have added that I did a MANUAL housekeeping at 09:34 local time just now.

      • chris_g0cng
        and I should also have added that in the Debug File above that 140103 03:00:01 ! |Enter HouseKeeping was when housekeeping this morning crashed and at
        Message 3 of 6 , Jan 3, 2014

          and I should also have added that in the Debug File above that 140103 03:00:01 !          |Enter HouseKeeping was when housekeeping this morning crashed and at 07:50 when I first checked the system and had to END PROCESS to quit the crashed BPQ32/Mailchat and manually restarted the BBS/Node.  On restarting it immediately came up with the error again.  After another END PROCESS and restart it restarted normally.  At 09:34 I did a manual housekeeping.

        • John Wiseman
          Chris, Housekeeping seems ok here on both my Win 7 and Wn98 system. The CreateNamedPipe failure seems to be due to Named Pipes not being available in Win98, so
          Message 4 of 6 , Jan 3, 2014

            Chris,

             

            Housekeeping seems ok here on both my Win 7 and Wn98 system.

             

            The CreateNamedPipe failure seems to be due to Named Pipes not being available in Win98, so will always have been there,. The Named Pipe is used  for the Web Management feature, so I assume this has never worked on 98.

             

            What do you have “Max Message No” set to in the housekeeping config?  If it is around 58000, maybe it is just coincidence it has reached the limit on 1st January.

             

            If it is genuinely trying to renumber messages, it could be that there is already a message file for message 1 in the Mail folder. If so, delete it, and any others below your current minimum message number. The latest code has an option to delete redundant message files, but I don’t think it is in the version you have.

             

            73,

            John


            From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of chris_g0cng@...
            Sent: 03 January 2014 10:00
            To: BPQ32@yahoogroups.com
            Subject: [BPQ32] Mailchat crashing on housekeeping since 1st January - Help!

             

             

            Firstly a very happy New Year to John and all members of the Group.

            Looking through the bulletins no one else seems to have experienced my problem as below:

            GB7MAX is having a problem! Since the clock rolled over to 2014 on New Years Day, GB7MAX's daily housekeeping is screwing up.  Housekeeping on my system is timed to occur at 3.00am local time ever day.  It first crashed at 3.01am on 1st January with the error message:

            COULD NOT RENAME MESSAGE NO 58115 TO 1      QUITTING

            At that point BPQ locks up, both MailChat and the BPQ32 Node.  The only way out is CTRL-ALT-DEL and then END TASK for BPQMAILCHAT which forcibly ends the process and it may then be restarted.

            All then proceeds fine until the next housekeeping when exactly the same happens!

            If I attempt a manual housekeeping - again the same!

            Looking at the    log_140103_DEBUG.txt  in the MailChat fol der for today, its contents is below:

            140103 03:00:01 !          |Enter HouseKeeping
            140103 07:50:43 !          Maint Clock 1388804400 NOW 1388735443 Time to HouseKeeping 68957
            140103 07:50:51 !          Create Reg Backup
            140103 07:50:52 !          Program Starting
            140103 07:50:52 !          BPQMailChat Starting
            140103 07:50:52 !          CreateNamedPipe failed, GLE=120.

            140103 09:34:23 !          Maint Clock 1388804400 NOW 1388741663 Time to HouseKeeping 62737
            140103 09:34:23 !          Program Starting
            140103 09:34:23 !          BPQMailChat St arting
            140103 09:34:23 !          CreateNamedPipe failed, GLE=120.

             

            Its the same for 1st January when the error first occurred and same for yesterday 2nd January.  It seems as though the  CreateNamedPipe failed, GLE=120.  has something to do with the error, but what or how, I've no idea!

             

            Looking back at my message listing, my messages only go back to 58151 so 58115 was probably deleted during the last successful housekeeping on 31st December 2013 at 3.00am local.

             

            This error seems clearly related to the year rollover to 2014 as I've NEVER seen it before.

             

            HAS ANYONE ELSE EXPERIENCED THIS AND FOUND A SOLUTION??

             

            I'm running Mailchat Version 1.4.54.1 and BPQ32 Version 6.0.1.6  on the Windows 98 SE Operating System.

             

            Hoping someone can help!

             

            Thanks

            Chris G0CNG   Sysop GB7MAX

             

          • chris_g0cng
            Hi John and the Group. Problem solved! I d got a few stray messages left in my mail folder with one of them being message 1. Possibly left over from a previous
            Message 5 of 6 , Jan 4, 2014

              Hi John and the Group. Problem solved! I'd got a few stray messages left in my mail folder with one of them being message 1. Possibly left over from a previous unsuccessful housekeeping? Maybe a power outage during a housekeeping at some stage in the past? Deleted these and restarted. All now perfect. This mornings 3am housekeeping  proceeded flawlessly. Tried a manual housekeep this morning and again perfect. 

              Thank you John for your very prompt advice and solution. I must upgrade to the latest version this weekend. Been busy with other things and not got round to doing it. 

              Do I gather that the Web Sysop management features are only available in Windows XP and above?  If so it's a new BBS machine for me as the current one would struggle with Windows XP let alone Windows 7. Or maybe consider going the Raspberry Pi route. 

              Thanks for all your help and hope 2014 is a good one for you. 

              Apologies for the late response - Have had friends staying overnight and only got chance to do the mod on my way to bed last night, test it in this mornings housekeeping and report back the result.  They have not long departed so finally had time to fire up the main computer!

              Chris

            • John Wiseman
              Chris, I m pleased to hear you ve fixed it. I hadn t realised that the web interface doesn t work on Win98 until I saw your error log, but you don t really
              Message 6 of 6 , Jan 4, 2014

                Chris,

                 

                I’m pleased to hear you’ve fixed it.

                 

                I hadn’t realised that the web interface doesn’t work on Win98 until I saw your error log, but you don’t really need it. It was added for the Linux version which doesn’t have a gui, so I thought I might as well include it in the Windows version, but you can manage fine without it.

                 

                73,

                John

                 

                 


                From: BPQ32@yahoogroups.com [mailto: BPQ32@yahoogroups.com ] On Behalf Of chris.g0cng@...
                Sent: 04 January 2014 16:24
                To: BPQ32@yahoogroups.com
                Subject: RE: [BPQ32] Mailchat crashing on housekeeping since 1st January - Help!

                 

                 

                Hi John and the Group. Problem solved! I'd got a few stray messages left in my mail folder with one of them being message 1. Possibly left over from a previous unsuccessful housekeeping? Maybe a power outage during a housekeeping at some stage in the past? Deleted these and restarted. All now perfect. This mornings 3am housekeeping  proceeded flawlessly. Tried a manual housekeep this morning and again perfect. 

                Thank you John for your very prompt advice and solution. I must upgrade to the latest version this weekend. Been busy with other things and not got round to doing it. 

                Do I gather that the Web Sysop management features are only available in Windows XP and above?  If so it's a new BBS machine for me as the current one would struggle with Windows XP let alone Windows 7. Or maybe consider going the Raspberry Pi route. 

                Thanks for all your help and hope 2014 is a good one for you. 

                Apologies for the late response - Have had friends staying overnight and only got chance to do the mod on my way to bed last night, test it in this mornings housekeeping and report back the result.  They have not long departed so finally had time to fire up the main computer!

                Chris

              Your message has been successfully submitted and would be delivered to recipients shortly.