Loading ...
Sorry, an error occurred while loading the content.

04-27-13 RASPBERRY PI SERIAL PORT CONFIGURATION

Expand Messages
  • David Bird
     Anyone, this is a noob question. I am moving my BPQ nodes to Raspberry PI using the console serial port, the one on the I/O header. I am using a serial
    Message 1 of 4 , Apr 27, 2013
    • 0 Attachment
       Anyone, this is a noob question.

      I am moving my BPQ nodes to Raspberry PI using the console serial port, the one on the I/O header. I am using a serial adapter which worked properly to the laptop as the console. I then enabled the KISS drivers in BPQ (I am using a Kantronics KPC-4) and everything appears to load properly.

      However, the KPC-4 does not respond to BPQ commands. The serial adapter has TX/RX LED indicators that show TX activity but no action from the KPC-4.

      I verified that the KPC-4 is in KISS mode by connecting back to the Windows computer running BPQ.

      I am wondering if the RasPI baudrate is being set properly? Are there any mysteries in using the console serial port with BPQ? Is there a RasPI command that will report the status of the serial port? baudrate? etc?

      I will appreciate any feedback as I would like to move BPQ radio control to the RasPI for a testing period since the node is located at a remote site.

      73, Dave
      WA7RYV
    • oh5rm
      Dave, I think you are trying to connect the TNC to the PI serial pins at GPIO. - They are at 3,3V level, so you have to use 3,3V TTL to RS232 adapter. - You
      Message 2 of 4 , Apr 27, 2013
      • 0 Attachment
        Dave,

        I think you are trying to connect the TNC to the PI serial pins at GPIO.
        - They are at 3,3V level, so you have to use 3,3V TTL to RS232 adapter.
        - You have to disable serial port login:

        http://www.hobbytronics.co.uk/raspberry-pi-serial-port

        Hope this helps

        73 Jouko OH5RM


        --- In BPQ32@yahoogroups.com, David Bird <db.mediaint@...> wrote:
        >
        >  Anyone, this is a noob question.
        >
        > I am moving my BPQ nodes to Raspberry PI using the console serial port, the one on the I/O header. I am using a serial adapter which worked properly to the laptop as the console. I then enabled the KISS drivers in BPQ (I am using a Kantronics KPC-4) and everything appears to load properly.
        >
        > However, the KPC-4 does not respond to BPQ commands. The serial adapter has TX/RX LED indicators that show TX activity but no action from the KPC-4.
        >
        > I verified that the KPC-4 is in KISS mode by connecting back to the Windows computer running BPQ.
        >
        > I am wondering if the RasPI baudrate is being set properly? Are there any mysteries in using the console serial port with BPQ? Is there a RasPI command that will report the status of the serial port? baudrate? etc?
        >
        > I will appreciate any feedback as I would like to move BPQ radio control to the RasPI for a testing period since the node is located at a remote site.
        >
        > 73, Dave
        > WA7RYV
        >
      • David Bird
        Junko, Thank you for your reply. I had already completed the steps included in the article. The problem is that the KPC is not responding/receiving the BPQ
        Message 3 of 4 , Apr 28, 2013
        • 0 Attachment
          Junko,

          Thank you for your reply. I had already completed the steps included in the article.

          The problem is that the KPC is not responding/receiving the BPQ data. I believe it may be a configuration problem on either the RasPI or BPQ.

          73, Dave
          WA7RYV


          From: oh5rm <oh5rm@...>
          To: BPQ32@yahoogroups.com
          Sent: Sunday, April 28, 2013 12:59 AM
          Subject: [BPQ32] Re: 04-27-13 RASPBERRY PI SERIAL PORT CONFIGURATION

           


          Dave,

          I think you are trying to connect the TNC to the PI serial pins at GPIO.
          - They are at 3,3V level, so you have to use 3,3V TTL to RS232 adapter.
          - You have to disable serial port login:

          http://www.hobbytronics.co.uk/raspberry-pi-serial-port

          Hope this helps

          73 Jouko OH5RM

          --- In BPQ32@yahoogroups.com, David Bird <db.mediaint@...> wrote:
          >
          >  Anyone, this is a noob question.
          >
          > I am moving my BPQ nodes to Raspberry PI using the console serial port, the one on the I/O header. I am using a serial adapter which worked properly to the laptop as the console. I then enabled the KISS drivers in BPQ (I am using a Kantronics KPC-4) and everything appears to load properly.
          >
          > However, the KPC-4 does not respond to BPQ commands. The serial adapter has TX/RX LED indicators that show TX activity but no action from the KPC-4.
          >
          > I verified that the KPC-4 is in KISS mode by connecting back to the Windows computer running BPQ.
          >
          > I am wondering if the RasPI baudrate is being set properly? Are there any mysteries in using the console serial port with BPQ? Is there a RasPI command that will report the status of the serial port? baudrate? etc?
          >
          > I will appreciate any feedback as I would like to move BPQ radio control to the RasPI for a testing period since the node is located at a remote site.
          >
          > 73, Dave
          > WA7RYV
          >



        • John Wiseman
          Dave, First make sure there isn t a getty attached to /dev/ttyAMA0 - ps ax | grep getty Try a bit of elimination. Loop the serial port (either on the pi
          Message 4 of 4 , Apr 28, 2013
          • 0 Attachment
            Dave,
             
            First make sure there isn't a getty attached to /dev/ttyAMA0 - ps ax | grep getty
             
            Try a bit of elimination. Loop the serial port (either on the pi connector or the converter output).
             
            See if BPQ receives it's own packets. If so, the serial port and BPQ are OK. Check that the BPQ port speed matches the KPC speed..
             
            If not, try a terminal program instead of BPQ (I use putty, but there are others). set to /dev/ttyAMA0, and see if you receive what is typed. If so, the serial port is ok, and you can check the BPQ config.
             
            You can also connect a terminal program with the KPC attached. You should see data as packets are received, though the headers will look odd as they are KISS format.
             
            73, John
             
             


            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of David Bird
            Sent: 28 April 2013 16:01
            To: BPQ32@yahoogroups.com
            Subject: Re: [BPQ32] Re: 04-27-13 RASPBERRY PI SERIAL PORT CONFIGURATION

             

            Junko,

            Thank you for your reply. I had already completed the steps included in the article.

            The problem is that the KPC is not responding/receiving the BPQ data. I believe it may be a configuration problem on either the RasPI or BPQ.

            73, Dave
            WA7RYV


            From: oh5rm <oh5rm@...>
            To: BPQ32@yahoogroups.com
            Sent: Sunday, April 28, 2013 12:59 AM
            Subject: [BPQ32] Re: 04-27-13 RASPBERRY PI SERIAL PORT CONFIGURATION

             


            Dave,

            I think you are trying to connect the TNC to the PI serial pins at GPIO.
            - They are at 3,3V level, so you have to use 3,3V TTL to RS232 adapter.
            - You have to disable serial port login:

            http://www.hobbytronics.co.uk/raspberry-pi-serial-port

            Hope this helps

            73 Jouko OH5RM

            --- In BPQ32@yahoogroups.com, David Bird <db.mediaint@...> wrote:
            >
            >  Anyone, this is a noob
            question.
            >
            > I am moving my BPQ nodes to Raspberry PI using the
            console serial port, the one on the I/O header. I am using a serial adapter which worked properly to the laptop as the console. I then enabled the KISS drivers in BPQ (I am using a Kantronics KPC-4) and everything appears to load properly.
            >
            > However, the KPC-4 does not respond to BPQ commands.
            The serial adapter has TX/RX LED indicators that show TX activity but no action from the KPC-4.
            >
            > I verified that the KPC-4 is in KISS mode by
            connecting back to the Windows computer running BPQ.
            >
            > I am
            wondering if the RasPI baudrate is being set properly? Are there any mysteries in using the console serial port with BPQ? Is there a RasPI command that will report the status of the serial port? baudrate? etc?
            >
            > I will
            appreciate any feedback as I would like to move BPQ radio control to the RasPI for a testing period since the node is located at a remote site.
            >
            > 73, Dave
            >
            WA7RYV
            >



          Your message has been successfully submitted and would be delivered to recipients shortly.