Loading ...
Sorry, an error occurred while loading the content.

[LinBPQ] Re: Start up errors..

Expand Messages
  • Richard
    John, like Ken of GB7COW, I get the same errors when starting up LinBPQ as he does … This morning, I rebooted my Linux box and thereafter I could start
    Message 1 of 5 , Mar 21, 2013
    • 0 Attachment

      John, like Ken of GB7COW, I get the same errors when starting up LinBPQ as he does … This morning, I rebooted my Linux box and thereafter I could start LinBPQ but within seconds it would close off  (crash) .. This happened repeatedly – I also restarted Linux again …

       

      In the end I found that by typing ‘./linbpq  tidymail’, it became stable !!! .. After being stable for some minutes I get messages “Sendto: Invalid argument” about six times .. What ‘argument’ as I haven’t really changed any configuration ???

       

      Talking about ‘tidymail’, must one use this from now on ?? .. I see my Mail directory growing bigger each day …

       

      73, Dick ZS6RO

    • John Wiseman
      Dick, Was there anything in syslog giving the reason for it closing? The Sendto: Invalid Argument is probably from the AX/UDP code, as nothing else uses the
      Message 2 of 5 , Mar 21, 2013
      • 0 Attachment
        Dick,
         
        Was there anything in syslog giving the reason for it closing?
         
        The Sendto: Invalid Argument is probably from the AX/UDP code, as nothing else uses the  sendto() system call. Check that no errors are reported whin initialising the axip port.
         
        John
         


        From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
        Sent: 21 March 2013 11:59
        To: BPQ32@yahoogroups.com
        Subject: [BPQ32] [LinBPQ] Re: Start up errors..

         

        John, like Ken of GB7COW, I get the same errors when starting up LinBPQ as he does … This morning, I rebooted my Linux box and thereafter I could start LinBPQ but within seconds it would close off  (crash) .. This happened repeatedly – I also restarted Linux again …

        In the end I found that by typing ‘./linbpq  tidymail’, it became stable !!! .. After being stable for some minutes I get messages “Sendto: Invalid argument” about six times .. What ‘argument’ as I haven’t really changed any configuration ???

        Talking about ‘tidymail’, must one use this from now on ?? .. I see my Mail directory growing bigger each day …

        73, Dick ZS6RO

      • Richard
        I forgot to look at the syslog at the time I had all the hassles of restarting LinBPQ (will remember next time!) .. I think this is the relevant bits . Dick
        Message 3 of 5 , Mar 21, 2013
        • 0 Attachment

          I forgot to look at the syslog at the time I had all the hassles of restarting LinBPQ (will remember next time!) ..

           

          I think this is the relevant bits …

           

          Dick

           

          ===============================================================

           

          Mar 21 09:50:50 ham-radio LINBPQ[2978]: AXIP Resolve complete - pausing#015

          Mar 21 09:50:53 ham-radio kernel: [  324.386318] linbpq[2978]: segfault at 84f6000 ip 080ab33f sp bfdd5620 error 4 in linbpq[8048000+c6000]

          Mar 21 09:51:08 ham-radio LINBPQ[2998]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

          Mar 21 09:51:08 ham-radio LINBPQ[2998]: AXIP Resolving names#015

          Mar 21 09:51:08 ham-radio LINBPQ[2998]: BPQ32 APRS IS Thread#015

          Mar 21 09:51:08 ham-radio LINBPQ[2998]: Resolving update.g8bpq.net#015

          Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #1: 116.212.194.60#015

          Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #2: 174.46.122.124#015

          Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #3: 204.8.136.30#015

          Mar 21 09:51:08 ham-radio kernel: [  339.229169] linbpq[3001]: segfault at 323a3a ip 080c666b sp b6d9e330 error 4 in linbpq[8048000+c6000]

          Mar 21 09:51:12 ham-radio LINBPQ[3005]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

          Mar 21 09:51:12 ham-radio LINBPQ[3005]: AXIP Resolving names#015

          Mar 21 09:51:12 ham-radio LINBPQ[3005]: BPQ32 APRS IS Thread#015

          Mar 21 09:51:12 ham-radio LINBPQ[3005]: Resolving update.g8bpq.net#015

          Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #1: 71.7.139.22#015

          Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #2: 116.212.194.60#015

          Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #3: 174.46.122.124#015

          Mar 21 09:51:12 ham-radio kernel: [  342.713305] linbpq[3008]: segfault at 323a3a ip 080c666b sp b6d2d330 error 4 in linbpq[8048000+c6000]

          Mar 21 09:51:14 ham-radio LINBPQ[3012]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

          Mar 21 09:51:14 ham-radio LINBPQ[3012]: AXIP Resolving names#015

          Mar 21 09:51:14 ham-radio LINBPQ[3012]: BPQ32 APRS IS Thread#015

          Mar 21 09:51:14 ham-radio LINBPQ[3012]: Resolving update.g8bpq.net#015

          Mar 21 09:51:14 ham-radio LINBPQ[3012]: CMS Address #1: 212.69.162.229#015

          Mar 21 09:51:14 ham-radio LINBPQ[3012]: CMS Address #2: 71.7.139.22#015

          Mar 21 09:51:14 ham-radio kernel: [  345.109800] linbpq[3015]: segfault at 32306666 ip 080c666b sp b6d38330 error 4 in linbpq[8048000+c6000]

          Mar 21 09:51:17 ham-radio LINBPQ[3019]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

          Mar 21 09:51:17 ham-radio LINBPQ[3019]: AXIP Resolving names#015

          Mar 21 09:51:17 ham-radio LINBPQ[3019]: BPQ32 APRS IS Thread#015

          ===============================================================

           

          Dick,

           

          Was there anything in syslog giving the reason for it closing?

           

          The Sendto: Invalid Argument is probably from the AX/UDP code, as nothing else uses the  sendto() system call. Check that no errors are reported whin initialising the axip port.

           

          John

           


          John, like Ken of GB7COW, I get the same errors when starting up LinBPQ as he does … This morning, I rebooted my Linux box and thereafter I could start LinBPQ but within seconds it would close off  (crash) .. This happened repeatedly – I also restarted Linux again …

          In the end I found that by typing ‘./linbpq  tidymail’, it became stable !!! .. After being stable for some minutes I get messages “Sendto: Invalid argument” about six times .. What ‘argument’ as I haven’t really changed any configuration ???

          Talking about ‘tidymail’, must one use this from now on ?? .. I see my Mail directory growing bigger each day …

          73, Dick ZS6RO

        • John Wiseman
          Thanks, Richard. That error is in the code that checks access to the CMS servers. I ll look into it. John _____ From: BPQ32@yahoogroups.com
          Message 4 of 5 , Mar 21, 2013
          • 0 Attachment
            Thanks, Richard.
             
            That error is in the code that checks access to the CMS servers. I'll look into it.
             
            John
             


            From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of Richard
            Sent: 21 March 2013 12:57
            To: BPQ32@yahoogroups.com
            Subject: RE: [BPQ32] [LinBPQ] Re: Start up errors..

             

            I forgot to look at the syslog at the time I had all the hassles of restarting LinBPQ (will remember next time!) ..

            I think this is the relevant bits …

            Dick

            ===============================================================

            Mar 21 09:50:50 ham-radio LINBPQ[2978]: AXIP Resolve complete - pausing#015

            Mar 21 09:50:53 ham-radio kernel: [  324.386318] linbpq[2978]: segfault at 84f6000 ip 080ab33f sp bfdd5620 error 4 in linbpq[8048000+c6000]

            Mar 21 09:51:08 ham-radio LINBPQ[2998]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

            Mar 21 09:51:08 ham-radio LINBPQ[2998]: AXIP Resolving names#015

            Mar 21 09:51:08 ham-radio LINBPQ[2998]: BPQ32 APRS IS Thread#015

            Mar 21 09:51:08 ham-radio LINBPQ[2998]: Resolv ing update.g8bpq.net#015

            Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #1: 116.212.194.60#015

            Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #2: 174.46.122.124#015

            Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #3: 204.8.136.30#015

            Mar 21 09:51:08 ham-radio kernel: [  339.229169] linbpq[3001]: segfault at 323a3a ip 080c666b sp b6d9e330 error 4 in linbpq[8048000+c6000]

            Mar 21 09:51:12 ham-radio LINBPQ[3005]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

            Mar 21 09:51:12 ham-radio LINBPQ[3005]: AXIP Resolving names#015

            Mar 21 09:51:12 ham-radio LINBPQ[3005]: BPQ32 APRS IS Thread#015

            Mar 21 09:51:12 ham-radio LINBPQ[3005]: Resolving update.g8bpq.net#015

            Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #1: 71.7.139.22#015

            Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #2: 116.212.194.60#015

            Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #3: 174.46.122.124#015

            Mar 21 09:51:12 ham-ra dio kernel: [  342.713305] linbpq[3008]: segfault at 323a3a ip 080c666b sp b6d2d330 error 4 in linbpq[8048000+c6000]

            Mar 21 09:51:14 ham-radio LINBPQ[3012]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

            Mar 21 09:51:14 ham-radio LINBPQ[3012]: AXIP Resolving names#015

            Mar 21 09:51:14 ham-radio LINBPQ[3012]: BPQ32 APRS IS Thread#015

            Mar 21 09:51:14 ham-radio LINBPQ[3012]: Resolving update.g8bpq.net#015

            Mar 21 09:51:14 ham-radio LINBPQ[3012]: CMS Address #1: 212.69.162.229#015

            Mar 21 09:51:14 ham-radio LINBPQ[3012]: CMS Address #2: 71.7.139.22#015

            Mar 21 09:51:14 ham-radio kernel: [  345.109800] linbpq[3015]: segfault at 32306666 ip 080c666b sp b6d38330 error 4 in linbpq[8048000+c6000]

            Mar 21 09:51:17 ham-radio LINBPQ[3019]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

            Mar 21 09:51:17 ham-radio LINBPQ[3019]: AXIP Resolving names#015

            Mar 21 09:51:17 ham-radio LINBPQ[3019]: BPQ32 APRS IS Thread#015

            ========================================== =====================

             

            Dick,

            Was there anything in syslog giving the reason for it closing?

            The Sendto: Invalid Argument is probably from the AX/UDP code, as nothing else uses the  sendto() system call. Check that no errors are reported whin initialising the axip port.

            John


            John, like Ken of GB7COW, I get the same errors when starting up LinBPQ as he does … This morning, I rebooted my Linux box and thereafter I could start LinBPQ but within seconds it would close off  (crash) .. This happened repeatedly – I also restarted Linux again …

            In the end I found that by typing ‘./linbpq  tidymail’, it became stable !!! .. After being stable for some minutes I get messages “Sendto: Invalid argument” about six times .. What ‘argument’ as I haven’t really changed any configuration ???

            Talking about ‘tidymail’, must one use this from now on ?? .. I see my Mail directory growing bigger each day …

            73, Dick ZS6RO

          • Richard
            Aha, thanks John, Ken gave me a skeleton LinBPQ config file and I embroidered it somewhat but I left the CMS in, even tried connecting to CMS once - it
            Message 5 of 5 , Mar 21, 2013
            • 0 Attachment

              Aha, thanks John, Ken gave me a skeleton LinBPQ config file and I embroidered it somewhat but I left the CMS in, even tried connecting to CMS once – it appeared to work .. (Interesting because Ken reported the same problem with the errors – he probably gave me a copy of his own config file when I first started with BPQ) ..

               

              73, Dick ZS6RO

              ~~~~~~~~~~~~~~~~~~~~~~~~~

              Thanks, Richard.

               

              That error is in the code that checks access to the CMS servers. I'll look into it.

               

              John

               ~~~~~~~~~~~~~~~~~~~~ 

              I forgot to look at the syslog at the time I had all the hassles of restarting LinBPQ (will remember next time!) ..

              I think this is the relevant bits …

              Dick

              ===============================================================

              Mar 21 09:50:50 ham-radio LINBPQ[2978]: AXIP Resolve complete - pausing#015

              Mar 21 09:50:53 ham-radio kernel: [  324.386318] linbpq[2978]: segfault at 84f6000 ip 080ab33f sp bfdd5620 error 4 in linbpq[8048000+c6000]

              Mar 21 09:51:08 ham-radio LINBPQ[2998]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

              Mar 21 09:51:08 ham-radio LINBPQ[2998]: AXIP Resolving names#015

              Mar 21 09:51:08 ham-radio LINBPQ[2998]: BPQ32 APRS IS Thread#015

              Mar 21 09:51:08 ham-radio LINBPQ[2998]: Resolv ing update.g8bpq.net#015

              Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #1: 116.212.194.60#015

              Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #2: 174.46.122.124#015

              Mar 21 09:51:08 ham-radio LINBPQ[2998]: CMS Address #3: 204.8.136.30#015

              Mar 21 09:51:08 ham-radio kernel: [  339.229169] linbpq[3001]: segfault at 323a3a ip 080c666b sp b6d9e330 error 4 in linbpq[8048000+c6000]

              Mar 21 09:51:12 ham-radio LINBPQ[3005]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

              Mar 21 09:51:12 ham-radio LINBPQ[3005]: AXIP Resolving names#015

              Mar 21 09:51:12 ham-radio LINBPQ[3005]: BPQ32 APRS IS Thread#015

              Mar 21 09:51:12 ham-radio LINBPQ[3005]: Resolving update.g8bpq.net#015

              Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #1: 71.7.139.22#015

              Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #2: 116.212.194.60#015

              Mar 21 09:51:12 ham-radio LINBPQ[3005]: CMS Address #3: 174.46.122.124#015

              Mar 21 09:51:12 ham-ra dio kernel: [  342.713305] linbpq[3008]: segfault at 323a3a ip 080c666b sp b6d2d330 error 4 in linbpq[8048000+c6000]

              Mar 21 09:51:14 ham-radio LINBPQ[3012]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

              Mar 21 09:51:14 ham-radio LINBPQ[3012]: AXIP Resolving names#015

              Mar 21 09:51:14 ham-radio LINBPQ[3012]: BPQ32 APRS IS Thread#015

              Mar 21 09:51:14 ham-radio LINBPQ[3012]: Resolving update.g8bpq.net#015

              Mar 21 09:51:14 ham-radio LINBPQ[3012]: CMS Address #1: 212.69.162.229#015

              Mar 21 09:51:14 ham-radio LINBPQ[3012]: CMS Address #2: 71.7.139.22#015

              Mar 21 09:51:14 ham-radio kernel: [  345.109800] linbpq[3015]: segfault at 32306666 ip 080c666b sp b6d38330 error 4 in linbpq[8048000+c6000]

              Mar 21 09:51:17 ham-radio LINBPQ[3019]: PORTS 8123960 LINKS 8125d0b DESTS 8128a14 ROUTES 812d6a4 L4 812ebe4 BUFFERS 8134b7c #015

              Mar 21 09:51:17 ham-radio LINBPQ[3019]: AXIP Resolving names#015

              Mar 21 09:51:17 ham-radio LINBPQ[3019]: BPQ32 APRS IS Thread#015

              ========================================== =====================

               

              Dick,

              Was there anything in syslog giving the reason for it closing?

              The Sendto: Invalid Argument is probably from the AX/UDP code, as nothing else uses the  sendto() system call. Check that no errors are reported whin initialising the axip port.

              John


              John, like Ken of GB7COW, I get the same errors when starting up LinBPQ as he does … This morning, I rebooted my Linux box and thereafter I could start LinBPQ but within seconds it would close off  (crash) .. This happened repeatedly – I also restarted Linux again …

              In the end I found that by typing ‘./linbpq  tidymail’, it became stable !!! .. After being stable for some minutes I get messages “Sendto: Invalid argument” about six times .. What ‘argument’ as I haven’t really changed any configuration ???

              Talking about ‘tidymail’, must one use this from now on ?? .. I see my Mail directory growing bigger each day …

              73, Dick ZS6RO

            Your message has been successfully submitted and would be delivered to recipients shortly.