Loading ...
Sorry, an error occurred while loading the content.

9626Re: ubuntu port

Expand Messages
  • kenny
    Feb 3, 2013
    • 0 Attachment
      All working now John
      i have never had to make a symlink before,learn something new everyday.
      with my Xrouter running under ubuntu i never had to make a symlink.

      regards
      Ken g7vja


      --- In BPQ32@yahoogroups.com, "John Wiseman" wrote:
      >
      > You have to create a symlink
      >
      > From the docs:
      >
      > As serial port names are pretty variable in Linux, the code accesses them
      > via symlinks in the linbpq directory to ports called com1 - com255. So, for
      > example, to access a TNC connected to the serial port on the PI, enter
      >
      >
      >
      > ln -s /dev/ttyAMA0 com1 (lower case!)
      >
      >
      >
      > In you case
      >
      >
      >
      > ln -s /dev/ttyS0 com1
      >
      >
      >
      > 73, John
      >
      >
      >
      >
      >
      > _____
      >
      > From: BPQ32@yahoogroups.com [mailto:BPQ32@yahoogroups.com] On Behalf Of
      > kenny
      > Sent: 03 February 2013 14:49
      > To: BPQ32@...
      > Subject: [BPQ32] Re: ubuntu port
      >
      >
      >
      >
      > Hi John
      > its ttys0,.. ttySierra zero
      > never made a symlink
      > the rights are ok
      >
      > Ken
      >
      > --- In BPQ32@yahoogroups.com , "John
      > Wiseman" wrote:
      > >
      > > Ok, Ken.
      > >
      > > Do you create the symlink from com1 to /dev/ttyS0? (Is it S zero or S
      > letter
      > > o?). Also check the rights on com1 and /dev/ttyS0.
      > >
      > > 73, John
      > >
      > >
      > > _____
      > >
      > > From: BPQ32@yahoogroups.com
      > [mailto:BPQ32@yahoogroups.com ] On Behalf
      > Of
      > > kenny
      > > Sent: 03 February 2013 13:35
      > > To: BPQ32@yahoogroups.com
      > > Subject: [BPQ32] Re: ubuntu port
      > >
      > >
      > >
      > >
      > >
      > > Hi John
      > > i am using your sample now,the error
      > > i am now getting is:
      > > ASYNC Com1 Chan A /home/linbpq/com1 could not be opened
      > >
      > > Ken
      > >
      > > --- In BPQ32@yahoogroups.com , "John
      > > Wiseman" wrote:
      > > >
      > > > Ken,
      > > >
      > > > When you say not seeing it, do you mean there is an error reported on
      > > > startup, or just that it doesn't work.?
      > > >
      > > > PORT
      > > > ID=KISS
      > > > TYPE=ASYNC
      > > > PROTOCOL=KISS
      > > > SPEED=9600
      > > > COMPORT=1
      > > > CHANNEL=A
      > > > QUALITY=0
      > > > MAXFRAME=2
      > > > FRACK=7000
      > > > RESPTIME=1500
      > > > RETRIES=10
      > > > PACLEN=128
      > > > TXDELAY=500
      > > > SLOTTIME=100
      > > > PERSIST=64
      > > > ;
      > > > ENDPORT
      > > >
      > > > 73, John
      > > >
      > > >
      > > > _____
      > > >
      > > > From: BPQ32@yahoogroups.com
      > > [mailto:BPQ32@yahoogroups.com ] On
      > Behalf
      > > Of
      > > > kenny
      > > > Sent: 03 February 2013 12:45
      > > > To: BPQ32@yahoogroups.com
      > > > Subject: [BPQ32] ubuntu port
      > > >
      > > >
      > > >
      > > >
      > > > Hi All
      > > > anyone got a sample port setting for ttyS0 (com1)
      > > > my ubuntu,bpq is not seeing it.
      > > >
      > > > Ken g7vja
      > > >
      > > >
      > > >
      > > >
      > > > _
      > > >
      > > d=9619/stime=1359895519/nc1=5758223/nc2=4025321/nc3=5741398> _._,_.___
      > > > .
      > > >
      > >
      >
    • Show all 15 messages in this topic