Loading ...
Sorry, an error occurred while loading the content.

RE: [ASCOM] Installing RCOS TCC focuser in CCDSoftV5.0

Expand Messages
  • Dan Azari
    Terry, Thanks to the suggestion from Bob Denny, the latest version of the TCC (1.5.8) automatically takes care of DCOM configuration. In case you don t know,
    Message 1 of 11 , Oct 1, 2004
    • 0 Attachment
      Terry,

      Thanks to the suggestion from Bob Denny, the latest version of the TCC
      (1.5.8) automatically takes care of DCOM configuration. In case you
      don't know, you need to use TCC v 1.5.8 or greater to use CCDSoft
      @focus. This release contains a step size calculator and returns the
      appropriate step sizes to CCDSoft need for @focus.

      Regards,
      Dan



      > -----Original Message-----
      > From: tstandefer2002 [mailto:tstandefer2002@...]
      > Sent: Monday, September 27, 2004 10:39 PM
      > To: ASCOM-Talk@yahoogroups.com
      > Subject: Re: [ASCOM] Installing RCOS TCC focuser in CCDSoftV5.0
      >
      > Dan and others,
      >
      > Thanks for all your help. I tried it out last night and I
      > was able to use the RCOS TCC with no issues. After running
      > DCOM it all worked.
      >
      > Cheers,
      >
      > Terry Standefer
      >
      > --- In ASCOM-Talk@yahoogroups.com, "Dan Azari" <Dan@p...> wrote:
      > > Terry,
      > >
      > > The problem you are experiencing is related to DCOM
      > authentication. If you have access to the RCOS Customer user
      > group check out http://customer.rcopticalsystems.com/eve/ubb.x?
      > a=tpc&s=265603&f=355604&m=247607155 for instructions on
      > configuring DCOM (instruction originally written by Tim Long
      > and adapted).
      > >
      > > BTW--I've written a 'native' driver for CCDSoft which has just
      > been released in CCDSoft's latest hotfix. Unfortunately
      > something went wrong when they compiled the code into CCDSoft
      > and it DOES NOT WORK. Hopefully will get the problem worked out soon.
      > >
      > > Dan
      > >
      > > ________________________________
      > >
      > > From: tstandefer2002 [mailto:tstandefer2002@y...]
      > > Sent: Fri 9/17/2004 12:56 AM
      > > To: ASCOM-Talk@yahoogroups.com
      > > Subject: Re: [ASCOM] Installing RCOS TCC focuser in CCDSoftV5.0
      > >
      > >
      > >
      > > Tim,
      > >
      > > I followed the instructions exactly and still get the same
      > message.
      > > I do notice that after selecting the API focuser and then choosing
      > > RCOS TCC focuser and then clicking properties, RCOS TCC
      > program begins
      > > running. It doesn't show up except under the Tasks Lists
      > (Control alt
      > > delete). I have also tried running RCOS TCC first and then
      > > configuring the camera and still same message. Could it be
      > because I
      > > am not connected the the focuser (trying this at home versus
      > > observatory)? The only thing I have not tried is reinstalling
      > > CCDSoftV5.
      > >
      > > Any comments would be appreciated.
      > >
      > > Terry Standefer
      > >
      > > --- In ASCOM-Talk@yahoogroups.com, "Tim Long" <Tim@l...> wrote:
      > > > Please see my FAQ page on this topic:
      > > > http://syd.tigranetworks.co.uk/ASCOMFocusAPI/FAQ.aspx
      > > >
      > > >
      > > > --Tim Long
      > > > http://syd.tigranetworks.co.uk - software for amateur astronomers
      > > >
      > > > > -----Original Message-----
      > > > > From: tstandefer2002 [mailto:tstandefer2002@y...]
      > > > > Sent: Tuesday, September 14, 2004 4:18 AM
      > > > > To: ASCOM-Talk@yahoogroups.com
      > > > > Subject: [ASCOM] Installing RCOS TCC focuser in CCDSoftV5.0
      > > > >
      > > > > Need some help. I have followed the instructions to download
      > the
      > > > > most recent ASCOM Drivers (version 3.0) and copy over the
      > latest
      > > > > FocusAPI.dll to the systems folder. I then went through and
      > set
      > > up
      > > > > RCOS as the focuser in CCDSoft V5.0. I selected Focus API for
      > > the
      > > > > focuser and then under setting/choose I selected RCOS TCC.
      > When
      > > I
      > > > > click properties I get a message "Failed to load driver: object
      > > > > required". I have tried it multipule times and still get the
      > > error.
      > > > >
      > > > > I do have the most recent RCOS TCC drivers installed.
      > > > >
      > > > > If it help any, there is a note below the ASOM Focuser Setting
      > > dialog
      > > > > that says "FocusAPI to ASCOM mapper 1.00.004 Copyright 2003
      > > Timmothy
      > > > > P. Long"
      > > > >
      > > > > If anyone has suggestions please email me. I would like to get
      > > the
      > > > > focuser up and running. I will be on the road for the next few
      > > days
      > > > > and may not be able to respond back.
      > > > >
      > > > > Regards,
      > > > >
      > > > > Terry Standefer
      > > > >
      > > > >
      > > > >
      > > > > ------------------------ Yahoo! Groups Sponsor ----------------
      > --
      > > --~-->
      > > > > $9.95 domain names from Yahoo!. Register anything.
      > > > > http://us.click.yahoo.com/J8kdrA/y20IAA/yQLSAA/1.XolB/TM
      > > > > ---------------------------------------------------------------
      > --
      > > ---~->
      > > > >
      > > > > For more information see http://ASCOM-Standards.org/.
      > > > >
      > > > > To unsubscribe from this group, send an email FROM THE ACCOUNT
      > > YOU USED TO
      > > > > SUBSCRIBE(!) to:
      > > > > ASCOM-Talk-unsubscribe@yahoogroups.com
      > > > >
      > > > >
      > > > > Yahoo! Groups Links
      > > > >
      > > > >
      > > > >
      > > > >
      > >
      > >
      > >
      > >
      > > For more information see http://ASCOM-Standards.org/.
      > >
      > > To unsubscribe from this group, send an email FROM THE ACCOUNT YOU
      > USED TO SUBSCRIBE(!) to:
      > > ASCOM-Talk-unsubscribe@yahoogroups.com
      > >
      > >
      > > Yahoo! Groups Links
      >
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      > --------------------~--> Make a clean sweep of pop-up ads.
      > Yahoo! Companion Toolbar.
      > Now with Pop-Up Blocker. Get it for free!
      > http://us.click.yahoo.com/L5YrjA/eSIIAA/yQLSAA/1.XolB/TM
      > --------------------------------------------------------------
      > ------~->
      >
      > For more information see http://ASCOM-Standards.org/.
      >
      > To unsubscribe from this group, send an email FROM THE
      > ACCOUNT YOU USED TO SUBSCRIBE(!) to:
      > ASCOM-Talk-unsubscribe@yahoogroups.com
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
    • tstandefer2002
      I will check the version I am using. Thanks for the tip. Terry Standefer ... TCC ... you ... the ... soon. ... choosing ... astronomers ... download ... and
      Message 2 of 11 , Oct 3, 2004
      • 0 Attachment
        I will check the version I am using. Thanks for the tip.

        Terry Standefer

        --- In ASCOM-Talk@yahoogroups.com, "Dan Azari" <Dan@p...> wrote:
        >
        > Terry,
        >
        > Thanks to the suggestion from Bob Denny, the latest version of the
        TCC
        > (1.5.8) automatically takes care of DCOM configuration. In case
        you
        > don't know, you need to use TCC v 1.5.8 or greater to use CCDSoft
        > @focus. This release contains a step size calculator and returns
        the
        > appropriate step sizes to CCDSoft need for @focus.
        >
        > Regards,
        > Dan
        >
        >
        >
        > > -----Original Message-----
        > > From: tstandefer2002 [mailto:tstandefer2002@y...]
        > > Sent: Monday, September 27, 2004 10:39 PM
        > > To: ASCOM-Talk@yahoogroups.com
        > > Subject: Re: [ASCOM] Installing RCOS TCC focuser in CCDSoftV5.0
        > >
        > > Dan and others,
        > >
        > > Thanks for all your help. I tried it out last night and I
        > > was able to use the RCOS TCC with no issues. After running
        > > DCOM it all worked.
        > >
        > > Cheers,
        > >
        > > Terry Standefer
        > >
        > > --- In ASCOM-Talk@yahoogroups.com, "Dan Azari" <Dan@p...> wrote:
        > > > Terry,
        > > >
        > > > The problem you are experiencing is related to DCOM
        > > authentication. If you have access to the RCOS Customer user
        > > group check out http://customer.rcopticalsystems.com/eve/ubb.x?
        > > a=tpc&s=265603&f=355604&m=247607155 for instructions on
        > > configuring DCOM (instruction originally written by Tim Long
        > > and adapted).
        > > >
        > > > BTW--I've written a 'native' driver for CCDSoft which has just
        > > been released in CCDSoft's latest hotfix. Unfortunately
        > > something went wrong when they compiled the code into CCDSoft
        > > and it DOES NOT WORK. Hopefully will get the problem worked out
        soon.
        > > >
        > > > Dan
        > > >
        > > > ________________________________
        > > >
        > > > From: tstandefer2002 [mailto:tstandefer2002@y...]
        > > > Sent: Fri 9/17/2004 12:56 AM
        > > > To: ASCOM-Talk@yahoogroups.com
        > > > Subject: Re: [ASCOM] Installing RCOS TCC focuser in CCDSoftV5.0
        > > >
        > > >
        > > >
        > > > Tim,
        > > >
        > > > I followed the instructions exactly and still get the same
        > > message.
        > > > I do notice that after selecting the API focuser and then
        choosing
        > > > RCOS TCC focuser and then clicking properties, RCOS TCC
        > > program begins
        > > > running. It doesn't show up except under the Tasks Lists
        > > (Control alt
        > > > delete). I have also tried running RCOS TCC first and then
        > > > configuring the camera and still same message. Could it be
        > > because I
        > > > am not connected the the focuser (trying this at home versus
        > > > observatory)? The only thing I have not tried is reinstalling
        > > > CCDSoftV5.
        > > >
        > > > Any comments would be appreciated.
        > > >
        > > > Terry Standefer
        > > >
        > > > --- In ASCOM-Talk@yahoogroups.com, "Tim Long" <Tim@l...> wrote:
        > > > > Please see my FAQ page on this topic:
        > > > > http://syd.tigranetworks.co.uk/ASCOMFocusAPI/FAQ.aspx
        > > > >
        > > > >
        > > > > --Tim Long
        > > > > http://syd.tigranetworks.co.uk - software for amateur
        astronomers
        > > > >
        > > > > > -----Original Message-----
        > > > > > From: tstandefer2002 [mailto:tstandefer2002@y...]
        > > > > > Sent: Tuesday, September 14, 2004 4:18 AM
        > > > > > To: ASCOM-Talk@yahoogroups.com
        > > > > > Subject: [ASCOM] Installing RCOS TCC focuser in CCDSoftV5.0
        > > > > >
        > > > > > Need some help. I have followed the instructions to
        download
        > > the
        > > > > > most recent ASCOM Drivers (version 3.0) and copy over the
        > > latest
        > > > > > FocusAPI.dll to the systems folder. I then went through
        and
        > > set
        > > > up
        > > > > > RCOS as the focuser in CCDSoft V5.0. I selected Focus API
        for
        > > > the
        > > > > > focuser and then under setting/choose I selected RCOS
        TCC.
        > > When
        > > > I
        > > > > > click properties I get a message "Failed to load driver:
        object
        > > > > > required". I have tried it multipule times and still get
        the
        > > > error.
        > > > > >
        > > > > > I do have the most recent RCOS TCC drivers installed.
        > > > > >
        > > > > > If it help any, there is a note below the ASOM Focuser
        Setting
        > > > dialog
        > > > > > that says "FocusAPI to ASCOM mapper 1.00.004 Copyright 2003
        > > > Timmothy
        > > > > > P. Long"
        > > > > >
        > > > > > If anyone has suggestions please email me. I would like
        to get
        > > > the
        > > > > > focuser up and running. I will be on the road for the
        next few
        > > > days
        > > > > > and may not be able to respond back.
        > > > > >
        > > > > > Regards,
        > > > > >
        > > > > > Terry Standefer
        > > > > >
        > > > > >
        > > > > >
        > > > > > ------------------------ Yahoo! Groups Sponsor ------------
        ----
        > > --
        > > > --~-->
        > > > > > $9.95 domain names from Yahoo!. Register anything.
        > > > > > http://us.click.yahoo.com/J8kdrA/y20IAA/yQLSAA/1.XolB/TM
        > > > > > -----------------------------------------------------------
        ----
        > > --
        > > > ---~->
        > > > > >
        > > > > > For more information see http://ASCOM-Standards.org/.
        > > > > >
        > > > > > To unsubscribe from this group, send an email FROM THE
        ACCOUNT
        > > > YOU USED TO
        > > > > > SUBSCRIBE(!) to:
        > > > > > ASCOM-Talk-unsubscribe@yahoogroups.com
        > > > > >
        > > > > >
        > > > > > Yahoo! Groups Links
        > > > > >
        > > > > >
        > > > > >
        > > > > >
        > > >
        > > >
        > > >
        > > >
        > > > For more information see http://ASCOM-Standards.org/.
        > > >
        > > > To unsubscribe from this group, send an email FROM THE ACCOUNT
        YOU
        > > USED TO SUBSCRIBE(!) to:
        > > > ASCOM-Talk-unsubscribe@yahoogroups.com
        > > >
        > > >
        > > > Yahoo! Groups Links
        > >
        > >
        > >
        > > ------------------------ Yahoo! Groups Sponsor
        > > --------------------~--> Make a clean sweep of pop-up ads.
        > > Yahoo! Companion Toolbar.
        > > Now with Pop-Up Blocker. Get it for free!
        > > http://us.click.yahoo.com/L5YrjA/eSIIAA/yQLSAA/1.XolB/TM
        > > --------------------------------------------------------------
        > > ------~->
        > >
        > > For more information see http://ASCOM-Standards.org/.
        > >
        > > To unsubscribe from this group, send an email FROM THE
        > > ACCOUNT YOU USED TO SUBSCRIBE(!) to:
        > > ASCOM-Talk-unsubscribe@yahoogroups.com
        > >
        > >
        > > Yahoo! Groups Links
        > >
        > >
        > >
        > >
        > >
        > >
      Your message has been successfully submitted and would be delivered to recipients shortly.