Loading ...
Sorry, an error occurred while loading the content.

Re: Image from "QHY8 CCD Camera" Driver

Expand Messages
  • Alan Orr
    Hello All and Thanks Tim! I have attached the older files (previously with bad links) as follows: GoodResult.png: Shows simple target on 3rd party software.
    Message 1 of 13 , May 28, 2012
    Hello All and Thanks Tim! I have attached the older files (previously with bad links) as follows:
    GoodResult.png: Shows simple target on 3rd party software.
    BadResult.png: Shows same target on my application with the hashing.
    SingleDotGood4.png: Shows image of single dot from 3rd party software.
    SingleDotBad4.png: Shows image of single dot within my application with hashing (but can see remnants of dot hashed in image).

    Crossing my fingers that this works :).

    Alan
    --- In ASCOM-Talk@yahoogroups.com, "Tim Long" <Tim@...> wrote:
    >
    > Alan, none of your links have worked. If you are posting by email, you
    > can simply attach your images to your message as normal file attachments
    > and Yahoo will sort out storing them and sending out correct links.
    >

    >
    > Regards,
    >
    > Tim Long <http://community.tigranetworks.co.uk/blogs/Tim_Long>
    >

    >
    > From: ASCOM-Talk@yahoogroups.com [mailto:ASCOM-Talk@yahoogroups.com] On
    > Behalf Of Alan Orr
    > Sent: 24 May 2012 21:50
    > To: ASCOM-Talk@yahoogroups.com
    > Subject: Re: [ASCOM] Image from "QHY8 CCD Camera" Driver
    >

    >
    >
    >
    > Links causing me problems as follows. If these do not work, they are
    > located in the "Files" section of the forum (png files). Thanks! Alan
    >
    > GoodResult
    > <http://f1.grp.yahoofs.com/v1/QJO-T-NjfH3KJPFSMRoL0AnR9rLaemYDqX6KSn_08i
    > WjoYWpOvSQfXuv25zV01uBR5kSOJu1OX6-HXTuROpxB2H1w0b8tW8/GoodResult.png>
    >
    > BadResult
    > <http://f1.grp.yahoofs.com/v1/QJO-T8DrirvKJPFS94EP6air2CmUZiQ1F9VrEbgMhs
    > oSViMuw0uaJpgq9dzRSW-anVhn7nNkTCPljNhrERNxwHxeqUxX0yw/BadResult.png> 
    >
    >
    > --- In ASCOM-Talk@yahoogroups.com, "Alan Orr" <alanrorr1@> wrote:
    > >
    > > Thanks for all of the feedback! I was hoping it would be simple like
    > > switching the width and height, but no luck. I hope the images below
    > > will shed a light on the issue (or how best to troubleshoot).
    > >
    > > Also, I just took single dot images to highlight the problem and as
    > > follows:
    > > SingleDotGood
    > >
    > <http://f1.grp.yahoofs.com/v1/MIW-T-MzyZiLm0MXwu9qYwQM20VLkYqwUtDUeDHdd1
    > \
    > <http://f1.grp.yahoofs.com/v1/MIW-T-MzyZiLm0MXwu9qYwQM20VLkYqwUtDUeDHdd1
    > /%0b> >
    > grSxSYKSL51BIZA8YIevE0bZxLbfKaCUpQKaSHeSVkmW_sirz19wo/SingleDotGood4.png
    > \
    > > >
    > > SingleDotGood is from 3rd party software.
    > >
    > > SingleDotBad
    > >
    > <http://f1.grp.yahoofs.com/v1/MIW-T_HoRMuLm0MXtH8Rohai8k1TMnUSJdGMEgkhSi
    > \
    > <http://f1.grp.yahoofs.com/v1/MIW-T_HoRMuLm0MXtH8Rohai8k1TMnUSJdGMEgkhSi
    > /%0b> >
    > pAQN-fx945M2PJ62-BqLfWfsItIgnv21yxILM617uDSf81dNowB7c/SingleDotBad4.png>
    > > SingleDotBad is from application being developed. It shows the
    > hashing.
    > >
    > > For the original sample imag! es, sorry, try these. Please let me know
    > if
    > > they do not work. They should.
    > > GoodResult.png
    > >
    > <http://f1.grp.yahoofs.com/v1/AFu-T4mP02Rg6Um9d_DWupBnzKeHQzE5F9dyTNAsaf
    > \
    > <http://f1.grp.yahoofs.com/v1/AFu-T4mP02Rg6Um9d_DWupBnzKeHQzE5F9dyTNAsaf
    > /%0b> >
    > l7PaYzM9DR6Q4-onWUEvTPlmrEJYPjN6t4vYixwg9hzU1BfndbdJw/GoodResult.png>
    > > Good Result is from 3rd party software.
    > >
    > > BadResult.png
    > >
    > <http://f1.grp.yahoofs.com/v1/AFu-T6oHJaJg6Um9Ff7o4YyvhdruUMYXCpVbUYYPL_
    > \
    > <http://f1.grp.yahoofs.com/v1/AFu-T6oHJaJg6Um9Ff7o4YyvhdruUMYXCpVbUYYPL_
    > /%0b> >
    > VaSLY2j79PGzkkPTMOIOc1hxVmLupgDOwCruoFJWm1Hculf2ndt_Y/BadResult.png>
    > > Bad hashed result from application being developed.
    > >
    > > These are located in the "Files" section of this forum.
    > >
    > > If I passed the original array to BitmapSource.Create directly (as
    > > suggested and I like), any ideas of what the correct PixelFormat would
    > > be? It is passed into the 5th param of the BitmapSource.Create call.
    > > int width = (int)((double)C.CameraXSize);
    > > int height = C.CameraYSize;
    > > int r! awStride = (width * pf.BitsPerPixel + 7) / 8;
    > >
    > > BitmapP alette palette = BitmapPalettes.Gray16;
    > > PixelFormat pf = PixelFormats.Gray16;
    > > BitmapSource bitmap = BitmapSource.Create(width, height,
    > > 96, 96, pf, palette /*16 shades of gray to accentuate single dot*/,
    > > img2Array, rawStride);
    > > Note: the width reported is 3040 and the height is 2016.
    > > This image has the Bayer matrix of pixels (since single shot color
    > > camera) which I am trying to get to show up in gray.
    > >
    > > Thanks!
    > >
    > > Alan
    > >
    > > --- In ASCOM-Talk@yahoogroups.com, "Tim Long" Tim@ wrote:
    > > >
    > > > Alan, neither of your links work.
    > > >
    > > > Regards,
    > > > Tim Long
    > > >
    > > >
    > > > > -----Original Message-----
    > > > > From: ASCOM-Talk@yahoogroups.com [mailto:ASCOM-
    > > > > Talk@yahoogroups.com] On Behalf Of Alan Orr
    > > > > Sent: 23 May 2012 17:50
    > > > > To: ASCOM-Talk@yahoo! groups.com
    > > > > Subject: [ASCOM] Image from "QHY8 CCD Camera" Driver
    > > > >
    > > > > Hi,
    > > > >
    > > > > Any ideas on troubleshooting this bad hashed image result?
    > > > >
    > > > > The bad result is shown at this location:
    > > > >
    > > > > http://f1.grp.yahoofs.com/v1/gAm9T9_dyhDKXbLL0Jb-
    > > > > eGMp0OMzi81QXOy2m9rPSpjMYHJItVJXEUg6lkWVYb52AcogMfqkhE1P2-
    > > > > nL4KyjRwtyAC4ulDA/BadResult.png
    > > > >
    > > > > What the image looks like using 3rd party software that works is
    > at:
    > > > >
    > > > > http://f1.grp.yahoofs.com/v1/gAm9T_xVPNbKXbLLsDbyhfrEmBoDfYUh71-
    > > > > yQb7F_BWaPLXqaR8r7-
    > > > > U4OATH_4pJoGYzHGd0ml8BdMYybfAEEp3KWHhEn8o/GoodResult.png
    > > > >
    > > > > These images uploaded are screenshots.
    > > > >
    > > > > The image data is being loaded from the array prov! ided by ASCOM
    > into
    > > > an
    > > > > array that is goi ng into a Bitmapsource. The core code that does
    > the
    > > > loading
    > > > > is as follows:
    > > > > int iXPosition = 0;
    > > > > int iYPosition = 0;
    > > > > long i = 0;
    > > > > while (i < size)
    > > > > {
    > > > >
    > > > > iXPosition = 0;
    > > > > while (iXPosition < C.CameraXSize)
    > > > > {
    > > > > img2Array[i] = (UInt16)(imgArray[iYPosition,
    > > > iXPosition]);
    > > > > //(UInt16)(iXPosition * 65535/C.CameraXSize);
    > > > > i++;
    > > > > iXPosition++;
    > > > > }
    > > > > iYPosition++;
    > > > > }
    > > > >
    > > > > Note t! hat I have loaded the destination array (img2Array[i])
    > with a
    > > > gray scale
    > > > > from 0 to 65535 across each row to verify that if the destination
    > > > array were
    > > > > loaded correctly it would display appropriately - it did.
    > > > >
    > > > > Thanks for any ideas,
    > > > >
    > > > > Alan
    > > > >
    > > > >
    > > > >
    > > > > ------------------------------------
    > > > >
    > > > > For more information see http://ASCOM-Standards.org/.
    > > > >
    > > > > To unsubscribe from this group, send an email FROM THE ACCOUNT YOU
    > > > > USED TO SUBSCRIBE(!) to:
    > > > > ASCOM-Talk-unsubscribe@yahoogroups.com
    > > > >
    > > > > Yahoo! Groups Links
    > > > >
    > > > >
    > > > >
    > > >
    > > > --
    > > > ExchangeDefender Message Security: Click below to verify authenti!
    > city
    > > >
    > > http://www.exchangedefender.com/verify.asp?i
    > d=q4OCZ7jS023753&from=tim@\
    > > .
    > > > Complete email hygiene and business continuity solution available
    > from
    > > http://www.tigranetworks.co.uk
    > > >
    > >
    >
    >
    >
    >
    >
    >
    >
    >
    > --
    > ExchangeDefender Message Security: Click below to verify authenticity
    > http://www.exchangedefender.com/verify.asp?id=q4Q2wbCq003029&from=tim@...
    > Complete email hygiene and business continuity solution available from http://www.tigranetworks.co.uk
    >
  • Alan Orr
    Rick, Chris, Jared, Tim, and All, Does anyone know where I can get the format of the returned array values for this driver? The format from the values as shown
    Message 2 of 13 , May 28, 2012
    Rick, Chris, Jared, Tim, and All,
    Does anyone know where I can get the format of the returned array values for this driver? The format from the values as shown in ImageArrayValuesBasedOnFilter.xls is not evident (to me). I used different colored filters to look at the values coming back from the camera/array and to determine what some of the format is(some is not clear). For example, I am seeing trailing zeros at the end of rows consistently.

    Rick
    - Thanks for your great comment and code regarding the rgba suggestion. Once I understand the array returned, I will pursue your idea (since need to understand the format first).

    Best and Thanks!

    Alan
Your message has been successfully submitted and would be delivered to recipients shortly.