Loading ...
Sorry, an error occurred while loading the content.

Re: LazyFocus help

Expand Messages
  • astrman
    Thanks for the help. Indeed it was both a ground problem and a bad pin assignment inside the lazyfocus unit itself. I managed to get the whole thing working
    Message 1 of 3 , Apr 22, 2012
    • 0 Attachment
      Thanks for the help. Indeed it was both a ground problem and a bad pin assignment inside the lazyfocus unit itself.

      I managed to get the whole thing working this morning around 4:30AM (worked on it all night).

      Indeed the ground wire on pin 5 needed to be connected.

      I had a Meade 497 controller hooked up to my ETX60, which I knew used the same pinouts, pins 1 & 2 are tx/rx and pin 4 is a gnd on the phone jack. The cable wasn't seeing this telescope either. When I hooked up the gnd to pin 4 on the cable voila it found the etx but still not seeing the lazy focuser, so something funny going on there yet. (Pins 1, 2,& 4 mapped to the std 2, 3 & 5 on the RS232).

      I suspect it was a gnd problem on the Lazyfocus unit, and pin 4 was the culprit, since it didn't seem to map to a gnd (or anything) on the lazy focus.

      I just happened to unplug the power cable (by accident) on the lazy focus and suddenly ASCOM was able to connect to the lazyfocus. Hmmm...

      I checked the gnd on the board (at the power input) and traced it to pin 3 on the phone jack (I noticed that that pin was connected to what appeared to be the ground layer on the bottom of the board as well). Hmmmm. Since pin 4 has the gnd, pin 4 on the lazy focus isn't mapped to anything that I can tell, I shorted pin 3 & pin 4 (ie. basically grounded pin 4 on the phone jack) and the unit still connected . Applied power to the lazy focus unit and the ASCOM driver was able to move my focuser now!!!

      I did find that the lazyfocus drivers must be used, the moonlight focuser ones do not work with ASCOM (neither the 64 bit and the other ASCOM one). Luckily I have copies of the original lazyfocus drivers in my archives. I tested this with both ASCOM 5 and ASCOM 6.

      If anybody needs the original lazyfocus drivers I can upload them to the files section if they are not there already.

      Here is a schematic of the pin assignment for the cable I built

      RS232 DB9 (female) 4 pin phone Lazyfocuser

      --(5)--------gnd-------------(4)-------------------(3 & 4)--

      Pins 3 & 4 needed to be shorted out internally inside Lazyfocuser

      Thanks again for all the help!


      --- In ASCOM-Talk@yahoogroups.com, "autostaretx" <rseymour@...> wrote:
      > One thing you're obviously missing is the GROUND wire between the PC and the focuser. On the DB9, that would be pin 5.
      > Simple RS232 is *3* wire protocol.
      > On a DB9 rs232 hookup, Pin 2 is the signal TO the PC,
      > Pin 3 is the signal FROM the PC, and pin 5 is the reference ground.
      > I suspect your follow-the-traces inside the Lazy Focus has an error in that the MAX232N should *not* be connecting Pin 10 to the outside world.
      > On the MAX232N, pin 13 is rs232 data arriving *at* the MAX,
      > pin 14 is rs232 data transmitting *from* the MAX,
      > whereas pin 10 is one of the TTL-level signals that is destined to be converted to rs232 and squirted out pin 7.
      > Ground on the MAX232N is pin 15, but there's no reason for that to be privately and directly routed to the external socket (unlike pins 13 and 14).
      > So you want DB9 pin 2 connected to MAX pin 14,
      > DB9 pin 3 connected to MAX pin 13,
      > and DB9 pin 5 connected to any ground point in the focuser.
      > So my first guess would be to attach pin 5 of the DB9 to either (or both?) pins 3 or 4 of the facuser's socket.
      > good luck
      > --dick
      > --- In ASCOM-Talk@yahoogroups.com, "astrman" <astrman@> wrote:
      > >
      > > I have had one of these units for years and finally am getting around to installing it on my scope but I am running into some roadblocks.
      > >
      > > 1) I lost the original serial cable (it was a 4 pin phone connector to adapter that plugged into the serial port on the computer). I have a 4 pin phone cord and bought a DB9 connector and just want to wire a new plug. The problem is I am not sure what wires to connect to what. The original came with a DB9 to phone jack but the two that I have are both for 6 wire phone connections (wider) and not the 4 (narrow). I think the original cable may have been a narrow to wide connector.
      > >
      > > If somebody has a cable can you tell me what wires on the 4 pin connector go to what pins on the DB9 so I can hard wire it.
      > >
      > > I opened up the box to look inside at where the connector pins run and they go to a MAX232N IC, which is a RS232 to TTL converter I believe. From what I have been able to tell pin 1 of the 4 pin phone connector goes to pin 13 IC, pin 2 to pin 14 of IC, pin 3 to pin 10 of IC, pin 4 to no connection (that I could tell). Further searching tells me that on the MAX232N chip Pin 14 goes to pin 3 on the DB9 (serial) and Pin 13 goes to pin 2, on the DB9. I can't seem to find any info on where Pin 10 would go on a DB9 and no idea for the non-connection pin4.
      > >
      > > I next checked the DB9 to phone converter plugs and they appear to only have pins 2 and 3 wired (which makes sense for RS232).
      > >
      > >
      > > 2) I have wired a 2 wire cable (pin 2 & 3 only) on the DB9 to pin 1 & 2 on the cable but my computer doesn't seem to find the lazyfocus
      > >
      > > Error: MaximDL failed to connect to the focuser, which returned the error: ASCOM Meade driver: The focuser is not connected to the specified com port.
      > >
      > > I am trying to drive it thru a USB to Serial converter cable (laptop only has USB ports). I can see the cable fine in windows (xp) and set the port up (com 2, 8n1) but ASCOM doesn't seem to find the focuser (see above error). The chip used in the USB to Serial converter is a prolific chipset. The converter works fine to control my LX200 thru the USB port, so I know it works for that.
      > >
      > > Running ASCOM 5.0a (I tried it in ASCOM 6 on another computer but same error).
      > >
      > > Am I missing some piece of the puzzle here on how to get this thing working? Does the telescope need to be connected and running first? I tried FocusMax as well and it tells me the same thing and can't connect to the Lazyfocus either. The unit also works fine using the manual push buttons to move the focuser, just not under computer control.
      > >
      > > Thanks,
      > >
      > > Jack
      > >
    Your message has been successfully submitted and would be delivered to recipients shortly.