Loading ...
Sorry, an error occurred while loading the content.

Re: [ASCOM] Re: Connection problems LX200GPS

Expand Messages
  • Graham Edridge
    Cheers...a comprehensive and very helpful reply. Gives me a bit of stuff to work with, thanks. I ll get on to it tomorrow and let you know how I get on. All
    Message 1 of 1 , Mar 29, 2012
    View Source
    • 0 Attachment

      Cheers...a comprehensive and very helpful reply. Gives me a bit of stuff to work with, thanks. I'll get on to it tomorrow and let you know how I get on. All the best. Graham

      - Sent from my HTC on 3 -
      Graham Edridge

      ----- Reply message -----
      From: "autostaretx" <rseymour@...>
      To: <ASCOM-Talk@yahoogroups.com>
      Subject: [ASCOM] Re: Connection problems LX200GPS
      Date: Thu, Mar 29, 2012 16:13




       

      Meade's ASU has a "Garbage Collect" choice under its Tools menu.
      I have not tried that in *years*... i have no idea if it will work correctly. There have been enough other bugs creeping into ASU's handling of the data structures that i sincerely hesitate to suggest it. I'll try to test it, but i probably won't be able to do so until Monday.

      good luck
      --dick

      --- In ASCOM-Talk@yahoogroups.com, "autostaretx" <rseymour@...> wrote:
      >
      > The error message means what it says:
      > The PC sent a command to the scope,
      > and the scope took too long to reply.
      >
      > I can think of two possible reasons for this:
      > (a) a recent Microsoft patch may have increased some lag in the "PC" side of the game, such that the total turn-around time grew too much
      > *OR*
      > (b) the LX200gps is taking a little bit longer to set the time/date and return its "I'm done" string
      >
      > I'm placing my money on (b) ... the LX200gps uses a linked-list data structure to hold the settings (such as "last date set" which will serve as a prompt the next time). Each time you use the scope, that linked-list (thousands of obsolete settings finally leading to the newest in-use one) gets longer and longer. Eventually it takes the very pokey Autostar CPU too long to reach the end, and ASCOM times out.
      >
      > You can *fix* this in one of two ways:
      > (A) use Meade's ASU updater to do an "Erase User Banks" which will *completely* scrub the FlashRam memory (the user data, not the firmware) and let you start anew. This would wipe out any PEC, SMT, Tours, Asteroids, Comets, Satellites, User Objects, Landmarks, Site data, etc.etc and require a bit of re-filling and re-training thereof.
      > (it's FAR more "destructive" than a simple Setup/Reset ... a Reset will NOT help this symptom).
      > *or*
      > (B) Use Andrew Johansen's "MyScope" application to save all of your current User Data to the PC, then (i think it can) let it do the "Erase" operation, then (i know it can) let it *restore* that saved data. Using MyScope avoids the need to retrain (etc etc), since it will completely restore the current state.
      > MyScope is here: http://members.optusnet.com.au/johansea
      > The "save/restore" operations are handled on the "List Data" tab's page. (the "Lists" include the PEC and SMT (etc) data structures).
      >
      > A work-around would be to extend the time-out that the LX200gps driver is using (from its current 5 seconds to perhaps 10).
      > I'll try to drop a Jira request for that (i'm time-crunched).
      >
      > good luck
      > --dick
      >
      > --- In ASCOM-Talk@yahoogroups.com, "DavidL" <dealawson@> wrote:
      > >
      > > I use ACP to control my telescope and it has worked without issue for a long time. The LX200GPS driver is set up as stated in the ACP help file. Previously on all occasions I power on the scope and wait until it shows the Daylight Savings prompt, then connect from the software. The time and date are then correctly displayed on the handbox and the scope connects. Two nights ago when I instructed ACP to connect to the scope as normal I received the following error message:
      > >
      > > Timed out waiting for received data
      > >
      > > I was unable to connect. I have checked the cables and the connections are fine. ASCOM 6SP1 diagnostics log states all 1150 functions are operating correctly.
      > >
      > >
      > > I do not understand why the previous hands off starting regime of having the auto reboot.init option and auto set time boxes checked and allowing a connection via ACP now results in a Timed out waiting for received data error and a failure to connect ACP to the scope. I have not made any changes at all to the telescope or ACP.
      > >
      > > I can connect if I deselect in the chooser properties for the LX200GPS driver the auto reboot.init option and auto set time boxes. Then when I power up the scope and it shows the Daylight Savings prompt, I have to manually enter the time and date. Once the scope is up I can then connect via ACP and it connects successfully and operates as normal and I can park the scope then power down.
      > >
      > > Does anyone have any suggestions as to why this issue is now occurring?
      > >
      >

    Your message has been successfully submitted and would be delivered to recipients shortly.