Loading ...
Sorry, an error occurred while loading the content.
 

Re: Ascom cannot see my Meade LS-6

Expand Messages
  • Chris
    ... I was afraid you would ask this :-) RTS enable isn t available in the current serial implementation but it looks as if this should be added for Platform 6.
    Message 1 of 68 , Apr 1, 2011
      > Chris? Could you please create an LXP driver that asserts RTS, too?

      I was afraid you would ask this :-)

      RTS enable isn't available in the current serial implementation but it looks as if this should be added for Platform 6. We will have to make this a Platform 6 compatible driver. We're fairly close to extending the beta to users so this shouldn't add too much delay.

      It would help if Dick or you could put this in the ASCOM Jira issue tracker, I think Tim posted a link to it a day or two ago. The tracking bug should go in there as well. I think this is because Pipe is also trying to use the file, I'm using CdC 2.76 as a test bed.

      Setting the flow control to None should mean that the state of DTR and RTS is irrelevant, shouldn't it?

      Chris
    • johansea
      Gday Tim ... No problems at all. I understand the Meade Firmware to a point where i sometimes wonder why others dont understand certain things. I m sure you
      Message 68 of 68 , Apr 8, 2011
        Gday Tim

        --- In ASCOM-Talk@yahoogroups.com, "Tim Long" <Tim@...> wrote:
        >
        > Fair enoughsky. Sorry for my assumption.

        No problems at all.
        I understand the Meade Firmware to a point where i sometimes wonder why others dont understand certain things.
        I'm sure you understand ASCOM and how it works in a similar way.
        This new little lurgie appears to fit inbetween both worlds,
        and it appears it can be easily fixed if we can force some port settings.
        As "big Arnie" once said,
        if it bleeds we can kill it :-)

        Andrew Johansen Melbourne Australia


        >
        > Regards,
        > Tim Long
        >
        >
        > > -----Original Message-----
        > > From: ASCOM-Talk@yahoogroups.com [mailto:ASCOM-
        > > Talk@yahoogroups.com] On Behalf Of johansea
        > > Sent: 05 April 2011 02:47
        > > To: ASCOM-Talk@yahoogroups.com
        > > Subject: [ASCOM] Re: Ascom cannot see my Meade LS-6
        > >
        > > Gday Tim
        > >
        > > I dont use dotnet or visual studio or anything else, hence have no
        > > understanding of their inner workings, nor of all the ASCOM
        > interfaces.
        > > My initial comment was based on reading the ASCOM help file which
        > listed
        > > what "port" properties were available.
        > >
        > > Andrew Johansen Melbourne Australia
        > >
        > >
        > >
        > > --- In ASCOM-Talk@yahoogroups.com, "Tim Long" <Tim@> wrote:
        > > >
        > > > The source is available, see
        > > > http://astroanswers.org/questions/556/how-do-i-access-the-ascom-
        > > source
        > > > -c
        > > > ode
        > > >
        > > > However, the ASCOM serial port is only a wrapper around the .NET
        > > > serial port, so you could use the .NET class directly, which will
        > give
        > > > you more fine-grained control over serial handling. In my drivers, I
        > > > always make all of the serial parameters editable in the app.config
        > > > file, with defaults chosen to work in most situations. This always
        > > > gives the user an 'out' if they have some slightly odd hardware.
        > It's
        > > > really easy to
        > > > do:
        > > >
        > > >
        > > >
        > > > using ASCOM.MyDriver.Properties;
        > > >
        > > >
        > > >
        > > > [...]
        > > >
        > > > /// <summary>
        > > >
        > > > /// Configures the serial port with settings obtained from
        > the
        > > > Application Settings file.
        > > >
        > > > /// </summary>
        > > >
        > > > /// <param name = "port">The <see cref = "ISerialPort" />
        > > > instance to be configured.</param>
        > > >
        > > > static void ConfigureSerialPort(ISerialPort port)
        > > >
        > > > {
        > > >
        > > > port.PortName = Settings.Default.CommPortName;
        > > >
        > > > port.BaudRate = Settings.Default.BaudRate;
        > > >
        > > > port.DataBits = Settings.Default.DataBits;
        > > >
        > > > port.DtrEnable = Settings.Default.DTREnable;
        > > >
        > > > port.DiscardNull = Settings.Default.DiscardNull;
        > > >
        > > > port.Handshake = Settings.Default.Handshake;
        > > >
        > > > port.Encoding = Encoding.ASCII;
        > > >
        > > > port.NewLine = Settings.Default.NewLine;
        > > >
        > > > port.Parity = Settings.Default.Parity;
        > > >
        > > > port.ReadBufferSize = Settings.Default.ReadBufferSize;
        > > >
        > > > port.ReadTimeout =
        > > > Settings.Default.ReadTimeoutMilliseconds;
        > > >
        > > > port.ReceivedBytesThreshold =
        > > > Settings.Default.ReceivedBytesThreshold;
        > > >
        > > > port.RtsEnable = Settings.Default.RTSEnable;
        > > >
        > > > port.StopBits = Settings.Default.StopBits;
        > > >
        > > > port.WriteBufferSize = Settings.Default.WriteBufferSize;
        > > >
        > > > port.WriteTimeout =
        > > > Settings.Default.WriteTimeoutMilliseconds;
        > > >
        > > > }
        > > >
        > > >
        > > >
        > > >
        > > >
        > > >
        > > >
        > > >
        > > >
        > > > Regards,
        > > >
        > > > Tim Long
        > > >
        > > >
        > > >
        > > >
        > > >
        > > > > -----Original Message-----
        > > >
        > > > > From: ASCOM-Talk@yahoogroups.com [mailto:ASCOM-
        > > >
        > > > > Talk@yahoogroups.com] On Behalf Of johansea
        > > >
        > > > > Sent: 31 March 2011 08:02
        > > >
        > > > > To: ASCOM-Talk@yahoogroups.com
        > > >
        > > > > Subject: [ASCOM] Re: Ascom cannot see my Meade LS-6
        > > >
        > > > >
        > > >
        > > > > Gday Bob/Tim??
        > > >
        > > > >
        > > >
        > > > > I have also been looking at this DTR setting within my app.
        > > >
        > > > > In my original apps version,
        > > >
        > > > > i have DTR set to ON and all H/W and S/W flow control off.
        > > >
        > > > > I can connect and talk to the Meade LS no problems.
        > > >
        > > > > After modifying my port component to boot with DTR OFF i also lock
        > > > > up
        > > > with
        > > >
        > > > > no response from the LS.
        > > >
        > > > > It certainly appears that DTR must be ON at the PC end before the
        > LS
        > > > will
        > > >
        > > > > respond ( and this lines up with lots of info on the net re modems
        > > > > not
        > > >
        > > > > responding unless DTR is ON at the PC ).
        > > >
        > > > > I looked at my current ASCOM sources and the help files, and it
        > > > > would
        > > >
        > > > > appear that the current serial interface has no access to set DTR
        > (
        > > > etc )
        > > >
        > > > > programatically.
        > > >
        > > > > Is the serial helper source available ( or can a test dll be made
        > up
        > > > that
        > > >
        > > > > exposes the ability to set the DTR settings etc ).
        > > >
        > > > >
        > > >
        > > > > Andrew Johansen Melbourne Australia
        > > >
        > > > >
        > > >
        > > > > --- In ASCOM-Talk@yahoogroups.com
        > > > > <mailto:ASCOM-Talk@yahoogroups.com>
        > > > , "autostaretx" <rseymour@ <mailto:rseymour@> > wrote:
        > > >
        > > > > >
        > > >
        > > > > > Early results from running a different test app:
        > > >
        > > > > >
        > > >
        > > > > > It would appear that DTR has to be asserted by the application.
        > > >
        > > > > > (or perhaps toggled from OFF to ON just after initial attempt at
        > > >
        > > > > > connection... we're still working on that aspect)
        > > >
        > > > > >
        > > >
        > > > > > If i start an app *without* DTR, i see the "blocked results"
        > > > Symptom.
        > > >
        > > > > > If i then assert DTR (data terminal ready), the results from the
        > > > commands
        > > >
        > > > > flow to the app.
        > > >
        > > > > > Subsequent commands (DTR still asserted) get immediate
        > responses.
        > > >
        > > > > > Turning off DTR blocks the results (again), until it's
        > re-asserted.
        > > >
        > > > > >
        > > >
        > > > > > Enabling "DTR Flow Control" does *not* clear the problem.
        > > >
        > > > > > The Meade-supplied USB-to-LS driver appears to require asserted
        > > > > > DTR
        > > >
        > > > > from the PC.
        > > >
        > > > > >
        > > >
        > > > > > ..stay tuned..
        > > >
        > > > > > --dick
        > > >
        > > > > >
        > > >
        > > > >
        > > >
        > > > >
        > > >
        > > > >
        > > >
        > > > >
        > > >
        > > > > ------------------------------------
        > > >
        > > > >
        > > >
        > > > > For more information see http://ASCOM-Standards.org/
        > > > <http://ASCOM-Standards.org/> .
        > > >
        > > > >
        > > >
        > > > > To unsubscribe from this group, send an email FROM THE ACCOUNT YOU
        > > >
        > > > > USED TO SUBSCRIBE(!) to:
        > > >
        > > > > ASCOM-Talk-unsubscribe@yahoogroups.com
        > > > <mailto:ASCOM-Talk-unsubscribe@yahoogroups.com>
        > > >
        > > > >
        > > >
        > > > > Yahoo! Groups Links
        > > >
        > > > >
        > > >
        > > > > http://groups.yahoo.com/group/ASCOM-Talk/
        > > > <http://groups.yahoo.com/group/ASCOM-Talk/>
        > > >
        > > > >
        > > >
        > > > > Individual Email | Traditional
        > > >
        > > > >
        > > >
        > > > > http://groups.yahoo.com/group/ASCOM-Talk/join
        > > > <http://groups.yahoo.com/group/ASCOM-Talk/join>
        > > >
        > > > > (Yahoo! ID required)
        > > >
        > > > >
        > > >
        > > > > ASCOM-Talk-digest@yahoogroups.com
        > > > <mailto:ASCOM-Talk-digest@yahoogroups.com>
        > > >
        > > > > ASCOM-Talk-fullfeatured@yahoogroups.com
        > > > <mailto:ASCOM-Talk-fullfeatured@yahoogroups.com>
        > > >
        > > > >
        > > >
        > > > > ASCOM-Talk-unsubscribe@yahoogroups.com
        > > > <mailto:ASCOM-Talk-unsubscribe@yahoogroups.com>
        > > >
        > > > >
        > > >
        > > > > http://docs.yahoo.com/info/terms/
        > > > <http://docs.yahoo.com/info/terms/>
        > > >
        > > >
        > > >
        > > >
        > > > --
        > > > ExchangeDefender Message Security: Click below to verify
        > authenticity
        > > >
        > > http://www.exchangedefender.com/verify.asp?id=p351KEA5003740&from=
        > > tim@
        > > > Complete email hygiene and business continuity solution available
        > from
        > > > http://www.tigranetworks.co.uk
        > > >
        > >
        > >
        > >
        > >
        > > ------------------------------------
        > >
        > > For more information see http://ASCOM-Standards.org/.
        > >
        > > To unsubscribe from this group, send an email FROM THE ACCOUNT YOU
        > > USED TO SUBSCRIBE(!) to:
        > > ASCOM-Talk-unsubscribe@yahoogroups.com
        > >
        > > Yahoo! Groups Links
        > >
        > >
        > >
        >
        > --
        > ExchangeDefender Message Security: Click below to verify authenticity
        > http://www.exchangedefender.com/verify.asp?id=p37MBCds001926&from=tim@...
        > Complete email hygiene and business continuity solution available from http://www.tigranetworks.co.uk
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.