Loading ...
Sorry, an error occurred while loading the content.
 

RE: [ARRL-LOTW] Ubuntu Linux: openssl not found

Expand Messages
  • Mike Mellinger WA0SXV
    Did edit the source this morning and successfully built tqsllib. However, TrustedQSL needs wxWindows - which now exists as wxWidgets and is possibly not
    Message 1 of 9 , Apr 10, 2008

      Did edit the source this morning and successfully built tqsllib.

       

      However, TrustedQSL needs wxWindows – which now exists as wxWidgets and is possibly not compatible.  So the make file (for one) needs to reflect this.

       

      Altogether a bit messier than I’d have liked.  May mess with it more this weekend.

       

      73,

      Mike WA0SXV

       

       

      From: ARRL-LOTW@yahoogroups.com [mailto:ARRL-LOTW@yahoogroups.com] On Behalf Of Rick Murphy/K1MU
      Sent: Thursday, April 10, 2008 15:55
      To: ARRL-LOTW@yahoogroups.com
      Subject: Re: [ARRL-LOTW] Ubuntu Linux: openssl not found

       

      At 12:38 PM 4/10/2008, w9wi wrote:

      >I'm not finding anything in the archives but maybe someone has some
      >ideas...
      >
      >I've had LOTW working nicely on Windows XP in the hamshack. However,
      >the computer in the den I use most of the time runs Ubuntu Linux.
      >(6.06) I've been trying to build tqsllib. Configure is failing to
      >find openssl:
      >
      > checking for OpenSSL library (libcrypto.a)... Not found
      > OpenSSL not found
      > Use --with-openssl option to fix this problem
      >
      >However, openssl *IS* installed:
      >
      > # which openssl
      > /usr/bin/openssl
      >
      >Running ./configure --with-openssl=/usr/bin/openssl doesn't make any
      >difference.
      >
      >Not sure where to look for libcrypto.a. /usr/bin contains a
      >libcrypt.a and a libcrypto.so.0.9.8. (pointing --with-openssl at
      >/usr/bin doesn't help, not that I really expected it to. If I do find
      >libcrypto.a, how do I tell configure where to look for it?)
      >
      >For what it's worth, Googling this problem shows that quite a few
      >non-ham programs seem to present this same issue. Unfortunately it
      >doesn't seem to show up any solutions!

      You need the headers and libraries installed for openssl development.
      Try
      sudo apt-get openssl-devel

      (I use fedora, which uses yum. "yum install openssl-devel" for me.)

      However, you're going to run into the problem that Mike WA0SXV found:
      tqsllib requires OpenSSL 9.6 or 9.7, and OpenSSL 9.8 is the current
      release. If you try to compile it, you get an error. There's a simple fix.
      In openssl_cert.cpp, edit line 1291 to read
      #elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00907000 ||
      (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00908000

      I've checked the compatibility; the structure is the same for 9.7 and
      9.8 so the edit above should work.
      73,
      -Rick

    • Mike Mellinger WA0SXV
      I now have it working (apparently - haven t downloaded anything) on FC8. Will test after dinner. Need to import some PK12 files from the Windows system.
      Message 2 of 9 , Apr 10, 2008

        I now have it working (apparently – haven’t downloaded anything) on FC8.  Will test after dinner.  Need to import some PK12 files from the Windows system.

         

        Instructions I used:

         

        http://aa6e.net/software/lotw-fc5.html

         

        Need wxGTK and a couple of simple source code patches.  Generates hundreds of warning messages.

         

        73,

        Mike

         

        From: ARRL-LOTW@yahoogroups.com [mailto:ARRL-LOTW@yahoogroups.com] On Behalf Of Rick Murphy/K1MU
        Sent: Thursday, April 10, 2008 15:55
        To: ARRL-LOTW@yahoogroups.com
        Subject: Re: [ARRL-LOTW] Ubuntu Linux: openssl not found

         

        At 12:38 PM 4/10/2008, w9wi wrote:

        >I'm not finding anything in the archives but maybe someone has some
        >ideas...
        >
        >I've had LOTW working nicely on Windows XP in the hamshack. However,
        >the computer in the den I use most of the time runs Ubuntu Linux.
        >(6.06) I've been trying to build tqsllib. Configure is failing to
        >find openssl:
        >
        > checking for OpenSSL library (libcrypto.a)... Not found
        > OpenSSL not found
        > Use --with-openssl option to fix this problem
        >
        >However, openssl *IS* installed:
        >
        > # which openssl
        > /usr/bin/openssl
        >
        >Running ./configure --with-openssl=/usr/bin/openssl doesn't make any
        >difference.
        >
        >Not sure where to look for libcrypto.a. /usr/bin contains a
        >libcrypt.a and a libcrypto.so.0.9.8. (pointing --with-openssl at
        >/usr/bin doesn't help, not that I really expected it to. If I do find
        >libcrypto.a, how do I tell configure where to look for it?)
        >
        >For what it's worth, Googling this problem shows that quite a few
        >non-ham programs seem to present this same issue. Unfortunately it
        >doesn't seem to show up any solutions!

        You need the headers and libraries installed for openssl development.
        Try
        sudo apt-get openssl-devel

        (I use fedora, which uses yum. "yum install openssl-devel" for me.)

        However, you're going to run into the problem that Mike WA0SXV found:
        tqsllib requires OpenSSL 9.6 or 9.7, and OpenSSL 9.8 is the current
        release. If you try to compile it, you get an error. There's a simple fix.
        In openssl_cert.cpp, edit line 1291 to read
        #elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00907000 ||
        (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00908000

        I've checked the compatibility; the structure is the same for 9.7 and
        9.8 so the edit above should work.
        73,
        -Rick

      • Bob Nielsen
        The needed package for Ubuntu 6.06 is libssl-dev . Bob, N7XY ... Bob Nielsen n7xy@clearwire.net
        Message 3 of 9 , Apr 10, 2008
          The needed package for Ubuntu 6.06 is "libssl-dev".

          Bob, N7XY

          On Apr 10, 2008, at 2:54 PM, Rick Murphy/K1MU wrote:
          > At 12:38 PM 4/10/2008, w9wi wrote:
          > >I'm not finding anything in the archives but maybe someone has some
          > >ideas...
          > >
          > >I've had LOTW working nicely on Windows XP in the hamshack. However,
          > >the computer in the den I use most of the time runs Ubuntu Linux.
          > >(6.06) I've been trying to build tqsllib. Configure is failing to
          > >find openssl:
          > >
          > > checking for OpenSSL library (libcrypto.a)... Not found
          > > OpenSSL not found
          > > Use --with-openssl option to fix this problem
          > >
          > >However, openssl *IS* installed:
          > >
          > > # which openssl
          > > /usr/bin/openssl
          > >
          > >Running ./configure --with-openssl=/usr/bin/openssl doesn't make any
          > >difference.
          > >
          > >Not sure where to look for libcrypto.a. /usr/bin contains a
          > >libcrypt.a and a libcrypto.so.0.9.8. (pointing --with-openssl at
          > >/usr/bin doesn't help, not that I really expected it to. If I do find
          > >libcrypto.a, how do I tell configure where to look for it?)
          > >
          > >For what it's worth, Googling this problem shows that quite a few
          > >non-ham programs seem to present this same issue. Unfortunately it
          > >doesn't seem to show up any solutions!
          >
          > You need the headers and libraries installed for openssl development.
          > Try
          > sudo apt-get openssl-devel
          >
          > (I use fedora, which uses yum. "yum install openssl-devel" for me.)
          >
          > However, you're going to run into the problem that Mike WA0SXV found:
          > tqsllib requires OpenSSL 9.6 or 9.7, and OpenSSL 9.8 is the current
          > release. If you try to compile it, you get an error. There's a
          > simple fix.
          > In openssl_cert.cpp, edit line 1291 to read
          > #elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00907000 ||
          > (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00908000
          >
          > I've checked the compatibility; the structure is the same for 9.7 and
          > 9.8 so the edit above should work.
          > 73,
          > -Rick
          >
          >
          >

          Bob Nielsen
          n7xy@...
        • Bob Nielsen
          I checked a bit further and there already is a trustedqsl package in the Ubuntu universe repository so there is no need to compile it yourself. Just type
          Message 4 of 9 , Apr 10, 2008
            I checked a bit further and there already is a trustedqsl package in
            the Ubuntu "universe" repository so there is no need to compile it
            yourself. Just type "sudo apt-get install trustedqsl". It is
            version 1.11, which is the latest. You may need to enable "universe"
            in /etc/apt/sources.list if you have not already done so.

            Bob, N7XY

            On Apr 10, 2008, at 4:02 PM, Bob Nielsen wrote:
            > The needed package for Ubuntu 6.06 is "libssl-dev".
            >
            > Bob, N7XY
            >
            > On Apr 10, 2008, at 2:54 PM, Rick Murphy/K1MU wrote:
            > > At 12:38 PM 4/10/2008, w9wi wrote:
            > > >I'm not finding anything in the archives but maybe someone has some
            > > >ideas...
            > > >
            > > >I've had LOTW working nicely on Windows XP in the hamshack.
            > However,
            > > >the computer in the den I use most of the time runs Ubuntu Linux.
            > > >(6.06) I've been trying to build tqsllib. Configure is failing to
            > > >find openssl:
            > > >
            > > > checking for OpenSSL library (libcrypto.a)... Not found
            > > > OpenSSL not found
            > > > Use --with-openssl option to fix this problem
            > > >
            > > >However, openssl *IS* installed:
            > > >
            > > > # which openssl
            > > > /usr/bin/openssl
            > > >
            > > >Running ./configure --with-openssl=/usr/bin/openssl doesn't make
            > any
            > > >difference.
            > > >
            > > >Not sure where to look for libcrypto.a. /usr/bin contains a
            > > >libcrypt.a and a libcrypto.so.0.9.8. (pointing --with-openssl at
            > > >/usr/bin doesn't help, not that I really expected it to. If I do
            > find
            > > >libcrypto.a, how do I tell configure where to look for it?)
            > > >
            > > >For what it's worth, Googling this problem shows that quite a few
            > > >non-ham programs seem to present this same issue. Unfortunately it
            > > >doesn't seem to show up any solutions!
            > >
            > > You need the headers and libraries installed for openssl
            > development.
            > > Try
            > > sudo apt-get openssl-devel
            > >
            > > (I use fedora, which uses yum. "yum install openssl-devel" for me.)
            > >
            > > However, you're going to run into the problem that Mike WA0SXV
            > found:
            > > tqsllib requires OpenSSL 9.6 or 9.7, and OpenSSL 9.8 is the current
            > > release. If you try to compile it, you get an error. There's a
            > > simple fix.
            > > In openssl_cert.cpp, edit line 1291 to read
            > > #elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00907000 ||
            > > (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00908000
            > >
            > > I've checked the compatibility; the structure is the same for 9.7
            > and
            > > 9.8 so the edit above should work.
            > > 73,
            > > -Rick
            > >
            > >
            > >
            >
            > Bob Nielsen
            > n7xy@...
            >
            >
            >

            Bob Nielsen
            n7xy@...
          • w9wi
            ... THANKS! Worked beautifully. If any of you have just received a LOTW QSL for a QSO with W9WI since January 8th, it was prepared on Linux. (now to see if I
            Message 5 of 9 , Apr 11, 2008
              --- In ARRL-LOTW@yahoogroups.com, Bob Nielsen <n7xy@...> wrote:
              > I checked a bit further and there already is a trustedqsl package in
              > the Ubuntu "universe" repository so there is no need to compile it
              > yourself. Just type "sudo apt-get install trustedqsl". It is
              > version 1.11, which is the latest. You may need to enable "universe"
              > in /etc/apt/sources.list if you have not already done so.
              >
              > Bob, N7XY

              THANKS! Worked beautifully. If any of you have just received a LOTW
              QSL for a QSO with W9WI since January 8th, it was prepared on Linux.

              (now to see if I can figure out how to tack direct LOTW support onto
              my homebrew Linux logging program, rather than manually signing ADIF
              files) (yes, I do have the developer's PDF. Just haven't read it yet!)

              (YK9G already QSLd? The QSO was less than 24 hours ago!)
            • Hamish Moffatt
              ... You need to install libssl-dev. But instead, why don t you just install the trustedqsl package? It s in the universe section. tqsllib/trustedqsl probably
              Message 6 of 9 , Apr 12, 2008
                On Thu, Apr 10, 2008 at 04:38:50PM -0000, w9wi wrote:
                > I'm not finding anything in the archives but maybe someone has some
                > ideas...
                >
                > I've had LOTW working nicely on Windows XP in the hamshack. However,
                > the computer in the den I use most of the time runs Ubuntu Linux.
                > (6.06) I've been trying to build tqsllib. Configure is failing to
                > find openssl:

                You need to install libssl-dev.

                But instead, why don't you just install the trustedqsl package? It's in
                the universe section. tqsllib/trustedqsl probably won't build for you
                without patches anyway.

                > However, openssl *IS* installed:
                >
                > # which openssl
                > /usr/bin/openssl
                >
                > Running ./configure --with-openssl=/usr/bin/openssl doesn't make any
                > difference.

                It's looking for libraries (libssl.so, libcrypto.so) not a binary.


                Hamish
                --
                Hamish Moffatt VK3SB <hamish@...> <hamish@...>
              Your message has been successfully submitted and would be delivered to recipients shortly.