Loading ...
Sorry, an error occurred while loading the content.

help installing gnu arm compiler

Expand Messages
  • sean.disman
    so i m installing the gnu arm compiler for the first time. I m following the exact instructions provided by the official support section of the gnu arm
    Message 1 of 3 , Feb 24, 2008
    • 0 Attachment
      so i'm installing the gnu arm compiler for the first time. I'm
      following the exact instructions provided by the official support
      section of the gnu arm website.
      I created a folder called build-binutils and i did the following

      $ ../binutils-2.17/configure --target=arm-elf --prefix=/usr/local/arm7
      --enable-interwork --enable-multilib
      $ make all install
      $ export PATH="$PATH:/usr/local/arm7/bin"

      I also changed my ~/.bash~ to reflect my new path variable.
      This worked perfectly.

      Then i created another folder called build-gcc and the following

      $ cd build-gcc
      $ ../gcc-4.1.1/configure --target=arm-elf --prefix=/usr/local/arm7
      --enable-interwork --enable-multilib --enable-languages="c,c++"
      --with-newlib
      $ make all-gcc install-gcc
      then I get the error:
      make[2]: arm-elf-ar: Command not found
      make[2]: *** [libgcc.a] Error 127

      however when i type arm-elf-ar It definetly seems to be working.
      Any help would be greatly appreciated!
    • Anton Erasmus
      ... Look at http://www.gnuarm.org/ under support for instructions on building the toolchain. 1. cd [binutils-build] 2. [binutils-source]/configure
      Message 2 of 3 , Feb 26, 2008
      • 0 Attachment
        On 25 Feb 2008 at 2:57, sean.disman wrote:


        > so i'm installing the gnu arm compiler for the first time. I'm
        > following the exact instructions provided by the official support
        > section of the gnu arm website.
        > I created a folder called build-binutils and i did the following
        >
        > $ ../binutils-2.17/configure --target=arm-elf --prefix=/usr/local/arm7
        > --enable-interwork --enable-multilib
        > $ make all install
        > $ export PATH="$PATH:/usr/local/arm7/bin"
        >
        > I also changed my ~/.bash~ to reflect my new path variable.
        > This worked perfectly.
        >
        > Then i created another folder called build-gcc and the following
        >
        > $ cd build-gcc
        > $ ../gcc-4.1.1/configure --target=arm-elf --prefix=/usr/local/arm7
        > --enable-interwork --enable-multilib --enable-languages="c,c++"
        > --with-newlib
        > $ make all-gcc install-gcc
        > then I get the error:
        > make[2]: arm-elf-ar: Command not found
        > make[2]: *** [libgcc.a] Error 127
        >
        > however when i type arm-elf-ar It definetly seems to be working.
        > Any help would be greatly appreciated!
        >

        Look at http://www.gnuarm.org/ under support for instructions on building
        the toolchain.
        1. cd [binutils-build]
        2. [binutils-source]/configure --target=arm-elf --prefix=[toolchain-prefix] --enable-interwork --
        enable-multilib --with-float=soft
        3. make all install
        4. export PATH="$PATH:[toolchain-prefix]/bin"
        5. cd [gcc-build]
        6. [gcc-source]/configure --target=arm-elf --prefix=[toolchain-prefix] --enable-interwork --
        enable-multilib --with-float=soft --enable-languages="c,c++" --with-newlib --with-
        headers=[newlib-source]/newlib/libc/include
        7. make all-gcc install-gcc
        8. cd [newlib-build]
        9. [newlib-source]/configure --target=arm-elf --prefix=[toolchain-prefix] --enable-interwork --
        enable-multilib --with-float=soft
        10. make all install
        11. cd [gcc-build]
        12. make all install
        13. cd [gdb-build]
        14. [gdb-source]/configure --target=arm-elf --prefix=[toolchain-prefix] --enable-interwork --
        enable-multilib --with-float=soft
        15. make all install

        It looks like you are missing the --with-headers option.
        Also note that you need the updated t-arm-elf file from the site.

        Regards
        Anton Erasmus

        --
        A J Erasmus
      • paloalgodon
        ... I suggest you join the gnuarm yahoo group and ask them. Personally, I m using FreeBSD, and some blessed soul has made custom makefiles so it just works .
        Message 3 of 3 , Mar 4, 2008
        • 0 Attachment
          --- In ADuC_ARM@yahoogroups.com, "sean.disman" <sean.disman@...> wrote:
          >
          > so i'm installing the gnu arm compiler for the first time. I'm
          > following the exact instructions provided by the official support
          > section of the gnu arm website.
          > I created a folder called build-binutils and i did the following
          >
          > $ ../binutils-2.17/configure --target=arm-elf --prefix=/usr/local/arm7
          > --enable-interwork --enable-multilib
          > $ make all install
          > $ export PATH="$PATH:/usr/local/arm7/bin"
          >
          > I also changed my ~/.bash~ to reflect my new path variable.
          > This worked perfectly.
          >
          > Then i created another folder called build-gcc and the following
          >
          > $ cd build-gcc
          > $ ../gcc-4.1.1/configure --target=arm-elf --prefix=/usr/local/arm7
          > --enable-interwork --enable-multilib --enable-languages="c,c++"
          > --with-newlib
          > $ make all-gcc install-gcc
          > then I get the error:
          > make[2]: arm-elf-ar: Command not found
          > make[2]: *** [libgcc.a] Error 127
          >
          > however when i type arm-elf-ar It definetly seems to be working.
          > Any help would be greatly appreciated!
          >

          I suggest you join the gnuarm yahoo group and ask them. Personally,
          I'm using FreeBSD, and some blessed soul has made custom makefiles so
          it 'just works'. Maybe someone has an RPM for gnuarm?

          Steve
        Your message has been successfully submitted and would be delivered to recipients shortly.