Loading ...
Sorry, an error occurred while loading the content.

Flash debugging with IAR + J-link

Expand Messages
  • larserik.svensson
    I am debugging my own board and testing it with IAR embbeded workbench and their own example code and J-link emulator. The board has a ADUC7021 mounted.
    Message 1 of 2 , Oct 3, 2007
    View Source
    • 0 Attachment
      I am debugging my own board and testing it with IAR embbeded workbench
      and their own example code and J-link emulator.
      The board has a ADUC7021 mounted.
      Debugging in RAM seems to work fine but when I try to debug in FLASH I
      can see in the log that the the flash loader gets loaded and target
      reset but then everthing stops.
      The IDE gets hang-up with the flashing progress window and I have to
      abort the flashing.
      Anyone who has a suggestion what is wrong?
    • larserik.svensson
      I actually think I solved it myself. The default flash loader uses a memory map with 8k RAM when in fact ADUC7021 only have 4k RAM. The flash loader had to be
      Message 2 of 2 , Oct 4, 2007
      View Source
      • 0 Attachment
        I actually think I solved it myself. The default flash loader uses
        a memory map with 8k RAM when in fact ADUC7021 only have 4k RAM.
        The flash loader had to be rebuilt with new linker file.

        One small step for mankind, one large step for me.


        --- In ADuC_ARM@yahoogroups.com, "larserik.svensson"
        <larserik.svensson@...> wrote:
        >
        > I am debugging my own board and testing it with IAR embbeded
        workbench
        > and their own example code and J-link emulator.
        > The board has a ADUC7021 mounted.
        > Debugging in RAM seems to work fine but when I try to debug in
        FLASH I
        > can see in the log that the the flash loader gets loaded and target
        > reset but then everthing stops.
        > The IDE gets hang-up with the flashing progress window and I have
        to
        > abort the flashing.
        > Anyone who has a suggestion what is wrong?
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.